Topics

NVDA and Firefox

Pele West
 

Hi Gene and Quentin

Thanks. I tried the Com Registration tool without success.

I am going to uninstall and reinstall Firefox and try Waterfox.

Pele

Quentin Christensen
 

RIght enough Gene - "COM Registration Fixing Tool".  And yes, that's what I would have suggested trying as well.


On Fri, Feb 14, 2020 at 1:07 AM Gene <gsasner@...> wrote:
This sounds to me like the longstanding problem that some programs, when you uninstall them, unregister some.dll files.  NVDA has a utility to correct the problem.  Open the menu with NVDA key n.  Find and open the tools submenu.  Find and run the com registry fixing tool.  That may not be the exact name but its close enough that you will know it.  The tool reregisters the .dll files, if they have become unregistered.
 
Gene
----- Original Message -----
Sent: Thursday, February 13, 2020 7:48 AM
Subject: Re: [nvda] NVDA and Firefox

This also happened to me and I dealt with it by  installing  Waterfox at that time as a slimmed down version of FireFox with at the time better accessibility.

I have now pretty much moved to using Brave full time now so I am not quite sure of the full status of Waterfox. I relaunched it just now and it appears to be still OK.

David Griffith




-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Pele West
Sent: 13 February 2020 13:09
To: NVDA <nvda@nvda.groups.io>
Subject: [nvda] NVDA and Firefox

Hi Everyone

I use Windows 7, NVDA 2019.3.1 and Firefox 68.5.0ESR. It works fine on
one machine.

I have just installed NVDA on another Windows 7 machine and, when I load
Firefox, it says the title of the page and then keeps saying "Unknown".
This machine had a previous version of Firefox which was updated today
to 68.5.0ESR.
I created a portable version of NVDA using the first machine and
installed it on the second one.

Can anyone advise me how to make it work on the second machine?

Thanks

pele West










--
Quentin Christensen
Training and Support Manager


Gene
 

This sounds to me like the longstanding problem that some programs, when you uninstall them, unregister some.dll files.  NVDA has a utility to correct the problem.  Open the menu with NVDA key n.  Find and open the tools submenu.  Find and run the com registry fixing tool.  That may not be the exact name but its close enough that you will know it.  The tool reregisters the .dll files, if they have become unregistered.
 
Gene

----- Original Message -----
Sent: Thursday, February 13, 2020 7:48 AM
Subject: Re: [nvda] NVDA and Firefox

This also happened to me and I dealt with it by  installing  Waterfox at that time as a slimmed down version of FireFox with at the time better accessibility.

I have now pretty much moved to using Brave full time now so I am not quite sure of the full status of Waterfox. I relaunched it just now and it appears to be still OK.

David Griffith




-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Pele West
Sent: 13 February 2020 13:09
To: NVDA <nvda@nvda.groups.io>
Subject: [nvda] NVDA and Firefox

Hi Everyone

I use Windows 7, NVDA 2019.3.1 and Firefox 68.5.0ESR. It works fine on
one machine.

I have just installed NVDA on another Windows 7 machine and, when I load
Firefox, it says the title of the page and then keeps saying "Unknown".
This machine had a previous version of Firefox which was updated today
to 68.5.0ESR.
I created a portable version of NVDA using the first machine and
installed it on the second one.

Can anyone advise me how to make it work on the second machine?

Thanks

pele West








David Griffith
 

This also happened to me and I dealt with it by installing Waterfox at that time as a slimmed down version of FireFox with at the time better accessibility.

I have now pretty much moved to using Brave full time now so I am not quite sure of the full status of Waterfox. I relaunched it just now and it appears to be still OK.

David Griffith

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Pele West
Sent: 13 February 2020 13:09
To: NVDA <nvda@nvda.groups.io>
Subject: [nvda] NVDA and Firefox

Hi Everyone

I use Windows 7, NVDA 2019.3.1 and Firefox 68.5.0ESR. It works fine on
one machine.

I have just installed NVDA on another Windows 7 machine and, when I load
Firefox, it says the title of the page and then keeps saying "Unknown".
This machine had a previous version of Firefox which was updated today
to 68.5.0ESR.
I created a portable version of NVDA using the first machine and
installed it on the second one.

Can anyone advise me how to make it work on the second machine?

Thanks

pele West

Pele West
 

Hi Everyone

I use Windows 7, NVDA 2019.3.1 and Firefox 68.5.0ESR. It works fine on
one machine.

I have just installed NVDA on another Windows 7 machine and, when I load
Firefox, it says the title of the page and then keeps saying "Unknown".
This machine had a previous version of Firefox which was updated today
to 68.5.0ESR.
I created a portable version of NVDA using the first machine and
installed it on the second one.

Can anyone advise me how to make it work on the second machine?

Thanks

pele West