links in email with thunderbird


Mary Otten
 

Hi all,


Until this most recent update to T-bird, the one that started the thread on all that extra chatter, it had been the case that if you opened a message and read it, or if you tabbed through the open message looking for links, those links which had English text associated with the url would announce the same way, i.e. the English text, not the http:// etc would be spoken by NVDA. Now, however, if I get a message and tab through to quickly find the link I know is there, all I get are the readouts of urls, which are not helpful at all. If I read through the message, I hear the actual English text, not the url, but that is inefficient as heck, since in a lot of instances, I know there are titles to stories, for instance in a newsletter, that I want to flip through, rather than listening to them all plus the blurbs after each one.


I hope this description makes sense. What can I do to get my tabbing to read the link label in English as it does when you read straight through, rather than read the html http:// stuff?


Mary


 

Mary,

            I'm sorry to say that this sounds like a bug that has crept in, so you probably can't.  I would have to presume this is on the Thunderbird side, too.

            As a curiosity question, and not just to you, do you have a "backup" e-mail client that you can use to test against?  Given that you can have as many e-mail clients as you might like on a given computer if they're all accessing the same accounts via IMAP, it's worth having an extra one to test against when stuff like this comes up so that you can differentiate between the problem possibly being on the screen reader side versus the email client side.

--

Brian - Windows 10 Pro, 64-Bit, Version 1909, Build 18363  

Power is being told you're not loved and not being destroyed by it.

       ~ Madonna

 

 


Henk Mulder
 

Hi Mary,

I think this also has to do with the extra chatter in the statusbar.
If I open a mail with the statusbar disabled, then NVDA will read the label of the link when I tab to it. If I enable the statusbar and tab to a link, then the URL is shown in the statusbar, and that is what's being read.
So I think that disabling the statusbar will solve your problem.
Note that, if messages are opened in a new window, it will not automatically use the same setting as for the main window of Thunderbird. Therefore you might have to adjust this setting for (1) the main window, (2) the window for reading messages, and (3) the window for composing messages.

Best,
Henk

Op 17/04/2020 om 17:16 schreef Mary Otten:

Hi all,


Until this most recent update to T-bird, the one that started the thread on all that extra chatter, it had been the case that if you opened a message and read it, or if you tabbed through the open message looking for links, those links which had English text associated with the url would announce the same way, i.e. the English text, not the http:// etc would be spoken by NVDA. Now, however, if I get a message and tab through to quickly find the link I know is there, all I get are the readouts of urls, which are not helpful at all. If I read through the message, I hear the actual English text, not the url, but that is inefficient as heck, since in a lot of instances, I know there are titles to stories, for instance in a newsletter, that I want to flip through, rather than listening to them all plus the blurbs after each one.


I hope this description makes sense. What can I do to get my tabbing to read the link label in English as it does when you read straight through, rather than read the html http:// stuff?


Mary




Mary Otten
 

Yes, I do have a back up email, but it’s the Windows 10 email client, which I loathe, and that’s being nice. I had an email client that I absolutely loved and used for well over a decade, long after I should’ve quit. I have never found anything since that comes close. I do not have Outlook, and I don’t want it. If somebody has a suggestion for another email client, I am willing to look into one.

Mary



On Apr 17, 2020, at 11:11 AM, Brian Vogel <britechguy@...> wrote:

Mary,

            I'm sorry to say that this sounds like a bug that has crept in, so you probably can't.  I would have to presume this is on the Thunderbird side, too.

            As a curiosity question, and not just to you, do you have a "backup" e-mail client that you can use to test against?  Given that you can have as many e-mail clients as you might like on a given computer if they're all accessing the same accounts via IMAP, it's worth having an extra one to test against when stuff like this comes up so that you can differentiate between the problem possibly being on the screen reader side versus the email client side.

--

Brian - Windows 10 Pro, 64-Bit, Version 1909, Build 18363  

Power is being told you're not loved and not being destroyed by it.

       ~ Madonna

 

 


Mary Otten
 

Thanks, Henk,
Thanks for that information. I did disable the status bar for the main window. I had no idea that I would have to go in and do it for the various other windows. I didn’t realize it had more than one. Hopefully this will do the job.
Mary

On Apr 17, 2020, at 11:24 AM, Henk Mulder <teakevw@gmail.com> wrote:

Hi Mary,

I think this also has to do with the extra chatter in the statusbar.
If I open a mail with the statusbar disabled, then NVDA will read the label of the link when I tab to it. If I enable the statusbar and tab to a link, then the URL is shown in the statusbar, and that is what's being read.
So I think that disabling the statusbar will solve your problem.
Note that, if messages are opened in a new window, it will not automatically use the same setting as for the main window of Thunderbird. Therefore you might have to adjust this setting for (1) the main window, (2) the window for reading messages, and (3) the window for composing messages.

Best,
Henk

Op 17/04/2020 om 17:16 schreef Mary Otten:
Hi all,


Until this most recent update to T-bird, the one that started the thread on all that extra chatter, it had been the case that if you opened a message and read it, or if you tabbed through the open message looking for links, those links which had English text associated with the url would announce the same way, i.e. the English text, not the http:// etc would be spoken by NVDA. Now, however, if I get a message and tab through to quickly find the link I know is there, all I get are the readouts of urls, which are not helpful at all. If I read through the message, I hear the actual English text, not the url, but that is inefficient as heck, since in a lot of instances, I know there are titles to stories, for instance in a newsletter, that I want to flip through, rather than listening to them all plus the blurbs after each one.


I hope this description makes sense. What can I do to get my tabbing to read the link label in English as it does when you read straight through, rather than read the html http:// stuff?


Mary






 

See this topic I posted in the Chat Subgroup earlier today:  
eM Client Email Client
Anyone can read the archive online, so you'll be able to see it whether you've joined the Chat Subgroup or not.
--

Brian - Windows 10 Pro, 64-Bit, Version 1909, Build 18363  

Power is being told you're not loved and not being destroyed by it.

       ~ Madonna

 

 


Stephen
 

The truth is out there.

----- Original Message -----
From: Henk Mulder <teakevw@gmail.com>
Reply-To: <nvda@nvda.groups.io>
To: <nvda@nvda.groups.io>
Sent: 4/18/2020 2:05:43 AM
Subject: Re: [nvda] links in email with thunderbird
________________________________________________________________________________

Hi Mary,

I think this also has to do with the extra chatter in the statusbar.
If I open a mail with the statusbar disabled, then NVDA will read the
label of the link when I tab to it. If I enable the statusbar and tab to
a link, then the URL is shown in the statusbar, and that is what's being
read.
So I think that disabling the statusbar will solve your problem.
Note that, if messages are opened in a new window, it will not
automatically use the same setting as for the main window of
Thunderbird. Therefore you might have to adjust this setting for (1) the
main window, (2) the window for reading messages, and (3) the window for
composing messages.

Best,
Henk

Op 17/04/2020 om 17:16 schreef Mary Otten:
Hi all,


Until this most recent update to T-bird, the one that started the
thread on all that extra chatter, it had been the case that if you
opened a message and read it, or if you tabbed through the open
message looking for links, those links which had English text
associated with the url would announce the same way, i.e. the English
text, not the http:// etc would be spoken by NVDA. Now, however, if I
get a message and tab through to quickly find the link I know is
there, all I get are the readouts of urls, which are not helpful at
all. If I read through the message, I hear the actual English text,
not the url, but that is inefficient as heck, since in a lot of
instances, I know there are titles to stories, for instance in a
newsletter, that I want to flip through, rather than listening to them
all plus the blurbs after each one.


I hope this description makes sense. What can I do to get my tabbing
to read the link label in English as it does when you read straight
through, rather than read the html http:// stuff?


Mary





Mary Otten
 

Henk,


Your advice to turn off the status bar when reading a mail message, so that you can tab through and get intelligible links worked like a charm. Thanks again!


Mary

On 4/17/2020 9:05 AM, Henk Mulder wrote:
Hi Mary,

I think this also has to do with the extra chatter in the statusbar.
If I open a mail with the statusbar disabled, then NVDA will read the label of the link when I tab to it. If I enable the statusbar and tab to a link, then the URL is shown in the statusbar, and that is what's being read.
So I think that disabling the statusbar will solve your problem.
Note that, if messages are opened in a new window, it will not automatically use the same setting as for the main window of Thunderbird. Therefore you might have to adjust this setting for (1) the main window, (2) the window for reading messages, and (3) the window for composing messages.

Best,
Henk

Op 17/04/2020 om 17:16 schreef Mary Otten:
Hi all,


Until this most recent update to T-bird, the one that started the thread on all that extra chatter, it had been the case that if you opened a message and read it, or if you tabbed through the open message looking for links, those links which had English text associated with the url would announce the same way, i.e. the English text, not the http:// etc would be spoken by NVDA. Now, however, if I get a message and tab through to quickly find the link I know is there, all I get are the readouts of urls, which are not helpful at all. If I read through the message, I hear the actual English text, not the url, but that is inefficient as heck, since in a lot of instances, I know there are titles to stories, for instance in a newsletter, that I want to flip through, rather than listening to them all plus the blurbs after each one.


I hope this description makes sense. What can I do to get my tabbing to read the link label in English as it does when you read straight through, rather than read the html http:// stuff?


Mary






Gene
 

But its good to keep the k command in mind.  I’ve seen times on web pages where links read more intelligibly when you use the k command than when you tab.  Also, if you just want to move by link, you will do so and all other controls will be skipped.  In addition, I’ve seen pages where, when you tab, you lose your place on the page and you don’t with k.
 
Gene
-
----
Original Message -----

From: Mary Otten
Sent: Friday, April 17, 2020 6:23 PM
Subject: Re: [nvda] links in email with thunderbird
 
Henk,


Your advice to turn off the status bar when reading a mail message, so
that you can tab through and get intelligible links worked like a charm.
Thanks again!


Mary

On 4/17/2020 9:05 AM, Henk Mulder wrote:
> Hi Mary,
>
> I think this also has to do with the extra chatter in the statusbar.
> If I open a mail with the statusbar disabled, then NVDA will read the
> label of the link when I tab to it. If I enable the statusbar and tab
> to a link, then the URL is shown in the statusbar, and that is what's
> being read.
> So I think that disabling the statusbar will solve your problem.
> Note that, if messages are opened in a new window, it will not
> automatically use the same setting as for the main window of
> Thunderbird. Therefore you might have to adjust this setting for (1)
> the main window, (2) the window for reading messages, and (3) the
> window for composing messages.
>
> Best,
> Henk
>
> Op 17/04/2020 om 17:16 schreef Mary Otten:
>> Hi all,
>>
>>
>> Until this most recent update to T-bird, the one that started the
>> thread on all that extra chatter, it had been the case that if you
>> opened a message and read it, or if you tabbed through the open
>> message looking for links, those links which had English text
>> associated with the url would announce the same way, i.e. the English
>> text, not the http:// etc would be spoken by NVDA. Now, however, if I
>> get a message and tab through to quickly find the link I know is
>> there, all I get are the readouts of urls, which are not helpful at
>> all. If I read through the message, I hear the actual English text,
>> not the url, but that is inefficient as heck, since in a lot of
>> instances, I know there are titles to stories, for instance in a
>> newsletter, that I want to flip through, rather than listening to
>> them all plus the blurbs after each one.
>>
>>
>> I hope this description makes sense. What can I do to get my tabbing
>> to read the link label in English as it does when you read straight
>> through, rather than read the html http:// stuff?
>>
>>
>> Mary
>>
>>
>>
>>
>>
>
>
>
>