Make NVDA speak certain character


Edhoari Setiyoso
 

Hi,

It's me again :) I still trying to get used with NVDA and could youe some help

I review a code with Visual Studio Code and can't get NVDA to spell the "-" operator when I press numpad 8 or up/down arrow keys. Therefore I have to traverse per character to hear if thera re any dash character in certain line. Tried with Notepas++ with same result.

It's a arithmetic operator and important for me to have it read correctly.

Any help would be appreciated

Best Regards

--
Edhoari Setiyoso
edhoari <dot> s [at] gmail <dot> com


Edhoari Setiyoso
 

FYI

I'm using latest NVDA 2017.4 on Windows 10 x64 (I doubt OS version has anything to do with this).

To summarize, I want to know how to make NVDA do not skip certain character while reading a line.

a = b - c

I only hear "a equals b c" from equation above. While it should be "a equals b minus c".

Best Regards

Edhoari Setiyoso
edhoari <dot> s [at] gmail <dot> com

On 04-Jan-18 1:54 PM, Edhoari Setiyoso wrote:
Hi,

It's me again :) I still trying to get used with NVDA and could youe some help

I review a code with Visual Studio Code and can't get NVDA to spell the "-" operator when I press numpad 8 or up/down arrow keys. Therefore I have to traverse per character to hear if thera re any dash character in certain line. Tried with Notepas++ with same result.

It's a arithmetic operator and important for me to have it read correctly.

Any help would be appreciated

Best Regards


Tyler Spivey
 

Hi.
To fix this, you can press NVDA+p to increase your symbol level. Each
higher level includes more characters. Set it to most and the dash
should speak.
If this speaks too many characters you don't want, you can use the
Punctuation/symbol pronunciation dialog to adjust what gets spoken at
each level.

On 1/4/2018 12:14 AM, Edhoari Setiyoso wrote:
FYI

I'm using latest NVDA 2017.4 on Windows 10 x64 (I doubt OS version has
anything to do with this).

To summarize, I want to know how to make NVDA do not skip certain
character while reading a line.

a = b - c

I only hear "a equals b c" from equation above. While it should be "a
equals b minus c".

Best Regards

Edhoari Setiyoso
edhoari <dot> s [at] gmail <dot> com

On 04-Jan-18 1:54 PM, Edhoari Setiyoso wrote:
Hi,

It's me again :) I still trying to get used with NVDA and could youe
some help

I review a code with Visual Studio Code and can't get NVDA to spell
the "-" operator when I press numpad 8 or up/down arrow keys.
Therefore I have to traverse per character to hear if thera re any
dash character in certain line. Tried with Notepas++ with same result.

It's a arithmetic operator and important for me to have it read
correctly.

Any help would be appreciated

Best Regards



Edhoari Setiyoso
 

Hi Tyler,

That did the trick. Thanks

Best Regards

Edhoari Setiyoso
edhoari <dot> s [at] gmail <dot> com

On 04-Jan-18 3:33 PM, Tyler Spivey wrote:
Hi.
To fix this, you can press NVDA+p to increase your symbol level. Each
higher level includes more characters. Set it to most and the dash
should speak.
If this speaks too many characters you don't want, you can use the
Punctuation/symbol pronunciation dialog to adjust what gets spoken at
each level.

On 1/4/2018 12:14 AM, Edhoari Setiyoso wrote:
FYI

I'm using latest NVDA 2017.4 on Windows 10 x64 (I doubt OS version has
anything to do with this).

To summarize, I want to know how to make NVDA do not skip certain
character while reading a line.

a = b - c

I only hear "a equals b c" from equation above. While it should be "a
equals b minus c".

Best Regards

Edhoari Setiyoso
edhoari <dot> s [at] gmail <dot> com

On 04-Jan-18 1:54 PM, Edhoari Setiyoso wrote:
Hi,

It's me again :) I still trying to get used with NVDA and could youe
some help

I review a code with Visual Studio Code and can't get NVDA to spell
the "-" operator when I press numpad 8 or up/down arrow keys.
Therefore I have to traverse per character to hear if thera re any
dash character in certain line. Tried with Notepas++ with same result.

It's a arithmetic operator and important for me to have it read
correctly.

Any help would be appreciated

Best Regards


Brian's Mail list account <bglists@...>
 

Have a look at the punctuation dialogue in nvdas preferences. I just made this read it as dashc, and I'd imagine if you can live with minus instead of dash you could make it say that.
The key is the punctuationlevel setting here, some will normally allow it to be spoken when cursoring down or up a line of code. one needs to be a little carful though as minus also exists in the table. Try playing with it on a portable version before you commit to it in the installed one.
Brian

bglists@blueyonder.co.uk
Sent via blueyonder.
Please address personal email to:-
briang1@blueyonder.co.uk, putting 'Brian Gaff'
in the display name field.

----- Original Message -----
From: "Edhoari Setiyoso" <edhoari.s@gmail.com>
To: <nvda@nvda.groups.io>
Sent: Thursday, January 04, 2018 8:14 AM
Subject: Re: [nvda] Make NVDA speak certain character


FYI

I'm using latest NVDA 2017.4 on Windows 10 x64 (I doubt OS version has anything to do with this).

To summarize, I want to know how to make NVDA do not skip certain character while reading a line.

a = b - c

I only hear "a equals b c" from equation above. While it should be "a equals b minus c".

Best Regards

Edhoari Setiyoso
edhoari <dot> s [at] gmail <dot> com

On 04-Jan-18 1:54 PM, Edhoari Setiyoso wrote:
Hi,

It's me again :) I still trying to get used with NVDA and could youe some help

I review a code with Visual Studio Code and can't get NVDA to spell the "-" operator when I press numpad 8 or up/down arrow keys. Therefore I have to traverse per character to hear if thera re any dash character in certain line. Tried with Notepas++ with same result.

It's a arithmetic operator and important for me to have it read correctly.

Any help would be appreciated

Best Regards


Quentin Christensen
 

Jumping in late, but what everyone else said is excellent.  All I would add is that for a program like Visual Studio where you will want to hear every symbol read generally, you might consider creating a configuration profile.  Basically, once you've started VS, open the NVDA menu and select configuration profiles from the main menu.  Create a new profile and set it to be triggered automatically by the current program.  Then any changes you make - such as changing the punctuation level - will be changed for that program specifically.  That way you can read the newspaper without every piece of punctuation read out, but alt+tab back to your code and have every symbol read without needing to change anything on the fly.

Regards

Quentin.

On Thu, Jan 4, 2018 at 9:04 PM, Brian's Mail list account via Groups.Io <bglists@...> wrote:
Have a look at the punctuation dialogue in nvdas preferences. I just made this read it as dashc, and I'd imagine if you can live with minus instead of dash you could make it say that.
The key is the punctuationlevel setting here, some will normally allow it to be spoken when cursoring down or up a line of code. one needs to be a little carful though as minus also exists in the table. Try playing with it on a portable version before you commit to it in the installed one.
Brian

bglists@...
Sent via blueyonder.
Please address personal email to:-
briang1@..., putting 'Brian Gaff'
in the display name field.
----- Original Message ----- From: "Edhoari Setiyoso" <edhoari.s@...>
To: <nvda@nvda.groups.io>
Sent: Thursday, January 04, 2018 8:14 AM
Subject: Re: [nvda] Make NVDA speak certain character


FYI

I'm using latest NVDA 2017.4 on Windows 10 x64 (I doubt OS version has anything to do with this).

To summarize, I want to know how to make NVDA do not skip certain character while reading a line.

a = b - c

I only hear "a equals b c" from equation above. While it should be "a equals b minus c".

Best Regards

Edhoari Setiyoso
edhoari <dot> s [at] gmail <dot> com

On 04-Jan-18 1:54 PM, Edhoari Setiyoso wrote:
Hi,

It's me again :) I still trying to get used with NVDA and could youe some help

I review a code with Visual Studio Code and can't get NVDA to spell the "-" operator when I press numpad 8 or up/down arrow keys. Therefore I have to traverse per character to hear if thera re any dash character in certain line. Tried with Notepas++ with same result.

It's a arithmetic operator and important for me to have it read correctly.

Any help would be appreciated

Best Regards












--
Quentin Christensen
Training and Support Manager

Official NVDA Training modules and expert certification now available: http://www.nvaccess.org/shop/

Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess