Topics

silencing certain reading of tables in NVDA


Sarah k Alawami
 

I think I’ve noticed this as well in programs such as excel. I’ll find out in a few weeks when I have to use it to make a report.

 

Tc all.

 

Sarah Alawami, owner of TFfP. We are also on lbry as well.

 

Stay in touch with us via our discord. This is an easier way to both contact us, and get to know your fellow listeners.

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Louise Pfau
Sent: Wednesday, January 27, 2021 3:03 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] silencing certain reading of tables in NVDA

 

Hi.  I've noticed that when you turn off cell coordinates as described, it completely silences the reading of blank cells in Microsoft Excel spreadsheets.  Cells which contain data are read.  I had to turn it back on.  I don't know if the same thing happens in other programs with a tabular structure.

Thanks,

Louise


Andre Fisher
 

Again, this is where configuration profiles would come in handy. You could have this on for Excel, but off for your web browser.


Louise Pfau
 

Hi.  I've noticed that when you turn off cell coordinates as described, it completely silences the reading of blank cells in Microsoft Excel spreadsheets.  Cells which contain data are read.  I had to turn it back on.  I don't know if the same thing happens in other programs with a tabular structure.

Thanks,

Louise


Andre Fisher
 

Hi.

Turn off row and column headers in the same document formatting settings in which you turn off the cell coordinates. That should fix your issue, and, of course, you can make good use of profiles for further customisation.


Bob Cavanaugh
 

Hi all,
Okay this is kind of a weird problem, and one that has just cropped up
in the last few months as Wikipedia has reformatted the table at the
top of their radio station articles. The table appears as follows:
First five or six rows read fine, column and row reports are a bit
annoying but I know how to turn those off if wanted.
The next row contains murged columns with the subheading programming.
The next several rows contain the programming information, reading
that before every row and column announcement.
Then another set of murged columns, this one saying ownership. Again,
NVDA reads these with the subheadings after every column.
Then it's history, technical information, and links. So, by the time
you get to the end of the table, you have NVDA saying "row 24 links
technical information history ownership programming" before it gets to
the actual information in the table. As I said, I know how to turn off
row and column reporting if desired, but how do I stop NVDA from
reading all these subheadings in every row and column of the table?
Bob