Topics

prevent pages from refreshing


Davy Cuppens
 

Hi folks
 
Is there a way in nvda that one can prevent pages from being constantly refreshed? In my professional sr Cobra I have a shortcut s in virtual mode so that pags become static and focus won’t jump to the front of it.
 
Regards
Davy


Mallard
 

Hello Davy,

I started this topic more than once, and even last week or ten days ago. I was told that "I was describing a way Firefox behaves on my machine", and that if this had been a problem for more people than myself, there would be ah uge number of messages on this (or soemthing to that ilk).

Clearly, this is an issue that NVDA should find a way of solving, one way or another. This constant refiesching of webpages is nnoying, and prevents one from working correctly.

Other screen readers have a way of blocking this, so it MUST be possible.

I'd hate to have to go back to commercial screen readers because of this issue, because more and moe web pages seem to be employing this horrible technology (Carousels, or whatever they call them).

Thanks for beinging this up again.
Hopefully, since there are now tro of us, someone will take a minute to look into this.
Ciao,
Ollie

Il 25/03/2016 17:34, Davy Cuppens ha scritto:
Hi folks
Is there a way in nvda that one can prevent pages from being constantly refreshed? In my professional sr Cobra I have a shortcut s in virtual mode so that pags become static and focus won’t jump to the front of it.
Regards
Davy


Gene
 

I don't know what Cobra is.  I can say that in Firefox, there is a setting to stop the browser from refreshing.  I don't know what effect the setting has on structures such as carousels.  Nor do I know if what is going on has the same or a similar cause because I don't know what is being described as refreshing in today's message. 
 
If you use firefox, in the main window, press alt, then press t, wait a moment then o.
Tab once after waiting a moment.
down arrow to advanced.
If you get stuck partway down the list, up arrow then continue down again to get you unstuck.
Once you get to advanced, start tabbing.  You will see a check box about notifying you if Firefox is being redirected or refreshing a page.  That isn't the exact wording but it's there and my description should allow you to kno it.  Check the check box.  There is no ok button.  Continue using firefox now.  Or close it if you wish. 
 
You may find that you get one such message when a page wants to do something and nothing more during that session of working on the page. You don't have to worry about closing such messages.  They don't block anything and will be replaced automaticaally with future messages. 
 
As far as commercial screen-readers are concerned, while they have features to stop refreshes, I don't know if they work in all cases.  I have found times in the past when the JAWS feature didn't work when confronted by some kinds of page refreshes.
 
Gene

----- Original Message -----
From: Mallard
Sent: Friday, March 25, 2016 2:07 PM
Subject: Re: [nvda] prevent pages from refreshing


Hello Davy,

I started this topic more than once, and even last week or ten days ago.
I was told that "I was describing a way Firefox behaves on my machine",
and that if this had been a problem for more people than myself, there
would be ah uge number of messages on this (or soemthing to that ilk).

Clearly, this is an issue that NVDA should find a way of solving, one
way or another. This constant refiesching of webpages is nnoying, and
prevents one from working correctly.

Other screen readers have a way of blocking this, so it MUST be possible.

I'd hate to have to go back to commercial screen readers because of this
issue, because more and moe web pages seem to be employing this horrible
technology (Carousels, or whatever they call them).

Thanks for beinging this up again.
Hopefully, since there are now tro of us, someone will take a minute to
look into this.
Ciao,
Ollie



Il 25/03/2016 17:34, Davy Cuppens ha scritto:
> Hi folks
> Is there a way in nvda that one can prevent pages from being
> constantly refreshed? In my professional sr Cobra I have a shortcut s
> in virtual mode so that pags become static and focus won’t jump to the
> front of it.
> Regards
> Davy
>





Davy Cuppens
 

I am very disappointed to read this all.

Indeed, this is a disadvantage of NVDA; just like you I would like to urge developers to work on this as quick as possible.
Regards
Davy

-----Oorspronkelijk bericht-----
From: Mallard
Sent: Friday, March 25, 2016 8:07 PM
To: nvda@groups.io
Subject: Re: [nvda] prevent pages from refreshing


Hello Davy,

I started this topic more than once, and even last week or ten days ago.
I was told that "I was describing a way Firefox behaves on my machine",
and that if this had been a problem for more people than myself, there
would be ah uge number of messages on this (or soemthing to that ilk).

Clearly, this is an issue that NVDA should find a way of solving, one
way or another. This constant refiesching of webpages is nnoying, and
prevents one from working correctly.

Other screen readers have a way of blocking this, so it MUST be possible.

I'd hate to have to go back to commercial screen readers because of this
issue, because more and moe web pages seem to be employing this horrible
technology (Carousels, or whatever they call them).

Thanks for beinging this up again.
Hopefully, since there are now tro of us, someone will take a minute to
look into this.
Ciao,
Ollie



Il 25/03/2016 17:34, Davy Cuppens ha scritto:
Hi folks
Is there a way in nvda that one can prevent pages from being constantly refreshed? In my professional sr Cobra I have a shortcut s in virtual mode so that pags become static and focus won’t jump to the front of it.
Regards
Davy


Davy Cuppens
 

Gene
 
Cobra is the screen reader from www.baum.de a German company for assistive technologies for the blind.
Regards
Davy
 

From: Gene
Sent: Friday, March 25, 2016 8:24 PM
Subject: Re: [nvda] prevent pages from refreshing
 
I don't know what Cobra is.  I can say that in Firefox, there is a setting to stop the browser from refreshing.  I don't know what effect the setting has on structures such as carousels.  Nor do I know if what is going on has the same or a similar cause because I don't know what is being described as refreshing in today's message. 
 
If you use firefox, in the main window, press alt, then press t, wait a moment then o.
Tab once after waiting a moment.
down arrow to advanced.
If you get stuck partway down the list, up arrow then continue down again to get you unstuck.
Once you get to advanced, start tabbing.  You will see a check box about notifying you if Firefox is being redirected or refreshing a page.  That isn't the exact wording but it's there and my description should allow you to kno it.  Check the check box.  There is no ok button.  Continue using firefox now.  Or close it if you wish. 
 
You may find that you get one such message when a page wants to do something and nothing more during that session of working on the page. You don't have to worry about closing such messages.  They don't block anything and will be replaced automaticaally with future messages.
 
As far as commercial screen-readers are concerned, while they have features to stop refreshes, I don't know if they work in all cases.  I have found times in the past when the JAWS feature didn't work when confronted by some kinds of page refreshes.
 
Gene
----- Original Message -----
From: Mallard
Sent: Friday, March 25, 2016 2:07 PM
Subject: Re: [nvda] prevent pages from refreshing
 

Hello Davy,

I started this topic more than once, and even last week or ten days ago.
I was told that "I was describing a way Firefox behaves on my machine",
and that if this had been a problem for more people than myself, there
would be ah uge number of messages on this (or soemthing to that ilk).

Clearly, this is an issue that NVDA should find a way of solving, one
way or another. This constant refiesching of webpages is nnoying, and
prevents one from working correctly.

Other screen readers have a way of blocking this, so it MUST be possible.

I'd hate to have to go back to commercial screen readers because of this
issue, because more and moe web pages seem to be employing this horrible
technology (Carousels, or whatever they call them).

Thanks for beinging this up again.
Hopefully, since there are now tro of us, someone will take a minute to
look into this.
Ciao,
Ollie



Il 25/03/2016 17:34, Davy Cuppens ha scritto:
> Hi folks
> Is there a way in nvda that one can prevent pages from being
> constantly refreshed? In my professional sr Cobra I have a shortcut s
> in virtual mode so that pags become static and focus won’t jump to the
> front of it.
> Regards
> Davy
>





Lino Morales
 

I agree. There is a website that I hve that problem with page refreshing. If JFW can support it NVDA should by now.

On 3/26/2016 8:11 AM, Davy Cuppens wrote:
I am very disappointed to read this all.

Indeed, this is a disadvantage of NVDA; just like you I would like to urge developers to work on this as quick as possible.
Regards
Davy

-----Oorspronkelijk bericht----- From: Mallard
Sent: Friday, March 25, 2016 8:07 PM
To: nvda@groups.io
Subject: Re: [nvda] prevent pages from refreshing


Hello Davy,

I started this topic more than once, and even last week or ten days ago.
I was told that "I was describing a way Firefox behaves on my machine",
and that if this had been a problem for more people than myself, there
would be ah uge number of messages on this (or soemthing to that ilk).

Clearly, this is an issue that NVDA should find a way of solving, one
way or another. This constant refiesching of webpages is nnoying, and
prevents one from working correctly.

Other screen readers have a way of blocking this, so it MUST be possible.

I'd hate to have to go back to commercial screen readers because of this
issue, because more and moe web pages seem to be employing this horrible
technology (Carousels, or whatever they call them).

Thanks for beinging this up again.
Hopefully, since there are now tro of us, someone will take a minute to
look into this.
Ciao,
Ollie



Il 25/03/2016 17:34, Davy Cuppens ha scritto:
Hi folks
Is there a way in nvda that one can prevent pages from being constantly refreshed? In my professional sr Cobra I have a shortcut s in virtual mode so that pags become static and focus won’t jump to the front of it.
Regards
Davy





Chris Mullins
 

Does the NVDA+4 on the number row make any difference?

Cheers
Chris

-----Original Message-----
From: Davy Cuppens [mailto:davycuppens@...]
Sent: 26 March 2016 12:11
To: nvda@groups.io
Subject: Re: [nvda] prevent pages from refreshing

I am very disappointed to read this all.

Indeed, this is a disadvantage of NVDA; just like you I would like to urge developers to work on this as quick as possible.
Regards
Davy

-----Oorspronkelijk bericht-----
From: Mallard
Sent: Friday, March 25, 2016 8:07 PM
To: nvda@groups.io
Subject: Re: [nvda] prevent pages from refreshing


Hello Davy,

I started this topic more than once, and even last week or ten days ago.
I was told that "I was describing a way Firefox behaves on my machine",
and that if this had been a problem for more people than myself, there
would be ah uge number of messages on this (or soemthing to that ilk).

Clearly, this is an issue that NVDA should find a way of solving, one
way or another. This constant refiesching of webpages is nnoying, and
prevents one from working correctly.

Other screen readers have a way of blocking this, so it MUST be possible.

I'd hate to have to go back to commercial screen readers because of this
issue, because more and moe web pages seem to be employing this horrible
technology (Carousels, or whatever they call them).

Thanks for beinging this up again.
Hopefully, since there are now tro of us, someone will take a minute to
look into this.
Ciao,
Ollie



Il 25/03/2016 17:34, Davy Cuppens ha scritto:
Hi folks
Is there a way in nvda that one can prevent pages from being constantly
refreshed? In my professional sr Cobra I have a shortcut s in virtual mode
so that pags become static and focus won’t jump to the front of it.
Regards
Davy


Pete <emac00@...>
 

What happens when escape is pressed?
May be not good probably have to keep pressing it.
Pete


Mallard
 

...And Cobra, just like Jaws, has been around for quite a while.
Threfore, I suppose, NVDA should be able to face this issue and solve it too.

I really find it strange (and disappointing) that, in spite of my bringing this up a few times, at different moments, nobody ever gave a REAL reply.
I hope that now, with a few more people complaining about this issue, it will be taken seriously and tackled once and for all.

Ciao,
Ollie

Il 26/03/2016 13:20, Davy Cuppens ha scritto:
Gene
Cobra is the screen reader from www.baum.de <http://www.baum.de> a German company for assistive technologies for the blind.
Regards
Davy
*From:* Gene <mailto:gsasner@...>
*Sent:* Friday, March 25, 2016 8:24 PM
*To:* nvda@groups.io <mailto:nvda@groups.io>
*Subject:* Re: [nvda] prevent pages from refreshing
I don't know what Cobra is. I can say that in Firefox, there is a setting to stop the browser from refreshing. I don't know what effect the setting has on structures such as carousels. Nor do I know if what is going on has the same or a similar cause because I don't know what is being described as refreshing in today's message.
If you use firefox, in the main window, press alt, then press t, wait a moment then o.
Tab once after waiting a moment.
down arrow to advanced.
If you get stuck partway down the list, up arrow then continue down again to get you unstuck.
Once you get to advanced, start tabbing. You will see a check box about notifying you if Firefox is being redirected or refreshing a page. That isn't the exact wording but it's there and my description should allow you to kno it. Check the check box. There is no ok button. Continue using firefox now. Or close it if you wish.
You may find that you get one such message when a page wants to do something and nothing more during that session of working on the page. You don't have to worry about closing such messages. They don't block anything and will be replaced automaticaally with future messages.
As far as commercial screen-readers are concerned, while they have features to stop refreshes, I don't know if they work in all cases. I have found times in the past when the JAWS feature didn't work when confronted by some kinds of page refreshes.
Gene
----- Original Message -----
*From:* Mallard <mailto:mallard@...>
*Sent:* Friday, March 25, 2016 2:07 PM
*To:* nvda@groups.io <mailto:nvda@groups.io>
*Subject:* Re: [nvda] prevent pages from refreshing

Hello Davy,

I started this topic more than once, and even last week or ten days ago.
I was told that "I was describing a way Firefox behaves on my machine",
and that if this had been a problem for more people than myself, there
would be ah uge number of messages on this (or soemthing to that ilk).

Clearly, this is an issue that NVDA should find a way of solving, one
way or another. This constant refiesching of webpages is nnoying, and
prevents one from working correctly.

Other screen readers have a way of blocking this, so it MUST be possible.

I'd hate to have to go back to commercial screen readers because of this
issue, because more and moe web pages seem to be employing this horrible
technology (Carousels, or whatever they call them).

Thanks for beinging this up again.
Hopefully, since there are now tro of us, someone will take a minute to
look into this.
Ciao,
Ollie



Il 25/03/2016 17:34, Davy Cuppens ha scritto:
Hi folks
Is there a way in nvda that one can prevent pages from being
constantly refreshed? In my professional sr Cobra I have a shortcut s
in virtual mode so that pags become static and focus won’t jump to the
front of it.
Regards
Davy




Mallard
 

Davy,

Don't talk to me about disappointment on this topic! lool

Between this and the loss of braille within Adobe Digital Editions, which everybody seems to be ignoring, I'm more than disappointed: I'm worried I'll have to instal another screen reader alongside NVDA...

Ciao,
Ollie

Il 26/03/2016 13:11, Davy Cuppens ha scritto:
I am very disappointed to read this all.

Indeed, this is a disadvantage of NVDA; just like you I would like to urge developers to work on this as quick as possible.
Regards
Davy

-----Oorspronkelijk bericht----- From: Mallard
Sent: Friday, March 25, 2016 8:07 PM
To: nvda@groups.io
Subject: Re: [nvda] prevent pages from refreshing


Hello Davy,

I started this topic more than once, and even last week or ten days ago.
I was told that "I was describing a way Firefox behaves on my machine",
and that if this had been a problem for more people than myself, there
would be ah uge number of messages on this (or soemthing to that ilk).

Clearly, this is an issue that NVDA should find a way of solving, one
way or another. This constant refiesching of webpages is nnoying, and
prevents one from working correctly.

Other screen readers have a way of blocking this, so it MUST be possible.

I'd hate to have to go back to commercial screen readers because of this
issue, because more and moe web pages seem to be employing this horrible
technology (Carousels, or whatever they call them).

Thanks for beinging this up again.
Hopefully, since there are now tro of us, someone will take a minute to
look into this.
Ciao,
Ollie



Il 25/03/2016 17:34, Davy Cuppens ha scritto:
Hi folks
Is there a way in nvda that one can prevent pages from being constantly refreshed? In my professional sr Cobra I have a shortcut s in virtual mode so that pags become static and focus won’t jump to the front of it.
Regards
Davy






Mallard
 

Chris,

I don't know this command... I'll try and report back.
Ciao,
Ollie

Il 26/03/2016 14:25, Chris Mullins ha scritto:
Does the NVDA+4 on the number row make any difference?

Cheers
Chris

-----Original Message-----
From: Davy Cuppens [mailto:davycuppens@...]
Sent: 26 March 2016 12:11
To: nvda@groups.io
Subject: Re: [nvda] prevent pages from refreshing

I am very disappointed to read this all.

Indeed, this is a disadvantage of NVDA; just like you I would like to urge developers to work on this as quick as possible.
Regards
Davy

-----Oorspronkelijk bericht-----
From: Mallard
Sent: Friday, March 25, 2016 8:07 PM
To: nvda@groups.io
Subject: Re: [nvda] prevent pages from refreshing


Hello Davy,

I started this topic more than once, and even last week or ten days ago.
I was told that "I was describing a way Firefox behaves on my machine",
and that if this had been a problem for more people than myself, there
would be ah uge number of messages on this (or soemthing to that ilk).

Clearly, this is an issue that NVDA should find a way of solving, one
way or another. This constant refiesching of webpages is nnoying, and
prevents one from working correctly.

Other screen readers have a way of blocking this, so it MUST be possible.

I'd hate to have to go back to commercial screen readers because of this
issue, because more and moe web pages seem to be employing this horrible
technology (Carousels, or whatever they call them).

Thanks for beinging this up again.
Hopefully, since there are now tro of us, someone will take a minute to
look into this.
Ciao,
Ollie



Il 25/03/2016 17:34, Davy Cuppens ha scritto:
Hi folks
Is there a way in nvda that one can prevent pages from being constantly
refreshed? In my professional sr Cobra I have a shortcut s in virtual mode
so that pags become static and focus won’t jump to the front of it.
Regards
Davy








Lino Morales
 

I agree Duck. I've been asking off and on like and no replies.

On 3/26/2016 10:02 AM, Mallard wrote:
...And Cobra, just like Jaws, has been around for quite a while.
Threfore, I suppose, NVDA should be able to face this issue and solve it too.

I really find it strange (and disappointing) that, in spite of my bringing this up a few times, at different moments, nobody ever gave a REAL reply.
I hope that now, with a few more people complaining about this issue, it will be taken seriously and tackled once and for all.

Ciao,
Ollie




Il 26/03/2016 13:20, Davy Cuppens ha scritto:
Gene
Cobra is the screen reader from www.baum.de <http://www.baum.de> a German company for assistive technologies for the blind.
Regards
Davy
*From:* Gene <mailto:gsasner@...>
*Sent:* Friday, March 25, 2016 8:24 PM
*To:* nvda@groups.io <mailto:nvda@groups.io>
*Subject:* Re: [nvda] prevent pages from refreshing
I don't know what Cobra is. I can say that in Firefox, there is a setting to stop the browser from refreshing. I don't know what effect the setting has on structures such as carousels. Nor do I know if what is going on has the same or a similar cause because I don't know what is being described as refreshing in today's message.
If you use firefox, in the main window, press alt, then press t, wait a moment then o.
Tab once after waiting a moment.
down arrow to advanced.
If you get stuck partway down the list, up arrow then continue down again to get you unstuck.
Once you get to advanced, start tabbing. You will see a check box about notifying you if Firefox is being redirected or refreshing a page. That isn't the exact wording but it's there and my description should allow you to kno it. Check the check box. There is no ok button. Continue using firefox now. Or close it if you wish.
You may find that you get one such message when a page wants to do something and nothing more during that session of working on the page. You don't have to worry about closing such messages. They don't block anything and will be replaced automaticaally with future messages.
As far as commercial screen-readers are concerned, while they have features to stop refreshes, I don't know if they work in all cases. I have found times in the past when the JAWS feature didn't work when confronted by some kinds of page refreshes.
Gene
----- Original Message -----
*From:* Mallard <mailto:mallard@...>
*Sent:* Friday, March 25, 2016 2:07 PM
*To:* nvda@groups.io <mailto:nvda@groups.io>
*Subject:* Re: [nvda] prevent pages from refreshing

Hello Davy,

I started this topic more than once, and even last week or ten days ago.
I was told that "I was describing a way Firefox behaves on my machine",
and that if this had been a problem for more people than myself, there
would be ah uge number of messages on this (or soemthing to that ilk).

Clearly, this is an issue that NVDA should find a way of solving, one
way or another. This constant refiesching of webpages is nnoying, and
prevents one from working correctly.

Other screen readers have a way of blocking this, so it MUST be possible.

I'd hate to have to go back to commercial screen readers because of this
issue, because more and moe web pages seem to be employing this horrible
technology (Carousels, or whatever they call them).

Thanks for beinging this up again.
Hopefully, since there are now tro of us, someone will take a minute to
look into this.
Ciao,
Ollie



Il 25/03/2016 17:34, Davy Cuppens ha scritto:
Hi folks
Is there a way in nvda that one can prevent pages from being
constantly refreshed? In my professional sr Cobra I have a shortcut s
in virtual mode so that pags become static and focus won’t jump to the
front of it.
Regards
Davy





Gene
 

Then maybe the Cobra developers should be approached as well concerning making their browsers not refresh.  Since this is a browser developed for the blind, they have as much or more responsibility to put such a feature in their browser.  And as I said in a previous message, my recollection is that in at least one commercial screen-reader, the refresh feature cannot control refreshing under certain conditions such as when JAVA scripts trigger refreshes.  That was years ago, when I used commercial screen-readers.  But I have no idea what the situation is today.
 
Gene

----- Original Message -----
Sent: Saturday, March 26, 2016 7:20 AM
Subject: Re: [nvda] prevent pages from refreshing

Gene
 
Cobra is the screen reader from www.baum.de a German company for assistive technologies for the blind.
Regards
Davy
 
From: Gene
Sent: Friday, March 25, 2016 8:24 PM
Subject: Re: [nvda] prevent pages from refreshing
 
I don't know what Cobra is.  I can say that in Firefox, there is a setting to stop the browser from refreshing.  I don't know what effect the setting has on structures such as carousels.  Nor do I know if what is going on has the same or a similar cause because I don't know what is being described as refreshing in today's message. 
 
If you use firefox, in the main window, press alt, then press t, wait a moment then o.
Tab once after waiting a moment.
down arrow to advanced.
If you get stuck partway down the list, up arrow then continue down again to get you unstuck.
Once you get to advanced, start tabbing.  You will see a check box about notifying you if Firefox is being redirected or refreshing a page.  That isn't the exact wording but it's there and my description should allow you to kno it.  Check the check box.  There is no ok button.  Continue using firefox now.  Or close it if you wish. 
 
You may find that you get one such message when a page wants to do something and nothing more during that session of working on the page. You don't have to worry about closing such messages.  They don't block anything and will be replaced automaticaally with future messages.
 
As far as commercial screen-readers are concerned, while they have features to stop refreshes, I don't know if they work in all cases.  I have found times in the past when the JAWS feature didn't work when confronted by some kinds of page refreshes.
 
Gene
----- Original Message -----
From: Mallard
Sent: Friday, March 25, 2016 2:07 PM
Subject: Re: [nvda] prevent pages from refreshing
 

Hello Davy,

I started this topic more than once, and even last week or ten days ago.
I was told that "I was describing a way Firefox behaves on my machine",
and that if this had been a problem for more people than myself, there
would be ah uge number of messages on this (or soemthing to that ilk).

Clearly, this is an issue that NVDA should find a way of solving, one
way or another. This constant refiesching of webpages is nnoying, and
prevents one from working correctly.

Other screen readers have a way of blocking this, so it MUST be possible.

I'd hate to have to go back to commercial screen readers because of this
issue, because more and moe web pages seem to be employing this horrible
technology (Carousels, or whatever they call them).

Thanks for beinging this up again.
Hopefully, since there are now tro of us, someone will take a minute to
look into this.
Ciao,
Ollie



Il 25/03/2016 17:34, Davy Cuppens ha scritto:
> Hi folks
> Is there a way in nvda that one can prevent pages from being
> constantly refreshed? In my professional sr Cobra I have a shortcut s
> in virtual mode so that pags become static and focus won’t jump to the
> front of it.
> Regards
> Davy
>





Patrick Le Baudour
 

if it is that important, maybe you should post a ticket on the dev site ?
As it is browser-dependant, it isn't that easy... it can probably be done, but i'd guess it would be quicker to find the option for most browsers. I've done it long ago in firefox and IE.

Not sure about javascript-based refreshing, though.


-- Patrick

Le 26/03/2016 15:02, Mallard a écrit :
...And Cobra, just like Jaws, has been around for quite a while.
Threfore, I suppose, NVDA should be able to face this issue and solve it
too.

I really find it strange (and disappointing) that, in spite of my
bringing this up a few times, at different moments, nobody ever gave a
REAL reply.
I hope that now, with a few more people complaining about this issue, it
will be taken seriously and tackled once and for all.

Ciao,
Ollie




Il 26/03/2016 13:20, Davy Cuppens ha scritto:
Gene
Cobra is the screen reader from www.baum.de <http://www.baum.de> a
German company for assistive technologies for the blind.
Regards
Davy
*From:* Gene <mailto:gsasner@...>
*Sent:* Friday, March 25, 2016 8:24 PM
*To:* nvda@groups.io <mailto:nvda@groups.io>
*Subject:* Re: [nvda] prevent pages from refreshing
I don't know what Cobra is. I can say that in Firefox, there is a
setting to stop the browser from refreshing. I don't know what effect
the setting has on structures such as carousels. Nor do I know if
what is going on has the same or a similar cause because I don't know
what is being described as refreshing in today's message.
If you use firefox, in the main window, press alt, then press t, wait
a moment then o.
Tab once after waiting a moment.
down arrow to advanced.
If you get stuck partway down the list, up arrow then continue down
again to get you unstuck.
Once you get to advanced, start tabbing. You will see a check box
about notifying you if Firefox is being redirected or refreshing a
page. That isn't the exact wording but it's there and my description
should allow you to kno it. Check the check box. There is no ok
button. Continue using firefox now. Or close it if you wish.
You may find that you get one such message when a page wants to do
something and nothing more during that session of working on the page.
You don't have to worry about closing such messages. They don't block
anything and will be replaced automaticaally with future messages.
As far as commercial screen-readers are concerned, while they have
features to stop refreshes, I don't know if they work in all cases. I
have found times in the past when the JAWS feature didn't work when
confronted by some kinds of page refreshes.
Gene
----- Original Message -----
*From:* Mallard <mailto:mallard@...>
*Sent:* Friday, March 25, 2016 2:07 PM
*To:* nvda@groups.io <mailto:nvda@groups.io>
*Subject:* Re: [nvda] prevent pages from refreshing

Hello Davy,

I started this topic more than once, and even last week or ten days ago.
I was told that "I was describing a way Firefox behaves on my machine",
and that if this had been a problem for more people than myself, there
would be ah uge number of messages on this (or soemthing to that ilk).

Clearly, this is an issue that NVDA should find a way of solving, one
way or another. This constant refiesching of webpages is nnoying, and
prevents one from working correctly.

Other screen readers have a way of blocking this, so it MUST be possible.

I'd hate to have to go back to commercial screen readers because of this
issue, because more and moe web pages seem to be employing this horrible
technology (Carousels, or whatever they call them).

Thanks for beinging this up again.
Hopefully, since there are now tro of us, someone will take a minute to
look into this.
Ciao,
Ollie



Il 25/03/2016 17:34, Davy Cuppens ha scritto:
Hi folks
Is there a way in nvda that one can prevent pages from being
constantly refreshed? In my professional sr Cobra I have a shortcut s
in virtual mode so that pags become static and focus won’t jump to the
front of it.
Regards
Davy





.


Kevin Chao
 

Has anyone filed a NVDA github issue on this? If so, what's link to bug? Thanks!


On Sat, Mar 26, 2016 at 8:38 AM Patrick Le Baudour <p.lebaudour@...> wrote:
if it is that important, maybe you should post a ticket on the dev site ?
As it is browser-dependant, it isn't that easy... it can probably be
done, but i'd guess it would be quicker to find the option for most
browsers. I've done it long ago in firefox and IE.

Not sure about javascript-based refreshing, though.


-- Patrick
Le 26/03/2016 15:02, Mallard a écrit :
> ...And Cobra, just like Jaws, has been around for quite a while.
> Threfore, I suppose, NVDA should be able to face this issue and solve it
> too.
>
> I really find it strange (and disappointing) that, in spite of my
> bringing this up a few times, at different moments, nobody ever gave a
> REAL reply.
> I hope that now, with a few more people complaining about this issue, it
> will be taken seriously and tackled once and for all.
>
> Ciao,
> Ollie
>
>
>
>
> Il 26/03/2016 13:20, Davy Cuppens ha scritto:
>> Gene
>> Cobra is the screen reader from www.baum.de <http://www.baum.de> a
>> German company for assistive technologies for the blind.
>> Regards
>> Davy
>> *From:* Gene <mailto:gsasner@...>
>> *Sent:* Friday, March 25, 2016 8:24 PM
>> *To:* nvda@groups.io <mailto:nvda@groups.io>
>> *Subject:* Re: [nvda] prevent pages from refreshing
>> I don't know what Cobra is.  I can say that in Firefox, there is a
>> setting to stop the browser from refreshing.  I don't know what effect
>> the setting has on structures such as carousels.  Nor do I know if
>> what is going on has the same or a similar cause because I don't know
>> what is being described as refreshing in today's message.
>> If you use firefox, in the main window, press alt, then press t, wait
>> a moment then o.
>> Tab once after waiting a moment.
>> down arrow to advanced.
>> If you get stuck partway down the list, up arrow then continue down
>> again to get you unstuck.
>> Once you get to advanced, start tabbing.  You will see a check box
>> about notifying you if Firefox is being redirected or refreshing a
>> page.  That isn't the exact wording but it's there and my description
>> should allow you to kno it.  Check the check box.  There is no ok
>> button. Continue using firefox now.  Or close it if you wish.
>> You may find that you get one such message when a page wants to do
>> something and nothing more during that session of working on the page.
>> You don't have to worry about closing such messages.  They don't block
>> anything and will be replaced automaticaally with future messages.
>> As far as commercial screen-readers are concerned, while they have
>> features to stop refreshes, I don't know if they work in all cases.  I
>> have found times in the past when the JAWS feature didn't work when
>> confronted by some kinds of page refreshes.
>> Gene
>> ----- Original Message -----
>> *From:* Mallard <mailto:mallard@...>
>> *Sent:* Friday, March 25, 2016 2:07 PM
>> *To:* nvda@groups.io <mailto:nvda@groups.io>
>> *Subject:* Re: [nvda] prevent pages from refreshing
>>
>> Hello Davy,
>>
>> I started this topic more than once, and even last week or ten days ago.
>> I was told that "I was describing a way Firefox behaves on my machine",
>> and that if this had been a problem for more people than myself, there
>> would be ah uge number of messages on this (or soemthing to that ilk).
>>
>> Clearly, this is an issue that NVDA should find a way of solving, one
>> way or another. This constant refiesching of webpages is nnoying, and
>> prevents one from working correctly.
>>
>> Other screen readers have a way of blocking this, so it MUST be possible.
>>
>> I'd hate to have to go back to commercial screen readers because of this
>> issue, because more and moe web pages seem to be employing this horrible
>> technology (Carousels, or whatever they call them).
>>
>> Thanks for beinging this up again.
>> Hopefully, since there are now tro of us, someone will take a minute to
>> look into this.
>> Ciao,
>> Ollie
>>
>>
>>
>> Il 25/03/2016 17:34, Davy Cuppens ha scritto:
>> > Hi folks
>> > Is there a way in nvda that one can prevent pages from being
>> > constantly refreshed? In my professional sr Cobra I have a shortcut s
>> > in virtual mode so that pags become static and focus won’t jump to the
>> > front of it.
>> > Regards
>> > Davy
>> >
>>
>>
>>
>>
>>
>
>
>
>
> .
>




Gene
 

Are you referring to the setting concerning metarefresh in Internet Explorer?  I don't use Internet Explorer to any extent any more but that is the only setting I know of that may affect page refreshing.  I am also not sure if that setting has any effect on JAVA scripted refreshes.
 
Gene

----- Original Message -----
Sent: Saturday, March 26, 2016 10:38 AM
Subject: Re: [nvda] prevent pages from refreshing

if it is that important, maybe you should post a ticket on the dev site ?
As it is browser-dependant, it isn't that easy... it can probably be
done, but i'd guess it would be quicker to find the option for most
browsers. I've done it long ago in firefox and IE.

Not sure about javascript-based refreshing, though.


-- Patrick
Le 26/03/2016 15:02, Mallard a écrit :
> ...And Cobra, just like Jaws, has been around for quite a while.
> Threfore, I suppose, NVDA should be able to face this issue and solve it
> too.
>
> I really find it strange (and disappointing) that, in spite of my
> bringing this up a few times, at different moments, nobody ever gave a
> REAL reply.
> I hope that now, with a few more people complaining about this issue, it
> will be taken seriously and tackled once and for all.
>
> Ciao,
> Ollie
>
>
>
>
> Il 26/03/2016 13:20, Davy Cuppens ha scritto:
>> Gene
>> Cobra is the screen reader from www.baum.de <http://www.baum.de> a
>> German company for assistive technologies for the blind.
>> Regards
>> Davy
>> *From:* Gene <mailto:gsasner@...>
>> *Sent:* Friday, March 25, 2016 8:24 PM
>> *To:* nvda@groups.io <mailto:nvda@groups.io>
>> *Subject:* Re: [nvda] prevent pages from refreshing
>> I don't know what Cobra is.  I can say that in Firefox, there is a
>> setting to stop the browser from refreshing.  I don't know what effect
>> the setting has on structures such as carousels.  Nor do I know if
>> what is going on has the same or a similar cause because I don't know
>> what is being described as refreshing in today's message.
>> If you use firefox, in the main window, press alt, then press t, wait
>> a moment then o.
>> Tab once after waiting a moment.
>> down arrow to advanced.
>> If you get stuck partway down the list, up arrow then continue down
>> again to get you unstuck.
>> Once you get to advanced, start tabbing.  You will see a check box
>> about notifying you if Firefox is being redirected or refreshing a
>> page.  That isn't the exact wording but it's there and my description
>> should allow you to kno it.  Check the check box.  There is no ok
>> button. Continue using firefox now.  Or close it if you wish.
>> You may find that you get one such message when a page wants to do
>> something and nothing more during that session of working on the page.
>> You don't have to worry about closing such messages.  They don't block
>> anything and will be replaced automaticaally with future messages.
>> As far as commercial screen-readers are concerned, while they have
>> features to stop refreshes, I don't know if they work in all cases.  I
>> have found times in the past when the JAWS feature didn't work when
>> confronted by some kinds of page refreshes.
>> Gene
>> ----- Original Message -----
>> *From:* Mallard <mailto:mallard@...>
>> *Sent:* Friday, March 25, 2016 2:07 PM
>> *To:* nvda@groups.io <mailto:nvda@groups.io>
>> *Subject:* Re: [nvda] prevent pages from refreshing
>>
>> Hello Davy,
>>
>> I started this topic more than once, and even last week or ten days ago.
>> I was told that "I was describing a way Firefox behaves on my machine",
>> and that if this had been a problem for more people than myself, there
>> would be ah uge number of messages on this (or soemthing to that ilk).
>>
>> Clearly, this is an issue that NVDA should find a way of solving, one
>> way or another. This constant refiesching of webpages is nnoying, and
>> prevents one from working correctly.
>>
>> Other screen readers have a way of blocking this, so it MUST be possible.
>>
>> I'd hate to have to go back to commercial screen readers because of this
>> issue, because more and moe web pages seem to be employing this horrible
>> technology (Carousels, or whatever they call them).
>>
>> Thanks for beinging this up again.
>> Hopefully, since there are now tro of us, someone will take a minute to
>> look into this.
>> Ciao,
>> Ollie
>>
>>
>>
>> Il 25/03/2016 17:34, Davy Cuppens ha scritto:
>> > Hi folks
>> > Is there a way in nvda that one can prevent pages from being
>> > constantly refreshed? In my professional sr Cobra I have a shortcut s
>> > in virtual mode so that pags become static and focus won’t jump to the
>> > front of it.
>> > Regards
>> > Davy
>> >
>>
>>
>>
>>
>>
>
>
>
>
> .
>



 

Hi,

If this happens on all browsers, chances are that we the developers will need to dive into this; but if this is specific to one or two browsers, this is going to be tough to fix.

A page refresh may happen due to several reasons, namely Javascript-based, live regions, dynamic parts of pages and so on.

As for the command given, it is actually NVDA+5 (toggling dynamic content changes).

Cheers,

Joseph

 

From: Kevin Chao [mailto:kevinchao89@...]
Sent: Saturday, March 26, 2016 9:15 AM
To: nvda@groups.io
Subject: Re: [nvda] prevent pages from refreshing

 

Has anyone filed a NVDA github issue on this? If so, what's link to bug? Thanks!

 

On Sat, Mar 26, 2016 at 8:38 AM Patrick Le Baudour <p.lebaudour@...> wrote:

if it is that important, maybe you should post a ticket on the dev site ?
As it is browser-dependant, it isn't that easy... it can probably be
done, but i'd guess it would be quicker to find the option for most
browsers. I've done it long ago in firefox and IE.

Not sure about javascript-based refreshing, though.


-- Patrick
Le 26/03/2016 15:02, Mallard a écrit :
> ...And Cobra, just like Jaws, has been around for quite a while.
> Threfore, I suppose, NVDA should be able to face this issue and solve it
> too.
>
> I really find it strange (and disappointing) that, in spite of my
> bringing this up a few times, at different moments, nobody ever gave a
> REAL reply.
> I hope that now, with a few more people complaining about this issue, it
> will be taken seriously and tackled once and for all.
>
> Ciao,
> Ollie
>
>
>
>
> Il 26/03/2016 13:20, Davy Cuppens ha scritto:
>> Gene
>> Cobra is the screen reader from www.baum.de <http://www.baum.de> a
>> German company for assistive technologies for the blind.
>> Regards
>> Davy
>> *From:* Gene <mailto:gsasner@...>
>> *Sent:* Friday, March 25, 2016 8:24 PM
>> *To:* nvda@groups.io <mailto:nvda@groups.io>
>> *Subject:* Re: [nvda] prevent pages from refreshing
>> I don't know what Cobra is.  I can say that in Firefox, there is a
>> setting to stop the browser from refreshing.  I don't know what effect
>> the setting has on structures such as carousels.  Nor do I know if
>> what is going on has the same or a similar cause because I don't know
>> what is being described as refreshing in today's message.
>> If you use firefox, in the main window, press alt, then press t, wait
>> a moment then o.
>> Tab once after waiting a moment.
>> down arrow to advanced.
>> If you get stuck partway down the list, up arrow then continue down
>> again to get you unstuck.
>> Once you get to advanced, start tabbing.  You will see a check box
>> about notifying you if Firefox is being redirected or refreshing a
>> page.  That isn't the exact wording but it's there and my description
>> should allow you to kno it.  Check the check box.  There is no ok
>> button. Continue using firefox now.  Or close it if you wish.
>> You may find that you get one such message when a page wants to do
>> something and nothing more during that session of working on the page.
>> You don't have to worry about closing such messages.  They don't block
>> anything and will be replaced automaticaally with future messages.
>> As far as commercial screen-readers are concerned, while they have
>> features to stop refreshes, I don't know if they work in all cases.  I
>> have found times in the past when the JAWS feature didn't work when
>> confronted by some kinds of page refreshes.
>> Gene
>> ----- Original Message -----
>> *From:* Mallard <mailto:mallard@...>
>> *Sent:* Friday, March 25, 2016 2:07 PM
>> *To:* nvda@groups.io <mailto:nvda@groups.io>
>> *Subject:* Re: [nvda] prevent pages from refreshing
>>
>> Hello Davy,
>>
>> I started this topic more than once, and even last week or ten days ago.
>> I was told that "I was describing a way Firefox behaves on my machine",
>> and that if this had been a problem for more people than myself, there
>> would be ah uge number of messages on this (or soemthing to that ilk).
>>
>> Clearly, this is an issue that NVDA should find a way of solving, one
>> way or another. This constant refiesching of webpages is nnoying, and
>> prevents one from working correctly.
>>
>> Other screen readers have a way of blocking this, so it MUST be possible.
>>
>> I'd hate to have to go back to commercial screen readers because of this
>> issue, because more and moe web pages seem to be employing this horrible
>> technology (Carousels, or whatever they call them).
>>
>> Thanks for beinging this up again.
>> Hopefully, since there are now tro of us, someone will take a minute to
>> look into this.
>> Ciao,
>> Ollie
>>
>>
>>
>> Il 25/03/2016 17:34, Davy Cuppens ha scritto:
>> > Hi folks
>> > Is there a way in nvda that one can prevent pages from being
>> > constantly refreshed? In my professional sr Cobra I have a shortcut s
>> > in virtual mode so that pags become static and focus won’t jump to the
>> > front of it.
>> > Regards
>> > Davy
>> >
>>
>>
>>
>>
>>
>
>
>
>
> .
>



Chris Mullins
 

Thanks Joseph, 'Report dynamic content changes' is indeed what I was referring to Control+5 on number row is the keystroke.

Cheers
Chris

-----Original Message-----
From: Chris Mullins [mailto:cjmullins29@...]
Sent: 26 March 2016 13:25
To: nvda@groups.io
Subject: Re: [nvda] prevent pages from refreshing

Does the NVDA+4 on the number row make any difference?

Cheers
Chris

-----Original Message-----
From: Davy Cuppens [mailto:davycuppens@...]
Sent: 26 March 2016 12:11
To: nvda@groups.io
Subject: Re: [nvda] prevent pages from refreshing

I am very disappointed to read this all.

Indeed, this is a disadvantage of NVDA; just like you I would like to urge developers to work on this as quick as possible.
Regards
Davy

-----Oorspronkelijk bericht-----
From: Mallard
Sent: Friday, March 25, 2016 8:07 PM
To: nvda@groups.io
Subject: Re: [nvda] prevent pages from refreshing


Hello Davy,

I started this topic more than once, and even last week or ten days ago.
I was told that "I was describing a way Firefox behaves on my machine", and that if this had been a problem for more people than myself, there would be ah uge number of messages on this (or soemthing to that ilk).

Clearly, this is an issue that NVDA should find a way of solving, one way or another. This constant refiesching of webpages is nnoying, and prevents one from working correctly.

Other screen readers have a way of blocking this, so it MUST be possible.

I'd hate to have to go back to commercial screen readers because of this issue, because more and moe web pages seem to be employing this horrible technology (Carousels, or whatever they call them).

Thanks for beinging this up again.
Hopefully, since there are now tro of us, someone will take a minute to look into this.
Ciao,
Ollie



Il 25/03/2016 17:34, Davy Cuppens ha scritto:
Hi folks
Is there a way in nvda that one can prevent pages from being
constantly refreshed? In my professional sr Cobra I have a shortcut s
in virtual mode so that pags become static and focus won’t jump to the front of it.
Regards
Davy


Arno Schuh
 

Hi,

Am Samstag, 26. März 2016 17:40 schrieb Gene <gsasner@...>:

Are you referring to the setting concerning metarefresh in Internet
Explorer?
That's the option. But it is pretty cumbersome to activate and deactivate this option anytime you came across such a site.
In Cobra you simply press letter s to freeze the site, and simply press letter s again to set it free again.
And of course it is no solution to keep the metarefresh option deactivated, because if so some sites don't work properly; i. e. you can't log in some site, can't select list items in a list etc.

So a simple feature like in Cobra would be pretty helpful when you came across such a site.

Yours sincerely

Arno


Kevin Chao
 

Can someone please provide examples of thes type of sites?


On Sat, Mar 26, 2016 at 12:30 PM Arno Schuh <arno.schuh@...> wrote:
Hi,

Am Samstag, 26. März 2016 17:40 schrieb Gene <gsasner@...>:

> Are you referring to the setting concerning metarefresh in Internet
> Explorer?

That's the option. But it is pretty cumbersome to activate and deactivate
this option anytime you came across such a site.
In Cobra you simply press letter s to freeze the site, and simply press
letter s again to set it free again.
And of course it is no solution to keep the metarefresh option deactivated,
because if so some sites don't work properly; i. e. you can't log in some
site, can't select list items in a list etc.

So a simple feature like in Cobra would be pretty helpful when you came
across such a site.

Yours sincerely

Arno