Toggling between keyboards (long description)


 
Edited

Hi all,

Let me reply in Korean first and provide translations below:

옛날에 한국어 번역을 담당하던 이성원입니다. 아마도 Language Bar를 말씀하시는것 같은데 저같은 경우 오른쪽 얼트를 누르면 한글과 영어로 전환됩니다. 한자같은 경우 아시다시피 오른쪽 컨트롤을 눌러서 한자 후보창을 호출합니다.

참고로 Windows+Space나 Alt+Shift+를 누르면 키보드 배열(정확하게 말하면 입력 방식)이 변경되는데 한국어 배열에서 위에 언급한 대로 한글/영어 전환 키가 없으면 오른쪽 얼트를 쓰면 됩니다.

English translation:

I'm Joseph Lee, the former leader of NVDA Korean translations team.

I think you might be talking about Language Bar. If so, you can just press right Alt key to switch between English and Korean. As you know, you can enter Hanja characters by pressing the right Control key, which opens candidates window.

For reference, Windows+Space and Alt+Shift is used to switch between keyboard layouts (input method, to be exact). In case your keyboard doesn't have the dedicated English/Korean key, you can use right Alt key.

By the way, if you want to search for more info on input methods on the group archive, look for CJK, IME, or keyboard language.

Cheers, Joseph


Ben J. Bloomgren
 

"I had wondered how to do that. Thanks! I'll check this out.

Ben

On Feb 25, 2021, at 16:09, Quentin Christensen <quentin@...> wrote:


is this the same as changing the Windows language?  You can do that with WINDOWS+SPACEBAR, and that also changes the keyboard.

Quentin.

On Fri, Feb 26, 2021 at 1:41 AM Brian Vogel <britechguy@...> wrote:
Hello,

            First, a huge thanks for having read the Welcome Message and having done some digging!!   From what you are saying, this is not really an NVDA question, but is related to Windows 10.  The solution, based on your description, is using WinKey+B to throw focus to the System Tray portion of the Notification Area, then right arrowing to the control for that toggle and activating it when you wish to toggle character sets.  If the toggle button happens to be hiding in your overflow area, then activate the notification chevron and up arrow or left arrow through the buttons that reside there until you find that toggle, and activate it.

--

Brian - Windows 10 Pro, 64-Bit, Version 20H2, Build 19042  

Any idiot can face a crisis. It's the day-to-day living that wears you out.

      ~ Anton Chekhov

 



--
Quentin Christensen
Training and Support Manager


Quentin Christensen
 

is this the same as changing the Windows language?  You can do that with WINDOWS+SPACEBAR, and that also changes the keyboard.

Quentin.

On Fri, Feb 26, 2021 at 1:41 AM Brian Vogel <britechguy@...> wrote:
Hello,

            First, a huge thanks for having read the Welcome Message and having done some digging!!   From what you are saying, this is not really an NVDA question, but is related to Windows 10.  The solution, based on your description, is using WinKey+B to throw focus to the System Tray portion of the Notification Area, then right arrowing to the control for that toggle and activating it when you wish to toggle character sets.  If the toggle button happens to be hiding in your overflow area, then activate the notification chevron and up arrow or left arrow through the buttons that reside there until you find that toggle, and activate it.

--

Brian - Windows 10 Pro, 64-Bit, Version 20H2, Build 19042  

Any idiot can face a crisis. It's the day-to-day living that wears you out.

      ~ Anton Chekhov

 



--
Quentin Christensen
Training and Support Manager


 

Hello,

            First, a huge thanks for having read the Welcome Message and having done some digging!!   From what you are saying, this is not really an NVDA question, but is related to Windows 10.  The solution, based on your description, is using WinKey+B to throw focus to the System Tray portion of the Notification Area, then right arrowing to the control for that toggle and activating it when you wish to toggle character sets.  If the toggle button happens to be hiding in your overflow area, then activate the notification chevron and up arrow or left arrow through the buttons that reside there until you find that toggle, and activate it.

--

Brian - Windows 10 Pro, 64-Bit, Version 20H2, Build 19042  

Any idiot can face a crisis. It's the day-to-day living that wears you out.

      ~ Anton Chekhov

 


Jiho Kim
 

Hello!

 

I read the automated “welcome message” in its entirety :) and I have a question: It may not be 100% related to the NVDA – not sure where to post this question. It may belong to the “chat” section but I need help regardless. I also checked the archive but no success.

First of all: English is not my first language – I may have some spelling errors or nonsensical sentences.

Secondly: we use Windows 10 (I think it’s relevant) and very new to NVDA or screen readers in general (other than voiceover for iphones?). well, I am still not sure if this is the right place to look for help.

In short: the issue is about being able to write in Korean letters.

I know how to toggle between pre-installed keyboards in windows (left Alt + left Shift by default) but If you change the keyboard layout with Alt+Shift to Korean, one more small button appears on the right side of the taskbar. Usually, you can toggle between Korean letters and English (or whatever romanised language) letters by left-clicking the button in the taskbar with mouse or some Korean keyboards has an extra (physical) key between spacebar and right Alt key. In my case, I don’t have the extra physical key, that’s assigned to this toggle button and cannot use the mouse.

I googled for very long time but could not find anything. I was hoping to find some solution here.

If needed, I can provide some screenshots(?)

 

FYI: we have no issues reading Korean (you can simply change the setting in NVDA) or changing the language settings in general. It seems, that’s one of the common issues from the archive.

 

Many thanks!

Jiho Kim