NVDA announcing Capital letters


Don H
 

Is there a setting in NVDA that causes the word capital to be spoken on capital letters?


Fawaz Abdul rahman
 

Hi,
if you mean while typing, then yes.
in the voice settings, you can find:
Say cap before capitals  check box  not checked  Alt+c
you can check it or use the beep option which is right after the cap option.
good luck.


On Tue, Jan 18, 2022 at 4:47 PM Don H <lmddh50@...> wrote:
Is there a setting in NVDA that causes the word capital to be spoken on
capital letters?






Gene
 

It isn't limited to typing.  If you move by letter through a document, you will hear cap spoken when you are on a capital letter.  The beep option works the same way.  All options, raise pitch, beep, and say cap, all change what is done when both typing and moving by character.


Gene

On 1/18/2022 7:53 AM, Fawaz Abdul rahman wrote:
Hi,
if you mean while typing, then yes.
in the voice settings, you can find:
Say cap before capitals  check box  not checked  Alt+c
you can check it or use the beep option which is right after the cap option.
good luck.

On Tue, Jan 18, 2022 at 4:47 PM Don H <lmddh50@...> wrote:
Is there a setting in NVDA that causes the word capital to be spoken on
capital letters?






Chris Mullins
 

Hi

In the voice settings NVDA+Ctrl+v, there is a setting for capitals which can be set to a pitch change, beep or announcement of “Cap” when capitals are encountered.

 

Cheers

Chris

 

Sent from Mail for Windows

 

From: Don H
Sent: 18 January 2022 13:47
To: nvda@nvda.groups.io
Subject: [nvda] NVDA announcing Capital letters

 

Is there a setting in NVDA that causes the word capital to be spoken on

capital letters?

 

 

 

 

 


Don H
 

I have both beep and say cap unchecked under speech settings and NVDA
still says capital before a capital letter and when typing a capital letter.

On 1/18/2022 7:53 AM, Fawaz Abdul rahman wrote:
Hi,
if you mean while typing, then yes.
in the voice settings, you can find:
Say cap before capitals  check box  not checked  Alt+c
you can check it or use the beep option which is right after the cap option.
good luck.

On Tue, Jan 18, 2022 at 4:47 PM Don H <lmddh50@...
<mailto:lmddh50@...>> wrote:

Is there a setting in NVDA that causes the word capital to be spoken on
capital letters?






Steve Nutt
 

Hi,

This is a function, or problem with, certain synthesisers.

For example, if you use CodeFactory's NVDA Vocalizer add-on, and turn off all the capital options, it will still say Capital, because NVDA doesn't intercept the interpretation of the add-on itself.

JAWS has a feature called Controlled By Synthesiser, which you can switch off. If you do, JAWS does all the processing. Maybe NVDA needs something like this. Controlled By Synthesiser can be seen in punctuation settings I believe.

All the best

Steve

--
To subscribe to our News and Special Offers list, go to https://www.comproom.co.uk/subscribe

Computer Room Services
77 Exeter Close
Stevenage
Hertfordshire
SG1 4PW
T: +44(0)1438-742286
M: +44(0)7956-334938
F: +44(0)1438-759589
E: steve@...
W: https://www.comproom.co.uk

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Don H
Sent: 18 January 2022 15:28
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA announcing Capital letters

I have both beep and say cap unchecked under speech settings and NVDA still says capital before a capital letter and when typing a capital letter.

On 1/18/2022 7:53 AM, Fawaz Abdul rahman wrote:
Hi,
if you mean while typing, then yes.
in the voice settings, you can find:
Say cap before capitals check box not checked Alt+c you can check
it or use the beep option which is right after the cap option.
good luck.

On Tue, Jan 18, 2022 at 4:47 PM Don H <lmddh50@...
<mailto:lmddh50@...>> wrote:

Is there a setting in NVDA that causes the word capital to be spoken on
capital letters?






Gene
 

I don't think that is true if you use Eloquence as provided by the add-on, at least when I tried the demo, I didn't have that problem.  I don't like the other synthesizer, I don't recall its name, and I hardly played with it.  I hope others will discuss whether I am correct because some who want to use eloquence as an add-on might be worried about that.


Gene

On 1/18/2022 9:53 AM, Steve Nutt wrote:
Hi,

This is a function, or problem with, certain synthesisers.

For example, if you use CodeFactory's NVDA Vocalizer add-on, and turn off all the capital options, it will still say Capital, because NVDA doesn't intercept the interpretation of the add-on itself.

JAWS has a feature called Controlled By Synthesiser, which you can switch off. If you do, JAWS does all the processing. Maybe NVDA needs something like this. Controlled By Synthesiser can be seen in punctuation settings I believe.

All the best

Steve

--
To subscribe to our News and Special Offers list, go to https://www.comproom.co.uk/subscribe

Computer Room Services
77 Exeter Close
Stevenage
Hertfordshire
SG1 4PW
T: +44(0)1438-742286
M: +44(0)7956-334938
F: +44(0)1438-759589
E: steve@...
W: https://www.comproom.co.uk

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Don H
Sent: 18 January 2022 15:28
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA announcing Capital letters

I have both beep and say cap unchecked under speech settings and NVDA still says capital before a capital letter and when typing a capital letter.

On 1/18/2022 7:53 AM, Fawaz Abdul rahman wrote:
Hi,
if you mean while typing, then yes.
in the voice settings, you can find:
Say cap before capitals check box not checked Alt+c you can check
it or use the beep option which is right after the cap option.
good luck.

On Tue, Jan 18, 2022 at 4:47 PM Don H <lmddh50@...
<mailto:lmddh50@...>> wrote:

Is there a setting in NVDA that causes the word capital to be spoken on
capital letters?














Marilyn and Don Bilderback
 

Hello, I have the beep option checked but I get no sound when I type.  I can’t seem to set the voice so that there is enough change in tone when caps are typed.  What am I missing?

Marilynn

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Fawaz Abdul rahman
Sent: Tuesday, January 18, 2022 6:54 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA announcing Capital letters

 

Hi,

if you mean while typing, then yes.

in the voice settings, you can find:

Say cap before capitals  check box  not checked  Alt+c

you can check it or use the beep option which is right after the cap option.

good luck.

 

On Tue, Jan 18, 2022 at 4:47 PM Don H <lmddh50@...> wrote:

Is there a setting in NVDA that causes the word capital to be spoken on
capital letters?





Steve Nutt
 

Hi Gene,

In my testing, you are right. It doesn't happen with Eloquence, but it does with Nuance Vocalizer.

This is because NVDA chucks an upper case character at it, and the synth interprets it correctly.

If you turn caps off completely, then NVDA should be chucking lower case letters at it when you type, then it would stop this happening.

All the best

Steve

--
To subscribe to our News and Special Offers list, go to https://www.comproom.co.uk/subscribe

Computer Room Services
77 Exeter Close
Stevenage
Hertfordshire
SG1 4PW
T: +44(0)1438-742286
M: +44(0)7956-334938
F: +44(0)1438-759589
E: steve@...
W: https://www.comproom.co.uk

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Gene
Sent: 18 January 2022 15:57
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA announcing Capital letters

I don't think that is true if you use Eloquence as provided by the add-on, at least when I tried the demo, I didn't have that problem. I don't like the other synthesizer, I don't recall its name, and I hardly played with it. I hope others will discuss whether I am correct because some who want to use eloquence as an add-on might be worried about that.


Gene

On 1/18/2022 9:53 AM, Steve Nutt wrote:
Hi,

This is a function, or problem with, certain synthesisers.

For example, if you use CodeFactory's NVDA Vocalizer add-on, and turn off all the capital options, it will still say Capital, because NVDA doesn't intercept the interpretation of the add-on itself.

JAWS has a feature called Controlled By Synthesiser, which you can switch off. If you do, JAWS does all the processing. Maybe NVDA needs something like this. Controlled By Synthesiser can be seen in punctuation settings I believe.

All the best

Steve

--
To subscribe to our News and Special Offers list, go to
https://www.comproom.co.uk/subscribe

Computer Room Services
77 Exeter Close
Stevenage
Hertfordshire
SG1 4PW
T: +44(0)1438-742286
M: +44(0)7956-334938
F: +44(0)1438-759589
E: steve@...
W: https://www.comproom.co.uk

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Don H
Sent: 18 January 2022 15:28
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA announcing Capital letters

I have both beep and say cap unchecked under speech settings and NVDA still says capital before a capital letter and when typing a capital letter.

On 1/18/2022 7:53 AM, Fawaz Abdul rahman wrote:
Hi,
if you mean while typing, then yes.
in the voice settings, you can find:
Say cap before capitals check box not checked Alt+c you can check
it or use the beep option which is right after the cap option.
good luck.

On Tue, Jan 18, 2022 at 4:47 PM Don H <lmddh50@...
<mailto:lmddh50@...>> wrote:

Is there a setting in NVDA that causes the word capital to be spoken on
capital letters?















David Griffith
 

This problem does not  appear to be existent with the Sapi versions of Eloquence.

I am using the Code Factory Sapi 5 Eloquence  to type this and there is no problem with capital announcement. Capitals are being indicated simply by increased pitch as expected.

Yesterday I was using the Kurzweil Sapi 4 version of Eloquence and again there was no  problem with simply hearing increased pitch to indicate capitals.

 

So this may be a problem confined to the Code Factory Addon versions?

I am constantly relieved that I did not go for the addon flavour given the multiple issues reported over the years with NVDA updates etc.

David Griffith

 

Sent from Mail for Windows

 

From: Steve Nutt
Sent: 18 January 2022 15:53
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA announcing Capital letters

 

Hi,

 

This is a function, or problem with, certain synthesisers.

 

For example, if you use CodeFactory's NVDA Vocalizer add-on, and turn off all the capital options, it will still say Capital, because NVDA doesn't intercept the interpretation of the add-on itself.

 

JAWS has a feature called Controlled By Synthesiser, which you can switch off. If you do, JAWS does all the processing. Maybe NVDA needs something like this. Controlled By Synthesiser can be seen in punctuation settings I believe.

 

All the best

 

Steve

 

--

To subscribe to our News and Special Offers list, go to https://www.comproom.co.uk/subscribe

 

Computer Room Services

77 Exeter Close

Stevenage

Hertfordshire

SG1 4PW

T: +44(0)1438-742286

M: +44(0)7956-334938

F: +44(0)1438-759589

E: steve@...

W: https://www.comproom.co.uk

 

-----Original Message-----

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Don H

Sent: 18 January 2022 15:28

To: nvda@nvda.groups.io

Subject: Re: [nvda] NVDA announcing Capital letters

 

I have both beep and say cap unchecked under speech settings and NVDA still says capital before a capital letter and when typing a capital letter.

 

On 1/18/2022 7:53 AM, Fawaz Abdul rahman wrote:

> Hi,

> if you mean while typing, then yes.

> in the voice settings, you can find:

> Say cap before capitals  check box  not checked  Alt+c you can check

> it or use the beep option which is right after the cap option.

> good luck.

> On Tue, Jan 18, 2022 at 4:47 PM Don H <lmddh50@...

> <mailto:lmddh50@...>> wrote:

>     Is there a setting in NVDA that causes the word capital to be spoken on

>     capital letters?

>

 

 

 

 

 

 

 

 

 

 

 

 


Marilyn and Don Bilderback
 

Hello,

I have the beep option checked but I get no sound when I type.

 I try to use the tone option, but   can’t seem to choose the   right numbers so I can use that method. I don’t hear   any change in tone when caps are typed.

 

I do not like the word caps spoken as I can’t hear what I am typing.    What am I missing?

Marilynn


Don H
 

I contacted Code Factory and they said it was a NVDA issue. So I don't
think anything will be done anytime soon to fix the problem.

On 1/20/2022 12:17 AM, Marilyn and Don Bilderback wrote:
Hello,

I have the beep option checked but I get no sound when I type.

 I try to use the tone option, but   can’t seem to choose the   right
numbers so I can use that method. I don’t hear   any change in tone when
caps are typed.

I do not like the word caps spoken as I can’t hear what I am typing.
What am I missing?

Marilynn


Gene
 

Here is a suggestion for those who don't want to hear cap spoken.  Try an NVDA speech dictionary entry for cap and place a space in the pronounced as field.  Be sure to select whole word or you won't hear cap wherever it appears.  Thus, Captain Kirk would be tain Kurk.


On a more general note, I don't understand the cause of the problem.  I would think that when a capital letter is found, NVDA sends instructions to the synthesizer such as raise voice, or actually sends the word cap to the synthesizer.  But turning off these options doesn't eliminate the word cap being spoken for some people and now one person says pitch isn't raised.


Yet, I wouldn't think the synthesizer would do something on its own like say cap if no information came from NVDA.  Perhaps someone with more technical knowledge might discuss what might be causing the problems.


Gene

On 1/20/2022 8:04 AM, Don H wrote:
I contacted Code Factory and they said it was a NVDA issue.  So I don't
think anything will be done anytime soon to fix the problem.

On 1/20/2022 12:17 AM, Marilyn and Don Bilderback wrote:
Hello,

I have the beep option checked but I get no sound when I type.

  I try to use the tone option, but   can’t seem to choose the   right
numbers so I can use that method. I don’t hear   any change in tone when
caps are typed.

I do not like the word caps spoken as I can’t hear what I am typing.
What am I missing?

Marilynn




Don H
 

Tried as you described by placing a new entry in the default dictionary.
Still says capital when typing a capital letter. I know the entry was
correct because if you type the word cap in a document and try to read
it NVDA says nothing.

On 1/20/2022 8:14 AM, Gene wrote:
Here is a suggestion for those who don't want to hear cap spoken.  Try
an NVDA speech dictionary entry for cap and place a space in the
pronounced as field.  Be sure to select whole word or you won't hear cap
wherever it appears.  Thus, Captain Kirk would be tain Kurk.


On a more general note, I don't understand the cause of the problem.  I
would think that when a capital letter is found, NVDA sends instructions
to the synthesizer such as raise voice, or actually sends the word cap
to the synthesizer.  But turning off these options doesn't eliminate the
word cap being spoken for some people and now one person says pitch
isn't raised.


Yet, I wouldn't think the synthesizer would do something on its own like
say cap if no information came from NVDA.  Perhaps someone with more
technical knowledge might discuss what might be causing the problems.


Gene

On 1/20/2022 8:04 AM, Don H wrote:
I contacted Code Factory and they said it was a NVDA issue.  So I don't
think anything will be done anytime soon to fix the problem.

On 1/20/2022 12:17 AM, Marilyn and Don Bilderback wrote:
Hello,

I have the beep option checked but I get no sound when I type.

  I try to use the tone option, but   can’t seem to choose the   right
numbers so I can use that method. I don’t hear   any change in tone when
caps are typed.

I do not like the word caps spoken as I can’t hear what I am typing.
What am I missing?

Marilynn







Chris
 

You are probably better off raising an issue on GitHub, if its an NVDA issue, giving more information than you have here will probably help diagnose the problem

 

 


Gene
 

That's very interesting and further raises the question of what is causing the problem.


Gene

On 1/20/2022 8:30 AM, Don H wrote:
Tried as you described by placing a new entry in the default dictionary.
 Still says capital when typing a capital letter.  I know the entry was
correct because if you type the word cap in a document and try to read
it NVDA says nothing.

On 1/20/2022 8:14 AM, Gene wrote:
Here is a suggestion for those who don't want to hear cap spoken.  Try
an NVDA speech dictionary entry for cap and place a space in the
pronounced as field.  Be sure to select whole word or you won't hear cap
wherever it appears.  Thus, Captain Kirk would be tain Kurk.


On a more general note, I don't understand the cause of the problem.  I
would think that when a capital letter is found, NVDA sends instructions
to the synthesizer such as raise voice, or actually sends the word cap
to the synthesizer.  But turning off these options doesn't eliminate the
word cap being spoken for some people and now one person says pitch
isn't raised.


Yet, I wouldn't think the synthesizer would do something on its own like
say cap if no information came from NVDA.  Perhaps someone with more
technical knowledge might discuss what might be causing the problems.


Gene

On 1/20/2022 8:04 AM, Don H wrote:
I contacted Code Factory and they said it was a NVDA issue.  So I don't
think anything will be done anytime soon to fix the problem.

On 1/20/2022 12:17 AM, Marilyn and Don Bilderback wrote:
Hello,

I have the beep option checked but I get no sound when I type.

  I try to use the tone option, but   can’t seem to choose the   right
numbers so I can use that method. I don’t hear   any change in tone when
caps are typed.

I do not like the word caps spoken as I can’t hear what I am typing.
What am I missing?

Marilynn










.


Chris Mullins
 

Hi

Can speech viewer be used to check what is being sent to the synthesizer?

 

Cheers

Chris

 

Sent from Mail for Windows

 

From: Gene
Sent: 20 January 2022 15:03
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA announcing Capital letters

 

That's very interesting and further raises the question of what is

causing the problem.

 

 

Gene

 

On 1/20/2022 8:30 AM, Don H wrote:

> Tried as you described by placing a new entry in the default dictionary.

>  Still says capital when typing a capital letter.  I know the entry was

> correct because if you type the word cap in a document and try to read

> it NVDA says nothing.

> On 1/20/2022 8:14 AM, Gene wrote:

>> Here is a suggestion for those who don't want to hear cap spoken.  Try

>> an NVDA speech dictionary entry for cap and place a space in the

>> pronounced as field.  Be sure to select whole word or you won't hear cap

>> wherever it appears.  Thus, Captain Kirk would be tain Kurk.

>> 

>> 

>> On a more general note, I don't understand the cause of the problem.  I

>> would think that when a capital letter is found, NVDA sends instructions

>> to the synthesizer such as raise voice, or actually sends the word cap

>> to the synthesizer.  But turning off these options doesn't eliminate the

>> word cap being spoken for some people and now one person says pitch

>> isn't raised.

>> 

>> 

>> Yet, I wouldn't think the synthesizer would do something on its own like

>> say cap if no information came from NVDA.  Perhaps someone with more

>> technical knowledge might discuss what might be causing the problems.

>> 

>> 

>> Gene

>> 

>> On 1/20/2022 8:04 AM, Don H wrote:

>>> I contacted Code Factory and they said it was a NVDA issue.  So I don't

>>> think anything will be done anytime soon to fix the problem.

>>> 

>>> On 1/20/2022 12:17 AM, Marilyn and Don Bilderback wrote:

>>>> Hello,

>>>> 

>>>> I have the beep option checked but I get no sound when I type.

>>>> 

>>>>   I try to use the tone option, but   can’t seem to choose the   right

>>>> numbers so I can use that method. I don’t hear   any change in tone

>>>> when

>>>> caps are typed.

>>>> 

>>>> I do not like the word caps spoken as I can’t hear what I am typing.

>>>> What am I missing?

>>>> 

>>>> Marilynn

>>>> 

>>>> 

>>> 

>>> 

>>> 

>>> 

>>> 

>> 

>> 

>> 

>> 

>> 

>

> .

 

 

 

 

 


Don H
 

So again I am running the latest released versions of NVDA, Win10 and latest vocalizer/eloquince addon from code factory. Despite having say cap on capital letters being unchecked NVDA still says cap with capital letters being typed and read.
I went into the defauld dictionary and added a entry for Capital A replacing it with a lower case a making it capital sensitive and set for anywhere.
Now when I type a Capital a I only hear the letter a at a raised pitch. Does this provide any reason for the problem of NVDA saying capital before each capital letter? If this is a possible solution is there a way to do it besides making 26 entries in the default dictionary thus covering the entire alphabet?


Gene
 

I don't know how to work with regular expressions.  I would imagine that this could be done with a regular expression but others would have to discuss that.


Those with more technical knowledge may wish to discuss if what you found brings us closer to understanding why the problem exists.


Your comments may prompt someone to send to the list what you should enter in the speech dictionary.


Gene

On 1/20/2022 1:43 PM, Don H wrote:
So again I am running the latest released versions of NVDA, Win10 and latest vocalizer/eloquince addon from code factory.  Despite having say cap on capital letters being unchecked NVDA still says cap with capital letters being typed and read.
I went into the defauld dictionary and added a entry for Capital A replacing it with a lower case a making it capital sensitive and set for anywhere.
Now when I type a Capital a I only hear the letter a at a raised pitch. Does this provide any reason for the problem of NVDA saying capital before each capital letter?  If this is a possible solution is there a way to do it besides making 26 entries in the default dictionary thus covering the entire alphabet?




Don H
 

Again running latest version of NVDA, Win 10 and latest code factory vocalizer/eloquence addon. Using the Vocalizer voices.
Despite having say caps unchecked under the NVDA voice settings NVDA still says capital before each capital letter typed.
A solution is found under the settings for the code factory vocalizer settings. Under the settings you can create a word list. I added a entry for each letter having each capitalized leter replaced with the locer case letter.
Now all capitals are identified with only a pitch change as desired. Did not change any of the NVDA dictionaries.