sound splitter addon


Don H
 

Running latest released version of Win 10 and NVDA. Thought I would give the new sound splitter addon a try. I did not like it so went to the tools/manage addons and removed it. Restarted NVDA and found that sound was still being split. Would have thought after removing the addon that things would go back to normal.


 

Hi,

Oops, should have looked into this...

One possible workaround is restarting the computer. Another workaround is pressing Alt+NVDA+S to disable sound splitter feature before removing or disabling this add-on. At least it might be possible to restore sounds to the right channels as the add-on terminates at the cost of hearing NVDA through both channels really briefly. At the moment the earliest I can look into this would be March unless folks provide a fix via pull requests (apologies).

Cheers,

Joseph


Don H
 

I solved the problem by reinstalling the sound splitter addon changing to not split the sound then removed the addon which got things back to normal.
Disabling the addon does not resolve the issue as even disabled sound is still split.

On 2/1/2022 11:26 PM, Joseph Lee wrote:
Hi,
Oops, should have looked into this...
One possible workaround is restarting the computer. Another workaround is pressing Alt+NVDA+S to disable sound splitter feature before removing or disabling this add-on. At least it might be possible to restore sounds to the right channels as the add-on terminates at the cost of hearing NVDA through both channels really briefly. At the moment the earliest I can look into this would be March unless folks provide a fix via pull requests (apologies).
Cheers,
Joseph


 

Hi Don,

The last bit you provided (disabling the add-on does not restore sounds to both channels) confirms the hypothesis I had about the add-on code. I'll look into this as a high priority issue.

Cheers,

Joseph


 

Hi Don,

While it may not be possible to resolve the right channel problem when disabling Sound Splitter and restarting NVDA, I might be able to restore NVDA sounds to both channels when you uninstall the add-on.

Cheers,

Joseph


Don H
 

So if you want to simply disable it you need to go into the addon settings and uncheck the box to split sounds

On 2/2/2022 2:25 PM, Joseph Lee wrote:
Hi Don,
While it may not be possible to resolve the right channel problem when disabling Sound Splitter and restarting NVDA, I might be able to restore NVDA sounds to both channels when you uninstall the add-on.
Cheers,
Joseph


 

Hi Don,

As noted in another thread, an alternative is pressing Alt+NVDA+S provided that it doens't conflict with other add-ons.

By the way, I figured out the problem: when closing NVDA, NVDA's own volume is not set correctly (that is, audio output is not restored to both audio channels). I'm testing a solution and plan to release a fix around the time NVDA 2022.1 beta 1 is released as I have suspended add-on releases until that time as to not overwhelm the community and myself; rest assured that I know what's going on and will do everything I can to resolve this issue.

Cheers,

Joseph