Reading Bangla number with nvda default espeak


farhan israk
 

Thank you. It has been fixed after changing voice to bengali. It has always been there. How can I send feedback to espeak developers? I am using nvda 2021.3.5. If I navigate word by word, nvda only announces the first letter of a bengali word. It does not announce the word. However, it does not happen with English words. If I navigate word by word in an English sentence, nvda announces word without any issue. It only happens while reading Bengali words.


On Mon, Apr 18, 2022 at 9:45 AM Sharad Koirala <shakoirala@...> wrote:
Hello Farhan
greetings from Nepal,

there is the same issue with nepali as well when one sets the voice to
english in the speech settings. this can be fixed by changing the
voice to bangla (in your case) in the speech settings. this can be
reached by going to nvda menu>preferences>settings>speech and pressing
tab repeatedly to reach voices and pressing"b" to reach bengali and
finally tabbing to "ok" button and pressing "enter".

I am using the nepali voice in this case.

however there is a hiccup that though espeak will read both english
and the specific language numbers correctly, you will get the feedback
while typing only in bangla.

hope this works,

On 4/18/22, Cyrille via groups.io <cyrille.bougot2=laposte.net@groups.io> wrote:
> Hi Farhan
>
> Which version of NVDA are you using?
> Is it a new issue or has it always been there?
> If it is a new issue in NVDA 2022.1 (beta), it should be reported to NVDA,
> since there has been work regarding Bangla in this version as you know; and
> it should be fixed before the definitive version.
> If it has always been there (especially before 2022.1), you should report it
> to eSpeak.
> Thanks,
> Cheers,
>
> Cyrille
>
>
>
>
>
>


--
Dr. Sharad Koirala
Lecturer
Department of Community Medicine
Gandaki Medical College, Pokhara, Nepal






Sharad Koirala
 

Hello Farhan
greetings from Nepal,

there is the same issue with nepali as well when one sets the voice to
english in the speech settings. this can be fixed by changing the
voice to bangla (in your case) in the speech settings. this can be
reached by going to nvda menu>preferences>settings>speech and pressing
tab repeatedly to reach voices and pressing"b" to reach bengali and
finally tabbing to "ok" button and pressing "enter".

I am using the nepali voice in this case.

however there is a hiccup that though espeak will read both english
and the specific language numbers correctly, you will get the feedback
while typing only in bangla.

hope this works,

On 4/18/22, Cyrille via groups.io <cyrille.bougot2@...> wrote:
Hi Farhan

Which version of NVDA are you using?
Is it a new issue or has it always been there?
If it is a new issue in NVDA 2022.1 (beta), it should be reported to NVDA,
since there has been work regarding Bangla in this version as you know; and
it should be fixed before the definitive version.
If it has always been there (especially before 2022.1), you should report it
to eSpeak.
Thanks,
Cheers,

Cyrille





--
Dr. Sharad Koirala
Lecturer
Department of Community Medicine
Gandaki Medical College, Pokhara, Nepal


Cyrille
 

Hi Farhan

Which version of NVDA are you using?
Is it a new issue or has it always been there?
If it is a new issue in NVDA 2022.1 (beta), it should be reported to NVDA, since there has been work regarding Bangla in this version as you know; and it should be fixed before the definitive version.
If it has always been there (especially before 2022.1), you should report it to eSpeak.
Thanks,
Cheers,

Cyrille


Rowen Cary
 

Hi,

This may require ESpeak NJ to fix.


farhan israk
 

Dear nvda developer,
I am from Bangladesh. My native language is Bangla. I use nvda default espeak to read both Bangla and English content. It reads English numbers nicely. However, it does not read the Vangla number. If I encounter any Bangla number, it reads it as zero. It does not announce the exact number. Please, fix it.