Audio ducking issue


Khalid Anwar
 

After I reset NVDA to factory settings, I’m having an issue where the volume of another app is decreasing when I have NVDA on, if I restart NVDA, the volume of the other app goes back to normal for about five or six minutes and then decreases again.
Notably, this isn’t just when NVDA speaking so I’m not sure if it has anything to do with Windows settings but I do know that it wasn’t happening before I reset NVDA. And I’ve checked and audio ducking is turned off.


Gene
 

it sounds like an NVDA problem.  You said it didn't happen until you set NVDA to factory defaults. 

In the Desktop layout, I don't know the laptop command, If you use the NVDA command NVDA key shift d, it will cycle through three options.  One is always duck, that is, duck just because NVDA is running, another is to duck when you input things like type letters, and the other choice is no ducking.  Cycle through the options and when you stop on no ducking, see if that solves the problem.  At times, when a setting has changed or isn't working properly, changing the setting, then changing it back to what you want it to be corrects the problem.

Gene

On 4/19/2022 7:26 AM, Khalid Anwar wrote:
After I reset NVDA to factory settings, I’m having an issue where the volume of another app is decreasing when I have NVDA on, if I restart NVDA, the volume of the other app goes back to normal for about five or six minutes and then decreases again.
Notably, this isn’t just when NVDA speaking so I’m not sure if it has anything to do with Windows settings but I do know that it wasn’t happening before I reset NVDA. And I’ve checked and audio ducking is turned off.


Gene
 

I just checked.  The command is the same for the laptop layout as the desktop layout.

Gene

On 4/19/2022 7:44 AM, Gene via groups.io wrote:
it sounds like an NVDA problem.  You said it didn't happen until you set NVDA to factory defaults. 

In the Desktop layout, I don't know the laptop command, If you use the NVDA command NVDA key shift d, it will cycle through three options.  One is always duck, that is, duck just because NVDA is running, another is to duck when you input things like type letters, and the other choice is no ducking.  Cycle through the options and when you stop on no ducking, see if that solves the problem.  At times, when a setting has changed or isn't working properly, changing the setting, then changing it back to what you want it to be corrects the problem.

Gene
On 4/19/2022 7:26 AM, Khalid Anwar wrote:
After I reset NVDA to factory settings, I’m having an issue where the volume of another app is decreasing when I have NVDA on, if I restart NVDA, the volume of the other app goes back to normal for about five or six minutes and then decreases again.
Notably, this isn’t just when NVDA speaking so I’m not sure if it has anything to do with Windows settings but I do know that it wasn’t happening before I reset NVDA. And I’ve checked and audio ducking is turned off.



Sarah k Alawami
 

Have you gone to sound, then communications,  and checked that the none radio button is checked? This in windows 10 btw.

 

----

 

Sarah Alawami, owner of TFfP. We are also on lbry as well.

 

Stay in touch with us via our discord. This is an easier way to both contact us, and get to know your fellow listeners.

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Khalid Anwar
Sent: Tuesday, April 19, 2022 5:26 AM
To: nvda@nvda.groups.io
Subject: [nvda] Audio ducking issue

 

After I reset NVDA to factory settings, I’m having an issue where the volume of another app is decreasing when I have NVDA on, if I restart NVDA, the volume of the other app goes back to normal for about five or six minutes and then decreases again.

Notably, this isn’t just when NVDA speaking so I’m not sure if it has anything to do with Windows settings but I do know that it wasn’t happening before I reset NVDA. And I’ve checked and audio ducking is turned off.


Gene
 

That setting is for what Windows does when you are making a phone call.  It isn't a general audio ducking setting. 

Gene

On 4/19/2022 10:30 AM, Sarah k Alawami wrote:

Have you gone to sound, then communications,  and checked that the none radio button is checked? This in windows 10 btw.

 

----

 

Sarah Alawami, owner of TFfP. We are also on lbry as well.

 

Stay in touch with us via our discord. This is an easier way to both contact us, and get to know your fellow listeners.

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Khalid Anwar
Sent: Tuesday, April 19, 2022 5:26 AM
To: nvda@nvda.groups.io
Subject: [nvda] Audio ducking issue

 

After I reset NVDA to factory settings, I’m having an issue where the volume of another app is decreasing when I have NVDA on, if I restart NVDA, the volume of the other app goes back to normal for about five or six minutes and then decreases again.

Notably, this isn’t just when NVDA speaking so I’m not sure if it has anything to do with Windows settings but I do know that it wasn’t happening before I reset NVDA. And I’ve checked and audio ducking is turned off.



Sarah k Alawami
 

Actually, it is.  I’ve had windows sounds and music duck when I get a skype call, or  when something else triggers such as my mail program or discord, or windows notifications of any kind. So that’s why I always set it to none as that can sometimes help with nvda’s issues believe it or not.  It is something to look at, at least. I try and think outside the box as I’ve seen the strangest things fix issues.

 

----

 

Sarah Alawami, owner of TFfP. We are also on lbry as well.

 

Stay in touch with us via our discord. This is an easier way to both contact us, and get to know your fellow listeners.

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Gene
Sent: Tuesday, April 19, 2022 8:40 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Audio ducking issue

 

That setting is for what Windows does when you are making a phone call.  It isn't a general audio ducking setting. 

Gene

On 4/19/2022 10:30 AM, Sarah k Alawami wrote:

Have you gone to sound, then communications,  and checked that the none radio button is checked? This in windows 10 btw.

 

----

 

Sarah Alawami, owner of TFfP. We are also on lbry as well.

 

Stay in touch with us via our discord. This is an easier way to both contact us, and get to know your fellow listeners.

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Khalid Anwar
Sent: Tuesday, April 19, 2022 5:26 AM
To: nvda@nvda.groups.io
Subject: [nvda] Audio ducking issue

 

After I reset NVDA to factory settings, I’m having an issue where the volume of another app is decreasing when I have NVDA on, if I restart NVDA, the volume of the other app goes back to normal for about five or six minutes and then decreases again.

Notably, this isn’t just when NVDA speaking so I’m not sure if it has anything to do with Windows settings but I do know that it wasn’t happening before I reset NVDA. And I’ve checked and audio ducking is turned off.

 


Chris Mullins
 

Hi

Activate all the apps for which you want to set a volume level, press Windows+r to activate the Run Dialog, type “sndvol” (without the quotes) at the prompt and press enter.  This opens the Volume Mixer app where you can set the relative volume levels for NVDA, System Sounds and the various apps you have active.  Use NVDA+Control+s to open the “Select Synthesizer” dialog and set the Audio Ducking parameter as required.

 

Cheers

Chris     

 

Sent from Mail for Windows

 

From: Sarah k Alawami
Sent: 19 April 2022 16:31
To: nvda@nvda.groups.io
Subject: Re: [nvda] Audio ducking issue

 

Have you gone to sound, then communications,  and checked that the none radio button is checked? This in windows 10 btw.

 

----

 

Sarah Alawami, owner of TFfP. We are also on lbry as well.

 

Stay in touch with us via our discord. This is an easier way to both contact us, and get to know your fellow listeners.

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Khalid Anwar
Sent: Tuesday, April 19, 2022 5:26 AM
To: nvda@nvda.groups.io
Subject: [nvda] Audio ducking issue

 

After I reset NVDA to factory settings, I’m having an issue where the volume of another app is decreasing when I have NVDA on, if I restart NVDA, the volume of the other app goes back to normal for about five or six minutes and then decreases again.

Notably, this isn’t just when NVDA speaking so I’m not sure if it has anything to do with Windows settings but I do know that it wasn’t happening before I reset NVDA. And I’ve checked and audio ducking is turned off.

 


Gene
 

There are times I try things that don't seem as though they would likely solve a problem and there are times when odd or unusual solutions work.  I don't think this is one of those times but if the person tries it, and there's no harm in trying it, we'll see.

I doubt it because it is so tangentially related to the problem and because the problem started after NVDA was set to original factory settings. 

Gene

On 4/19/2022 10:54 AM, Sarah k Alawami wrote:

Actually, it is.  I’ve had windows sounds and music duck when I get a skype call, or  when something else triggers such as my mail program or discord, or windows notifications of any kind. So that’s why I always set it to none as that can sometimes help with nvda’s issues believe it or not.  It is something to look at, at least. I try and think outside the box as I’ve seen the strangest things fix issues.

 

----

 

Sarah Alawami, owner of TFfP. We are also on lbry as well.

 

Stay in touch with us via our discord. This is an easier way to both contact us, and get to know your fellow listeners.

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Gene
Sent: Tuesday, April 19, 2022 8:40 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Audio ducking issue

 

That setting is for what Windows does when you are making a phone call.  It isn't a general audio ducking setting. 

Gene

On 4/19/2022 10:30 AM, Sarah k Alawami wrote:

Have you gone to sound, then communications,  and checked that the none radio button is checked? This in windows 10 btw.

 

----

 

Sarah Alawami, owner of TFfP. We are also on lbry as well.

 

Stay in touch with us via our discord. This is an easier way to both contact us, and get to know your fellow listeners.

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Khalid Anwar
Sent: Tuesday, April 19, 2022 5:26 AM
To: nvda@nvda.groups.io
Subject: [nvda] Audio ducking issue

 

After I reset NVDA to factory settings, I’m having an issue where the volume of another app is decreasing when I have NVDA on, if I restart NVDA, the volume of the other app goes back to normal for about five or six minutes and then decreases again.

Notably, this isn’t just when NVDA speaking so I’m not sure if it has anything to do with Windows settings but I do know that it wasn’t happening before I reset NVDA. And I’ve checked and audio ducking is turned off.

 



Jason Bratcher
 

This
Sound" > "Communications" tab > "Do nothing" radio option
also exists in Win11 as well.
BTW, to check that:
1. WinKey+r for Runn... dialog,
2. Type "MMSys.CPL" into this edit box without quoting and Enter.
When the "Sound" dialog opens,
(You'll initially be on the "PlayBack" tab).
3. CTRL+Shift+Tab once to the "Communications" property sheet.
A series of four radiobuttons is now in focus (That's all there is on this property page prior to your
OK
Cancel
possibly an Apply button if you were already here on a different tab changing things but didn't save them yet).
The first one here (Not Recommended!) is to
"Mute all other sounds".
The second and third options are to
"Reduce the volume of other sounds by 80%",
"Reduce the volume of other sounds by 50%",
Now the option I use is at the very bottom:
Do nothing".
Assuming this is the choice you want,
Tap Enter and this change is applied.
Now that that's done,
On a minor "yay!" moment I stopped ThunderBird from inserting the
--
before my signature.
That'll tidy me messages up a bit?
I think that oughta be enough...
Jason Bratcher