any work updating the speech history addon, formally clip copy, to the new NVDA 2022? #addonrelease #addonrelease


Johnny Lam
 

hey guys, now that NVDA is updated to 2022, I haven't seen any news about some addons that are now incompatible, witch is really frustrating when the anual update breaks compatibility.
Just wondering if there were any attempts to update the speech history addon, formally clip copy, to support 2022? also the sys tray addon is now incompatible as well.
I haven't wanted to update to 2022 because of this reason of the addon compatibility, I remember when 2021 came out, we had to wait for some many months for the popular addons to be updated.


Gene
 

That isn't the production release of NVDA.  The current release is 2021.3.5.

I believe there is a beta version of 22.x or perhaps more than one, but if you look at the web site, the current version is as I stated.

many or perhaps a lot of add-ons will be made compatible that aren't now.

Gene
On 4/25/2022 8:28 PM, Johnny Lam wrote:

hey guys, now that NVDA is updated to 2022, I haven't seen any news about some addons that are now incompatible, witch is really frustrating when the anual update breaks compatibility.
Just wondering if there were any attempts to update the speech history addon, formally clip copy, to support 2022? also the sys tray addon is now incompatible as well.
I haven't wanted to update to 2022 because of this reason of the addon compatibility, I remember when 2021 came out, we had to wait for some many months for the popular addons to be updated.


 

Hi,

Systray List add-on is compatible now, actually.

Cheers,

Joseph


Johnny Lam
 

hi Joseph, I did try looking for the updated sys tray addon from doing
a google search, but I only saw the one updated for only 2021. but not
for the current version 2022.

On 4/25/22, Joseph Lee <joseph.lee22590@...> wrote:
Hi,

Systray List add-on is compatible now, actually.

Cheers,

Joseph






 

Hi,

I bet the first result that came up was systray List add-on entry from addons.nvda-project.org. Can you:

  1. Tell us the version of Systray List add-on you have?
  2. Try installing Add-on Updater and see if detects newer versions of add-ons you've got?

If it is what I suspect is happening, then I guess I need a reminder from someone to post a community-wide message about add-ons and updating them. As Gene pointed out, 2022.1 is in beta phase, and add-on authors are aware of making add-ons compatible with changes introduced in 2022.1 (at least folks subscribed to a certain NVDA related list or two in addition to this forum).

Cheers,

Joseph