Insert/override mode


Tony Malykh
 

Hi all,


NVDA uses the insert key extensively. Often times I accidentally press it twice, and then my text editor goes into override mode. Is there a way to prevent this from happening? I don't want to enter the override mode to begin with, but every time it takes me a long time to figure out that I'm in override mode.


Or is there a way to play some sound signal when I"m entering override mode to alert me?


Thank you

Tony


Gene
 

NVDA is designed to take the action of the insert key when you press it twice.  The first time you press it, it performs its NVDA function.  If you press it twice quickly, it performs the function it performs otherwise.  That is also true if you have shift set as a modifier.  Pressing once, it's an NVDA key.  Press it twice quickly and it turns the caps lock on or off.  Perhaps you should use the caps lock key as a modifier.  You will quickly know if you've accidentally turned the caps lock on.  Windows beeps if the caps lock is on and you press the shift key while typing. Also, the caps lock being turned on and off is announced by NVDA.  So using the caps lock is the only solution I know and it's a pretty good one.
 
Gene 

----- Original Message -----
Sent: Thursday, January 25, 2018 5:38 PM
Subject: [nvda] Insert/override mode

Hi all,


NVDA uses the insert key extensively. Often times I accidentally press
it twice, and then my text editor goes into override mode. Is there a
way to prevent this from happening? I don't want to enter the override
mode to begin with, but every time it takes me a long time to figure out
that I'm in override mode.


Or is there a way to play some sound signal when I"m entering override
mode to alert me?


Thank you

Tony





Quentin Christensen
 

Hi Tony,

Insert / Overtype mode is a function of your text editor.  Whether it can be disabled will be up to the editor itself then.  If you advise what program you are using, someone might be able to assist.

I just had a look in Notepad++ and I can't find a feature to disable overtype mode.  I know you can disable or enable it in Word (options, advanced, "Use the insert key to control overtype mode" and "Use overtype mode").

Kind regards

Quentin.

On Fri, Jan 26, 2018 at 10:38 AM, Tony Malykh <anton.malykh@...> wrote:
Hi all,


NVDA uses the insert key extensively. Often times I accidentally press it twice, and then my text editor goes into override mode. Is there a way to prevent this from happening? I don't want to enter the override mode to begin with, but every time it takes me a long time to figure out that I'm in override mode.


Or is there a way to play some sound signal when I"m entering override mode to alert me?


Thank you

Tony








--
Quentin Christensen
Training and Support Manager

Official NVDA Training modules and expert certification now available: http://www.nvaccess.org/shop/

Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess