How to not start NVDA at login?


Tony Malykh
 

Hi all,
I somehow broke my NVDA by writing a buggy addon and now NVDA doesn’t work. Moreover it somehow prevents the other screenreaders (jaws, narrator) from running. To make things even worse, the keyboard doesn’t seem to be working - otherwise I would’ve opened a command line terminal and typed up the command to erase the file in appdata\roaming\NVDA\globalPlugins. Insert+Q doesn’t work either.

So my question is: Is there a way to not start NVDA at login time? Or at least make it not load the addons?

NVDA seems to be working fine at the login screen where I need to enter the password, but that is probably because it doesn’t load addons at this time. Once I log in, I hear the four tones NVDA start sound and right after that my keyboard is pretty much dead. I know it’s my fault, I wrote some buggy addon code, but now I really want to revive my computer.

Thank you
Tony


Sent from my iPhone


 

Well if you have a portable nvda on you or can get one and maybe a sightling to right click nvda icon for you and quit it or end it in task manager then you can use that and then well run a system restore, or just clear the mangled file that may work.

Thats probably the only thing I can suggest.

I have had this happen myself with some software I have always had this happen with some users I have done work for.

I luckily had the system backed up and I was able to reformat and make the issue go away.

I never really looked into fixing this when it happened to me once before as after a good reformat it never came back but maybe I was lucky.

On 2/02/2018 5:30 p.m., Tony Malykh wrote:
Hi all,
I somehow broke my NVDA by writing a buggy addon and now NVDA doesn’t work. Moreover it somehow prevents the other screenreaders (jaws, narrator) from running. To make things even worse, the keyboard doesn’t seem to be working - otherwise I would’ve opened a command line terminal and typed up the command to erase the file in appdata\roaming\NVDA\globalPlugins. Insert+Q doesn’t work either.

So my question is: Is there a way to not start NVDA at login time? Or at least make it not load the addons?

NVDA seems to be working fine at the login screen where I need to enter the password, but that is probably because it doesn’t load addons at this time. Once I log in, I hear the four tones NVDA start sound and right after that my keyboard is pretty much dead. I know it’s my fault, I wrote some buggy addon code, but now I really want to revive my computer.

Thank you
Tony


Sent from my iPhone


Gene
 

You should be able to go into save mode, with sighted help.  You can then uninstall NVDA or, perhaps, someone can tell us how to remove the add on files. 
 
Gene

----- Original Message -----
Sent: Thursday, February 01, 2018 11:20 PM
Subject: Re: [nvda] How to not start NVDA at login?

Well if you have a portable nvda on you or can get one and maybe a
sightling to right click nvda icon for you and quit it or end it in task
manager then you can use that and then well run a system restore, or
just clear the mangled file that may work.

Thats probably the only thing I can suggest.

I have had this happen myself with some software I have always had this
happen with some users I have done work for.

I luckily had the system backed up and I was able to reformat and make
the issue go away.

I never really looked into fixing this when it happened to me once
before as after a good reformat it never came back but maybe I was lucky.




On 2/02/2018 5:30 p.m., Tony Malykh wrote:
> Hi all,
> I somehow broke my NVDA by writing a buggy addon and now NVDA doesn’t work. Moreover it somehow prevents the other screenreaders (jaws, narrator) from running. To make things even worse, the keyboard doesn’t seem to be working - otherwise I would’ve opened a command line terminal and typed up the command to erase the file in appdata\roaming\NVDA\globalPlugins. Insert+Q doesn’t work either.
>
> So my question is: Is there a way to not start NVDA at login time? Or at least make it not load the addons?
>
> NVDA seems to be working fine at the login screen where I need to enter the password, but that is probably because it doesn’t load addons at this time. Once I log in, I hear the four tones NVDA start sound and right after that my keyboard is pretty much dead. I know it’s my fault, I wrote some buggy addon code, but now I really want to revive my computer.
>
> Thank you
> Tony
>
>
> Sent from my iPhone
>
>
>




Chris
 

If nvda runs on the login screen then you can bring up the nvda menu and change the way nvda starts or in your case not at all to get into windows

After the required changes save the settings and restart, then you should be good to go

 

 

From: Tony Malykh
Sent: 02 February 2018 04:31
To: nvda@nvda.groups.io
Subject: [nvda] How to not start NVDA at login?

 

Hi all,

I somehow broke my NVDA by writing a buggy addon and now NVDA doesn’t work. Moreover it somehow prevents the other screenreaders (jaws, narrator) from running. To make things even worse, the keyboard doesn’t seem to be working - otherwise I would’ve opened a command line terminal and typed up the command to erase the file in appdata\roaming\NVDA\globalPlugins. Insert+Q doesn’t work either.

 

So my question is: Is there a way to not start NVDA at login time? Or at least make it not load the addons?

 

NVDA seems to be working fine at the login screen where I need to enter the password, but that is probably because it doesn’t load addons at this time. Once I log in, I hear the four tones NVDA start sound and right after that my keyboard is pretty much dead. I know it’s my fault, I wrote some buggy addon code, but now I really want to revive my computer.

 

Thank you

Tony

 

 

 

 


Tony Malykh
 

Thank you all for help. A sighted person managed to boot into recovery console and delete the file from there.


Tony


On 2/2/2018 1:11 AM, Chris wrote:

If nvda runs on the login screen then you can bring up the nvda menu and change the way nvda starts or in your case not at all to get into windows

After the required changes save the settings and restart, then you should be good to go

 

 

From: Tony Malykh
Sent: 02 February 2018 04:31
To: nvda@nvda.groups.io
Subject: [nvda] How to not start NVDA at login?

 

Hi all,

I somehow broke my NVDA by writing a buggy addon and now NVDA doesn’t work. Moreover it somehow prevents the other screenreaders (jaws, narrator) from running. To make things even worse, the keyboard doesn’t seem to be working - otherwise I would’ve opened a command line terminal and typed up the command to erase the file in appdata\roaming\NVDA\globalPlugins. Insert+Q doesn’t work either.

 

So my question is: Is there a way to not start NVDA at login time? Or at least make it not load the addons?

 

NVDA seems to be working fine at the login screen where I need to enter the password, but that is probably because it doesn’t load addons at this time. Once I log in, I hear the four tones NVDA start sound and right after that my keyboard is pretty much dead. I know it’s my fault, I wrote some buggy addon code, but now I really want to revive my computer.

 

Thank you

Tony