Topics

accessing embedded video links in Power point slides

Payal Kapoor
 

hi,
i am working with a PPT with several slides which have not only
graphics as part of the content of a slide, but also links to videos.
however, i am unable to access the links(which don't show up as a link
there) .
i have tried everything but have had no success. when checking using
insert+F1, the message very clearly said there were hyperlinks as part
of the content.
to test that theory, i did copy the content of the slide to a word doc
and it shows a link as well.
i am using the latest version of NVDA and have tried it with one of
the earlier versions of JAWS 18 installed on my Windows 10 laptop.
the office version is 2016.
the message when focusing on the video in the slide is: video
obscured. also, i saw a message about access to the links being
blocked. now i don't know which key combination brought that one on.
after all that mishmash of information, i would be eternally grateful
to anyone who can help me get to the video links.
it is critical, since those are part of the training content for work i do.
thanks for any possible help.
Best,

Quentin Christensen
 

When you say link to a video, do you mean a text URL or link on the slide, or do you mean an embedded video?  When you activate a link it will open your browser to the specified URL.  An embedded video has a preview of the video (a still image, similar to that shown on thumbnails in Youtube etc) with a triangle play button), when you activate it, the video plays there in the slideshow without opening another program.

While running the slideshow, activating embedded videos should work ok.  Activating links is a bit problematic and sounds like what you are encountering.  To activate a link on a slide, press TAB to move to it - NVDA reports nothing - and then press ENTER.  Out of curiosity, since you mentioned trying it with Jaws, did you have trouble with Jaws as well?  (That would help narrow down the issue - if it works fine with Jaws, it could be NVDA not responding correctly to the link - if it doesn't work any better with Jaws then it's more likely to be PowerPoint not exposing it correctly).

Re obscured, that is usually reported at design time (ie when you open the file in PowerPoint but haven't pressed F5 to run the slideshow). and means that one placeholder is covering another on the slide.  It may not mean the contents of each aren't visible - if you have a one line title, but expand the size of the placeholder to cover the whole slide, it won't actually hide any other content but it will announce that it is covering it (and that the other content is obscured).  Overlapping placeholders can also be used for visual effect, although in general, when creating, it is safest to try to avoid overlapping unless you are sure of what you are doing.

If you want to activate a link within a placeholder at design time, you can move to it, then open the context menu and select "Open link".

We do have an issue for the problem with links while running slideshows here: https://github.com/nvaccess/nvda/issues/7288  Feel free to add any extra comments on that (if you do, the issue is still present in the latest alpha).

Regards

Quentin.

On Mon, Dec 2, 2019 at 2:02 AM Payal Kapoor <payal69@...> wrote:
hi,
i am working with a PPT with several slides which have not only
graphics as part of the content of a slide, but also links to videos.
however, i am unable to access the links(which don't show up as a link
there) .
i have tried everything  but have had no success. when checking using
insert+F1, the message very clearly said there were hyperlinks as part
of the content.
to test that theory, i did copy the content of the slide to a word doc
and it shows a link as well.
i am using the latest version of NVDA and have tried it with one of
the earlier versions of JAWS 18  installed on my Windows 10 laptop.
the office version is 2016.
the message when focusing on the video in the slide is: video
obscured. also, i saw a message about access to the links being
blocked. now i don't know which key combination brought that one on.
after all that mishmash of information, i would be eternally grateful
to anyone who can help me get to the video links.
it is critical, since those are part of the training content for work i do.
thanks for any possible help.
Best,





--
Quentin Christensen
Training and Support Manager

Payal Kapoor
 

hi Quentin,
here is my response to the questions you've asked. thought i'd break
them up into two parts.
Q: When you say link to a video, do you mean a text URL or link on the
slide, or do you mean an embedded video?  When you activate a link it
will open your browser to the specified URL.  An embedded video has a
preview of the video (a still image, similar to that shown on
thumbnails in Youtube etc) with a triangle play button), when you
activate it, the video plays there in the slideshow without opening
another program.
P: There is no real text link, only some image and text saying video.
when coppied on to a word doc, it says hyperlink, but, no real URL. i
am not sure what that would be ccalled. it is however, not an external
source, but links to a folder that has all the relevant videos. i was
told it links there and plays.
essentially, it is an entire presentation made by sighted folk at my
work place that is used for training. i am the first blind person
attempting to use it. it contains two different PPTs for two different
programmes we run. also, it has other training material we access from
within the whole thing.
Q: Activating links is a bit problematic and sounds like what you are
encountering.  To activate a link on a slide, press TAB to move to it
- NVDA reports nothing - and then press ENTER.  Out of curiosity,
since you mentioned trying it with Jaws, did you have trouble with
Jaws as well?  (That would help narrow down the issue - if it works
fine with Jaws, it could be NVDA not responding correctly to the link
- if it doesn't work any better with Jaws then it's more likely to be
PowerPoint not exposing it correctly).
P: I think what you have said about the problem with accessing links
is exactly what i'm having trouble with. however, i noticed that when
the PPT is in slide mode, where more specifically, i activate the edit
mode by pressing enter when in the specific slide, the link appears
alongside the video. arrow down to it, choosing the open hyperlink
option in the applications menu, voila! the video began playing.
i was told that this option cannot be used when making a presentation,
since it is not visually appealing or as good as it is in the
presentation mode.
the presentation mode won't show me a link,and when pressing enter
there brings a prompt saying-no pointer available; choose a pointer.
back to the application menu, but this time, all the pointer options
do nothing.
JAWS did nothing different either. in fact, NVDA allowed me to see the
link; JAWS didn't. that might also be due to the old version of JAWS i
have installed on my laptop.
also, could you tell me how can i copy the contents of the slides, so
i have it in a word doc to refer as notes rather than opepning the PPT
eacj time? i did try the universal copy paste command, but strangely
nothing showed up.
this is definitely a deterrent in being able to run presentations
visually for sighted folk when training. i hope we find a resolution
to it soon enough.
thanks for the help.
Best,
Payal

On 12/2/19, Quentin Christensen <quentin@...> wrote:
When you say link to a video, do you mean a text URL or link on the slide,
or do you mean an embedded video? When you activate a link it will open
your browser to the specified URL. An embedded video has a preview of the
video (a still image, similar to that shown on thumbnails in Youtube etc)
with a triangle play button), when you activate it, the video plays there
in the slideshow without opening another program.

While running the slideshow, activating embedded videos should work ok.
Activating links is a bit problematic and sounds like what you are
encountering. To activate a link on a slide, press TAB to move to it -
NVDA reports nothing - and then press ENTER. Out of curiosity, since you
mentioned trying it with Jaws, did you have trouble with Jaws as well?
(That would help narrow down the issue - if it works fine with Jaws, it
could be NVDA not responding correctly to the link - if it doesn't work any
better with Jaws then it's more likely to be PowerPoint not exposing it
correctly).

Re obscured, that is usually reported at design time (ie when you open the
file in PowerPoint but haven't pressed F5 to run the slideshow). and means
that one placeholder is covering another on the slide. It may not mean the
contents of each aren't visible - if you have a one line title, but expand
the size of the placeholder to cover the whole slide, it won't actually
hide any other content but it will announce that it is covering it (and
that the other content is obscured). Overlapping placeholders can also be
used for visual effect, although in general, when creating, it is safest to
try to avoid overlapping unless you are sure of what you are doing.

If you want to activate a link within a placeholder at design time, you can
move to it, then open the context menu and select "Open link".

We do have an issue for the problem with links while running slideshows
here: https://github.com/nvaccess/nvda/issues/7288 Feel free to add any
extra comments on that (if you do, the issue is still present in the latest
alpha).

Regards

Quentin.

On Mon, Dec 2, 2019 at 2:02 AM Payal Kapoor <payal69@...> wrote:

hi,
i am working with a PPT with several slides which have not only
graphics as part of the content of a slide, but also links to videos.
however, i am unable to access the links(which don't show up as a link
there) .
i have tried everything but have had no success. when checking using
insert+F1, the message very clearly said there were hyperlinks as part
of the content.
to test that theory, i did copy the content of the slide to a word doc
and it shows a link as well.
i am using the latest version of NVDA and have tried it with one of
the earlier versions of JAWS 18 installed on my Windows 10 laptop.
the office version is 2016.
the message when focusing on the video in the slide is: video
obscured. also, i saw a message about access to the links being
blocked. now i don't know which key combination brought that one on.
after all that mishmash of information, i would be eternally grateful
to anyone who can help me get to the video links.
it is critical, since those are part of the training content for work i
do.
thanks for any possible help.
Best,



--
Quentin Christensen
Training and Support Manager

Web: www.nvaccess.org
Training: https://www.nvaccess.org/shop/
Certification: https://certification.nvaccess.org/
User group: https://nvda.groups.io/g/nvda
Facebook: http://www.facebook.com/NVAccess
Twitter: @NVAccess <https://twitter.com/NVAccess>



Quentin Christensen
 

Hi Payal,

There are several different ways of inserting videos.  Depending on how it was inserted, PowerPoint treats it differently when running the presentation.  To be honest, from what you've described I'm not exactly sure how they created it.  If you can get it to work though, that's good :)

Linking to other powerpoint files from within one file is not something I would generally try to do.  If it works, I guess that's one way of doing things, but it seems messy.

Copying things out of PowerPoint can be done in a couple of ways depending on what you need.

If you go to Outline view (alt+w, p, o) you can select all (control+a) then copy (control+c), move to Word and paste it (control+v).  It won't necessarily paste everything, but in general, it should copy most titles, and possibly some content (again, PowerPoint is not very consistent, and it depends on the content).

You could also move to the top of your presentation, and on the first slide, select all, copy and paste into Word, come back, press page down, repeat.  Graphics don't always copy nicely, but text is often ok.

If what you really want is a set of notes to work off when presenting, you can use F6 to jump between sections until you get to the notes section, type what you want for each slide, and then when you run the slideshow, press CONTROL+SHIFT+S to toggle between NVDA reading the slide content, and the speaker notes.

Kind regards

Quentin.

On Mon, Dec 2, 2019 at 10:15 PM Payal Kapoor <payal69@...> wrote:
hi Quentin,
here is my response to the questions you've asked. thought i'd break
them up into two parts.
Q: When you say link to a video, do you mean a text URL or link on the
slide, or do you mean an embedded video?  When you activate a link it
will open your browser to the specified URL.  An embedded video has a
preview of the video (a still image, similar to that shown on
thumbnails in Youtube etc) with a triangle play button), when you
activate it, the video plays there in the slideshow without opening
another program.
P: There is no real text link, only some image and text saying video.
when coppied on to a word doc, it says hyperlink, but, no real URL. i
am not sure what that would be ccalled. it is however, not an external
source, but links to a folder that has all the relevant videos. i was
told it links there and plays.
essentially, it is an entire presentation made by sighted folk at my
work place that is used for training. i am the first blind person
attempting to use it. it contains two different PPTs for two different
programmes we run. also, it has other training material we access from
within the whole thing.
Q: Activating links is a bit problematic and sounds like what you are
encountering.  To activate a link on a slide, press TAB to move to it
- NVDA reports nothing - and then press ENTER.  Out of curiosity,
since you mentioned trying it with Jaws, did you have trouble with
Jaws as well?  (That would help narrow down the issue - if it works
fine with Jaws, it could be NVDA not responding correctly to the link
- if it doesn't work any better with Jaws then it's more likely to be
PowerPoint not exposing it correctly).
P: I think what you have said about the problem with accessing links
is exactly what i'm having trouble with. however, i noticed that when
the PPT is in slide mode, where more specifically, i activate the edit
mode by pressing enter when in the specific slide, the link appears
alongside the video. arrow down to it, choosing the open hyperlink
option in the applications menu, voila! the video began playing.
i was told that this option cannot be used when making a presentation,
since it is not visually appealing or as good as it is in the
presentation mode.
the presentation mode won't show me a link,and when pressing enter
there brings a prompt saying-no pointer available; choose a pointer.
back to the application menu, but this time, all the pointer options
do nothing.
JAWS did nothing different either. in fact, NVDA allowed me to see the
link; JAWS didn't. that might also be due to the old version of JAWS i
have installed on my laptop.
also, could you tell me how can i copy the contents of the slides, so
i have it in a word doc to refer as notes rather than opepning the PPT
eacj time? i did try the universal copy paste command, but strangely
nothing showed up.
this  is definitely a deterrent in being able to run presentations
visually for sighted folk when training. i hope we find a resolution
to it soon enough.
thanks for the help.
Best,
Payal


On 12/2/19, Quentin Christensen <quentin@...> wrote:
> When you say link to a video, do you mean a text URL or link on the slide,
> or do you mean an embedded video?  When you activate a link it will open
> your browser to the specified URL.  An embedded video has a preview of the
> video (a still image, similar to that shown on thumbnails in Youtube etc)
> with a triangle play button), when you activate it, the video plays there
> in the slideshow without opening another program.
>
> While running the slideshow, activating embedded videos should work ok.
> Activating links is a bit problematic and sounds like what you are
> encountering.  To activate a link on a slide, press TAB to move to it -
> NVDA reports nothing - and then press ENTER.  Out of curiosity, since you
> mentioned trying it with Jaws, did you have trouble with Jaws as well?
> (That would help narrow down the issue - if it works fine with Jaws, it
> could be NVDA not responding correctly to the link - if it doesn't work any
> better with Jaws then it's more likely to be PowerPoint not exposing it
> correctly).
>
> Re obscured, that is usually reported at design time (ie when you open the
> file in PowerPoint but haven't pressed F5 to run the slideshow). and means
> that one placeholder is covering another on the slide.  It may not mean the
> contents of each aren't visible - if you have a one line title, but expand
> the size of the placeholder to cover the whole slide, it won't actually
> hide any other content but it will announce that it is covering it (and
> that the other content is obscured).  Overlapping placeholders can also be
> used for visual effect, although in general, when creating, it is safest to
> try to avoid overlapping unless you are sure of what you are doing.
>
> If you want to activate a link within a placeholder at design time, you can
> move to it, then open the context menu and select "Open link".
>
> We do have an issue for the problem with links while running slideshows
> here: https://github.com/nvaccess/nvda/issues/7288  Feel free to add any
> extra comments on that (if you do, the issue is still present in the latest
> alpha).
>
> Regards
>
> Quentin.
>
> On Mon, Dec 2, 2019 at 2:02 AM Payal Kapoor <payal69@...> wrote:
>
>> hi,
>> i am working with a PPT with several slides which have not only
>> graphics as part of the content of a slide, but also links to videos.
>> however, i am unable to access the links(which don't show up as a link
>> there) .
>> i have tried everything  but have had no success. when checking using
>> insert+F1, the message very clearly said there were hyperlinks as part
>> of the content.
>> to test that theory, i did copy the content of the slide to a word doc
>> and it shows a link as well.
>> i am using the latest version of NVDA and have tried it with one of
>> the earlier versions of JAWS 18  installed on my Windows 10 laptop.
>> the office version is 2016.
>> the message when focusing on the video in the slide is: video
>> obscured. also, i saw a message about access to the links being
>> blocked. now i don't know which key combination brought that one on.
>> after all that mishmash of information, i would be eternally grateful
>> to anyone who can help me get to the video links.
>> it is critical, since those are part of the training content for work i
>> do.
>> thanks for any possible help.
>> Best,
>>
>>
>>
>>
>
> --
> Quentin Christensen
> Training and Support Manager
>
> Web: www.nvaccess.org
> Training: https://www.nvaccess.org/shop/
> Certification: https://certification.nvaccess.org/
> User group: https://nvda.groups.io/g/nvda
> Facebook: http://www.facebook.com/NVAccess
> Twitter: @NVAccess <https://twitter.com/NVAccess>
>
>
>
>





--
Quentin Christensen
Training and Support Manager

Payal Kapoor
 

thanks for the inputs Quentin. for now i'll simply have to make do
with whatever is available-juggle around a bit; figure out the best
way to get it going. ultimately though, i'll look at creating my own
presentation in Powerr Point with the same content and videos. since
it is my first time using all this overload of information, it's
rather overwhelming.
i've been given various workarounds by other friends using PPT with
media info. maybe i will try and work with those as well.
Best,
Payal

On 12/3/19, Quentin Christensen <quentin@...> wrote:
Hi Payal,

There are several different ways of inserting videos. Depending on how it
was inserted, PowerPoint treats it differently when running the
presentation. To be honest, from what you've described I'm not exactly
sure how they created it. If you can get it to work though, that's good :)

Linking to other powerpoint files from within one file is not something I
would generally try to do. If it works, I guess that's one way of doing
things, but it seems messy.

Copying things out of PowerPoint can be done in a couple of ways depending
on what you need.

If you go to Outline view (alt+w, p, o) you can select all (control+a) then
copy (control+c), move to Word and paste it (control+v). It won't
necessarily paste everything, but in general, it should copy most titles,
and possibly some content (again, PowerPoint is not very consistent, and it
depends on the content).

You could also move to the top of your presentation, and on the first
slide, select all, copy and paste into Word, come back, press page down,
repeat. Graphics don't always copy nicely, but text is often ok.

If what you really want is a set of notes to work off when presenting, you
can use F6 to jump between sections until you get to the notes section,
type what you want for each slide, and then when you run the slideshow,
press CONTROL+SHIFT+S to toggle between NVDA reading the slide content, and
the speaker notes.

Kind regards

Quentin.

On Mon, Dec 2, 2019 at 10:15 PM Payal Kapoor <payal69@...> wrote:

hi Quentin,
here is my response to the questions you've asked. thought i'd break
them up into two parts.
Q: When you say link to a video, do you mean a text URL or link on the
slide, or do you mean an embedded video? When you activate a link it
will open your browser to the specified URL. An embedded video has a
preview of the video (a still image, similar to that shown on
thumbnails in Youtube etc) with a triangle play button), when you
activate it, the video plays there in the slideshow without opening
another program.
P: There is no real text link, only some image and text saying video.
when coppied on to a word doc, it says hyperlink, but, no real URL. i
am not sure what that would be ccalled. it is however, not an external
source, but links to a folder that has all the relevant videos. i was
told it links there and plays.
essentially, it is an entire presentation made by sighted folk at my
work place that is used for training. i am the first blind person
attempting to use it. it contains two different PPTs for two different
programmes we run. also, it has other training material we access from
within the whole thing.
Q: Activating links is a bit problematic and sounds like what you are
encountering. To activate a link on a slide, press TAB to move to it
- NVDA reports nothing - and then press ENTER. Out of curiosity,
since you mentioned trying it with Jaws, did you have trouble with
Jaws as well? (That would help narrow down the issue - if it works
fine with Jaws, it could be NVDA not responding correctly to the link
- if it doesn't work any better with Jaws then it's more likely to be
PowerPoint not exposing it correctly).
P: I think what you have said about the problem with accessing links
is exactly what i'm having trouble with. however, i noticed that when
the PPT is in slide mode, where more specifically, i activate the edit
mode by pressing enter when in the specific slide, the link appears
alongside the video. arrow down to it, choosing the open hyperlink
option in the applications menu, voila! the video began playing.
i was told that this option cannot be used when making a presentation,
since it is not visually appealing or as good as it is in the
presentation mode.
the presentation mode won't show me a link,and when pressing enter
there brings a prompt saying-no pointer available; choose a pointer.
back to the application menu, but this time, all the pointer options
do nothing.
JAWS did nothing different either. in fact, NVDA allowed me to see the
link; JAWS didn't. that might also be due to the old version of JAWS i
have installed on my laptop.
also, could you tell me how can i copy the contents of the slides, so
i have it in a word doc to refer as notes rather than opepning the PPT
eacj time? i did try the universal copy paste command, but strangely
nothing showed up.
this is definitely a deterrent in being able to run presentations
visually for sighted folk when training. i hope we find a resolution
to it soon enough.
thanks for the help.
Best,
Payal


On 12/2/19, Quentin Christensen <quentin@...> wrote:
When you say link to a video, do you mean a text URL or link on the
slide,
or do you mean an embedded video? When you activate a link it will
open
your browser to the specified URL. An embedded video has a preview of
the
video (a still image, similar to that shown on thumbnails in Youtube
etc)
with a triangle play button), when you activate it, the video plays
there
in the slideshow without opening another program.

While running the slideshow, activating embedded videos should work ok.
Activating links is a bit problematic and sounds like what you are
encountering. To activate a link on a slide, press TAB to move to it -
NVDA reports nothing - and then press ENTER. Out of curiosity, since
you
mentioned trying it with Jaws, did you have trouble with Jaws as well?
(That would help narrow down the issue - if it works fine with Jaws, it
could be NVDA not responding correctly to the link - if it doesn't work
any
better with Jaws then it's more likely to be PowerPoint not exposing it
correctly).

Re obscured, that is usually reported at design time (ie when you open
the
file in PowerPoint but haven't pressed F5 to run the slideshow). and
means
that one placeholder is covering another on the slide. It may not mean
the
contents of each aren't visible - if you have a one line title, but
expand
the size of the placeholder to cover the whole slide, it won't actually
hide any other content but it will announce that it is covering it (and
that the other content is obscured). Overlapping placeholders can also
be
used for visual effect, although in general, when creating, it is
safest
to
try to avoid overlapping unless you are sure of what you are doing.

If you want to activate a link within a placeholder at design time, you
can
move to it, then open the context menu and select "Open link".

We do have an issue for the problem with links while running slideshows
here: https://github.com/nvaccess/nvda/issues/7288 Feel free to add
any
extra comments on that (if you do, the issue is still present in the
latest
alpha).

Regards

Quentin.

On Mon, Dec 2, 2019 at 2:02 AM Payal Kapoor <payal69@...> wrote:

hi,
i am working with a PPT with several slides which have not only
graphics as part of the content of a slide, but also links to videos.
however, i am unable to access the links(which don't show up as a link
there) .
i have tried everything but have had no success. when checking using
insert+F1, the message very clearly said there were hyperlinks as part
of the content.
to test that theory, i did copy the content of the slide to a word doc
and it shows a link as well.
i am using the latest version of NVDA and have tried it with one of
the earlier versions of JAWS 18 installed on my Windows 10 laptop.
the office version is 2016.
the message when focusing on the video in the slide is: video
obscured. also, i saw a message about access to the links being
blocked. now i don't know which key combination brought that one on.
after all that mishmash of information, i would be eternally grateful
to anyone who can help me get to the video links.
it is critical, since those are part of the training content for work
i
do.
thanks for any possible help.
Best,



--
Quentin Christensen
Training and Support Manager

Web: www.nvaccess.org
Training: https://www.nvaccess.org/shop/
Certification: https://certification.nvaccess.org/
User group: https://nvda.groups.io/g/nvda
Facebook: http://www.facebook.com/NVAccess
Twitter: @NVAccess <https://twitter.com/NVAccess>





--
Quentin Christensen
Training and Support Manager

Web: www.nvaccess.org
Training: https://www.nvaccess.org/shop/
Certification: https://certification.nvaccess.org/
User group: https://nvda.groups.io/g/nvda
Facebook: http://www.facebook.com/NVAccess
Twitter: @NVAccess <https://twitter.com/NVAccess>



Quentin Christensen
 

If you are able to share the file with me personally offlist (I won't share it further), I can have a look and see what I can learn from it - as well as being in the middle of writing the "Microsoft PowerPoint with NVDA" training material, I am also filing lots of issues (or confirming existing issues) in both our own issue tracker - https://github.com/nvaccess/nvda/issues and with Microsoft.

During this process, while I can work my way through all the features of the software, it's always good to get some real world examples like yours which demonstrate the interesting ways those features are used.

Kind regards

Quentin.

On Tue, Dec 3, 2019 at 9:11 PM Payal Kapoor <payal69@...> wrote:
thanks for the inputs Quentin. for now i'll simply have to make do
with whatever is available-juggle around a bit; figure out the best
way to get it going. ultimately though, i'll look at creating my own
presentation in Powerr Point with the same content and videos. since
it is my first time using all this overload of information, it's
rather overwhelming.
i've been given various workarounds by other friends using PPT with
media info. maybe i will try and work with those as well.
Best,
Payal


On 12/3/19, Quentin Christensen <quentin@...> wrote:
> Hi Payal,
>
> There are several different ways of inserting videos.  Depending on how it
> was inserted, PowerPoint treats it differently when running the
> presentation.  To be honest, from what you've described I'm not exactly
> sure how they created it.  If you can get it to work though, that's good :)
>
> Linking to other powerpoint files from within one file is not something I
> would generally try to do.  If it works, I guess that's one way of doing
> things, but it seems messy.
>
> Copying things out of PowerPoint can be done in a couple of ways depending
> on what you need.
>
> If you go to Outline view (alt+w, p, o) you can select all (control+a) then
> copy (control+c), move to Word and paste it (control+v).  It won't
> necessarily paste everything, but in general, it should copy most titles,
> and possibly some content (again, PowerPoint is not very consistent, and it
> depends on the content).
>
> You could also move to the top of your presentation, and on the first
> slide, select all, copy and paste into Word, come back, press page down,
> repeat.  Graphics don't always copy nicely, but text is often ok.
>
> If what you really want is a set of notes to work off when presenting, you
> can use F6 to jump between sections until you get to the notes section,
> type what you want for each slide, and then when you run the slideshow,
> press CONTROL+SHIFT+S to toggle between NVDA reading the slide content, and
> the speaker notes.
>
> Kind regards
>
> Quentin.
>
> On Mon, Dec 2, 2019 at 10:15 PM Payal Kapoor <payal69@...> wrote:
>
>> hi Quentin,
>> here is my response to the questions you've asked. thought i'd break
>> them up into two parts.
>> Q: When you say link to a video, do you mean a text URL or link on the
>> slide, or do you mean an embedded video?  When you activate a link it
>> will open your browser to the specified URL.  An embedded video has a
>> preview of the video (a still image, similar to that shown on
>> thumbnails in Youtube etc) with a triangle play button), when you
>> activate it, the video plays there in the slideshow without opening
>> another program.
>> P: There is no real text link, only some image and text saying video.
>> when coppied on to a word doc, it says hyperlink, but, no real URL. i
>> am not sure what that would be ccalled. it is however, not an external
>> source, but links to a folder that has all the relevant videos. i was
>> told it links there and plays.
>> essentially, it is an entire presentation made by sighted folk at my
>> work place that is used for training. i am the first blind person
>> attempting to use it. it contains two different PPTs for two different
>> programmes we run. also, it has other training material we access from
>> within the whole thing.
>> Q: Activating links is a bit problematic and sounds like what you are
>> encountering.  To activate a link on a slide, press TAB to move to it
>> - NVDA reports nothing - and then press ENTER.  Out of curiosity,
>> since you mentioned trying it with Jaws, did you have trouble with
>> Jaws as well?  (That would help narrow down the issue - if it works
>> fine with Jaws, it could be NVDA not responding correctly to the link
>> - if it doesn't work any better with Jaws then it's more likely to be
>> PowerPoint not exposing it correctly).
>> P: I think what you have said about the problem with accessing links
>> is exactly what i'm having trouble with. however, i noticed that when
>> the PPT is in slide mode, where more specifically, i activate the edit
>> mode by pressing enter when in the specific slide, the link appears
>> alongside the video. arrow down to it, choosing the open hyperlink
>> option in the applications menu, voila! the video began playing.
>> i was told that this option cannot be used when making a presentation,
>> since it is not visually appealing or as good as it is in the
>> presentation mode.
>> the presentation mode won't show me a link,and when pressing enter
>> there brings a prompt saying-no pointer available; choose a pointer.
>> back to the application menu, but this time, all the pointer options
>> do nothing.
>> JAWS did nothing different either. in fact, NVDA allowed me to see the
>> link; JAWS didn't. that might also be due to the old version of JAWS i
>> have installed on my laptop.
>> also, could you tell me how can i copy the contents of the slides, so
>> i have it in a word doc to refer as notes rather than opepning the PPT
>> eacj time? i did try the universal copy paste command, but strangely
>> nothing showed up.
>> this  is definitely a deterrent in being able to run presentations
>> visually for sighted folk when training. i hope we find a resolution
>> to it soon enough.
>> thanks for the help.
>> Best,
>> Payal
>>
>>
>> On 12/2/19, Quentin Christensen <quentin@...> wrote:
>> > When you say link to a video, do you mean a text URL or link on the
>> slide,
>> > or do you mean an embedded video?  When you activate a link it will
>> > open
>> > your browser to the specified URL.  An embedded video has a preview of
>> the
>> > video (a still image, similar to that shown on thumbnails in Youtube
>> > etc)
>> > with a triangle play button), when you activate it, the video plays
>> > there
>> > in the slideshow without opening another program.
>> >
>> > While running the slideshow, activating embedded videos should work ok.
>> > Activating links is a bit problematic and sounds like what you are
>> > encountering.  To activate a link on a slide, press TAB to move to it -
>> > NVDA reports nothing - and then press ENTER.  Out of curiosity, since
>> > you
>> > mentioned trying it with Jaws, did you have trouble with Jaws as well?
>> > (That would help narrow down the issue - if it works fine with Jaws, it
>> > could be NVDA not responding correctly to the link - if it doesn't work
>> any
>> > better with Jaws then it's more likely to be PowerPoint not exposing it
>> > correctly).
>> >
>> > Re obscured, that is usually reported at design time (ie when you open
>> the
>> > file in PowerPoint but haven't pressed F5 to run the slideshow). and
>> means
>> > that one placeholder is covering another on the slide.  It may not mean
>> the
>> > contents of each aren't visible - if you have a one line title, but
>> expand
>> > the size of the placeholder to cover the whole slide, it won't actually
>> > hide any other content but it will announce that it is covering it (and
>> > that the other content is obscured).  Overlapping placeholders can also
>> be
>> > used for visual effect, although in general, when creating, it is
>> > safest
>> to
>> > try to avoid overlapping unless you are sure of what you are doing.
>> >
>> > If you want to activate a link within a placeholder at design time, you
>> can
>> > move to it, then open the context menu and select "Open link".
>> >
>> > We do have an issue for the problem with links while running slideshows
>> > here: https://github.com/nvaccess/nvda/issues/7288  Feel free to add
>> > any
>> > extra comments on that (if you do, the issue is still present in the
>> latest
>> > alpha).
>> >
>> > Regards
>> >
>> > Quentin.
>> >
>> > On Mon, Dec 2, 2019 at 2:02 AM Payal Kapoor <payal69@...> wrote:
>> >
>> >> hi,
>> >> i am working with a PPT with several slides which have not only
>> >> graphics as part of the content of a slide, but also links to videos.
>> >> however, i am unable to access the links(which don't show up as a link
>> >> there) .
>> >> i have tried everything  but have had no success. when checking using
>> >> insert+F1, the message very clearly said there were hyperlinks as part
>> >> of the content.
>> >> to test that theory, i did copy the content of the slide to a word doc
>> >> and it shows a link as well.
>> >> i am using the latest version of NVDA and have tried it with one of
>> >> the earlier versions of JAWS 18  installed on my Windows 10 laptop.
>> >> the office version is 2016.
>> >> the message when focusing on the video in the slide is: video
>> >> obscured. also, i saw a message about access to the links being
>> >> blocked. now i don't know which key combination brought that one on.
>> >> after all that mishmash of information, i would be eternally grateful
>> >> to anyone who can help me get to the video links.
>> >> it is critical, since those are part of the training content for work
>> >> i
>> >> do.
>> >> thanks for any possible help.
>> >> Best,
>> >>
>> >>
>> >>
>> >>
>> >
>> > --
>> > Quentin Christensen
>> > Training and Support Manager
>> >
>> > Web: www.nvaccess.org
>> > Training: https://www.nvaccess.org/shop/
>> > Certification: https://certification.nvaccess.org/
>> > User group: https://nvda.groups.io/g/nvda
>> > Facebook: http://www.facebook.com/NVAccess
>> > Twitter: @NVAccess <https://twitter.com/NVAccess>
>> >
>> >
>> >
>> >
>>
>>
>>
>>
>
> --
> Quentin Christensen
> Training and Support Manager
>
> Web: www.nvaccess.org
> Training: https://www.nvaccess.org/shop/
> Certification: https://certification.nvaccess.org/
> User group: https://nvda.groups.io/g/nvda
> Facebook: http://www.facebook.com/NVAccess
> Twitter: @NVAccess <https://twitter.com/NVAccess>
>
>
>
>





--
Quentin Christensen
Training and Support Manager