Topics

Add-on Updater and NVDA 2019.3 add-ons: more add-on updates are on their way #addonrelease

 

Hello everyone,

 

First, on behalf of the NVDA add-ons community, I would like to thank everyone for your patience and encouragements regarding NVDA 2019.3 development. Now that 2019.3 (or rather, 2019.3.1) stable is out, more add-ons are making themselves visible via stable update channel. As such, if you are using NVDA 2019.3.x, please use Add-on Updater to update to compatible add-on releases.

 

NOTE: if you are still using 2019.2.1 or earlier, you’ll get a notice about add-on incompatibility when you update various add-ons. If you absolutely need to use NVDA 2019.2.1 due to important add-ons you’ve got, please DO NOT update add-ons. Going forward, most add-ons will require 2019.3 or later.

 

Another note: as I promised back in December 2019, Add-on Updater will be one of the last add-ons to require 2019.3 (last of my add-ons to require 2019.3.).


Thank you.

Cheers,

Joseph

 

Good to know joseph.

Looks like report symbols and emoteicons are updated and stable.

Dropbox is the last to become stable still at least from the site.

Everything else just works.

Technically image describer needs updates but I have removed it as I don't use it right now.

There are the nstockton addons but right now when I doodled with the manafests the addon can't just run, and I guess it will eventually get updated like everything else.

If not I will just run old nvda when playing interactive fiction when I need to.



On 11/02/2020 8:54 am, Joseph Lee wrote:

Hello everyone,

 

First, on behalf of the NVDA add-ons community, I would like to thank everyone for your patience and encouragements regarding NVDA 2019.3 development. Now that 2019.3 (or rather, 2019.3.1) stable is out, more add-ons are making themselves visible via stable update channel. As such, if you are using NVDA 2019.3.x, please use Add-on Updater to update to compatible add-on releases.

 

NOTE: if you are still using 2019.2.1 or earlier, you’ll get a notice about add-on incompatibility when you update various add-ons. If you absolutely need to use NVDA 2019.2.1 due to important add-ons you’ve got, please DO NOT update add-ons. Going forward, most add-ons will require 2019.3 or later.

 

Another note: as I promised back in December 2019, Add-on Updater will be one of the last add-ons to require 2019.3 (last of my add-ons to require 2019.3.).


Thank you.

Cheers,

Joseph