Topics

Addon development guide

=?ISO-2022-JP?Q?=1B$B9b=4082=22=1B=28J?=
 

Hi

Why it says need python 2.7?

 

First, interesting user name.

Second, probably because it hasn't been updated.  This happens with a vast amount of documentation over time, particularly documentation not aimed at end users.  With all the fanfare about NVDA now using Python 3 . . . 
--

Brian - Windows 10 Pro, 64-Bit, Version 1909, Build 18363  

Power is being told you're not loved and not being destroyed by it.

       ~ Madonna

 

 

 

Hi,
It hasn't been updated - I'll take care of that in just a few moments.
Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of ???
Sent: Saturday, March 14, 2020 6:38 AM
To: nvda@groups.io
Subject: [nvda] Addon development guide

Hi

Why it says need python 2.7?

Rui Fontes
 

Don't forget to actualize also the versions of Gettext, MarkDown and SCons at least...


Rui Fontes


Às 15:09 de 14/03/2020, Joseph Lee escreveu:

Hi,
It hasn't been updated - I'll take care of that in just a few moments.
Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of ???
Sent: Saturday, March 14, 2020 6:38 AM
To: nvda@groups.io
Subject: [nvda] Addon development guide

Hi

Why it says need python 2.7?




 

Hi,
For these, actual versions re listed.
Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Rui Fontes
Sent: Saturday, March 14, 2020 8:17 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Addon development guide

Don't forget to actualize also the versions of Gettext, MarkDown and SCons at least...


Rui Fontes


Às 15:09 de 14/03/2020, Joseph Lee escreveu:
Hi,
It hasn't been updated - I'll take care of that in just a few moments.
Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of ???
Sent: Saturday, March 14, 2020 6:38 AM
To: nvda@groups.io
Subject: [nvda] Addon development guide

Hi

Why it says need python 2.7?





Rui Fontes
 

In my case I have to instal Gettext 0.20 to be able to compile pot files...


Rui Fontes


Às 15:22 de 14/03/2020, Joseph Lee escreveu:

Hi,
For these, actual versions re listed.
Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Rui Fontes
Sent: Saturday, March 14, 2020 8:17 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Addon development guide

Don't forget to actualize also the versions of Gettext, MarkDown and SCons at least...


Rui Fontes


Às 15:09 de 14/03/2020, Joseph Lee escreveu:
Hi,
It hasn't been updated - I'll take care of that in just a few moments.
Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of ???
Sent: Saturday, March 14, 2020 6:38 AM
To: nvda@groups.io
Subject: [nvda] Addon development guide

Hi

Why it says need python 2.7?







=?ISO-2022-JP?Q?=1B$B9b=4082=22=1B=28J?=
 

Hi,

The copyright year also need to change.

On Sat, 14 Mar 2020, Joseph Lee wrote:

Date: Sat, 14 Mar 2020 08:09:16 -0700
From: Joseph Lee <@joslee>
Reply-To: nvda@nvda.groups.io
To: nvda@nvda.groups.io
Subject: Re: [nvda] Addon development guide
Hi,
It hasn't been updated - I'll take care of that in just a few moments.
Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of ???
Sent: Saturday, March 14, 2020 6:38 AM
To: nvda@groups.io
Subject: [nvda] Addon development guide

Hi

Why it says need python 2.7?