Topics

addons becoming incompatible after beta2 installed


mike mcglashon
 

Hi guys:

Installed nvda beta2 this morning;

When I did,

Many of my addons became incompatible, and,

I had to check a box claiming I understand this before installation;

Hence,

My question is,

How and where do I get the newer versions of the addons allegedly incompatible?

And,

Am I simply screwed if the author of the addon hasn’t updated it to the newest version of nvda?

 

 

Please advise as you like.

 

Mike M.

 

Mike mcglashon

Email: Michael.mcglashon@...

Ph: 618 783 9331

 


Chris Smart
 

Mike


just wondering


why you


separate


every couple


of


words


in your


posts


by


a


blank line?


 

Hi Mike,

Which add-ons are seen as incompatible with NVDA? To find out, open Add-ons Manager (NvDA menu/Tools/Manage add-ons), then select “view incompatible add-ons” and scroll through the list. The latest backwards incompatible version of NVDA is 2019.3 (due to Python 3 transition), and 2020.4 beta is not a compatibility breaking release, so the list of incompatible add-ons should not be that big.

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of mike mcglashon
Sent: Wednesday, December 23, 2020 9:42 AM
To: nvda@nvda.groups.io
Subject: [nvda] addons becoming incompatible after beta2 installed

 

Hi guys:

Installed nvda beta2 this morning;

When I did,

Many of my addons became incompatible, and,

I had to check a box claiming I understand this before installation;

Hence,

My question is,

How and where do I get the newer versions of the addons allegedly incompatible?

And,

Am I simply screwed if the author of the addon hasn’t updated it to the newest version of nvda?

 

 

Please advise as you like.

 

Mike M.

 

Mike mcglashon

Email: Michael.mcglashon@...

Ph: 618 783 9331

 


mike mcglashon
 

Oh that's easy;
I write how my thought pattern goes,
I get confused if I put more than one thought per line;

If it makes you feel better,
I get reprimanded for it in law school,
All the time;


Please advise as you like.

Mike M.

Mike mcglashon
Email: Michael.mcglashon@comcast.net
Ph: 618 783 9331

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Chris Smart
Sent: Wednesday, December 23, 2020 12:52 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] addons becoming incompatible after beta2 installed

Mike


just wondering


why you


separate


every couple


of


words


in your


posts


by


a


blank line?


mike mcglashon
 

Here is what I found whenst opening the “manage addons” dialogue;

 

The following add-ons are incompatible with NVDA version 2020.4. These add-ons can not be enabled.

Please contact the add-on author for further assistance.

Incompatible add-ons

Package Version Incompatible reason

DictationBridge Demo 0.1 An updated version of this add-on is required. T...

Golden Cursor moves the ... 1.2 An updated version of this add-on is required. T...

PC Keyboard Braille Input 2014.1 An updated version of this add-on is required. T...

Remote Support 2.2 An updated version of this add-on is required. T...

Resource Monitor 17.11 An updated version of this add-on is required. T...

Windows 10 App Essentia... 19.01.1 An updated version of this add-on is required. T...

 

About add-on... C

 

Please advise as you like.

 

Mike M.

 

Mike mcglashon

Email: Michael.mcglashon@...

Ph: 618 783 9331

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Joseph Lee
Sent: Wednesday, December 23, 2020 12:54 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] addons becoming incompatible after beta2 installed

 

Hi Mike,

Which add-ons are seen as incompatible with NVDA? To find out, open Add-ons Manager (NvDA menu/Tools/Manage add-ons), then select “view incompatible add-ons” and scroll through the list. The latest backwards incompatible version of NVDA is 2019.3 (due to Python 3 transition), and 2020.4 beta is not a compatibility breaking release, so the list of incompatible add-ons should not be that big.

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of mike mcglashon
Sent: Wednesday, December 23, 2020 9:42 AM
To: nvda@nvda.groups.io
Subject: [nvda] addons becoming incompatible after beta2 installed

 

Hi guys:

Installed nvda beta2 this morning;

When I did,

Many of my addons became incompatible, and,

I had to check a box claiming I understand this before installation;

Hence,

My question is,

How and where do I get the newer versions of the addons allegedly incompatible?

And,

Am I simply screwed if the author of the addon hasn’t updated it to the newest version of nvda?

 

 

Please advise as you like.

 

Mike M.

 

Mike mcglashon

Email: Michael.mcglashon@...

Ph: 618 783 9331

 


mike mcglashon
 

Sorry about that,

It looks like it cut off some of the messages for each addon;

It was supposed to say something like 2019.3 after each addon;

 

 

Please advise as you like.

 

Mike M.

 

Mike mcglashon

Email: Michael.mcglashon@...

Ph: 618 783 9331

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of mike mcglashon
Sent: Wednesday, December 23, 2020 1:03 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] addons becoming incompatible after beta2 installed

 

Here is what I found whenst opening the “manage addons” dialogue;

 

The following add-ons are incompatible with NVDA version 2020.4. These add-ons can not be enabled.

Please contact the add-on author for further assistance.

Incompatible add-ons

Package Version Incompatible reason

DictationBridge Demo 0.1 An updated version of this add-on is required. T...

Golden Cursor moves the ... 1.2 An updated version of this add-on is required. T...

PC Keyboard Braille Input 2014.1 An updated version of this add-on is required. T...

Remote Support 2.2 An updated version of this add-on is required. T...

Resource Monitor 17.11 An updated version of this add-on is required. T...

Windows 10 App Essentia... 19.01.1 An updated version of this add-on is required. T...

 

About add-on... C

 

Please advise as you like.

 

Mike M.

 

Mike mcglashon

Email: Michael.mcglashon@...

Ph: 618 783 9331

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Joseph Lee
Sent: Wednesday, December 23, 2020 12:54 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] addons becoming incompatible after beta2 installed

 

Hi Mike,

Which add-ons are seen as incompatible with NVDA? To find out, open Add-ons Manager (NvDA menu/Tools/Manage add-ons), then select “view incompatible add-ons” and scroll through the list. The latest backwards incompatible version of NVDA is 2019.3 (due to Python 3 transition), and 2020.4 beta is not a compatibility breaking release, so the list of incompatible add-ons should not be that big.

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of mike mcglashon
Sent: Wednesday, December 23, 2020 9:42 AM
To: nvda@nvda.groups.io
Subject: [nvda] addons becoming incompatible after beta2 installed

 

Hi guys:

Installed nvda beta2 this morning;

When I did,

Many of my addons became incompatible, and,

I had to check a box claiming I understand this before installation;

Hence,

My question is,

How and where do I get the newer versions of the addons allegedly incompatible?

And,

Am I simply screwed if the author of the addon hasn’t updated it to the newest version of nvda?

 

 

Please advise as you like.

 

Mike M.

 

Mike mcglashon

Email: Michael.mcglashon@...

Ph: 618 783 9331

 


Chris Smart
 

Hahaha no worries. I wondered if it was some encoding difference between our email software or something.

On 2020-12-23 12:58 p.m., mike mcglashon wrote:
Oh that's easy;
I write how my thought pattern goes,
I get confused if I put more than one thought per line;

If it makes you feel better,
I get reprimanded for it in law school,
All the time;


Please advise as you like.

Mike M.

Mike mcglashon
Email: Michael.mcglashon@comcast.net
Ph: 618 783 9331

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Chris Smart
Sent: Wednesday, December 23, 2020 12:52 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] addons becoming incompatible after beta2 installed

Mike


just wondering


why you


separate


every couple


of


words


in your


posts


by


a


blank line?













Gene
 

But your message implies that you read mail down arrowing through it. Why not use read to end?

Gene

-----Original Message-----
From: Chris Smart
Sent: Wednesday, December 23, 2020 12:12 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] addons becoming incompatible after beta2 installed

Hahaha no worries. I wondered if it was some encoding difference between
our email software or something.



On 2020-12-23 12:58 p.m., mike mcglashon wrote:
Oh that's easy;
I write how my thought pattern goes,
I get confused if I put more than one thought per line;

If it makes you feel better,
I get reprimanded for it in law school,
All the time;


Please advise as you like.

Mike M.

Mike mcglashon
Email: Michael.mcglashon@comcast.net
Ph: 618 783 9331

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Chris Smart
Sent: Wednesday, December 23, 2020 12:52 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] addons becoming incompatible after beta2 installed

Mike


just wondering


why you


separate


every couple


of


words


in your


posts


by


a


blank line?














mike mcglashon
 

Well,
If you are talking to me,
It's because,
When I use read to end,
Outlook does something weird and reboots itself,
(closes and reopens);


Please advise as you like.

Mike M.

Mike mcglashon
Email: Michael.mcglashon@comcast.net
Ph: 618 783 9331

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Gene
Sent: Wednesday, December 23, 2020 1:37 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] addons becoming incompatible after beta2 installed

But your message implies that you read mail down arrowing through it. Why not use read to end?

Gene
-----Original Message-----
From: Chris Smart
Sent: Wednesday, December 23, 2020 12:12 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] addons becoming incompatible after beta2 installed

Hahaha no worries. I wondered if it was some encoding difference between our email software or something.



On 2020-12-23 12:58 p.m., mike mcglashon wrote:
Oh that's easy;
I write how my thought pattern goes,
I get confused if I put more than one thought per line;

If it makes you feel better,
I get reprimanded for it in law school, All the time;


Please advise as you like.

Mike M.

Mike mcglashon
Email: Michael.mcglashon@comcast.net
Ph: 618 783 9331

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Chris Smart
Sent: Wednesday, December 23, 2020 12:52 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] addons becoming incompatible after beta2 installed

Mike


just wondering


why you


separate


every couple


of


words


in your


posts


by


a


blank line?














 

Hi,

Do you have Add-on Updater installed? I advise installing it as most add-ons in your list have received updates. There are exceptions such as DictationBridge, and if you do need that add-on, I advise searching for DicationBridge 1.1 beta (although I wrote that beta, I’m no longer maintaining DictationBridge in order to reduce my workload).

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of mike mcglashon
Sent: Wednesday, December 23, 2020 10:03 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] addons becoming incompatible after beta2 installed

 

Here is what I found whenst opening the “manage addons” dialogue;

 

The following add-ons are incompatible with NVDA version 2020.4. These add-ons can not be enabled.

Please contact the add-on author for further assistance.

Incompatible add-ons

Package Version Incompatible reason

DictationBridge Demo 0.1 An updated version of this add-on is required. T...

Golden Cursor moves the ... 1.2 An updated version of this add-on is required. T...

PC Keyboard Braille Input 2014.1 An updated version of this add-on is required. T...

Remote Support 2.2 An updated version of this add-on is required. T...

Resource Monitor 17.11 An updated version of this add-on is required. T...

Windows 10 App Essentia... 19.01.1 An updated version of this add-on is required. T...

 

About add-on... C

 

Please advise as you like.

 

Mike M.

 

Mike mcglashon

Email: Michael.mcglashon@...

Ph: 618 783 9331

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Joseph Lee
Sent: Wednesday, December 23, 2020 12:54 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] addons becoming incompatible after beta2 installed

 

Hi Mike,

Which add-ons are seen as incompatible with NVDA? To find out, open Add-ons Manager (NvDA menu/Tools/Manage add-ons), then select “view incompatible add-ons” and scroll through the list. The latest backwards incompatible version of NVDA is 2019.3 (due to Python 3 transition), and 2020.4 beta is not a compatibility breaking release, so the list of incompatible add-ons should not be that big.

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of mike mcglashon
Sent: Wednesday, December 23, 2020 9:42 AM
To: nvda@nvda.groups.io
Subject: [nvda] addons becoming incompatible after beta2 installed

 

Hi guys:

Installed nvda beta2 this morning;

When I did,

Many of my addons became incompatible, and,

I had to check a box claiming I understand this before installation;

Hence,

My question is,

How and where do I get the newer versions of the addons allegedly incompatible?

And,

Am I simply screwed if the author of the addon hasn’t updated it to the newest version of nvda?

 

 

Please advise as you like.

 

Mike M.

 

Mike mcglashon

Email: Michael.mcglashon@...

Ph: 618 783 9331

 


Gene
 

I was addressing you. I should have used your name to avoid possible confusion.

I have a possible work around. Try using the NVDA command that reads from the review cursor position to the end of the text. I have no idea if that will work around the problem but you never know. If you are using the desktop layout, its numpad plus, the second long key from the bottom on the right of the numpad.

I don't know the laptop command.

Gene

-----Original Message-----
From: mike mcglashon
Sent: Wednesday, December 23, 2020 12:50 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] addons becoming incompatible after beta2 installed

Well,
If you are talking to me,
It's because,
When I use read to end,
Outlook does something weird and reboots itself,
(closes and reopens);


Please advise as you like.

Mike M.

Mike mcglashon
Email: Michael.mcglashon@comcast.net
Ph: 618 783 9331

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Gene
Sent: Wednesday, December 23, 2020 1:37 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] addons becoming incompatible after beta2 installed

But your message implies that you read mail down arrowing through it. Why not use read to end?

Gene
-----Original Message-----
From: Chris Smart
Sent: Wednesday, December 23, 2020 12:12 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] addons becoming incompatible after beta2 installed

Hahaha no worries. I wondered if it was some encoding difference between our email software or something.



On 2020-12-23 12:58 p.m., mike mcglashon wrote:
Oh that's easy;
I write how my thought pattern goes,
I get confused if I put more than one thought per line;

If it makes you feel better,
I get reprimanded for it in law school, All the time;


Please advise as you like.

Mike M.

Mike mcglashon
Email: Michael.mcglashon@comcast.net
Ph: 618 783 9331

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Chris Smart
Sent: Wednesday, December 23, 2020 12:52 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] addons becoming incompatible after beta2 installed

Mike


just wondering


why you


separate


every couple


of


words


in your


posts


by


a


blank line?














mike mcglashon
 

Hi mr. joseph:

 

First,

How do I know if I have “addon updater” installed?

And,

If I don’t,

Do I go to “nvaccess.com” to get it?

 

 

Please advise as you like.

 

Mike M.

 

Mike mcglashon

Email: Michael.mcglashon@...

Ph: 618 783 9331

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Joseph Lee
Sent: Wednesday, December 23, 2020 1:52 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] addons becoming incompatible after beta2 installed

 

Hi,

Do you have Add-on Updater installed? I advise installing it as most add-ons in your list have received updates. There are exceptions such as DictationBridge, and if you do need that add-on, I advise searching for DicationBridge 1.1 beta (although I wrote that beta, I’m no longer maintaining DictationBridge in order to reduce my workload).

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of mike mcglashon
Sent: Wednesday, December 23, 2020 10:03 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] addons becoming incompatible after beta2 installed

 

Here is what I found whenst opening the “manage addons” dialogue;

 

The following add-ons are incompatible with NVDA version 2020.4. These add-ons can not be enabled.

Please contact the add-on author for further assistance.

Incompatible add-ons

Package Version Incompatible reason

DictationBridge Demo 0.1 An updated version of this add-on is required. T...

Golden Cursor moves the ... 1.2 An updated version of this add-on is required. T...

PC Keyboard Braille Input 2014.1 An updated version of this add-on is required. T...

Remote Support 2.2 An updated version of this add-on is required. T...

Resource Monitor 17.11 An updated version of this add-on is required. T...

Windows 10 App Essentia... 19.01.1 An updated version of this add-on is required. T...

 

About add-on... C

 

Please advise as you like.

 

Mike M.

 

Mike mcglashon

Email: Michael.mcglashon@...

Ph: 618 783 9331

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Joseph Lee
Sent: Wednesday, December 23, 2020 12:54 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] addons becoming incompatible after beta2 installed

 

Hi Mike,

Which add-ons are seen as incompatible with NVDA? To find out, open Add-ons Manager (NvDA menu/Tools/Manage add-ons), then select “view incompatible add-ons” and scroll through the list. The latest backwards incompatible version of NVDA is 2019.3 (due to Python 3 transition), and 2020.4 beta is not a compatibility breaking release, so the list of incompatible add-ons should not be that big.

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of mike mcglashon
Sent: Wednesday, December 23, 2020 9:42 AM
To: nvda@nvda.groups.io
Subject: [nvda] addons becoming incompatible after beta2 installed

 

Hi guys:

Installed nvda beta2 this morning;

When I did,

Many of my addons became incompatible, and,

I had to check a box claiming I understand this before installation;

Hence,

My question is,

How and where do I get the newer versions of the addons allegedly incompatible?

And,

Am I simply screwed if the author of the addon hasn’t updated it to the newest version of nvda?

 

 

Please advise as you like.

 

Mike M.

 

Mike mcglashon

Email: Michael.mcglashon@...

Ph: 618 783 9331

 


 

Hi,

There are two ways to find out if you have Add-on Updater add-on installed:

  1. Open NVDA menu, Tools, and see if “Check for add-on updates” item is showing in Tools menu. If not, then either Add-on Updater is installed but disabled or you don’t have it.
  2. Open Add-ons Manager and see if “Add-on Updater” is listed in there.

 

To install Add-on Updater, go to community add-ons website (https://addons.nvda-project.org), select “Add-on Updater”, then choose “stable version” link to download the latest version of this add-on. After installing Add-on Updater, you may get a notification telling you that add-on updates are available.

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of mike mcglashon
Sent: Wednesday, December 23, 2020 11:21 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] addons becoming incompatible after beta2 installed

 

Hi mr. joseph:

 

First,

How do I know if I have “addon updater” installed?

And,

If I don’t,

Do I go to “nvaccess.com” to get it?

 

 

Please advise as you like.

 

Mike M.

 

Mike mcglashon

Email: Michael.mcglashon@...

Ph: 618 783 9331

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Joseph Lee
Sent: Wednesday, December 23, 2020 1:52 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] addons becoming incompatible after beta2 installed

 

Hi,

Do you have Add-on Updater installed? I advise installing it as most add-ons in your list have received updates. There are exceptions such as DictationBridge, and if you do need that add-on, I advise searching for DicationBridge 1.1 beta (although I wrote that beta, I’m no longer maintaining DictationBridge in order to reduce my workload).

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of mike mcglashon
Sent: Wednesday, December 23, 2020 10:03 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] addons becoming incompatible after beta2 installed

 

Here is what I found whenst opening the “manage addons” dialogue;

 

The following add-ons are incompatible with NVDA version 2020.4. These add-ons can not be enabled.

Please contact the add-on author for further assistance.

Incompatible add-ons

Package Version Incompatible reason

DictationBridge Demo 0.1 An updated version of this add-on is required. T...

Golden Cursor moves the ... 1.2 An updated version of this add-on is required. T...

PC Keyboard Braille Input 2014.1 An updated version of this add-on is required. T...

Remote Support 2.2 An updated version of this add-on is required. T...

Resource Monitor 17.11 An updated version of this add-on is required. T...

Windows 10 App Essentia... 19.01.1 An updated version of this add-on is required. T...

 

About add-on... C

 

Please advise as you like.

 

Mike M.

 

Mike mcglashon

Email: Michael.mcglashon@...

Ph: 618 783 9331

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Joseph Lee
Sent: Wednesday, December 23, 2020 12:54 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] addons becoming incompatible after beta2 installed

 

Hi Mike,

Which add-ons are seen as incompatible with NVDA? To find out, open Add-ons Manager (NvDA menu/Tools/Manage add-ons), then select “view incompatible add-ons” and scroll through the list. The latest backwards incompatible version of NVDA is 2019.3 (due to Python 3 transition), and 2020.4 beta is not a compatibility breaking release, so the list of incompatible add-ons should not be that big.

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of mike mcglashon
Sent: Wednesday, December 23, 2020 9:42 AM
To: nvda@nvda.groups.io
Subject: [nvda] addons becoming incompatible after beta2 installed

 

Hi guys:

Installed nvda beta2 this morning;

When I did,

Many of my addons became incompatible, and,

I had to check a box claiming I understand this before installation;

Hence,

My question is,

How and where do I get the newer versions of the addons allegedly incompatible?

And,

Am I simply screwed if the author of the addon hasn’t updated it to the newest version of nvda?

 

 

Please advise as you like.

 

Mike M.

 

Mike mcglashon

Email: Michael.mcglashon@...

Ph: 618 783 9331