Audio ducking not supported


Nikola Jovic
 

Hello,

I was wondering if anyone encountered the following issue:

Under Windows 10, 21 H 2 in this case, NVDA obviously installed, NVDA reports "Audio ducking not supported" when trying to use NVDA shift D to cycle between the available audio ducking modes.


I am using NVDA 2021.3.1, and I have tried several other versions as well.

With NVDA 2021.3 or 2021.2 audio ducking does not work for me either, but I can use it just fine with NVDA 2021.1.

I suspect something broke on my system or there was a certain change I am not aware of, since I use audio ducking almost daily and it definitely was not broken for two versions without me noticing, thus posting here to see if someone has any clues rather than creating a GitHub issue.


Thanks for any help.


 

It certainly can't hurt to try:  Using DISM (Deployment Imaging Servicing and Management) and SFC (System File Checker) to Repair Windows 8 & 10

If that doesn't do it, I'd try completely uninstalling NVDA and reinstalling.  I've got NVDA 2021.3 (right now 2021.3.1 is downloading) and NVDA + SHIFT + D cycles through the three ducking states without issue.
--

Brian - Windows 10, 64-Bit, Version 21H2, Build 19044  

The real art of conversation is not only to say the right thing in the right place but to leave unsaid the wrong thing at the tempting moment.

        ~ Dorothy Nevill

 


Sarah k Alawami
 

No can't reproduce here. Windows 10 21H1 (x64) build 19043.1415 and nvda 21.2.x. I just tried it as I was reading this message. I have ducking turned off btw however I was able to cycle through all of the choices.

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Nikola Jovic
Sent: Saturday, January 1, 2022 7:46 AM
To: NVDA@groups.io
Subject: [nvda] Audio ducking not supported

Hello,

I was wondering if anyone encountered the following issue:

Under Windows 10, 21 H 2 in this case, NVDA obviously installed, NVDA reports "Audio ducking not supported" when trying to use NVDA shift D to cycle between the available audio ducking modes.


I am using NVDA 2021.3.1, and I have tried several other versions as well.

With NVDA 2021.3 or 2021.2 audio ducking does not work for me either, but I can use it just fine with NVDA 2021.1.

I suspect something broke on my system or there was a certain change I am not aware of, since I use audio ducking almost daily and it definitely was not broken for two versions without me noticing, thus posting here to see if someone has any clues rather than creating a GitHub issue.


Thanks for any help.


Nikola Jovic
 

Hi,

thanks for the idea.

I've managed to fix the problem.


For some reason, on the desktop under NVDA's shortcut properties, in the compatibility tab, NVDA was set to run with administrator privileges. Unchecking this, which is the default, restored audio ducking support.

I'm not entirely sure however why this same property didn't cause issues in 2021.1 but does in later versions, however replying in case someone else encounters this weird situation.

On 1/1/2022 5:03 PM, Brian Vogel wrote:
It certainly can't hurt to try:  Using DISM (Deployment Imaging Servicing and Management) and SFC (System File Checker) to Repair Windows 8 & 10

If that doesn't do it, I'd try completely uninstalling NVDA and reinstalling.  I've got NVDA 2021.3 (right now 2021.3.1 is downloading) and NVDA + SHIFT + D cycles through the three ducking states without issue.
--

Brian - Windows 10, 64-Bit, Version 21H2, Build 19044  

The real art of conversation is not only to say the right thing in the right place but to leave unsaid the wrong thing at the tempting moment.

        ~ Dorothy Nevill

 


Sarah k Alawami
 

How strange, thanks for the tip, but I’m running nvda in admin mode, I think? And I can cycle through these options. Did you try the admin mode in 2021.2.x?

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Nikola Jovic
Sent: Saturday, January 1, 2022 9:53 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Audio ducking not supported

 

Hi,

thanks for the idea.

I've managed to fix the problem.

 

For some reason, on the desktop under NVDA's shortcut properties, in the compatibility tab, NVDA was set to run with administrator privileges. Unchecking this, which is the default, restored audio ducking support.

I'm not entirely sure however why this same property didn't cause issues in 2021.1 but does in later versions, however replying in case someone else encounters this weird situation.

On 1/1/2022 5:03 PM, Brian Vogel wrote:

It certainly can't hurt to try:  Using DISM (Deployment Imaging Servicing and Management) and SFC (System File Checker) to Repair Windows 8 & 10

If that doesn't do it, I'd try completely uninstalling NVDA and reinstalling.  I've got NVDA 2021.3 (right now 2021.3.1 is downloading) and NVDA + SHIFT + D cycles through the three ducking states without issue.
--

Brian - Windows 10, 64-Bit, Version 21H2, Build 19044  

The real art of conversation is not only to say the right thing in the right place but to leave unsaid the wrong thing at the tempting moment.

        ~ Dorothy Nevill

 


 

On Sat, Jan 1, 2022 at 12:52 PM, Nikola Jovic wrote:
Unchecking this, which is the default, restored audio ducking support.
-
I have no idea how it got turned on initially, nor do I understand why turning it off fixed the problem.

I just intentionally turned Run as administrator on for the NVDA desktop shortcut, and when I try the NVDA + Shift + D command it behaves precisely as it did when it was off.

Very strange.  I'd still suggest you do a DISM and SFC run.  Something's off somewhere, and there's absolutely nothing to lose but a little bit of time by doing so.
--

Brian - Windows 10, 64-Bit, Version 21H2, Build 19044  

The real art of conversation is not only to say the right thing in the right place but to leave unsaid the wrong thing at the tempting moment.

        ~ Dorothy Nevill