Topics

Automatic Column and Row Header Reading


Sam Taylor
 

Hi all,

11.2.1 of the NVDA user guide mentions that NVDA is able to automatically announce appropriate row and column headers when navigating around Excel worksheets.

I used to be able to achieve this but it doesn't appear to work for me any more, and indeed as of NVDA 2019.3.

The cell coordinates just appear to read as usual, rather than reading any additional cell references.

I have enabled the Report Table row / column headers option in NVDA's Document Formatting settings.

y duCan anybodyplicate or suggest anything? This is highly likely to be user error.

Cheers

Sam



Quentin Christensen
 

You need to tell NVDA where the headers are for it to read them.  Press NVDA+shift+c to set column headers and NVDA+shift+r to set row headers.  Note that you need to be in the first cell you want headers read.

Quentin

On Mon, Jul 13, 2020 at 5:30 PM Sam Taylor via groups.io <samtaylor9=me.com@groups.io> wrote:

Hi all,

11.2.1 of the NVDA user guide mentions that NVDA is able to automatically announce appropriate row and column headers when navigating around Excel worksheets.

I used to be able to achieve this but it doesn't appear to work for me any more, and indeed as of NVDA 2019.3.

The cell coordinates just appear to read as usual, rather than reading any additional cell references.

I have enabled the Report Table row / column headers option in NVDA's Document Formatting settings.

y duCan anybodyplicate or suggest anything? This is highly likely to be user error.

Cheers

Sam




--
Quentin Christensen
Training and Support Manager


Sam Taylor
 

Yep, I did that also, but still nothing appears to change. I followed the example in the Excel with NVDA study material.



On 13/07/2020 6:00 pm, Quentin Christensen wrote:
You need to tell NVDA where the headers are for it to read them.  Press NVDA+shift+c to set column headers and NVDA+shift+r to set row headers.  Note that you need to be in the first cell you want headers read.

Quentin

On Mon, Jul 13, 2020 at 5:30 PM Sam Taylor via groups.io <samtaylor9=me.com@groups.io> wrote:

Hi all,

11.2.1 of the NVDA user guide mentions that NVDA is able to automatically announce appropriate row and column headers when navigating around Excel worksheets.

I used to be able to achieve this but it doesn't appear to work for me any more, and indeed as of NVDA 2019.3.

The cell coordinates just appear to read as usual, rather than reading any additional cell references.

I have enabled the Report Table row / column headers option in NVDA's Document Formatting settings.

y duCan anybodyplicate or suggest anything? This is highly likely to be user error.

Cheers

Sam




--
Quentin Christensen
Training and Support Manager


Cearbhall O'Meadhra
 

Sam,

 

Have you any blank columns separating blocks of columns. If so, you would need to set the column headings on the first cell in the heading row of each block to make NVDA call out the column headings for that block.

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Sam Taylor via groups.io
Sent: Monday, July 13, 2020 11:08 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Automatic Column and Row Header Reading

 

Yep, I did that also, but still nothing appears to change. I followed the example in the Excel with NVDA study material.

 

 

On 13/07/2020 6:00 pm, Quentin Christensen wrote:

You need to tell NVDA where the headers are for it to read them.  Press NVDA+shift+c to set column headers and NVDA+shift+r to set row headers.  Note that you need to be in the first cell you want headers read.

 

Quentin

 

On Mon, Jul 13, 2020 at 5:30 PM Sam Taylor via groups.io <samtaylor9=me.com@groups.io> wrote:

Hi all,

11.2.1 of the NVDA user guide mentions that NVDA is able to automatically announce appropriate row and column headers when navigating around Excel worksheets.

I used to be able to achieve this but it doesn't appear to work for me any more, and indeed as of NVDA 2019.3.

The cell coordinates just appear to read as usual, rather than reading any additional cell references.

I have enabled the Report Table row / column headers option in NVDA's Document Formatting settings.

y duCan anybodyplicate or suggest anything? This is highly likely to be user error.

Cheers

Sam

 


 

--

Quentin Christensen
Training and Support Manager

 


Sam Taylor
 

Thanks Cearbhall,

I have constructed a test workbook without any blank lines. Still I cannot get NVDA to read the coordinates as it should. I have tested with NVDA 2019 and 2017 with the same result, so I am beginning to wonder whether there is some type of setting in Excel itself which is causing this to happen.

Thanks

Sam


On 13/07/2020 11:00 pm, Cearbhall O'Meadhra wrote:

Sam,

 

Have you any blank columns separating blocks of columns. If so, you would need to set the column headings on the first cell in the heading row of each block to make NVDA call out the column headings for that block.

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Sam Taylor via groups.io
Sent: Monday, July 13, 2020 11:08 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Automatic Column and Row Header Reading

 

Yep, I did that also, but still nothing appears to change. I followed the example in the Excel with NVDA study material.

 

 

On 13/07/2020 6:00 pm, Quentin Christensen wrote:

You need to tell NVDA where the headers are for it to read them.  Press NVDA+shift+c to set column headers and NVDA+shift+r to set row headers.  Note that you need to be in the first cell you want headers read.

 

Quentin

 

On Mon, Jul 13, 2020 at 5:30 PM Sam Taylor via groups.io <samtaylor9=me.com@groups.io> wrote:

Hi all,

11.2.1 of the NVDA user guide mentions that NVDA is able to automatically announce appropriate row and column headers when navigating around Excel worksheets.

I used to be able to achieve this but it doesn't appear to work for me any more, and indeed as of NVDA 2019.3.

The cell coordinates just appear to read as usual, rather than reading any additional cell references.

I have enabled the Report Table row / column headers option in NVDA's Document Formatting settings.

y duCan anybodyplicate or suggest anything? This is highly likely to be user error.

Cheers

Sam

 


 

--

Quentin Christensen
Training and Support Manager

 


 

Sam,

          Have you tried setting a heading row (for the columns beneath it) and/or a heading column (for the row to the right of it) in Excel itself?  I have found that this tends to work, and across screen readers, better than doing said definition via the screen reader itself.

           This can be done whether or not one is using an actual table in a spreadsheet or not.

--

Brian - Windows 10 Pro, 64-Bit, Version 1909, Build 18363  

Science has become just another voice in the room; it has lost its platform.  Now, you simply declare your own truth.

      ~ Dr. Paul A. Offit, in New York Times article, How Anti-Vaccine Sentiment Took Hold in the United States, September 23, 2019

 

 


Tyler Spivey
 

Is Tables checked in NVDA, Preferences, Settings, Document Formatting?
If not, check it.

On 7/13/2020 3:46 PM, Sam Taylor via groups.io wrote:
Thanks Cearbhall,

I have constructed a test workbook without any blank lines. Still I
cannot get NVDA to read the coordinates as it should. I have tested with
NVDA 2019 and 2017 with the same result, so I am beginning to wonder
whether there is some type of setting in Excel itself which is causing
this to happen.

Thanks

Sam


On 13/07/2020 11:00 pm, Cearbhall O'Meadhra wrote:

Sam,

 

Have you any blank columns separating blocks of columns. If so, you
would need to set the column headings on the first cell in the heading
row of each block to make NVDA call out the column headings for that
block.

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

*From:*nvda@nvda.groups.io <nvda@nvda.groups.io> *On Behalf Of *Sam
Taylor via groups.io
*Sent:* Monday, July 13, 2020 11:08 AM
*To:* nvda@nvda.groups.io
*Subject:* Re: [nvda] Automatic Column and Row Header Reading

 

Yep, I did that also, but still nothing appears to change. I followed
the example in the Excel with NVDA study material.

 

 

On 13/07/2020 6:00 pm, Quentin Christensen wrote:

You need to tell NVDA where the headers are for it to read them. 
Press NVDA+shift+c to set column headers and NVDA+shift+r to set
row headers.  Note that you need to be in the first cell you want
headers read.

 

Quentin

 

On Mon, Jul 13, 2020 at 5:30 PM Sam Taylor via groups.io
<http://groups.io> <samtaylor9=me.com@groups.io
<mailto:me.com@groups.io>> wrote:

Hi all,

11.2.1 of the NVDA user guide mentions that NVDA is able to
automatically announce appropriate row and column headers when
navigating around Excel worksheets.

I used to be able to achieve this but it doesn't appear to
work for me any more, and indeed as of NVDA 2019.3.

The cell coordinates just appear to read as usual, rather than
reading any additional cell references.

I have enabled the Report Table row / column headers option in
NVDA's Document Formatting settings.

y duCan anybodyplicate or suggest anything? This is highly
likely to be user error.

Cheers

Sam

 


 

--

Quentin Christensen
Training and Support Manager

 

Web: www.nvaccess.org <http://www.nvaccess.org/

Training: https://www.nvaccess.org/shop/

Certification: https://certification.nvaccess.org/

User group: https://nvda.groups.io/g/nvda

Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess <https://twitter.com/NVAccess>


Sam Taylor
 

Thank you, Tyler. No, it wasn't, and this is precisely what I needed to do. I have this off for usual activity, and clearly I'm going to have to set up a trigger. If this isn't mentioned in the documentation along with the need for enabling row/column headers which I did know about, it may be worth including.

Thanks again.

Sam


On 14/07/2020 9:31 am, Tyler Spivey wrote:
Is Tables checked in NVDA, Preferences, Settings, Document Formatting?
If not, check it.

On 7/13/2020 3:46 PM, Sam Taylor via groups.io wrote:
Thanks Cearbhall,

I have constructed a test workbook without any blank lines. Still I
cannot get NVDA to read the coordinates as it should. I have tested with
NVDA 2019 and 2017 with the same result, so I am beginning to wonder
whether there is some type of setting in Excel itself which is causing
this to happen.

Thanks

Sam


On 13/07/2020 11:00 pm, Cearbhall O'Meadhra wrote:
Sam,

 

Have you any blank columns separating blocks of columns. If so, you
would need to set the column headings on the first cell in the heading
row of each block to make NVDA call out the column headings for that
block.

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

*From:*nvda@nvda.groups.io <nvda@nvda.groups.io> *On Behalf Of *Sam
Taylor via groups.io
*Sent:* Monday, July 13, 2020 11:08 AM
*To:* nvda@nvda.groups.io
*Subject:* Re: [nvda] Automatic Column and Row Header Reading

 

Yep, I did that also, but still nothing appears to change. I followed
the example in the Excel with NVDA study material.

 

 

On 13/07/2020 6:00 pm, Quentin Christensen wrote:

    You need to tell NVDA where the headers are for it to read them. 
    Press NVDA+shift+c to set column headers and NVDA+shift+r to set
    row headers.  Note that you need to be in the first cell you want
    headers read.

     

    Quentin

     

    On Mon, Jul 13, 2020 at 5:30 PM Sam Taylor via groups.io
    <http://groups.io> <samtaylor9@...
    <mailto:me.com@groups.io>> wrote:

        Hi all,

        11.2.1 of the NVDA user guide mentions that NVDA is able to
        automatically announce appropriate row and column headers when
        navigating around Excel worksheets.

        I used to be able to achieve this but it doesn't appear to
        work for me any more, and indeed as of NVDA 2019.3.

        The cell coordinates just appear to read as usual, rather than
        reading any additional cell references.

        I have enabled the Report Table row / column headers option in
        NVDA's Document Formatting settings.

        y duCan anybodyplicate or suggest anything? This is highly
        likely to be user error.

        Cheers

        Sam

         


     

    -- 

    Quentin Christensen
    Training and Support Manager

     

    Web: www.nvaccess.org <http://www.nvaccess.org/> 

    Training: https://www.nvaccess.org/shop/

    Certification: https://certification.nvaccess.org/

    User group: https://nvda.groups.io/g/nvda

    Facebook: http://www.facebook.com/NVAccess 
    Twitter: @NVAccess <https://twitter.com/NVAccess>


      



Quentin Christensen
 

Good pickup, yes you need to have NVDA set to report "tables", as well as column and row headers in NVDA's document formatting for this to work.  It's not well documented so I will ensure this is updated and noted in the User Guiide and Excel module.

If you otherwise prefer to have reporting of tables off, you can setup a configuration profile for Excel which has this setting enabled:

1) Open Excel
2) Press NVDA+control+p to open the configuration profiles dialog
3) press alt+n to create a new profile
4) Leave the name and press tab once to "use this profile for".
5) press the right arrow to move to "Current application (Excel)
6) Press Enter.

That creates the profile and now any change you make to NVDA's settings while in Excel will be saved in this profile rather than the "normal" profile.

Regards

Quentin.

On Tue, Jul 14, 2020 at 9:48 AM Sam Taylor via groups.io <samtaylor9=me.com@groups.io> wrote:

Thank you, Tyler. No, it wasn't, and this is precisely what I needed to do. I have this off for usual activity, and clearly I'm going to have to set up a trigger. If this isn't mentioned in the documentation along with the need for enabling row/column headers which I did know about, it may be worth including.

Thanks again.

Sam


On 14/07/2020 9:31 am, Tyler Spivey wrote:
Is Tables checked in NVDA, Preferences, Settings, Document Formatting?
If not, check it.

On 7/13/2020 3:46 PM, Sam Taylor via groups.io wrote:
Thanks Cearbhall,

I have constructed a test workbook without any blank lines. Still I
cannot get NVDA to read the coordinates as it should. I have tested with
NVDA 2019 and 2017 with the same result, so I am beginning to wonder
whether there is some type of setting in Excel itself which is causing
this to happen.

Thanks

Sam


On 13/07/2020 11:00 pm, Cearbhall O'Meadhra wrote:
Sam,

 

Have you any blank columns separating blocks of columns. If so, you
would need to set the column headings on the first cell in the heading
row of each block to make NVDA call out the column headings for that
block.

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

*From:*nvda@nvda.groups.io <nvda@nvda.groups.io> *On Behalf Of *Sam
Taylor via groups.io
*Sent:* Monday, July 13, 2020 11:08 AM
*To:* nvda@nvda.groups.io
*Subject:* Re: [nvda] Automatic Column and Row Header Reading

 

Yep, I did that also, but still nothing appears to change. I followed
the example in the Excel with NVDA study material.

 

 

On 13/07/2020 6:00 pm, Quentin Christensen wrote:

    You need to tell NVDA where the headers are for it to read them. 
    Press NVDA+shift+c to set column headers and NVDA+shift+r to set
    row headers.  Note that you need to be in the first cell you want
    headers read.

     

    Quentin

     

    On Mon, Jul 13, 2020 at 5:30 PM Sam Taylor via groups.io
    <http://groups.io> <samtaylor9@...
    <mailto:me.com@groups.io>> wrote:

        Hi all,

        11.2.1 of the NVDA user guide mentions that NVDA is able to
        automatically announce appropriate row and column headers when
        navigating around Excel worksheets.

        I used to be able to achieve this but it doesn't appear to
        work for me any more, and indeed as of NVDA 2019.3.

        The cell coordinates just appear to read as usual, rather than
        reading any additional cell references.

        I have enabled the Report Table row / column headers option in
        NVDA's Document Formatting settings.

        y duCan anybodyplicate or suggest anything? This is highly
        likely to be user error.

        Cheers

        Sam

         


     

    -- 

    Quentin Christensen
    Training and Support Manager

     

    Web: www.nvaccess.org <http://www.nvaccess.org/> 

    Training: https://www.nvaccess.org/shop/

    Certification: https://certification.nvaccess.org/

    User group: https://nvda.groups.io/g/nvda

    Facebook: http://www.facebook.com/NVAccess 
    Twitter: @NVAccess <https://twitter.com/NVAccess>


      

    



--
Quentin Christensen
Training and Support Manager


Sam Taylor
 

Many thanks Quentin. Works perfectly.


On 14/07/2020 10:11 am, Quentin Christensen wrote:
Good pickup, yes you need to have NVDA set to report "tables", as well as column and row headers in NVDA's document formatting for this to work.  It's not well documented so I will ensure this is updated and noted in the User Guiide and Excel module.

If you otherwise prefer to have reporting of tables off, you can setup a configuration profile for Excel which has this setting enabled:

1) Open Excel
2) Press NVDA+control+p to open the configuration profiles dialog
3) press alt+n to create a new profile
4) Leave the name and press tab once to "use this profile for".
5) press the right arrow to move to "Current application (Excel)
6) Press Enter.

That creates the profile and now any change you make to NVDA's settings while in Excel will be saved in this profile rather than the "normal" profile.

Regards

Quentin.

On Tue, Jul 14, 2020 at 9:48 AM Sam Taylor via groups.io <samtaylor9=me.com@groups.io> wrote:

Thank you, Tyler. No, it wasn't, and this is precisely what I needed to do. I have this off for usual activity, and clearly I'm going to have to set up a trigger. If this isn't mentioned in the documentation along with the need for enabling row/column headers which I did know about, it may be worth including.

Thanks again.

Sam


On 14/07/2020 9:31 am, Tyler Spivey wrote:
Is Tables checked in NVDA, Preferences, Settings, Document Formatting?
If not, check it.

On 7/13/2020 3:46 PM, Sam Taylor via groups.io wrote:
Thanks Cearbhall,

I have constructed a test workbook without any blank lines. Still I
cannot get NVDA to read the coordinates as it should. I have tested with
NVDA 2019 and 2017 with the same result, so I am beginning to wonder
whether there is some type of setting in Excel itself which is causing
this to happen.

Thanks

Sam


On 13/07/2020 11:00 pm, Cearbhall O'Meadhra wrote:
Sam,

 

Have you any blank columns separating blocks of columns. If so, you
would need to set the column headings on the first cell in the heading
row of each block to make NVDA call out the column headings for that
block.

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

*From:*nvda@nvda.groups.io <nvda@nvda.groups.io> *On Behalf Of *Sam
Taylor via groups.io
*Sent:* Monday, July 13, 2020 11:08 AM
*To:* nvda@nvda.groups.io
*Subject:* Re: [nvda] Automatic Column and Row Header Reading

 

Yep, I did that also, but still nothing appears to change. I followed
the example in the Excel with NVDA study material.

 

 

On 13/07/2020 6:00 pm, Quentin Christensen wrote:

    You need to tell NVDA where the headers are for it to read them. 
    Press NVDA+shift+c to set column headers and NVDA+shift+r to set
    row headers.  Note that you need to be in the first cell you want
    headers read.

     

    Quentin

     

    On Mon, Jul 13, 2020 at 5:30 PM Sam Taylor via groups.io
    <http://groups.io> <samtaylor9@...
    <mailto:me.com@groups.io>> wrote:

        Hi all,

        11.2.1 of the NVDA user guide mentions that NVDA is able to
        automatically announce appropriate row and column headers when
        navigating around Excel worksheets.

        I used to be able to achieve this but it doesn't appear to
        work for me any more, and indeed as of NVDA 2019.3.

        The cell coordinates just appear to read as usual, rather than
        reading any additional cell references.

        I have enabled the Report Table row / column headers option in
        NVDA's Document Formatting settings.

        y duCan anybodyplicate or suggest anything? This is highly
        likely to be user error.

        Cheers

        Sam

         


     

    -- 

    Quentin Christensen
    Training and Support Manager

     

    Web: www.nvaccess.org <http://www.nvaccess.org/> 

    Training: https://www.nvaccess.org/shop/

    Certification: https://certification.nvaccess.org/

    User group: https://nvda.groups.io/g/nvda

    Facebook: http://www.facebook.com/NVAccess 
    Twitter: @NVAccess <https://twitter.com/NVAccess>



--
Quentin Christensen
Training and Support Manager


Cearbhall O'Meadhra
 

Sam,

 

Are you able to edit text in each individual cell? If not, that might be a pointer to an Excel option that need to be set

 

We used to have to make sure that Allow editing in cells under the advanced tab in Excel > Options in order to make NVDA work while editing, for example.

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Sam Taylor via groups.io
Sent: Monday, July 13, 2020 11:47 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Automatic Column and Row Header Reading

 

Thanks Cearbhall,

I have constructed a test workbook without any blank lines. Still I cannot get NVDA to read the coordinates as it should. I have tested with NVDA 2019 and 2017 with the same result, so I am beginning to wonder whether there is some type of setting in Excel itself which is causing this to happen.

Thanks

Sam

 

On 13/07/2020 11:00 pm, Cearbhall O'Meadhra wrote:

Sam,

 

Have you any blank columns separating blocks of columns. If so, you would need to set the column headings on the first cell in the heading row of each block to make NVDA call out the column headings for that block.

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Sam Taylor via groups.io
Sent: Monday, July 13, 2020 11:08 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Automatic Column and Row Header Reading

 

Yep, I did that also, but still nothing appears to change. I followed the example in the Excel with NVDA study material.

 

 

On 13/07/2020 6:00 pm, Quentin Christensen wrote:

You need to tell NVDA where the headers are for it to read them.  Press NVDA+shift+c to set column headers and NVDA+shift+r to set row headers.  Note that you need to be in the first cell you want headers read.

 

Quentin

 

On Mon, Jul 13, 2020 at 5:30 PM Sam Taylor via groups.io <samtaylor9=me.com@groups.io> wrote:

Hi all,

11.2.1 of the NVDA user guide mentions that NVDA is able to automatically announce appropriate row and column headers when navigating around Excel worksheets.

I used to be able to achieve this but it doesn't appear to work for me any more, and indeed as of NVDA 2019.3.

The cell coordinates just appear to read as usual, rather than reading any additional cell references.

I have enabled the Report Table row / column headers option in NVDA's Document Formatting settings.

y duCan anybodyplicate or suggest anything? This is highly likely to be user error.

Cheers

Sam

 


 

--

Quentin Christensen
Training and Support Manager

 


Cearbhall O'Meadhra
 

Tyler,

 

I normally keep Tables unchecked in the document formatting settings in NVDA because NVDA becomes extremely sluggish when it is set and frequently lapses into Unknown. When I leave Tables unchecked, I can still set the row and column headings and the NVDA response is much sharper.

 

Does this make sense?

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Sam Taylor via groups.io
Sent: Tuesday, July 14, 2020 12:49 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Automatic Column and Row Header Reading

 

Thank you, Tyler. No, it wasn't, and this is precisely what I needed to do. I have this off for usual activity, and clearly I'm going to have to set up a trigger. If this isn't mentioned in the documentation along with the need for enabling row/column headers which I did know about, it may be worth including.

Thanks again.

Sam

 

On 14/07/2020 9:31 am, Tyler Spivey wrote:

Is Tables checked in NVDA, Preferences, Settings, Document Formatting?
If not, check it.
 
On 7/13/2020 3:46 PM, Sam Taylor via groups.io wrote:
Thanks Cearbhall,
 
I have constructed a test workbook without any blank lines. Still I
cannot get NVDA to read the coordinates as it should. I have tested with
NVDA 2019 and 2017 with the same result, so I am beginning to wonder
whether there is some type of setting in Excel itself which is causing
this to happen.
 
Thanks
 
Sam
 
 
On 13/07/2020 11:00 pm, Cearbhall O'Meadhra wrote:
 
Sam,
 
 
 
Have you any blank columns separating blocks of columns. If so, you
would need to set the column headings on the first cell in the heading
row of each block to make NVDA call out the column headings for that
block.
 
 
 
All the best,
 
 
 
Cearbhall
 
 
 
m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...
 
 
 
 
 
*From:*nvda@nvda.groups.io <nvda@nvda.groups.io> *On Behalf Of *Sam
Taylor via groups.io
*Sent:* Monday, July 13, 2020 11:08 AM
*To:* nvda@nvda.groups.io
*Subject:* Re: [nvda] Automatic Column and Row Header Reading
 
 
 
Yep, I did that also, but still nothing appears to change. I followed
the example in the Excel with NVDA study material.
 
 
 
 
 
On 13/07/2020 6:00 pm, Quentin Christensen wrote:
 
    You need to tell NVDA where the headers are for it to read them. 
    Press NVDA+shift+c to set column headers and NVDA+shift+r to set
    row headers.  Note that you need to be in the first cell you want
    headers read.
 
     
 
    Quentin
 
     
 
    On Mon, Jul 13, 2020 at 5:30 PM Sam Taylor via groups.io
    <http://groups.io> <samtaylor9@...
    <mailto:me.com@groups.io>> wrote:
 
        Hi all,
 
        11.2.1 of the NVDA user guide mentions that NVDA is able to
        automatically announce appropriate row and column headers when
        navigating around Excel worksheets.
 
        I used to be able to achieve this but it doesn't appear to
        work for me any more, and indeed as of NVDA 2019.3.
 
        The cell coordinates just appear to read as usual, rather than
        reading any additional cell references.
 
        I have enabled the Report Table row / column headers option in
        NVDA's Document Formatting settings.
 
        y duCan anybodyplicate or suggest anything? This is highly
        likely to be user error.
 
        Cheers
 
        Sam
 
         
 
 
     
 
    -- 
 
    Quentin Christensen
    Training and Support Manager
 
     
 
    Web: www.nvaccess.org <http://www.nvaccess.org/> 
 
    Training: https://www.nvaccess.org/shop/
 
    Certification: https://certification.nvaccess.org/
 
    User group: https://nvda.groups.io/g/nvda
 
    Facebook: http://www.facebook.com/NVAccess 
    Twitter: @NVAccess <https://twitter.com/NVAccess>