bug: when unchecking the keys not to use as modifiers, they become rechecked upon restarting nvda.


Sarah k Alawami
 

Can anyone reproduce this?

 

Bug

When nvda is restarted, the use insert key option becomes rechecked even after the user unchecks it.

Steps

·         Launch nvda

·         Go to settings

·         Go to keyboard

·         Choose laptop (not sure if desktop will work the same

·         Uncheck insert under the section where it lists 4 check boxes for nvda modifiers.

·         Hit ok

·         Restart nvda

 

Expected

Nvda should not recheck the box for the keys you unchecked

Actual

The box becomes rechecked upon restarting nvda

 

Windows 11 22H2 (x64) build 22621.819

Nonvisual Desktop Access (NVDA)

Version: 2022.3.2

 


Bob Cavanaugh
 

Is this exclusive to this command, or does this happen regardless of
what settings you change? This sounds to me like the box in general
settings to save configuration on exit isn't checked.

On 11/29/22, Sarah k Alawami <marrie12@...> wrote:
Can anyone reproduce this?




Bug


When nvda is restarted, the use insert key option becomes rechecked even
after the user unchecks it.


Steps


* Launch nvda

* Go to settings

* Go to keyboard

* Choose laptop (not sure if desktop will work the same

* Uncheck insert under the section where it lists 4 check boxes for
nvda modifiers.

* Hit ok

* Restart nvda




Expected


Nvda should not recheck the box for the keys you unchecked


Actual


The box becomes rechecked upon restarting nvda



Windows 11 22H2 (x64) build 22621.819

Nonvisual Desktop Access (NVDA)

Version: 2022.3.2









 

On Tue, Nov 29, 2022 at 10:55 PM, Bob Cavanaugh wrote:
This sounds to me like the box in general settings to save configuration on exit isn't checked.
-
If it isn't, and they weren't saved intentionally by the user before exiting, they're gone.  (That needs to be emphasized because one can save them manually, but you must do so if that box is unchecked.  [It is checked by default if NVDA is in it's "fresh install default state."])
--

Brian Virginia, USA Windows 10, 64-Bit, Version 22H2, Build 19045; Office 2016, Version 16.0.15726.20188, 32-bit

"Be Yourself" is the worst advice you can give to some people.

       ~ Tom Masson


Sarah k Alawami
 

I don't recall on checking that box. My configuration is saved otherwise. I will have to keep an eye on this as if this is a me error, I will feel very stupid!

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Bob Cavanaugh
Sent: Tuesday, November 29, 2022 7:55 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] bug: when unchecking the keys not to use as modifiers, they become rechecked upon restarting nvda.

Is this exclusive to this command, or does this happen regardless of what settings you change? This sounds to me like the box in general settings to save configuration on exit isn't checked.

On 11/29/22, Sarah k Alawami <marrie12@...> wrote:
Can anyone reproduce this?




Bug


When nvda is restarted, the use insert key option becomes rechecked
even after the user unchecks it.


Steps


* Launch nvda

* Go to settings

* Go to keyboard

* Choose laptop (not sure if desktop will work the same

* Uncheck insert under the section where it lists 4 check boxes for
nvda modifiers.

* Hit ok

* Restart nvda




Expected


Nvda should not recheck the box for the keys you unchecked


Actual


The box becomes rechecked upon restarting nvda



Windows 11 22H2 (x64) build 22621.819

Nonvisual Desktop Access (NVDA)

Version: 2022.3.2









Sarah k Alawami
 

I just checked, the box is in fact checked, so yes something is amiss here.  Hopefully, whatever happened will fix itself. I could have sworn I did uncheck the insert thing months ago. I never had to use insert on my 6 pack until recently. Anyway, I’ll have to test with other keys.

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Brian Vogel
Sent: Tuesday, November 29, 2022 8:09 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] bug: when unchecking the keys not to use as modifiers, they become rechecked upon restarting nvda.

 

On Tue, Nov 29, 2022 at 10:55 PM, Bob Cavanaugh wrote:

This sounds to me like the box in general settings to save configuration on exit isn't checked.

-
If it isn't, and they weren't saved intentionally by the user before exiting, they're gone.  (That needs to be emphasized because one can save them manually, but you must do so if that box is unchecked.  [It is checked by default if NVDA is in it's "fresh install default state."])
--

Brian Virginia, USA Windows 10, 64-Bit, Version 22H2, Build 19045; Office 2016, Version 16.0.15726.20188, 32-bit

"Be Yourself" is the worst advice you can give to some people.

       ~ Tom Masson


Kefas
 

Some times it fails  for what ever reason.

and in my case, I have to do it manually.

 

Sent from KefasLungu

 

From: Sarah k Alawami
Sent: Wednesday, November 30, 2022 5:39 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] bug: when unchecking the keys not to use as modifiers, they become rechecked upon restarting nvda.

 

I just checked, the box is in fact checked, so yes something is amiss here.  Hopefully, whatever happened will fix itself. I could have sworn I did uncheck the insert thing months ago. I never had to use insert on my 6 pack until recently. Anyway, I’ll have to test with other keys.

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Brian Vogel
Sent: Tuesday, November 29, 2022 8:09 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] bug: when unchecking the keys not to use as modifiers, they become rechecked upon restarting nvda.

 

On Tue, Nov 29, 2022 at 10:55 PM, Bob Cavanaugh wrote:

This sounds to me like the box in general settings to save configuration on exit isn't checked.

-
If it isn't, and they weren't saved intentionally by the user before exiting, they're gone.  (That needs to be emphasized because one can save them manually, but you must do so if that box is unchecked.  [It is checked by default if NVDA is in it's "fresh install default state."])
--

Brian Virginia, USA Windows 10, 64-Bit, Version 22H2, Build 19045; Office 2016, Version 16.0.15726.20188, 32-bit

"Be Yourself" is the worst advice you can give to some people.

       ~ Tom Masson

 


Brian's Mail list account
 

I'm not so sure. I have noticed this sometimes, but like you have not actually looked deeply into it. I wondered if it might be a cashing issue on windows which does not read the right data. Not knowing how those settings are stored its hard to know.
Brian

--
bglists@...
Sent via blueyonder.(Virgin media)
Please address personal E-mail to:-
briang1@..., putting 'Brian Gaff'
in the display name field.

----- Original Message -----
From: "Sarah k Alawami" <marrie12@...>
To: <nvda@nvda.groups.io>
Sent: Wednesday, November 30, 2022 4:37 AM
Subject: Re: [nvda] bug: when unchecking the keys not to use as modifiers, they become rechecked upon restarting nvda.


I don't recall on checking that box. My configuration is saved otherwise. I will have to keep an eye on this as if this is a me error, I will feel very stupid!
-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Bob Cavanaugh
Sent: Tuesday, November 29, 2022 7:55 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] bug: when unchecking the keys not to use as modifiers, they become rechecked upon restarting nvda.

Is this exclusive to this command, or does this happen regardless of what settings you change? This sounds to me like the box in general settings to save configuration on exit isn't checked.

On 11/29/22, Sarah k Alawami <marrie12@...> wrote:
Can anyone reproduce this?




Bug


When nvda is restarted, the use insert key option becomes rechecked
even after the user unchecks it.


Steps


* Launch nvda

* Go to settings

* Go to keyboard

* Choose laptop (not sure if desktop will work the same

* Uncheck insert under the section where it lists 4 check boxes for
nvda modifiers.

* Hit ok

* Restart nvda




Expected


Nvda should not recheck the box for the keys you unchecked


Actual


The box becomes rechecked upon restarting nvda



Windows 11 22H2 (x64) build 22621.819

Nonvisual Desktop Access (NVDA)

Version: 2022.3.2









Gerardo Corripio <gera1027@...>
 

I don't know if this is somehow related to what happened last evening,on my Hp Pavillion Windows10 Laptop which is a bit over 4 years old: So I powered on my Laptop just fine; I was able to use NVDA commands via the Caps-lock key just fine without issues, but about 5-10 minutes later, not only the NVDA command key didn't work, but the Tab, Escape or the Number1 key on the top number row! So I restarted the computer, and the above-mentioned keys worked great for about 5-10 minutes, after which no go! not even restarting NVDA! So I restarted the computer a 2nd time, and used it over an hour without issues! with all the expected keys working just fine!
So might this be related to what you're talking about in this thread?

Gera
Enviado desde mi iPhone SE (2nd Generation) de Telcel

El 29 nov 2022, a la(s) 9:46 p.m., Sarah k Alawami <marrie12@...> escribió:



Can anyone reproduce this?

 

Bug

When nvda is restarted, the use insert key option becomes rechecked even after the user unchecks it.

Steps

·         Launch nvda

·         Go to settings

·         Go to keyboard

·         Choose laptop (not sure if desktop will work the same

·         Uncheck insert under the section where it lists 4 check boxes for nvda modifiers.

·         Hit ok

·         Restart nvda

 

Expected

Nvda should not recheck the box for the keys you unchecked

Actual

The box becomes rechecked upon restarting nvda

 

Windows 11 22H2 (x64) build 22621.819

Nonvisual Desktop Access (NVDA)

Version: 2022.3.2

 


Gene
 

No.  You are talking about keys not functioning.  the original question is about a setting not being retained when you close and then open NVDA.  The setting would not be retained immediately.  It wouldn't take a certain amount of use time for the functionality to be lost.

Gene

On 11/30/2022 6:51 AM, Gerardo Corripio wrote:

I don't know if this is somehow related to what happened last evening,on my Hp Pavillion Windows10 Laptop which is a bit over 4 years old: So I powered on my Laptop just fine; I was able to use NVDA commands via the Caps-lock key just fine without issues, but about 5-10 minutes later, not only the NVDA command key didn't work, but the Tab, Escape or the Number1 key on the top number row! So I restarted the computer, and the above-mentioned keys worked great for about 5-10 minutes, after which no go! not even restarting NVDA! So I restarted the computer a 2nd time, and used it over an hour without issues! with all the expected keys working just fine!
So might this be related to what you're talking about in this thread?

Gera
Enviado desde mi iPhone SE (2nd Generation) de Telcel

El 29 nov 2022, a la(s) 9:46 p.m., Sarah k Alawami <marrie12@...> escribió:



Can anyone reproduce this?

 

Bug

When nvda is restarted, the use insert key option becomes rechecked even after the user unchecks it.

Steps

·         Launch nvda

·         Go to settings

·         Go to keyboard

·         Choose laptop (not sure if desktop will work the same

·         Uncheck insert under the section where it lists 4 check boxes for nvda modifiers.

·         Hit ok

·         Restart nvda

 

Expected

Nvda should not recheck the box for the keys you unchecked

Actual

The box becomes rechecked upon restarting nvda

 

Windows 11 22H2 (x64) build 22621.819

Nonvisual Desktop Access (NVDA)

Version: 2022.3.2

 



Sarah k Alawami
 

Yep it just failed for me upon restart of nvdas and restart of my computer. I tested with 2 profiles, and  it fails in each of trhose as well. Everything else gets saved upon exit.

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Kefas
Sent: Tuesday, November 29, 2022 10:59 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] bug: when unchecking the keys not to use as modifiers, they become rechecked upon restarting nvda.

 

Some times it fails  for what ever reason.

and in my case, I have to do it manually.

 

Sent from KefasLungu

 

From: Sarah k Alawami
Sent: Wednesday, November 30, 2022 5:39 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] bug: when unchecking the keys not to use as modifiers, they become rechecked upon restarting nvda.

 

I just checked, the box is in fact checked, so yes something is amiss here.  Hopefully, whatever happened will fix itself. I could have sworn I did uncheck the insert thing months ago. I never had to use insert on my 6 pack until recently. Anyway, I’ll have to test with other keys.

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Brian Vogel
Sent: Tuesday, November 29, 2022 8:09 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] bug: when unchecking the keys not to use as modifiers, they become rechecked upon restarting nvda.

 

On Tue, Nov 29, 2022 at 10:55 PM, Bob Cavanaugh wrote:

This sounds to me like the box in general settings to save configuration on exit isn't checked.

-
If it isn't, and they weren't saved intentionally by the user before exiting, they're gone.  (That needs to be emphasized because one can save them manually, but you must do so if that box is unchecked.  [It is checked by default if NVDA is in it's "fresh install default state."])
--

Brian Virginia, USA Windows 10, 64-Bit, Version 22H2, Build 19045; Office 2016, Version 16.0.15726.20188, 32-bit

"Be Yourself" is the worst advice you can give to some people.

       ~ Tom Masson

 


Sarah k Alawami
 

No not at all, follow my steps  and you hopefully can repro. Basically, uncheck insert or what ever modifiers you don’t want to use. Restart nvda and those boxes will become checked. Make sure save config upon exit is  checked.

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Gerardo Corripio
Sent: Wednesday, November 30, 2022 4:51 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] bug: when unchecking the keys not to use as modifiers, they become rechecked upon restarting nvda.

 

I don't know if this is somehow related to what happened last evening,on my Hp Pavillion Windows10 Laptop which is a bit over 4 years old: So I powered on my Laptop just fine; I was able to use NVDA commands via the Caps-lock key just fine without issues, but about 5-10 minutes later, not only the NVDA command key didn't work, but the Tab, Escape or the Number1 key on the top number row! So I restarted the computer, and the above-mentioned keys worked great for about 5-10 minutes, after which no go! not even restarting NVDA! So I restarted the computer a 2nd time, and used it over an hour without issues! with all the expected keys working just fine!

So might this be related to what you're talking about in this thread?

Gera

Enviado desde mi iPhone SE (2nd Generation) de Telcel



El 29 nov 2022, a la(s) 9:46 p.m., Sarah k Alawami <marrie12@...> escribió:



Can anyone reproduce this?

 

Bug

When nvda is restarted, the use insert key option becomes rechecked even after the user unchecks it.

Steps

1.       Launch nvda

2.       Go to settings

3.       Go to keyboard

4.       Choose laptop (not sure if desktop will work the same

5.       Uncheck insert under the section where it lists 4 check boxes for nvda modifiers.

6.       Hit ok

7.       Restart nvda

 

Expected

Nvda should not recheck the box for the keys you unchecked

Actual

The box becomes rechecked upon restarting nvda

 

Windows 11 22H2 (x64) build 22621.819

Nonvisual Desktop Access (NVDA)

Version: 2022.3.2

 


Kefas
 

Even when save config upon exit is  checked, it some times fail.

 

Manually save it your self, and then see if the problem will be resolved.

 

Sent from KefasLungu

 

From: Sarah k Alawami
Sent: Wednesday, November 30, 2022 6:16 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] bug: when unchecking the keys not to use as modifiers, they become rechecked upon restarting nvda.

 

No not at all, follow my steps  and you hopefully can repro. Basically, uncheck insert or what ever modifiers you don’t want to use. Restart nvda and those boxes will become checked. Make sure save config upon exit is  checked.

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Gerardo Corripio
Sent: Wednesday, November 30, 2022 4:51 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] bug: when unchecking the keys not to use as modifiers, they become rechecked upon restarting nvda.

 

I don't know if this is somehow related to what happened last evening,on my Hp Pavillion Windows10 Laptop which is a bit over 4 years old: So I powered on my Laptop just fine; I was able to use NVDA commands via the Caps-lock key just fine without issues, but about 5-10 minutes later, not only the NVDA command key didn't work, but the Tab, Escape or the Number1 key on the top number row! So I restarted the computer, and the above-mentioned keys worked great for about 5-10 minutes, after which no go! not even restarting NVDA! So I restarted the computer a 2nd time, and used it over an hour without issues! with all the expected keys working just fine!

So might this be related to what you're talking about in this thread?

Gera

Enviado desde mi iPhone SE (2nd Generation) de Telcel

 

El 29 nov 2022, a la(s) 9:46 p.m., Sarah k Alawami <marrie12@...> escribió:



Can anyone reproduce this?

 

Bug

When nvda is restarted, the use insert key option becomes rechecked even after the user unchecks it.

Steps

1.       Launch nvda

2.       Go to settings

3.       Go to keyboard

4.       Choose laptop (not sure if desktop will work the same

5.       Uncheck insert under the section where it lists 4 check boxes for nvda modifiers.

6.       Hit ok

7.       Restart nvda

 

Expected

Nvda should not recheck the box for the keys you unchecked

Actual

The box becomes rechecked upon restarting nvda

 

Windows 11 22H2 (x64) build 22621.819

Nonvisual Desktop Access (NVDA)

Version: 2022.3.2

 

 


Sarah k Alawami
 

I tried this. No go. It will still recheck on restart of nvda.

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Kefas
Sent: Wednesday, November 30, 2022 9:23 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] bug: when unchecking the keys not to use as modifiers, they become rechecked upon restarting nvda.

 

Even when save config upon exit is  checked, it some times fail.

 

Manually save it your self, and then see if the problem will be resolved.

 

Sent from KefasLungu

 

From: Sarah k Alawami
Sent: Wednesday, November 30, 2022 6:16 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] bug: when unchecking the keys not to use as modifiers, they become rechecked upon restarting nvda.

 

No not at all, follow my steps  and you hopefully can repro. Basically, uncheck insert or what ever modifiers you don’t want to use. Restart nvda and those boxes will become checked. Make sure save config upon exit is  checked.

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Gerardo Corripio
Sent: Wednesday, November 30, 2022 4:51 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] bug: when unchecking the keys not to use as modifiers, they become rechecked upon restarting nvda.

 

I don't know if this is somehow related to what happened last evening,on my Hp Pavillion Windows10 Laptop which is a bit over 4 years old: So I powered on my Laptop just fine; I was able to use NVDA commands via the Caps-lock key just fine without issues, but about 5-10 minutes later, not only the NVDA command key didn't work, but the Tab, Escape or the Number1 key on the top number row! So I restarted the computer, and the above-mentioned keys worked great for about 5-10 minutes, after which no go! not even restarting NVDA! So I restarted the computer a 2nd time, and used it over an hour without issues! with all the expected keys working just fine!

So might this be related to what you're talking about in this thread?

Gera

Enviado desde mi iPhone SE (2nd Generation) de Telcel

 

El 29 nov 2022, a la(s) 9:46 p.m., Sarah k Alawami <marrie12@...> escribió:



Can anyone reproduce this?

 

Bug

When nvda is restarted, the use insert key option becomes rechecked even after the user unchecks it.

Steps

1.       Launch nvda

2.       Go to settings

3.       Go to keyboard

4.       Choose laptop (not sure if desktop will work the same

5.       Uncheck insert under the section where it lists 4 check boxes for nvda modifiers.

6.       Hit ok

7.       Restart nvda

 

Expected

Nvda should not recheck the box for the keys you unchecked

Actual

The box becomes rechecked upon restarting nvda

 

Windows 11 22H2 (x64) build 22621.819

Nonvisual Desktop Access (NVDA)

Version: 2022.3.2

 

 


Christopher Duffley
 

Hello all,

 

Everything works correctly for me, both in NVDA 2022.3.2 and also one of the latest Alpha builds.

 

Can you try backing up your config into a portable copy (Tools > Create Portable Copy > Copy Current User Configuration) and reset your configuration to see if something happened with your INI that is not making it enforce the option?

 

Chris

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Sarah k Alawami
Sent: Wednesday, November 30, 2022 12:17
To: nvda@nvda.groups.io
Subject: Re: [nvda] bug: when unchecking the keys not to use as modifiers, they become rechecked upon restarting nvda.

 

No not at all, follow my steps  and you hopefully can repro. Basically, uncheck insert or what ever modifiers you don’t want to use. Restart nvda and those boxes will become checked. Make sure save config upon exit is  checked.

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Gerardo Corripio
Sent: Wednesday, November 30, 2022 4:51 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] bug: when unchecking the keys not to use as modifiers, they become rechecked upon restarting nvda.

 

I don't know if this is somehow related to what happened last evening,on my Hp Pavillion Windows10 Laptop which is a bit over 4 years old: So I powered on my Laptop just fine; I was able to use NVDA commands via the Caps-lock key just fine without issues, but about 5-10 minutes later, not only the NVDA command key didn't work, but the Tab, Escape or the Number1 key on the top number row! So I restarted the computer, and the above-mentioned keys worked great for about 5-10 minutes, after which no go! not even restarting NVDA! So I restarted the computer a 2nd time, and used it over an hour without issues! with all the expected keys working just fine!

So might this be related to what you're talking about in this thread?

Gera

Enviado desde mi iPhone SE (2nd Generation) de Telcel

 

El 29 nov 2022, a la(s) 9:46 p.m., Sarah k Alawami <marrie12@...> escribió:



Can anyone reproduce this?

 

Bug

When nvda is restarted, the use insert key option becomes rechecked even after the user unchecks it.

Steps

1.   Launch nvda

2.   Go to settings

3.   Go to keyboard

4.   Choose laptop (not sure if desktop will work the same

5.   Uncheck insert under the section where it lists 4 check boxes for nvda modifiers.

6.   Hit ok

7.   Restart nvda

 

Expected

Nvda should not recheck the box for the keys you unchecked

Actual

The box becomes rechecked upon restarting nvda

 

Windows 11 22H2 (x64) build 22621.819

Nonvisual Desktop Access (NVDA)

Version: 2022.3.2

 


Gene
 

I just tried this with the current NVDA version 2022.3.2, installed.  The setting is saved properly.  I manually saved the configuration before exiting NVDA but I don't think using automatic saving of settings would matter.

Gene

On 11/30/2022 11:16 AM, Sarah k Alawami wrote:

No not at all, follow my steps  and you hopefully can repro. Basically, uncheck insert or what ever modifiers you don’t want to use. Restart nvda and those boxes will become checked. Make sure save config upon exit is  checked.

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Gerardo Corripio
Sent: Wednesday, November 30, 2022 4:51 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] bug: when unchecking the keys not to use as modifiers, they become rechecked upon restarting nvda.

 

I don't know if this is somehow related to what happened last evening,on my Hp Pavillion Windows10 Laptop which is a bit over 4 years old: So I powered on my Laptop just fine; I was able to use NVDA commands via the Caps-lock key just fine without issues, but about 5-10 minutes later, not only the NVDA command key didn't work, but the Tab, Escape or the Number1 key on the top number row! So I restarted the computer, and the above-mentioned keys worked great for about 5-10 minutes, after which no go! not even restarting NVDA! So I restarted the computer a 2nd time, and used it over an hour without issues! with all the expected keys working just fine!

So might this be related to what you're talking about in this thread?

Gera

Enviado desde mi iPhone SE (2nd Generation) de Telcel



El 29 nov 2022, a la(s) 9:46 p.m., Sarah k Alawami <marrie12@...> escribió:



Can anyone reproduce this?

 

Bug

When nvda is restarted, the use insert key option becomes rechecked even after the user unchecks it.

Steps

1.       Launch nvda

2.       Go to settings

3.       Go to keyboard

4.       Choose laptop (not sure if desktop will work the same

5.       Uncheck insert under the section where it lists 4 check boxes for nvda modifiers.

6.       Hit ok

7.       Restart nvda

 

Expected

Nvda should not recheck the box for the keys you unchecked

Actual

The box becomes rechecked upon restarting nvda

 

Windows 11 22H2 (x64) build 22621.819

Nonvisual Desktop Access (NVDA)

Version: 2022.3.2

 



Jackie
 

Sarah, is this a straight Windows box or are you perchance running it
thru a mac or vm? Also, is this an installed or portable version?

On 11/30/22, Gene <gsasner@...> wrote:
I just tried this with the current NVDA version 2022.3.2, installed.
The setting is saved properly.  I manually saved the configuration
before exiting NVDA but I don't think using automatic saving of settings
would matter.

Gene

On 11/30/2022 11:16 AM, Sarah k Alawami wrote:

No not at all, follow my steps  and you hopefully can repro.
Basically, uncheck insert or what ever modifiers you don’t want to
use. Restart nvda and those boxes will become checked. Make sure save
config upon exit is  checked.

*From:* nvda@nvda.groups.io <nvda@nvda.groups.io> *On Behalf Of
*Gerardo Corripio
*Sent:* Wednesday, November 30, 2022 4:51 AM
*To:* nvda@nvda.groups.io
*Subject:* Re: [nvda] bug: when unchecking the keys not to use as
modifiers, they become rechecked upon restarting nvda.

I don't know if this is somehow related to what happened last
evening,on my Hp Pavillion Windows10 Laptop which is a bit over 4
years old: So I powered on my Laptop just fine; I was able to use NVDA
commands via the Caps-lock key just fine without issues, but about
5-10 minutes later, not only the NVDA command key didn't work, but the
Tab, Escape or the Number1 key on the top number row! So I restarted
the computer, and the above-mentioned keys worked great for about 5-10
minutes, after which no go! not even restarting NVDA! So I restarted
the computer a 2nd time, and used it over an hour without issues! with
all the expected keys working just fine!

So might this be related to what you're talking about in this thread?

Gera

Enviado desde mi iPhone SE (2nd Generation) de Telcel



El 29 nov 2022, a la(s) 9:46 p.m., Sarah k Alawami
<marrie12@... <mailto:marrie12@...>> escribió:



Can anyone reproduce this?


Bug

When nvda is restarted, the use insert key option becomes
rechecked even after the user unchecks it.


Steps

1.Launch nvda

2.Go to settings

3.Go to keyboard

4.Choose laptop (not sure if desktop will work the same

5.Uncheck insert under the section where it lists 4 check boxes
for nvda modifiers.

6.Hit ok

7.Restart nvda


Expected

Nvda should not recheck the box for the keys you unchecked


Actual

The box becomes rechecked upon restarting nvda

Windows 11 22H2 (x64) build 22621.819

Nonvisual Desktop Access (NVDA)

Version: 2022.3.2






--
Jackie McBride
Be a hero. Fight Scams. Learn how at www.scam911.org
Also check out brightstarsweb.com & mysitesbeenhacked.com


Sarah k Alawami
 

This is a straight windows box, and a regular copy of nvda. I don't do portable copies if I can help it. I'm not looking forward to nuking my install, I know I can back them up with a portable, however that will suck major.

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Jackie
Sent: Wednesday, November 30, 2022 10:20 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] bug: when unchecking the keys not to use as modifiers, they become rechecked upon restarting nvda.

Sarah, is this a straight Windows box or are you perchance running it thru a mac or vm? Also, is this an installed or portable version?

On 11/30/22, Gene <gsasner@...> wrote:
I just tried this with the current NVDA version 2022.3.2, installed.
The setting is saved properly. I manually saved the configuration
before exiting NVDA but I don't think using automatic saving of
settings would matter.

Gene

On 11/30/2022 11:16 AM, Sarah k Alawami wrote:

No not at all, follow my steps and you hopefully can repro.
Basically, uncheck insert or what ever modifiers you don’t want to
use. Restart nvda and those boxes will become checked. Make sure save
config upon exit is checked.

*From:* nvda@nvda.groups.io <nvda@nvda.groups.io> *On Behalf Of
*Gerardo Corripio
*Sent:* Wednesday, November 30, 2022 4:51 AM
*To:* nvda@nvda.groups.io
*Subject:* Re: [nvda] bug: when unchecking the keys not to use as
modifiers, they become rechecked upon restarting nvda.

I don't know if this is somehow related to what happened last
evening,on my Hp Pavillion Windows10 Laptop which is a bit over 4
years old: So I powered on my Laptop just fine; I was able to use
NVDA commands via the Caps-lock key just fine without issues, but
about
5-10 minutes later, not only the NVDA command key didn't work, but
the Tab, Escape or the Number1 key on the top number row! So I
restarted the computer, and the above-mentioned keys worked great for
about 5-10 minutes, after which no go! not even restarting NVDA! So I
restarted the computer a 2nd time, and used it over an hour without
issues! with all the expected keys working just fine!

So might this be related to what you're talking about in this thread?

Gera

Enviado desde mi iPhone SE (2nd Generation) de Telcel



El 29 nov 2022, a la(s) 9:46 p.m., Sarah k Alawami
<marrie12@... <mailto:marrie12@...>> escribió:



Can anyone reproduce this?


Bug

When nvda is restarted, the use insert key option becomes
rechecked even after the user unchecks it.


Steps

1.Launch nvda

2.Go to settings

3.Go to keyboard

4.Choose laptop (not sure if desktop will work the same

5.Uncheck insert under the section where it lists 4 check boxes
for nvda modifiers.

6.Hit ok

7.Restart nvda


Expected

Nvda should not recheck the box for the keys you unchecked


Actual

The box becomes rechecked upon restarting nvda

Windows 11 22H2 (x64) build 22621.819

Nonvisual Desktop Access (NVDA)

Version: 2022.3.2







--
Jackie McBride
Be a hero. Fight Scams. Learn how at www.scam911.org Also check out brightstarsweb.com & mysitesbeenhacked.com


Jackie
 

Ok, so this is a person w/a Linux background speaking, but, does the
folder where your configs are being saved have proper write
permissions?

On 11/30/22, Sarah k Alawami <marrie12@...> wrote:
This is a straight windows box, and a regular copy of nvda. I don't do
portable copies if I can help it. I'm not looking forward to nuking my
install, I know I can back them up with a portable, however that will suck
major.

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Jackie
Sent: Wednesday, November 30, 2022 10:20 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] bug: when unchecking the keys not to use as modifiers,
they become rechecked upon restarting nvda.

Sarah, is this a straight Windows box or are you perchance running it thru a
mac or vm? Also, is this an installed or portable version?

On 11/30/22, Gene <gsasner@...> wrote:
I just tried this with the current NVDA version 2022.3.2, installed.
The setting is saved properly. I manually saved the configuration
before exiting NVDA but I don't think using automatic saving of
settings would matter.

Gene

On 11/30/2022 11:16 AM, Sarah k Alawami wrote:

No not at all, follow my steps and you hopefully can repro.
Basically, uncheck insert or what ever modifiers you don’t want to
use. Restart nvda and those boxes will become checked. Make sure save
config upon exit is checked.

*From:* nvda@nvda.groups.io <nvda@nvda.groups.io> *On Behalf Of
*Gerardo Corripio
*Sent:* Wednesday, November 30, 2022 4:51 AM
*To:* nvda@nvda.groups.io
*Subject:* Re: [nvda] bug: when unchecking the keys not to use as
modifiers, they become rechecked upon restarting nvda.

I don't know if this is somehow related to what happened last
evening,on my Hp Pavillion Windows10 Laptop which is a bit over 4
years old: So I powered on my Laptop just fine; I was able to use
NVDA commands via the Caps-lock key just fine without issues, but
about
5-10 minutes later, not only the NVDA command key didn't work, but
the Tab, Escape or the Number1 key on the top number row! So I
restarted the computer, and the above-mentioned keys worked great for
about 5-10 minutes, after which no go! not even restarting NVDA! So I
restarted the computer a 2nd time, and used it over an hour without
issues! with all the expected keys working just fine!

So might this be related to what you're talking about in this thread?

Gera

Enviado desde mi iPhone SE (2nd Generation) de Telcel



El 29 nov 2022, a la(s) 9:46 p.m., Sarah k Alawami
<marrie12@... <mailto:marrie12@...>> escribió:



Can anyone reproduce this?


Bug

When nvda is restarted, the use insert key option becomes
rechecked even after the user unchecks it.


Steps

1.Launch nvda

2.Go to settings

3.Go to keyboard

4.Choose laptop (not sure if desktop will work the same

5.Uncheck insert under the section where it lists 4 check boxes
for nvda modifiers.

6.Hit ok

7.Restart nvda


Expected

Nvda should not recheck the box for the keys you unchecked


Actual

The box becomes rechecked upon restarting nvda

Windows 11 22H2 (x64) build 22621.819

Nonvisual Desktop Access (NVDA)

Version: 2022.3.2







--
Jackie McBride
Be a hero. Fight Scams. Learn how at www.scam911.org Also check out
brightstarsweb.com & mysitesbeenhacked.com











--
Jackie McBride
Be a hero. Fight Scams. Learn how at www.scam911.org
Also check out brightstarsweb.com & mysitesbeenhacked.com


Sarah k Alawami
 

I'm 100 percent sure it does, and I totally understand, I used to be in the unix/Linux stuff every day. So far nuking the config helped. Now I have to figure out how to not spell space with cf eloquence, I'll ask that one on my mastodon.

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Jackie
Sent: Wednesday, November 30, 2022 11:38 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] bug: when unchecking the keys not to use as modifiers, they become rechecked upon restarting nvda.

Ok, so this is a person w/a Linux background speaking, but, does the folder where your configs are being saved have proper write permissions?

On 11/30/22, Sarah k Alawami <marrie12@...> wrote:
This is a straight windows box, and a regular copy of nvda. I don't
do portable copies if I can help it. I'm not looking forward to nuking
my install, I know I can back them up with a portable, however that
will suck major.

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Jackie
Sent: Wednesday, November 30, 2022 10:20 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] bug: when unchecking the keys not to use as
modifiers, they become rechecked upon restarting nvda.

Sarah, is this a straight Windows box or are you perchance running it
thru a mac or vm? Also, is this an installed or portable version?

On 11/30/22, Gene <gsasner@...> wrote:
I just tried this with the current NVDA version 2022.3.2, installed.
The setting is saved properly. I manually saved the configuration
before exiting NVDA but I don't think using automatic saving of
settings would matter.

Gene

On 11/30/2022 11:16 AM, Sarah k Alawami wrote:

No not at all, follow my steps and you hopefully can repro.
Basically, uncheck insert or what ever modifiers you don’t want to
use. Restart nvda and those boxes will become checked. Make sure
save config upon exit is checked.

*From:* nvda@nvda.groups.io <nvda@nvda.groups.io> *On Behalf Of
*Gerardo Corripio
*Sent:* Wednesday, November 30, 2022 4:51 AM
*To:* nvda@nvda.groups.io
*Subject:* Re: [nvda] bug: when unchecking the keys not to use as
modifiers, they become rechecked upon restarting nvda.

I don't know if this is somehow related to what happened last
evening,on my Hp Pavillion Windows10 Laptop which is a bit over 4
years old: So I powered on my Laptop just fine; I was able to use
NVDA commands via the Caps-lock key just fine without issues, but
about
5-10 minutes later, not only the NVDA command key didn't work, but
the Tab, Escape or the Number1 key on the top number row! So I
restarted the computer, and the above-mentioned keys worked great
for about 5-10 minutes, after which no go! not even restarting NVDA!
So I restarted the computer a 2nd time, and used it over an hour
without issues! with all the expected keys working just fine!

So might this be related to what you're talking about in this thread?

Gera

Enviado desde mi iPhone SE (2nd Generation) de Telcel



El 29 nov 2022, a la(s) 9:46 p.m., Sarah k Alawami
<marrie12@... <mailto:marrie12@...>> escribió:



Can anyone reproduce this?


Bug

When nvda is restarted, the use insert key option becomes
rechecked even after the user unchecks it.


Steps

1.Launch nvda

2.Go to settings

3.Go to keyboard

4.Choose laptop (not sure if desktop will work the same

5.Uncheck insert under the section where it lists 4 check boxes
for nvda modifiers.

6.Hit ok

7.Restart nvda


Expected

Nvda should not recheck the box for the keys you unchecked


Actual

The box becomes rechecked upon restarting nvda

Windows 11 22H2 (x64) build 22621.819

Nonvisual Desktop Access (NVDA)

Version: 2022.3.2







--
Jackie McBride
Be a hero. Fight Scams. Learn how at www.scam911.org Also check out
brightstarsweb.com & mysitesbeenhacked.com












--
Jackie McBride
Be a hero. Fight Scams. Learn how at www.scam911.org Also check out brightstarsweb.com & mysitesbeenhacked.com


Cyrille
 

Hi Sarah

Just to be sure, since I and other persons cannot reproduce:
1. did you test with add-on disabled?
2. did you test with an NVDA from scratch, e.g. by creating a portable NVDA without copying the configuration and reproducing your steps?