Topics

Change in CTRL+Backspace behavior in MS-Word, but not Notepad or Outlook

konnieellis71@...
 

Lately, when I hit the control+backspace keys to delete a word, NVDA does not announce the word I am deleting. Instead, it says “delete back word.”

I would much prefer that it says the word I am deleting, as it always has before.

I have also since tested this in Notepad, and in Outlook. Both of those are acting normally. They do not say “delete back word.”

If anyone can help me figure out how to set this back to normal in MS Word, please let me know. Thanks so much.

Konnie Ellis

 

Hi,

Ha, found the root cause: this is Word issue, not NVDA. In short, Word announces this, which NVDA picks up. The short-term solution is to block all sorts of announcements like this from Word, with the ideal solution being blocking only some messages.

Technical: UIA notification event problem.

I’ll comment on a potential fix on a GitHub issue Quentin has created.

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of konnieellis71@...
Sent: Friday, March 6, 2020 12:02 PM
To: nvda@nvda.groups.io
Subject: [nvda] Change in CTRL+Backspace behavior in MS-Word, but not Notepad or Outlook

 

Lately, when I hit the control+backspace keys to delete a word, NVDA does not announce the word I am deleting. Instead, it says “delete back word.”

I would much prefer that it says the word I am deleting, as it always has before.

I have also since tested this in Notepad, and in Outlook. Both of those are acting normally. They do not say “delete back word.”

If anyone can help me figure out how to set this back to normal in MS Word, please let me know. Thanks so much.

Konnie Ellis

konnieellis71@...
 

Thanks. Just need to know how to turn off these notifications, and what wondering what other types of notifications I’ll be missing?

Konnie

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Joseph Lee
Sent: Saturday, March 7, 2020 5:41 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Change in CTRL+Backspace behavior in MS-Word, but not Notepad or Outlook

 

Hi,

Ha, found the root cause: this is Word issue, not NVDA. In short, Word announces this, which NVDA picks up. The short-term solution is to block all sorts of announcements like this from Word, with the ideal solution being blocking only some messages.

Technical: UIA notification event problem.

I’ll comment on a potential fix on a GitHub issue Quentin has created.

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of konnieellis71@...
Sent: Friday, March 6, 2020 12:02 PM
To: nvda@nvda.groups.io
Subject: [nvda] Change in CTRL+Backspace behavior in MS-Word, but not Notepad or Outlook

 

Lately, when I hit the control+backspace keys to delete a word, NVDA does not announce the word I am deleting. Instead, it says “delete back word.”

I would much prefer that it says the word I am deleting, as it always has before.

I have also since tested this in Notepad, and in Outlook. Both of those are acting normally. They do not say “delete back word.”

If anyone can help me figure out how to set this back to normal in MS Word, please let me know. Thanks so much.

Konnie Ellis

 

Hmmm I wander if this is a word issue if someone has contacted the microsoft guy supposedly on the win10 list.

I think his name is shuching, he doesn't often send at all, but pops up from time to time when a problem is really bad.

So while I am unsure if he is on this list to, its possible he allready knows about it and is doing something about it without telling us.

I do wander if someone can do feadback to microsoft or ring microsoft access and report this.



On 8/03/2020 1:41 am, Joseph Lee wrote:

Hi,

Ha, found the root cause: this is Word issue, not NVDA. In short, Word announces this, which NVDA picks up. The short-term solution is to block all sorts of announcements like this from Word, with the ideal solution being blocking only some messages.

Technical: UIA notification event problem.

I’ll comment on a potential fix on a GitHub issue Quentin has created.

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of konnieellis71@...
Sent: Friday, March 6, 2020 12:02 PM
To: nvda@nvda.groups.io
Subject: [nvda] Change in CTRL+Backspace behavior in MS-Word, but not Notepad or Outlook

 

Lately, when I hit the control+backspace keys to delete a word, NVDA does not announce the word I am deleting. Instead, it says “delete back word.”

I would much prefer that it says the word I am deleting, as it always has before.

I have also since tested this in Notepad, and in Outlook. Both of those are acting normally. They do not say “delete back word.”

If anyone can help me figure out how to set this back to normal in MS Word, please let me know. Thanks so much.

Konnie Ellis

 

On Sat, Mar 7, 2020 at 08:07 PM, Shaun Everiss wrote:
I do wander if someone can do feedback to microsoft or ring microsoft access and report this.
NVDA's development team (like that of most major software makers, and NVDA definitely counts in the screen reader world) has direct contacts with Microsoft.  That's been mentioned in this forum several times in the past.

I have every reason to believe that once Joseph reports the issue in GitHub that the appropriate communications with Microsoft will occur as a natural progression.
 
--

Brian - Windows 10 Pro, 64-Bit, Version 1909, Build 18363  

Power is being told you're not loved and not being destroyed by it.

       ~ Madonna

 

 

 

Hi,

You can’t turn these off at the moment – I’ll introduce a quick workaround next week that will stop these announcements as part of Windows 10 App Essentials 20.03.1.

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of konnieellis71@...
Sent: Saturday, March 7, 2020 8:43 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Change in CTRL+Backspace behavior in MS-Word, but not Notepad or Outlook

 

Thanks. Just need to know how to turn off these notifications, and what wondering what other types of notifications I’ll be missing?

Konnie

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Joseph Lee
Sent: Saturday, March 7, 2020 5:41 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Change in CTRL+Backspace behavior in MS-Word, but not Notepad or Outlook

 

Hi,

Ha, found the root cause: this is Word issue, not NVDA. In short, Word announces this, which NVDA picks up. The short-term solution is to block all sorts of announcements like this from Word, with the ideal solution being blocking only some messages.

Technical: UIA notification event problem.

I’ll comment on a potential fix on a GitHub issue Quentin has created.

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of konnieellis71@...
Sent: Friday, March 6, 2020 12:02 PM
To: nvda@nvda.groups.io
Subject: [nvda] Change in CTRL+Backspace behavior in MS-Word, but not Notepad or Outlook

 

Lately, when I hit the control+backspace keys to delete a word, NVDA does not announce the word I am deleting. Instead, it says “delete back word.”

I would much prefer that it says the word I am deleting, as it always has before.

I have also since tested this in Notepad, and in Outlook. Both of those are acting normally. They do not say “delete back word.”

If anyone can help me figure out how to set this back to normal in MS Word, please let me know. Thanks so much.

Konnie Ellis