Topics

Changing speech rate not working

Anna Givens
 

I am doing Control + insert + up arrow to increase speech but it is not changing the speech rate.


Anna

Tyler Spivey
 

If you're using the laptop layout, try ctrl+insert+shift+up.

On 3/1/2020 6:21 PM, Anna Givens wrote:
I am doing Control + insert + up arrow to increase speech but it is not changing the speech rate.


Anna

Anna Givens
 

That worked! Thank you.
I just started using NVDA, used to use JAWS. It doesn’t sound like NVDA speaks as fast as JAWS even at 100 percent. Or is that just my imagination?

Anna

On Mar 1, 2020, at 10:42 PM, Tyler Spivey <tspivey@...> wrote:

If you're using the laptop layout, try ctrl+insert+shift+up.


On 3/1/2020 6:21 PM, Anna Givens wrote:
I am doing Control + insert + up arrow to increase speech but it is not changing the speech rate.


Anna

Tyler Spivey
 

No problem.

Assuming you're using OneCore or eSpeak, You need to turn on rate boost. Use ctrl+nvda+shift+left and right arrows until you find it, then use CTRL+nvda+shift+up and down to toggle it between on and off.

On 3/1/2020 8:12 PM, Anna Givens wrote:
That worked! Thank you.
I just started using NVDA, used to use JAWS. It doesn’t sound like NVDA speaks as fast as JAWS even at 100 percent. Or is that just my imagination?

Anna

On Mar 1, 2020, at 10:42 PM, Tyler Spivey <tspivey@...> wrote:

If you're using the laptop layout, try ctrl+insert+shift+up.


On 3/1/2020 6:21 PM, Anna Givens wrote:
I am doing Control + insert + up arrow to increase speech but it is not changing the speech rate.


Anna

Cecelia Rodriguez
 

You can use page up

On Mar 1, 2020, at 10:42 PM, Tyler Spivey <tspivey@...> wrote:

If you're using the laptop layout, try ctrl+insert+shift+up.


On 3/1/2020 6:21 PM, Anna Givens wrote:
I am doing Control + insert + up arrow to increase speech but it is not changing the speech rate.


Anna

Howard Traxler
 

I'm usinng the laptop keyboard setup on my desktop computer. ctrl+insert+shift+up makes it faster, but ctrl+insert+shift+down does nothing.  Is there a change I need to do?

Thanks.

On 3/3/2020 1:00 PM, Cecelia Rodriguez wrote:
You can use page up
On Mar 1, 2020, at 10:42 PM, Tyler Spivey <tspivey@...> wrote:

If you're using the laptop layout, try ctrl+insert+shift+up.


On 3/1/2020 6:21 PM, Anna Givens wrote:
I am doing Control + insert + up arrow to increase speech but it is not changing the speech rate.


Anna

Tyler Spivey
 

Try using caps lock instead of insert, or the other insert key.
Some keyboards aren't capable of registering certain combinations of keys, and yours might be one of them.
If that doesn't work, you can always reassign the gesture.

On 3/3/2020 11:31 AM, Howard Traxler wrote:
I'm usinng the laptop keyboard setup on my desktop computer. ctrl+insert+shift+up makes it faster, but ctrl+insert+shift+down does nothing.  Is there a change I need to do?

Thanks.
On 3/3/2020 1:00 PM, Cecelia Rodriguez wrote:
You can use page up
On Mar 1, 2020, at 10:42 PM, Tyler Spivey <tspivey@...> wrote:

If you're using the laptop layout, try ctrl+insert+shift+up.


On 3/1/2020 6:21 PM, Anna Givens wrote:
I am doing Control + insert + up arrow to increase speech but it is not changing the speech rate.


Anna

Quentin Christensen
 

To double check what Tyler suggested - if you press NVDA+1 to turn on "Input help", every key or set of keys you press gets read out (rather than doing whatever it normally does) - if you press an NVDA keystroke, such as NVDA+shift+control+down arrow, NVDA will read out the keys AND what function they do.  If your keyboard is only recognising some of the keys, it should read out something like CONTROL+SHIFT+DOWN ARROW or NVDA+SHIFT+DOWN ARROW etc.

Press NVDA+1 to turn input help off again.

Note that you can also adjust speech settings such as rate from NVDA's settings screen.  Press NVDA+control+v to open the settings directly to the speech / voice settings and tab through that screen to the option you want to change.

Regards

Quentin.

On Wed, Mar 4, 2020 at 8:59 AM Tyler Spivey <tspivey@...> wrote:
Try using caps lock instead of insert, or the other insert key.
Some keyboards aren't capable of registering certain combinations of
keys, and yours might be one of them.
If that doesn't work, you can always reassign the gesture.

On 3/3/2020 11:31 AM, Howard Traxler wrote:
> I'm usinng the laptop keyboard setup on my desktop computer.
> ctrl+insert+shift+up makes it faster, but ctrl+insert+shift+down does
> nothing.  Is there a change I need to do?
>
> Thanks.
> On 3/3/2020 1:00 PM, Cecelia Rodriguez wrote:
>> You can use page up
>>> On Mar 1, 2020, at 10:42 PM, Tyler Spivey <tspivey@...> wrote:
>>>
>>> If you're using the laptop layout, try ctrl+insert+shift+up.
>>>
>>>
>>>> On 3/1/2020 6:21 PM, Anna Givens wrote:
>>>> I am doing Control + insert + up arrow to increase speech but it is
>>>> not changing the speech rate.
>>>>
>>>>
>>>> Anna
>>>>
>>>
>>>
>>
>>
>
>
>
>





--
Quentin Christensen
Training and Support Manager


Gene
 

That is true up to a point.  But NVDA key describer doesn't read many combinations of keys in a useful manner.  It has nothing to do with whether it recognizes the keys.  Try shift dash or shift equals or shift plus number keys on the main keyboard.  it does no useful good when it announces such things as shift plus 5.  Of course its shift plus five.  But what character does shift plus 5 cause to be typed?  Its percent, but input mode doesn't tell you that.  Hearing shift plus dash is similarly next to useless.  This is something that should be corrected.
 
Gene

----- Original Message -----
Sent: Tuesday, March 03, 2020 5:40 PM
Subject: Re: [nvda] Changing speech rate not working

To double check what Tyler suggested - if you press NVDA+1 to turn on "Input help", every key or set of keys you press gets read out (rather than doing whatever it normally does) - if you press an NVDA keystroke, such as NVDA+shift+control+down arrow, NVDA will read out the keys AND what function they do.  If your keyboard is only recognising some of the keys, it should read out something like CONTROL+SHIFT+DOWN ARROW or NVDA+SHIFT+DOWN ARROW etc.

Press NVDA+1 to turn input help off again.

Note that you can also adjust speech settings such as rate from NVDA's settings screen.  Press NVDA+control+v to open the settings directly to the speech / voice settings and tab through that screen to the option you want to change.

Regards

Quentin.

On Wed, Mar 4, 2020 at 8:59 AM Tyler Spivey <tspivey@...> wrote:
Try using caps lock instead of insert, or the other insert key.
Some keyboards aren't capable of registering certain combinations of
keys, and yours might be one of them.
If that doesn't work, you can always reassign the gesture.

On 3/3/2020 11:31 AM, Howard Traxler wrote:
> I'm usinng the laptop keyboard setup on my desktop computer.
> ctrl+insert+shift+up makes it faster, but ctrl+insert+shift+down does
> nothing.  Is there a change I need to do?
>
> Thanks.
> On 3/3/2020 1:00 PM, Cecelia Rodriguez wrote:
>> You can use page up
>>> On Mar 1, 2020, at 10:42 PM, Tyler Spivey <tspivey@...> wrote:
>>>
>>> If you're using the laptop layout, try ctrl+insert+shift+up.
>>>
>>>
>>>> On 3/1/2020 6:21 PM, Anna Givens wrote:
>>>> I am doing Control + insert + up arrow to increase speech but it is
>>>> not changing the speech rate.
>>>>
>>>>
>>>> Anna
>>>>
>>>
>>>
>>
>>
>
>
>
>





--
Quentin Christensen
Training and Support Manager


Quentin Christensen
 

Good point Gene, we do have an open issue for this at  https://github.com/nvaccess/nvda/issues/6621 (feel free to add anything extra).

For the purposes of checking the synth setting ring keys input help should work fine still.

Regards

Quentin

On Wed, Mar 4, 2020 at 11:08 AM Gene <gsasner@...> wrote:
That is true up to a point.  But NVDA key describer doesn't read many combinations of keys in a useful manner.  It has nothing to do with whether it recognizes the keys.  Try shift dash or shift equals or shift plus number keys on the main keyboard.  it does no useful good when it announces such things as shift plus 5.  Of course its shift plus five.  But what character does shift plus 5 cause to be typed?  Its percent, but input mode doesn't tell you that.  Hearing shift plus dash is similarly next to useless.  This is something that should be corrected.
 
Gene
----- Original Message -----
Sent: Tuesday, March 03, 2020 5:40 PM
Subject: Re: [nvda] Changing speech rate not working

To double check what Tyler suggested - if you press NVDA+1 to turn on "Input help", every key or set of keys you press gets read out (rather than doing whatever it normally does) - if you press an NVDA keystroke, such as NVDA+shift+control+down arrow, NVDA will read out the keys AND what function they do.  If your keyboard is only recognising some of the keys, it should read out something like CONTROL+SHIFT+DOWN ARROW or NVDA+SHIFT+DOWN ARROW etc.

Press NVDA+1 to turn input help off again.

Note that you can also adjust speech settings such as rate from NVDA's settings screen.  Press NVDA+control+v to open the settings directly to the speech / voice settings and tab through that screen to the option you want to change.

Regards

Quentin.

On Wed, Mar 4, 2020 at 8:59 AM Tyler Spivey <tspivey@...> wrote:
Try using caps lock instead of insert, or the other insert key.
Some keyboards aren't capable of registering certain combinations of
keys, and yours might be one of them.
If that doesn't work, you can always reassign the gesture.

On 3/3/2020 11:31 AM, Howard Traxler wrote:
> I'm usinng the laptop keyboard setup on my desktop computer.
> ctrl+insert+shift+up makes it faster, but ctrl+insert+shift+down does
> nothing.  Is there a change I need to do?
>
> Thanks.
> On 3/3/2020 1:00 PM, Cecelia Rodriguez wrote:
>> You can use page up
>>> On Mar 1, 2020, at 10:42 PM, Tyler Spivey <tspivey@...> wrote:
>>>
>>> If you're using the laptop layout, try ctrl+insert+shift+up.
>>>
>>>
>>>> On 3/1/2020 6:21 PM, Anna Givens wrote:
>>>> I am doing Control + insert + up arrow to increase speech but it is
>>>> not changing the speech rate.
>>>>
>>>>
>>>> Anna
>>>>
>>>
>>>
>>
>>
>
>
>
>





--
Quentin Christensen
Training and Support Manager




--
Quentin Christensen
Training and Support Manager


Gene
 

The settings ring commands are spoken correctly. 
 
Gene

----- Original Message -----
Sent: Tuesday, March 03, 2020 6:25 PM
Subject: Re: [nvda] Changing speech rate not working

Good point Gene, we do have an open issue for this at  https://github.com/nvaccess/nvda/issues/6621 (feel free to add anything extra).

For the purposes of checking the synth setting ring keys input help should work fine still.

Regards

Quentin

On Wed, Mar 4, 2020 at 11:08 AM Gene <gsasner@...> wrote:
That is true up to a point.  But NVDA key describer doesn't read many combinations of keys in a useful manner.  It has nothing to do with whether it recognizes the keys.  Try shift dash or shift equals or shift plus number keys on the main keyboard.  it does no useful good when it announces such things as shift plus 5.  Of course its shift plus five.  But what character does shift plus 5 cause to be typed?  Its percent, but input mode doesn't tell you that.  Hearing shift plus dash is similarly next to useless.  This is something that should be corrected.
 
Gene
----- Original Message -----
Sent: Tuesday, March 03, 2020 5:40 PM
Subject: Re: [nvda] Changing speech rate not working

To double check what Tyler suggested - if you press NVDA+1 to turn on "Input help", every key or set of keys you press gets read out (rather than doing whatever it normally does) - if you press an NVDA keystroke, such as NVDA+shift+control+down arrow, NVDA will read out the keys AND what function they do.  If your keyboard is only recognising some of the keys, it should read out something like CONTROL+SHIFT+DOWN ARROW or NVDA+SHIFT+DOWN ARROW etc.

Press NVDA+1 to turn input help off again.

Note that you can also adjust speech settings such as rate from NVDA's settings screen.  Press NVDA+control+v to open the settings directly to the speech / voice settings and tab through that screen to the option you want to change.

Regards

Quentin.

On Wed, Mar 4, 2020 at 8:59 AM Tyler Spivey <tspivey@...> wrote:
Try using caps lock instead of insert, or the other insert key.
Some keyboards aren't capable of registering certain combinations of
keys, and yours might be one of them.
If that doesn't work, you can always reassign the gesture.

On 3/3/2020 11:31 AM, Howard Traxler wrote:
> I'm usinng the laptop keyboard setup on my desktop computer.
> ctrl+insert+shift+up makes it faster, but ctrl+insert+shift+down does
> nothing.  Is there a change I need to do?
>
> Thanks.
> On 3/3/2020 1:00 PM, Cecelia Rodriguez wrote:
>> You can use page up
>>> On Mar 1, 2020, at 10:42 PM, Tyler Spivey <tspivey@...> wrote:
>>>
>>> If you're using the laptop layout, try ctrl+insert+shift+up.
>>>
>>>
>>>> On 3/1/2020 6:21 PM, Anna Givens wrote:
>>>> I am doing Control + insert + up arrow to increase speech but it is
>>>> not changing the speech rate.
>>>>
>>>>
>>>> Anna
>>>>
>>>
>>>
>>
>>
>
>
>
>





--
Quentin Christensen
Training and Support Manager




--
Quentin Christensen
Training and Support Manager


Howard Traxler
 

I am using the caps lock key.  But tell me how to reassign the gesture?

On 3/3/2020 3:29 PM, Tyler Spivey wrote:
Try using caps lock instead of insert, or the other insert key.
Some keyboards aren't capable of registering certain combinations of keys, and yours might be one of them.
If that doesn't work, you can always reassign the gesture.

On 3/3/2020 11:31 AM, Howard Traxler wrote:
I'm usinng the laptop keyboard setup on my desktop computer. ctrl+insert+shift+up makes it faster, but ctrl+insert+shift+down does nothing.  Is there a change I need to do?

Thanks.
On 3/3/2020 1:00 PM, Cecelia Rodriguez wrote:
You can use page up
On Mar 1, 2020, at 10:42 PM, Tyler Spivey <tspivey@...> wrote:

If you're using the laptop layout, try ctrl+insert+shift+up.


On 3/1/2020 6:21 PM, Anna Givens wrote:
I am doing Control + insert + up arrow to increase speech but it is not changing the speech rate.


Anna


Tyler Spivey
 

Try the insert key on the keyboard; maybe that'll work. Or maybe your keyboard just can't do it.

To reassign the gesture, go to the NVDA menu, Preferences, Input gestures. Find it in there and reassign it.

To do that, find Speech in the tree, and expand it. You should then be able to find "Decreases the currently active setting in the synth settings ring".

You can add a gesture with the Add button.

On 3/3/2020 5:51 PM, Howard Traxler wrote:
I am using the caps lock key.  But tell me how to reassign the gesture?

On 3/3/2020 3:29 PM, Tyler Spivey wrote:
Try using caps lock instead of insert, or the other insert key.
Some keyboards aren't capable of registering certain combinations of keys, and yours might be one of them.
If that doesn't work, you can always reassign the gesture.

On 3/3/2020 11:31 AM, Howard Traxler wrote:
I'm usinng the laptop keyboard setup on my desktop computer. ctrl+insert+shift+up makes it faster, but ctrl+insert+shift+down does nothing.  Is there a change I need to do?

Thanks.
On 3/3/2020 1:00 PM, Cecelia Rodriguez wrote:
You can use page up
On Mar 1, 2020, at 10:42 PM, Tyler Spivey <tspivey@...> wrote:

If you're using the laptop layout, try ctrl+insert+shift+up.


On 3/1/2020 6:21 PM, Anna Givens wrote:
I am doing Control + insert + up arrow to increase speech but it is not changing the speech rate.


Anna