Clock add-on 21.09 and other add-on updates #addonrelease


 

Hello everyone,

Another good news on top of release of NVDA 2021.2: more add-ons have become compatible with NVDA 2021.1 or later. Among these are MP3 Direct Cut, Say current keyboard language, Day of the week and a few others. If y9ou happen to be using Add-on Updater, you can now install updates to these add-ons.

 

Speaking of add-on updates, Clock version 21.09 was just released. This is a significant update in that it modernizes add-on internals. More importantly, starting from this release, NVDA 2019.3 or later is required. This is just the beginning – I’m working on a more significant release that will not only change the internals a bit, but will also introduce big changes to Clock settings interface, quiet hours definition and others; this big release is scheduled for sometime later this year (likely November), and you can subscribe to dev channel to receive development builds for the next release.

 

One more thing: I’m finalizing the October 2021 releases of most of my add-ons. Due to internal changes, most of my add-ons will now require NVDA 2021.2 or later, especially if you are planning to use Windows 11 with NVDA.

Enjoy the new add-on updates.

Cheers,

Joseph


William
 

Joseph,

thanks for your hard work.

Could you add a function to the clock addon which allow user to define the date and time string?

e.g. dddd mm yyyy etc.


 

Hi,

Ah, custom date and time formats? It might be possible, at least for Gregorian calendar - might not hold true on all calendars.

Even then, I'm a bit hesitant to add new features at this time:

  1. I'm moving away from date/time format specifiers in general at this time as it is prone to errors if not done well and is not really user friendly (one can argue custom date/time format might make things better for users).
  2. My job with the Clock add-on at this time is to modernize and update existing features. This is more so as Clock add-on is not my own add-on.
  3. Most importantly, I'm limited in what I can do now (will explain in the next post).

Cheers,

Joseph


Betsy Grenevitch
 

My clock is not working with the new NVDA update. It does not show it as incompatible from what I can tell but it is no longer announcing the time on the half and hour.


On 9/14/2021 8:27 AM, Joseph Lee wrote:

Hi,

Ah, custom date and time formats? It might be possible, at least for Gregorian calendar - might not hold true on all calendars.

Even then, I'm a bit hesitant to add new features at this time:

  1. I'm moving away from date/time format specifiers in general at this time as it is prone to errors if not done well and is not really user friendly (one can argue custom date/time format might make things better for users).
  2. My job with the Clock add-on at this time is to modernize and update existing features. This is more so as Clock add-on is not my own add-on.
  3. Most importantly, I'm limited in what I can do now (will explain in the next post).

Cheers,

Joseph

--
Betsy Grenevitch 678-862-3876


 

Hi,

Can you try setting up auto announce interval (interval combo box) again as NVDA might not be understanding that setting somehow?

Cheers,

Joseph


Betsy Grenevitch
 

I need steps for this please. I have no idea what you are talking about.


On 9/14/2021 9:06 AM, Joseph Lee wrote:

Hi,

Can you try setting up auto announce interval (interval combo box) again as NVDA might not be understanding that setting somehow?

Cheers,

Joseph

--
Betsy Grenevitch 678-862-3876


 

Hi,

  1. Open NVDA menu/Preferences/Settings.
  2. From NvDA Settings, select CLock Setup panel.
  3. Tab through the panel until you come across "interval" combo box, then select the interval from the combo box (every 30 minutes, for exmaple).
  4. Select OK, and NVDA should play a sound an/or say something every half an hour or so.

Cheers,

Joseph


Betsy Grenevitch
 

I do not see how to find the clock under settings. I must be doing something incorrectly. I pressed enter on setting and just see 16 options and the clock is not one of them.  So sorry.


On 9/14/2021 4:15 PM, Joseph Lee wrote:

Hi,

  1. Open NVDA menu/Preferences/Settings.
  2. From NvDA Settings, select CLock Setup panel.
  3. Tab through the panel until you come across "interval" combo box, then select the interval from the combo box (every 30 minutes, for exmaple).
  4. Select OK, and NVDA should play a sound an/or say something every half an hour or so.

Cheers,

Joseph

--
Betsy Grenevitch 678-862-3876


 

Hi,

I see. See if Clock add-on is even loaded:

  1. Open NVDA menu/Tools/Manage add-ons.
  2. Look for Clock add-on.
  3. If you find it, see if the add-on is listed as enabled.
  4. If the add-on is listed as "disabled", press Alt+E to enable, then press Escape, then say "yes" when asked to restart.

Also, if Clock add-on is present, let me konw what the version is. If it is Clock 21.09 and it is not working, chances are that it might be corrupted add-on settings.

Cheers,

Joseph


Betsy Grenevitch
 

Joseph, for some reason the clock had not updated and as far as I can tell the updater is set to automatically update. Anyway, I updated it now and had to reset the interval for the clock and it now seems to be working. I have written down the steps from both emails and want to thank you so much for doing such a great job with your instructions. Thank you for all of your work with NVDA.


Thank you to others who also contribute to the ad-ons and other things with NVDA.



On 9/14/2021 5:13 PM, Joseph Lee wrote:

Hi,

I see. See if Clock add-on is even loaded:

  1. Open NVDA menu/Tools/Manage add-ons.
  2. Look for Clock add-on.
  3. If you find it, see if the add-on is listed as enabled.
  4. If the add-on is listed as "disabled", press Alt+E to enable, then press Escape, then say "yes" when asked to restart.

Also, if Clock add-on is present, let me konw what the version is. If it is Clock 21.09 and it is not working, chances are that it might be corrupted add-on settings.

Cheers,

Joseph

--
Betsy Grenevitch 678-862-3876


Ron Canazzi
 

Hi Betsy,

1.  NVDA + N
2. P for preferences press enter
3. C for clock set up.
4.  Use tab to tab to the combo box that says 'interval.'
5.  use up/down arrow keys to select desired interval
6.  Tab to OK and press enter.

t

On 9/14/2021 4:42 PM, Betsy Grenevitch wrote:

I do not see how to find the clock under settings. I must be doing something incorrectly. I pressed enter on setting and just see 16 options and the clock is not one of them.  So sorry.


On 9/14/2021 4:15 PM, Joseph Lee wrote:

Hi,

  1. Open NVDA menu/Preferences/Settings.
  2. From NvDA Settings, select CLock Setup panel.
  3. Tab through the panel until you come across "interval" combo box, then select the interval from the combo box (every 30 minutes, for exmaple).
  4. Select OK, and NVDA should play a sound an/or say something every half an hour or so.

Cheers,

Joseph

--
Betsy Grenevitch 678-862-3876

-- 
Signature:
For a nation to admit it has done grevous wrongs and will strive to correct them for the betterment of all is no vice;
For a nation to claim it has always been great, needs no improvement  and to cling to its past achievements is no virtue!