Topics

Directing NVDA output to a particular audio device

Sile
 

Hello


I know I have seen a thread about this, but I can't recall what the name of the thread is so couldn't find it in the list archive.


I want to be able to set the audio device that NVDA output goes to so that I can separate it from my main headphone output for presentations.


--Sile

Sile
 

P.s., this used to be an option within the synthesizer selection dialog but it does not appear to be there any more.  I am running NVDA version 2019.1.1 on a windows 10 machine.


--Sile

On 2019-10-03 7:32 p.m., Sile via Groups.Io wrote:
Hello


I know I have seen a thread about this, but I can't recall what the name of the thread is so couldn't find it in the list archive.


I want to be able to set the audio device that NVDA output goes to so that I can separate it from my main headphone output for presentations.


--Sile



Kerryn Gunness
 

sile

1. press control NVDA key and s to open synth box
2. tab once to a combo box with options
3. use arro keys to choose your option, for example u s b head phones
4 tab to ok button and press enter

NVDA should be heard in the option you picked

you're done

----- Original Message -----
From: "Sile via Groups.Io" <somodhrain=googlemail.com@groups.io>
To: <nvda@nvda.groups.io>
Sent: Thursday, October 3, 2019 7:32 PM
Subject: [nvda] Directing NVDA output to a particular audio device


Hello


I know I have seen a thread about this, but I can't recall what the name of the thread is so couldn't find it in the list archive.


I want to be able to set the audio device that NVDA output goes to so that I can separate it from my main headphone output for presentations.


--Sile



Jaffar Sidek
 

Hi.  I will stand corrected on this, but if you have two sound cards, one of which has a USB connection, then just set your default sound to be that on your computer's onboard sound chip, RealTech for example.  You can then connect a different set of headphones or speakers to your USB powered sound card and listen to other stuff from there.  I use this setup daily as Part of my work involves sound and music production.  Cheers!

On 10/4/2019 7:32 AM, Sile via Groups.Io wrote:
Hello


I know I have seen a thread about this, but I can't recall what the name of the thread is so couldn't find it in the list archive.


I want to be able to set the audio device that NVDA output goes to so that I can separate it from my main headphone output for presentations.


--Sile



Quentin Christensen
 

"Output device" is still on the synthesizer dialog - NVDA+control+s - I haven't checked this, but maybe it is greyed out if you only have one sound device?  (I have several options so I can't test that theory out).


On Fri, Oct 4, 2019 at 9:42 AM Sile via Groups.Io <somodhrain=googlemail.com@groups.io> wrote:
P.s., this used to be an option within the synthesizer selection dialog
but it does not appear to be there any more.  I am running NVDA version
2019.1.1 on a windows 10 machine.


--Sile

On 2019-10-03 7:32 p.m., Sile via Groups.Io wrote:
> Hello
>
>
> I know I have seen a thread about this, but I can't recall what the
> name of the thread is so couldn't find it in the list archive.
>
>
> I want to be able to set the audio device that NVDA output goes to so
> that I can separate it from my main headphone output for presentations.
>
>
> --Sile
>
>
>
>
>





--
Quentin Christensen
Training and Support Manager

Tyler Spivey
 

Control insert s, tab, select your device. Alternatively, NVDA menu, Preferences, Settings, Speech, Change, select it there.

Due to a longstanding bug, selecting anything other than sound mapper may end up with your speech going to somewhere else if you plug in or unplug an audio device, or switch the default.

Another longstanding unfixed bug is that when you switch the output device in NVDA, the beeps generated by NVDA won't switch along with the synth.
Restarting NVDA should fix these when they happen.

On 10/3/2019 4:42 PM, Sile via Groups.Io wrote:
P.s., this used to be an option within the synthesizer selection dialog but it does not appear to be there any more.  I am running NVDA version 2019.1.1 on a windows 10 machine.
--Sile
On 2019-10-03 7:32 p.m., Sile via Groups.Io wrote:
Hello


I know I have seen a thread about this, but I can't recall what the name of the thread is so couldn't find it in the list archive.


I want to be able to set the audio device that NVDA output goes to so that I can separate it from my main headphone output for presentations.


--Sile




Sile
 

I’m using eloquence from coat factory, do you think that makes a difference?



On Oct 3, 2019, at 8:14 PM, Quentin Christensen <quentin@...> wrote:

"Output device" is still on the synthesizer dialog - NVDA+control+s - I haven't checked this, but maybe it is greyed out if you only have one sound device?  (I have several options so I can't test that theory out).

On Fri, Oct 4, 2019 at 9:42 AM Sile via Groups.Io <somodhrain=googlemail.com@groups.io> wrote:
P.s., this used to be an option within the synthesizer selection dialog
but it does not appear to be there any more.  I am running NVDA version
2019.1.1 on a windows 10 machine.


--Sile

On 2019-10-03 7:32 p.m., Sile via Groups.Io wrote:
> Hello
>
>
> I know I have seen a thread about this, but I can't recall what the
> name of the thread is so couldn't find it in the list archive.
>
>
> I want to be able to set the audio device that NVDA output goes to so
> that I can separate it from my main headphone output for presentations.
>
>
> --Sile
>
>
>
>
>





--
Quentin Christensen
Training and Support Manager

Sile
 


Sile


On Oct 3, 2019, at 9:09 PM, Sile via Groups.Io <somodhrain@...> wrote:

I’m using eloquence from coat factory, do you think that makes a difference?



On Oct 3, 2019, at 8:14 PM, Quentin Christensen <quentin@...> wrote:

"Output device" is still on the synthesizer dialog - NVDA+control+s - I haven't checked this, but maybe it is greyed out if you only have one sound device?  (I have several options so I can't test that theory out).

On Fri, Oct 4, 2019 at 9:42 AM Sile via Groups.Io <somodhrain=googlemail.com@groups.io> wrote:
P.s., this used to be an option within the synthesizer selection dialog
but it does not appear to be there any more.  I am running NVDA version
2019.1.1 on a windows 10 machine.


--Sile

On 2019-10-03 7:32 p.m., Sile via Groups.Io wrote:
> Hello
>
>
> I know I have seen a thread about this, but I can't recall what the
> name of the thread is so couldn't find it in the list archive.
>
>
> I want to be able to set the audio device that NVDA output goes to so
> that I can separate it from my main headphone output for presentations.
>
>
> --Sile
>
>
>
>
>





--
Quentin Christensen
Training and Support Manager

Gene
 

I'm doubtful anyone has just one device.  When only my internal sound card is in use, I still have two choices, such as Microsoft Sound Mapper and also the name of my internal sound card.  I haven't checked in Windows 7 but that's the case in XP.
 
Also, I saw a message yesterday commenting that if you don't select a device for audio, that the internal soundcard will continue to be used by NVDA if you connect another soundcard.  That may be partly true but it isn't what is supposed to happen.  The internal soundcard may continue to be used, but if you exit and restart NVDA, it will play through the external soundcard, which is now the default device.  Also, on my Windows 7 machine, at times, spontaneously, NVDA starts using the external sound card. 
 
Gene

----- Original Message -----
Sent: Thursday, October 03, 2019 7:14 PM
Subject: Re: [nvda] Directing NVDA output to a particular audio device

"Output device" is still on the synthesizer dialog - NVDA+control+s - I haven't checked this, but maybe it is greyed out if you only have one sound device?  (I have several options so I can't test that theory out).

On Fri, Oct 4, 2019 at 9:42 AM Sile via Groups.Io <somodhrain=googlemail.com@groups.io> wrote:
P.s., this used to be an option within the synthesizer selection dialog
but it does not appear to be there any more.  I am running NVDA version
2019.1.1 on a windows 10 machine.


--Sile

On 2019-10-03 7:32 p.m., Sile via Groups.Io wrote:
> Hello
>
>
> I know I have seen a thread about this, but I can't recall what the
> name of the thread is so couldn't find it in the list archive.
>
>
> I want to be able to set the audio device that NVDA output goes to so
> that I can separate it from my main headphone output for presentations.
>
>
> --Sile
>
>
>
>
>





--
Quentin Christensen
Training and Support Manager

Gene
 

I don't know, but have you looked through whatever menus and dialogs may apply within the Code Factory program or plugin itself?  Are you using the SAPI 5 version or the add-on, I believe Code Factory may make both.
 
Gene

----- Original Message -----
Sent: Thursday, October 03, 2019 8:09 PM
Subject: Re: [nvda] Directing NVDA output to a particular audio device

I’m using eloquence from coat factory, do you think that makes a difference?



On Oct 3, 2019, at 8:14 PM, Quentin Christensen <quentin@...> wrote:

"Output device" is still on the synthesizer dialog - NVDA+control+s - I haven't checked this, but maybe it is greyed out if you only have one sound device?  (I have several options so I can't test that theory out).

On Fri, Oct 4, 2019 at 9:42 AM Sile via Groups.Io <somodhrain=googlemail.com@groups.io> wrote:
P.s., this used to be an option within the synthesizer selection dialog
but it does not appear to be there any more.  I am running NVDA version
2019.1.1 on a windows 10 machine.


--Sile

On 2019-10-03 7:32 p.m., Sile via Groups.Io wrote:
> Hello
>
>
> I know I have seen a thread about this, but I can't recall what the
> name of the thread is so couldn't find it in the list archive.
>
>
> I want to be able to set the audio device that NVDA output goes to so
> that I can separate it from my main headphone output for presentations.
>
>
> --Sile
>
>
>
>
>





--
Quentin Christensen
Training and Support Manager

Luke
 

Hi! I followed Kerryn’s steps and it didn’t work for me. Both The computer and NVDA audio was coming through the headphones. I think I want to do what Sile wants to do. I want NVDA to come through my headphones only when they are plugged in the headphone jack and the Computer audio for example music and game sounds to come out the computer speakers. Maybe you need 2 sound cards for that? Which I don’t know how many I have and don’t know how you can tell.

On Oct 3, 2019, at 7:43 PM, Kerryn Gunness via Groups.Io <k_gunness=yahoo.ca@groups.io> wrote:

sile

1. press control NVDA key and s to open synth box
2. tab once to a combo box with options
3. use arro keys to choose your option, for example u s b head phones
4 tab to ok button and press enter

NVDA should be heard in the option you picked

you're done

----- Original Message ----- From: "Sile via Groups.Io" <somodhrain=googlemail.com@groups.io>
To: <nvda@nvda.groups.io>
Sent: Thursday, October 3, 2019 7:32 PM
Subject: [nvda] Directing NVDA output to a particular audio device


Hello


I know I have seen a thread about this, but I can't recall what the name of the thread is so couldn't find it in the list archive.


I want to be able to set the audio device that NVDA output goes to so that I can separate it from my main headphone output for presentations.


--Sile




Robert Doc Wright godfearer
 

As long as you keep plugging and unplugging the headset you are going to have this problem. When you plug in a USB headset it becomes the new default device. When you unplug it the system falls back to the internal default speaker.

 

******If we can't look at ourselves, and ask, why?  then where does the learning start?***     

 

From: Luke
Sent: Sunday, October 6, 2019 11:33 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Directing NVDA output to a particular audio device

 

Hi! I followed Kerryn’s steps and it didn’t work for me. Both The computer and NVDA audio was coming through the headphones. I think I want to do what Sile wants to do. I want NVDA to come through my headphones only when they are plugged in the headphone jack and the Computer audio for example music and game sounds to come out the computer speakers. Maybe you need 2 sound cards for that? Which I don’t know how many I have and don’t know how you can tell.

 

> On Oct 3, 2019, at 7:43 PM, Kerryn Gunness via Groups.Io <k_gunness@...> wrote:

>

> sile

>

> 1. press control NVDA key and s to open synth box

> 2. tab once to a combo box with options

> 3. use arro keys to choose your option, for example u s b head phones

> 4 tab to ok button and press enter

>

> NVDA should be heard in the option you picked

>

> you're done

>

> ----- Original Message ----- From: "Sile via Groups.Io" <somodhrain@...>

> To: <nvda@nvda.groups.io>

> Sent: Thursday, October 3, 2019 7:32 PM

> Subject: [nvda] Directing NVDA output to a particular audio device

>

>

>> Hello

>>

>>

>> I know I have seen a thread about this, but I can't recall what the name of the thread is so couldn't find it in the list archive.

>>

>>

>> I want to be able to set the audio device that NVDA output goes to so that I can separate it from my main headphone output for presentations.

>>

>>

>> --Sile

>>

>>

>>

>

>

>

>

 

 

 

Sarah k Alawami
 

AAcutally for me it does not, unless maybe I have my volume on that sound card turned down. but I unplug my usb sound card and nvda and system sounds go silent. I think in my case the fix is simple though.

Sarah Alawami, owner of TFFP. . For more info go to our website. This is also our libsyn page as well.
For stuff we sell, mac training materials and  tutorials go here.
and for hosting options go here
to subscribe to the feed click here

Our telegram channel is also a good place for an announce only in regard to podcasts, contests, etc.

Our discord is where you will know when we go live on youtube, twitch and mixer. Thanks Restream staff.

Finally, to become a patron and help support the podcast go here

On 6 Oct 2019, at 10:52, Robert Doc Wright godfearer wrote:

As long as you keep plugging and unplugging the headset you are going to have this problem. When you plug in a USB headset it becomes the new default device. When you unplug it the system falls back to the internal default speaker.

 

******If we can't look at ourselves, and ask, why?  then where does the learning start?***     

 

From: Luke
Sent: Sunday, October 6, 2019 11:33 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Directing NVDA output to a particular audio device

 

Hi! I followed Kerryn’s steps and it didn’t work for me. Both The computer and NVDA audio was coming through the headphones. I think I want to do what Sile wants to do. I want NVDA to come through my headphones only when they are plugged in the headphone jack and the Computer audio for example music and game sounds to come out the computer speakers. Maybe you need 2 sound cards for that? Which I don’t know how many I have and don’t know how you can tell.

 

> On Oct 3, 2019, at 7:43 PM, Kerryn Gunness via Groups.Io <k_gunness@...> wrote:

>

> sile

>

> 1. press control NVDA key and s to open synth box

> 2. tab once to a combo box with options

> 3. use arro keys to choose your option, for example u s b head phones

> 4 tab to ok button and press enter

>

> NVDA should be heard in the option you picked

>

> you're done

>

> ----- Original Message ----- From: "Sile via Groups.Io" <somodhrain@...>

> To: <nvda@nvda.groups.io>

> Sent: Thursday, October 3, 2019 7:32 PM

> Subject: [nvda] Directing NVDA output to a particular audio device

>

>

>> Hello

>>

>>

>> I know I have seen a thread about this, but I can't recall what the name of the thread is so couldn't find it in the list archive.

>>

>>

>> I want to be able to set the audio device that NVDA output goes to so that I can separate it from my main headphone output for presentations.

>>

>>

>> --Sile

>>

>>

>>

>

>

>

>

 

 

 

Luke
 

I don’t know if this makes a difference but my headphones or not USB. They use the headphone jack on the computer  

On Oct 6, 2019, at 1:52 PM, Robert Doc Wright godfearer <godfearer@...> wrote:

As long as you keep plugging and unplugging the headset you are going to have this problem. When you plug in a USB headset it becomes the new default device. When you unplug it the system falls back to the internal default speaker.

 

******If we can't look at ourselves, and ask, why?  then where does the learning start?***     

 

From: Luke
Sent: Sunday, October 6, 2019 11:33 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Directing NVDA output to a particular audio device

 

Hi! I followed Kerryn’s steps and it didn’t work for me. Both The computer and NVDA audio was coming through the headphones. I think I want to do what Sile wants to do. I want NVDA to come through my headphones only when they are plugged in the headphone jack and the Computer audio for example music and game sounds to come out the computer speakers. Maybe you need 2 sound cards for that? Which I don’t know how many I have and don’t know how you can tell.

 

> On Oct 3, 2019, at 7:43 PM, Kerryn Gunness via Groups.Io <k_gunness@...> wrote:

>

> sile

>

> 1. press control NVDA key and s to open synth box

> 2. tab once to a combo box with options

> 3. use arro keys to choose your option, for example u s b head phones

> 4 tab to ok button and press enter

>

> NVDA should be heard in the option you picked

>

> you're done

>

> ----- Original Message ----- From: "Sile via Groups.Io" <somodhrain@...>

> To: <nvda@nvda.groups.io>

> Sent: Thursday, October 3, 2019 7:32 PM

> Subject: [nvda] Directing NVDA output to a particular audio device

>

>

>> Hello

>>

>>

>> I know I have seen a thread about this, but I can't recall what the name of the thread is so couldn't find it in the list archive.

>>

>>

>> I want to be able to set the audio device that NVDA output goes to so that I can separate it from my main headphone output for presentations.

>>

>>

>> --Sile

>>

>>

>>

>

>

>

>

 

 

 

Sile
 

That’s a great idea, I totally forgot I have a USB audio device that I can plug into my laptop.

On Oct 6, 2019, at 1:33 PM, Luke <bugsyman35@...> wrote:

Hi! I followed Kerryn’s steps and it didn’t work for me. Both The computer and NVDA audio was coming through the headphones. I think I want to do what Sile wants to do. I want NVDA to come through my headphones only when they are plugged in the headphone jack and the Computer audio for example music and game sounds to come out the computer speakers. Maybe you need 2 sound cards for that? Which I don’t know how many I have and don’t know how you can tell.

On Oct 3, 2019, at 7:43 PM, Kerryn Gunness via Groups.Io <k_gunness=yahoo.ca@groups.io> wrote:

sile

1. press control NVDA key and s to open synth box
2. tab once to a combo box with options
3. use arro keys to choose your option, for example u s b head phones
4 tab to ok button and press enter

NVDA should be heard in the option you picked

you're done

----- Original Message ----- From: "Sile via Groups.Io" <somodhrain=googlemail.com@groups.io>
To: <nvda@nvda.groups.io>
Sent: Thursday, October 3, 2019 7:32 PM
Subject: [nvda] Directing NVDA output to a particular audio device


Hello


I know I have seen a thread about this, but I can't recall what the name of the thread is so couldn't find it in the list archive.


I want to be able to set the audio device that NVDA output goes to so that I can separate it from my main headphone output for presentations.


--Sile





Gene
 

You are using the same sound card if the headphones are not USB headphones but plug into a standard headphone jack.
 
There is no practical way to solve your problem if you want to use these headphones, except to get an external USB soundcard. 
 
You can buy very inexpensive USB soundcards.  Then, you would need to direct whatever audio you want to play through whichever sound card you want.
 
Gene

----- Original Message -----
From: Luke
Sent: Sunday, October 06, 2019 5:27 PM
Subject: Re: [nvda] Directing NVDA output to a particular audio device

I don’t know if this makes a difference but my headphones or not USB. They use the headphone jack on the computer  

On Oct 6, 2019, at 1:52 PM, Robert Doc Wright godfearer <godfearer@...> wrote:

As long as you keep plugging and unplugging the headset you are going to have this problem. When you plug in a USB headset it becomes the new default device. When you unplug it the system falls back to the internal default speaker.

 

******If we can't look at ourselves, and ask, why?  then where does the learning start?***     

 

From: Luke
Sent: Sunday, October 6, 2019 11:33 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Directing NVDA output to a particular audio device

 

Hi! I followed Kerryn’s steps and it didn’t work for me. Both The computer and NVDA audio was coming through the headphones. I think I want to do what Sile wants to do. I want NVDA to come through my headphones only when they are plugged in the headphone jack and the Computer audio for example music and game sounds to come out the computer speakers. Maybe you need 2 sound cards for that? Which I don’t know how many I have and don’t know how you can tell.

 

> On Oct 3, 2019, at 7:43 PM, Kerryn Gunness via Groups.Io <k_gunness@...> wrote:

>

> sile

>

> 1. press control NVDA key and s to open synth box

> 2. tab once to a combo box with options

> 3. use arro keys to choose your option, for example u s b head phones

> 4 tab to ok button and press enter

>

> NVDA should be heard in the option you picked

>

> you're done

>

> ----- Original Message ----- From: "Sile via Groups.Io" <somodhrain@...>

> To: <nvda@nvda.groups.io>

> Sent: Thursday, October 3, 2019 7:32 PM

> Subject: [nvda] Directing NVDA output to a particular audio device

>

>

>> Hello

>>

>>

>> I know I have seen a thread about this, but I can't recall what the name of the thread is so couldn't find it in the list archive.

>>

>>

>> I want to be able to set the audio device that NVDA output goes to so that I can separate it from my main headphone output for presentations.

>>

>>

>> --Sile

>>

>>

>>

>

>

>

>

 

 

 

Luke
 

OK then. Stupid question for you. If I bought A USB headset or headphones then I could get NVDA audio through the headset or headphones and Computer audio through computer speakers? 

On Oct 6, 2019, at 7:11 PM, Gene <gsasner@...> wrote:

You are using the same sound card if the headphones are not USB headphones but plug into a standard headphone jack.
 
There is no practical way to solve your problem if you want to use these headphones, except to get an external USB soundcard. 
 
You can buy very inexpensive USB soundcards.  Then, you would need to direct whatever audio you want to play through whichever sound card you want.
 
Gene
----- Original Message -----
From: Luke
Sent: Sunday, October 06, 2019 5:27 PM
Subject: Re: [nvda] Directing NVDA output to a particular audio device

I don’t know if this makes a difference but my headphones or not USB. They use the headphone jack on the computer  

On Oct 6, 2019, at 1:52 PM, Robert Doc Wright godfearer <godfearer@...> wrote:

As long as you keep plugging and unplugging the headset you are going to have this problem. When you plug in a USB headset it becomes the new default device. When you unplug it the system falls back to the internal default speaker.

 

******If we can't look at ourselves, and ask, why?  then where does the learning start?***     

 

From: Luke
Sent: Sunday, October 6, 2019 11:33 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Directing NVDA output to a particular audio device

 

Hi! I followed Kerryn’s steps and it didn’t work for me. Both The computer and NVDA audio was coming through the headphones. I think I want to do what Sile wants to do. I want NVDA to come through my headphones only when they are plugged in the headphone jack and the Computer audio for example music and game sounds to come out the computer speakers. Maybe you need 2 sound cards for that? Which I don’t know how many I have and don’t know how you can tell.

 

> On Oct 3, 2019, at 7:43 PM, Kerryn Gunness via Groups.Io <k_gunness@...> wrote:

>

> sile

>

> 1. press control NVDA key and s to open synth box

> 2. tab once to a combo box with options

> 3. use arro keys to choose your option, for example u s b head phones

> 4 tab to ok button and press enter

>

> NVDA should be heard in the option you picked

>

> you're done

>

> ----- Original Message ----- From: "Sile via Groups.Io" <somodhrain@...>

> To: <nvda@nvda.groups.io>

> Sent: Thursday, October 3, 2019 7:32 PM

> Subject: [nvda] Directing NVDA output to a particular audio device

>

>

>> Hello

>>

>>

>> I know I have seen a thread about this, but I can't recall what the name of the thread is so couldn't find it in the list archive.

>>

>>

>> I want to be able to set the audio device that NVDA output goes to so that I can separate it from my main headphone output for presentations.

>>

>>

>> --Sile

>>

>>

>>

>

>

>

>

 

 

 

Gene
 

If you want the NVDA audio to go through the USB soundcard, you would set NVDA to use that sound card.  This is done within NVDA itself.
But I don't know how you direct the other audio to use the original internal sound card.  Others would have to answer that.  I've never tried such a setting.
 
Gene

----- Original Message -----
From: Luke
Sent: Sunday, October 06, 2019 7:20 PM
Subject: Re: [nvda] Directing NVDA output to a particular audio device

OK then. Stupid question for you. If I bought A USB headset or headphones then I could get NVDA audio through the headset or headphones and Computer audio through computer speakers? 

On Oct 6, 2019, at 7:11 PM, Gene <gsasner@...> wrote:

You are using the same sound card if the headphones are not USB headphones but plug into a standard headphone jack.
 
There is no practical way to solve your problem if you want to use these headphones, except to get an external USB soundcard. 
 
You can buy very inexpensive USB soundcards.  Then, you would need to direct whatever audio you want to play through whichever sound card you want.
 
Gene
----- Original Message -----
From: Luke
Sent: Sunday, October 06, 2019 5:27 PM
Subject: Re: [nvda] Directing NVDA output to a particular audio device

I don’t know if this makes a difference but my headphones or not USB. They use the headphone jack on the computer  

On Oct 6, 2019, at 1:52 PM, Robert Doc Wright godfearer <godfearer@...> wrote:

As long as you keep plugging and unplugging the headset you are going to have this problem. When you plug in a USB headset it becomes the new default device. When you unplug it the system falls back to the internal default speaker.

 

******If we can't look at ourselves, and ask, why?  then where does the learning start?***     

 

From: Luke
Sent: Sunday, October 6, 2019 11:33 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Directing NVDA output to a particular audio device

 

Hi! I followed Kerryn’s steps and it didn’t work for me. Both The computer and NVDA audio was coming through the headphones. I think I want to do what Sile wants to do. I want NVDA to come through my headphones only when they are plugged in the headphone jack and the Computer audio for example music and game sounds to come out the computer speakers. Maybe you need 2 sound cards for that? Which I don’t know how many I have and don’t know how you can tell.

 

> On Oct 3, 2019, at 7:43 PM, Kerryn Gunness via Groups.Io <k_gunness@...> wrote:

>

> sile

>

> 1. press control NVDA key and s to open synth box

> 2. tab once to a combo box with options

> 3. use arro keys to choose your option, for example u s b head phones

> 4 tab to ok button and press enter

>

> NVDA should be heard in the option you picked

>

> you're done

>

> ----- Original Message ----- From: "Sile via Groups.Io" <somodhrain@...>

> To: <nvda@nvda.groups.io>

> Sent: Thursday, October 3, 2019 7:32 PM

> Subject: [nvda] Directing NVDA output to a particular audio device

>

>

>> Hello

>>

>>

>> I know I have seen a thread about this, but I can't recall what the name of the thread is so couldn't find it in the list archive.

>>

>>

>> I want to be able to set the audio device that NVDA output goes to so that I can separate it from my main headphone output for presentations.

>>

>>

>> --Sile

>>

>>

>>

>

>

>

>

 

 

 

Roger Stewart
 

Someone told me a while back you can create a hardware profile so that all your devices can be permanently set the way you want them even if you plug and unplug something and then plug it in again. However, I've not been able to figure it out. Is there such a thing, and if so, how do you create a hardware profile? I checked under Hardware in Control Panel and didn't find such a thing. Maybe that person was wrong, but if it can be done, that would be great.
Roger










On 10/6/2019 7:20 PM, Luke wrote:
OK then. Stupid question for you. If I bought A USB headset or headphones then I could get NVDA audio through the headset or headphones and Computer audio through computer speakers? 

On Oct 6, 2019, at 7:11 PM, Gene <gsasner@...> wrote:

You are using the same sound card if the headphones are not USB headphones but plug into a standard headphone jack.
 
There is no practical way to solve your problem if you want to use these headphones, except to get an external USB soundcard. 
 
You can buy very inexpensive USB soundcards.  Then, you would need to direct whatever audio you want to play through whichever sound card you want.
 
Gene
----- Original Message -----
From: Luke
Sent: Sunday, October 06, 2019 5:27 PM
Subject: Re: [nvda] Directing NVDA output to a particular audio device

I don’t know if this makes a difference but my headphones or not USB. They use the headphone jack on the computer  

On Oct 6, 2019, at 1:52 PM, Robert Doc Wright godfearer <godfearer@...> wrote:

As long as you keep plugging and unplugging the headset you are going to have this problem. When you plug in a USB headset it becomes the new default device. When you unplug it the system falls back to the internal default speaker.

 

******If we can't look at ourselves, and ask, why?  then where does the learning start?***     

 

From: Luke
Sent: Sunday, October 6, 2019 11:33 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Directing NVDA output to a particular audio device

 

Hi! I followed Kerryn’s steps and it didn’t work for me. Both The computer and NVDA audio was coming through the headphones. I think I want to do what Sile wants to do. I want NVDA to come through my headphones only when they are plugged in the headphone jack and the Computer audio for example music and game sounds to come out the computer speakers. Maybe you need 2 sound cards for that? Which I don’t know how many I have and don’t know how you can tell.

 

> On Oct 3, 2019, at 7:43 PM, Kerryn Gunness via Groups.Io <k_gunness@...> wrote:

>

> sile

>

> 1. press control NVDA key and s to open synth box

> 2. tab once to a combo box with options

> 3. use arro keys to choose your option, for example u s b head phones

> 4 tab to ok button and press enter

>

> NVDA should be heard in the option you picked

>

> you're done

>

> ----- Original Message ----- From: "Sile via Groups.Io" <somodhrain@...>

> To: <nvda@nvda.groups.io>

> Sent: Thursday, October 3, 2019 7:32 PM

> Subject: [nvda] Directing NVDA output to a particular audio device

>

>

>> Hello

>>

>>

>> I know I have seen a thread about this, but I can't recall what the name of the thread is so couldn't find it in the list archive.

>>

>>

>> I want to be able to set the audio device that NVDA output goes to so that I can separate it from my main headphone output for presentations.

>>

>>

>> --Sile

>>

>>

>>

>

>

>

>

 

 

 


 

Hmmm this is from win7 days, you can.

The disadvantage is that on every boot you will have to select that profile and until you do you have no speech its not worth it.



On 7/10/2019 3:06 pm, Roger Stewart wrote:
Someone told me a while back you can create a hardware profile so that all your devices can be permanently set the way you want them even if you plug and unplug something and then plug it in again. However, I've not been able to figure it out. Is there such a thing, and if so, how do you create a hardware profile? I checked under Hardware in Control Panel and didn't find such a thing. Maybe that person was wrong, but if it can be done, that would be great.
Roger










On 10/6/2019 7:20 PM, Luke wrote:
OK then. Stupid question for you. If I bought A USB headset or headphones then I could get NVDA audio through the headset or headphones and Computer audio through computer speakers? 

On Oct 6, 2019, at 7:11 PM, Gene <gsasner@...> wrote:

You are using the same sound card if the headphones are not USB headphones but plug into a standard headphone jack.
 
There is no practical way to solve your problem if you want to use these headphones, except to get an external USB soundcard. 
 
You can buy very inexpensive USB soundcards.  Then, you would need to direct whatever audio you want to play through whichever sound card you want.
 
Gene
----- Original Message -----
From: Luke
Sent: Sunday, October 06, 2019 5:27 PM
Subject: Re: [nvda] Directing NVDA output to a particular audio device

I don’t know if this makes a difference but my headphones or not USB. They use the headphone jack on the computer  

On Oct 6, 2019, at 1:52 PM, Robert Doc Wright godfearer <godfearer@...> wrote:

As long as you keep plugging and unplugging the headset you are going to have this problem. When you plug in a USB headset it becomes the new default device. When you unplug it the system falls back to the internal default speaker.

 

******If we can't look at ourselves, and ask, why?  then where does the learning start?***     

 

From: Luke
Sent: Sunday, October 6, 2019 11:33 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Directing NVDA output to a particular audio device

 

Hi! I followed Kerryn’s steps and it didn’t work for me. Both The computer and NVDA audio was coming through the headphones. I think I want to do what Sile wants to do. I want NVDA to come through my headphones only when they are plugged in the headphone jack and the Computer audio for example music and game sounds to come out the computer speakers. Maybe you need 2 sound cards for that? Which I don’t know how many I have and don’t know how you can tell.

 

> On Oct 3, 2019, at 7:43 PM, Kerryn Gunness via Groups.Io <k_gunness@...> wrote:

>

> sile

>

> 1. press control NVDA key and s to open synth box

> 2. tab once to a combo box with options

> 3. use arro keys to choose your option, for example u s b head phones

> 4 tab to ok button and press enter

>

> NVDA should be heard in the option you picked

>

> you're done

>

> ----- Original Message ----- From: "Sile via Groups.Io" <somodhrain@...>

> To: <nvda@nvda.groups.io>

> Sent: Thursday, October 3, 2019 7:32 PM

> Subject: [nvda] Directing NVDA output to a particular audio device

>

>

>> Hello

>>

>>

>> I know I have seen a thread about this, but I can't recall what the name of the thread is so couldn't find it in the list archive.

>>

>>

>> I want to be able to set the audio device that NVDA output goes to so that I can separate it from my main headphone output for presentations.

>>

>>

>> --Sile

>>

>>

>>

>

>

>

>