Topics

Elements List not working correctly in Slack

Martin O'Sullivan
 

Hi

 

When I bring up the Elements List using Insert and F7, in Slack. the links section is empty.  I am using the Slack app, and not the website.  This was working fine until this morning. 

 

Does anyone else here use slack? 


Do you have the same issue?

 


--
Martin O'Sullivan
‎"When I give food to the poor, they call me a saint. When I ask why the poor have no food, they call me a communist."  Hélder Câmara

"Act your way into a feeling don’t feel your way into Action" (Gandhi)
"Be the change you want to see in the world." (Gandhi)

"We must always take sides. Neutrality helps the oppressor, never the victim. Silence encourages the tormentor, never the tormented." (Elie Wiesel )
Tel: +353878289243

E-mail osumartin@...

APT 29 Falcons View
Blanchardstown Centre
Blanchardstown
D15 VK88
Co Dublin
Ireland


Quentin Christensen
 

Hi Martin,

The vast majority of Slack's interface is buttons and clickables, and really no links at all, except for in specific messages.

However, all the messages are within an ARIA application, which means that NVDA does not render this in browseMode, rather when focus goes inside the application, focus mode is used. This also therefore means that those links will not appear in NVDA's elements list.

The exception to this is when arrowing down to a particular message and then pressing tab, focus moves inside a document specific to the current message, and therefore browseMode can be used, though bounded only to that message content. Within this particular subdocument, NVDA's elements list can be used, and any links in that specific message will be listed.

The ARIA application around the message list was introduced sometime last year in the Slack app, so none of that is new, unless you happened to be using an old version of the app until just recently?

Regards

Quentin.

On Tue, Mar 17, 2020 at 8:55 PM Martin O'Sullivan <osumartin@...> wrote:

Hi

 

When I bring up the Elements List using Insert and F7, in Slack. the links section is empty.  I am using the Slack app, and not the website.  This was working fine until this morning. 

 

Does anyone else here use slack? 


Do you have the same issue?

 


--
Martin O'Sullivan
‎"When I give food to the poor, they call me a saint. When I ask why the poor have no food, they call me a communist."  Hélder Câmara

"Act your way into a feeling don’t feel your way into Action" (Gandhi)
"Be the change you want to see in the world." (Gandhi)

"We must always take sides. Neutrality helps the oppressor, never the victim. Silence encourages the tormentor, never the tormented." (Elie Wiesel )
Tel: +353878289243

E-mail osumartin@...

APT 29 Falcons View
Blanchardstown Centre
Blanchardstown
D15 VK88
Co Dublin
Ireland




--
Quentin Christensen
Training and Support Manager

Martin O'Sullivan
 

I was using the elements list up until yesterday at noon, and I would come out of Focus mode, and I could use the elements list to access things such as jumping to messages, very fast.  However, this just stopped working and now I find the Slack app much slower to use. 

 

I found the following articles on the Slack website, which may be of use.

Use a screen reader with Slack on desktop
https://slack.com/intl/en-ie/help/articles/360000411963-Use-a-screen-reader-with-Slack-on-desktop

Keyboard accessibility in Slack 
https://slack.com/intl/en-ie/help/articles/115003340723-Keyboard-accessibility-in-Slack-