Topics

locked firefox autoplay exceptions accessibility issue


enes sarıbaş
 

Hi all,

Mozilla, with their infinite tweaking have yet again broken something in accessibility. It is no longer possible to add an exception to block all video and audio. There is a field to type the website, but no field to put in the exception.


 

When I look at the Autoplay page, at the top is a dropdown that allows you to pick the default action (which is Block Audio by default) for all websites which can be changed to Block Audio and Video or Allow Audio and Video.  But beyond that I can't even figure out how you get sites added to the list below, as nothing I put in the Search Website box results in any Add button coming up and the Remove Website and Remove All Websites buttons are stippled out and intentionally inaccessible since my list is empty.  Definitely looks like something's "gone buggy" to me, particularly the lack of an Add button.

--

Brian - Windows 10 Pro, 64-Bit, Version 2004, Build 19041  

It’s hard waking up and realizing it’s not always black and white.

     ~ Kelley Boorn

 


 

https://support.mozilla.org/en-US/kb/block-autoplay 

It's all managed via buttons and dropdowns, there's no typing of anything.  See the section Site Settings in particular.
--

Brian - Windows 10 Pro, 64-Bit, Version 2004, Build 19041  

It’s hard waking up and realizing it’s not always black and white.

     ~ Kelley Boorn

 


 

In playing a bit more, once I open any site that has audio/video content, in order to access the control to change what's blocked (or not blocked) I have to throw focus to the address box, Shift+Tab once, then right arrow to get to that button.  Hitting enter then gives a dropdown related to that site and its specific permissions, and the autoplay selection is the first in the permissions list.

It appears that all adding/changing of sites is done via this method, while the Autoplay Settings dialog is mostly focused on removing individual sites or all sites for which you've set non-default handling.
--

Brian - Windows 10 Pro, 64-Bit, Version 2004, Build 19041  

It’s hard waking up and realizing it’s not always black and white.

     ~ Kelley Boorn

 


enes sarıbaş
 

Thanks brian, figured it out now.

On 10/31/2020 10:26 AM, Brian Vogel wrote:
https://support.mozilla.org/en-US/kb/block-autoplay 

It's all managed via buttons and dropdowns, there's no typing of anything.  See the section Site Settings in particular.
--

Brian - Windows 10 Pro, 64-Bit, Version 2004, Build 19041  

It’s hard waking up and realizing it’s not always black and white.

     ~ Kelley Boorn

 


 

Enes,

         You're welcome.

         I'm also going to lock this topic at this point.  I went "down the rabbit hole" of discussing how to use Firefox with it's tweaked settings, which really has nothing to do with NVDA proper.  If something else happens to come up with regard to Firefox itself, please start a new topic on the Chat Subgroup.

--

Brian - Windows 10 Pro, 64-Bit, Version 2004, Build 19041  

It’s hard waking up and realizing it’s not always black and white.

     ~ Kelley Boorn