Goldwave NVDA question


Charles Adkins
 

I am using the latest NVDA and the latest Goldwave add on with a new 14 inch Dell laptop. When I have a file open in Goldwave and hit play, nvda tells me what file I am playing. That of course makes editing difficult when using one soundcard. I've only had this happen on this laptop. Normally when I hit play, I just hear the word play or I just hear the audio start playing. Why is this happening on the laptop and how can I stop it. Thanks so much. Side note, at my advanced age it seems harder to learn a new keyboard lol!!!! Thanks for reading and thanks for your help.


Gene
 

Have you used the latest add-on before?  I suspect the add-on is causing the problem.  You can stop speech if you don’t need it for what you are doing with the command NVDA key s.  To restore speech, issue the command twice.  You can just hold the NVDA key and press s twice.
 
Gene

-----Original Message-----
Sent: Wednesday, October 13, 2021 2:13 PM
Subject: [nvda] Goldwave NVDA question
 
I am using the latest NVDA and the latest Goldwave add on with a new 14 inch Dell laptop. When I have a file open in Goldwave and hit play, nvda tells me what file I am playing. That of course makes editing difficult when using one soundcard. I've only had this happen on this laptop. Normally when I hit play, I just hear the word play or I just hear the audio start playing. Why is this happening on the laptop and how can I stop it. Thanks so much. Side note, at my advanced age it seems harder to learn a new keyboard lol!!!! Thanks for reading and thanks for your help.





dennis huckle
 

Hello,
As well as muting speech with nvda key and s you could try from your start button press windows key and in the edit box type goldwave setup.
This takes you to a selection of different settings that aren't in goldwave itself.
At the bottom of that screen is a setting to
Force screen reader mode.
Try checking this and see if it makes a difference.
I know this works with jaws but aren't sure about nvda.
Tab then to save and press enter.
Hope this helps although I am using the latest add on for goldwave and running windows 10 and don't have the same problem but it may be worth fiddling with those settings to see if any make a difference.
Remember to restore speech having muted press nvda key and s twice.
Kind regards,
Dennis huckle.

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Charles Adkins
Sent: 13 October 2021 20:13
To: nvda@nvda.groups.io
Subject: [nvda] Goldwave NVDA question

I am using the latest NVDA and the latest Goldwave add on with a new 14 inch Dell laptop. When I have a file open in Goldwave and hit play, nvda tells me what file I am playing. That of course makes editing difficult when using one soundcard. I've only had this happen on this laptop. Normally when I hit play, I just hear the word play or I just hear the audio start playing. Why is this happening on the laptop and how can I stop it. Thanks so much. Side note, at my advanced age it seems harder to learn a new keyboard lol!!!! Thanks for reading and thanks for your help.


Gene
 

Is this setting to deal with a situation such as in JARTE where JARTE doesn’t recognize JAWS and doesn’t automatically go into screen mode? 
 
Gene

-----Original Message-----
Sent: Wednesday, October 13, 2021 2:58 PM
Subject: Re: [nvda] Goldwave NVDA question
 
Hello,
As well as muting speech with nvda key and s you could try from your start button press windows key and in the edit box type goldwave setup.
This takes you to a selection of different settings that aren't in goldwave itself.
At the bottom of that screen is a setting to
Force screen reader mode.
Try checking this and see if it makes a difference.
I know this works with jaws but aren't sure about nvda.
Tab then to save and press enter.
Hope this helps although I am using the latest add on for goldwave and running windows 10 and don't have the same problem but it may be worth fiddling with those settings to see if any make a difference.
Remember to restore speech having muted press nvda key and s twice.
Kind regards,
Dennis huckle.

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Charles Adkins
Sent: 13 October 2021 20:13
To: nvda@nvda.groups.io
Subject: [nvda] Goldwave NVDA question

I am using the latest NVDA and the latest Goldwave add on with a new 14 inch Dell laptop. When I have a file open in Goldwave and hit play, nvda tells me what file I am playing. That of course makes editing difficult when using one soundcard. I've only had this happen on this laptop. Normally when I hit play, I just hear the word play or I just hear the audio start playing. Why is this happening on the laptop and how can I stop it. Thanks so much. Side note, at my advanced age it seems harder to learn a new keyboard lol!!!! Thanks for reading and thanks for your help.










Gene
 

I should have said screen-reader mode.
 
Gene

-----Original Message-----
Sent: Wednesday, October 13, 2021 2:58 PM
Subject: Re: [nvda] Goldwave NVDA question
 
Hello,
As well as muting speech with nvda key and s you could try from your start button press windows key and in the edit box type goldwave setup.
This takes you to a selection of different settings that aren't in goldwave itself.
At the bottom of that screen is a setting to
Force screen reader mode.
Try checking this and see if it makes a difference.
I know this works with jaws but aren't sure about nvda.
Tab then to save and press enter.
Hope this helps although I am using the latest add on for goldwave and running windows 10 and don't have the same problem but it may be worth fiddling with those settings to see if any make a difference.
Remember to restore speech having muted press nvda key and s twice.
Kind regards,
Dennis huckle.

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Charles Adkins
Sent: 13 October 2021 20:13
To: nvda@nvda.groups.io
Subject: [nvda] Goldwave NVDA question

I am using the latest NVDA and the latest Goldwave add on with a new 14 inch Dell laptop. When I have a file open in Goldwave and hit play, nvda tells me what file I am playing. That of course makes editing difficult when using one soundcard. I've only had this happen on this laptop. Normally when I hit play, I just hear the word play or I just hear the audio start playing. Why is this happening on the laptop and how can I stop it. Thanks so much. Side note, at my advanced age it seems harder to learn a new keyboard lol!!!! Thanks for reading and thanks for your help.










Gene
 

I didn’t ask the question properly.  I should have said, is this for a situation where Gold Wave doesn’t know a screen-reader is being used and therefore doesn’t automatically go into screen-reader mode?
 
Gene

-----Original Message-----
Sent: Wednesday, October 13, 2021 2:58 PM
Subject: Re: [nvda] Goldwave NVDA question
 
Hello,
As well as muting speech with nvda key and s you could try from your start button press windows key and in the edit box type goldwave setup.
This takes you to a selection of different settings that aren't in goldwave itself.
At the bottom of that screen is a setting to
Force screen reader mode.
Try checking this and see if it makes a difference.
I know this works with jaws but aren't sure about nvda.
Tab then to save and press enter.
Hope this helps although I am using the latest add on for goldwave and running windows 10 and don't have the same problem but it may be worth fiddling with those settings to see if any make a difference.
Remember to restore speech having muted press nvda key and s twice.
Kind regards,
Dennis huckle.

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Charles Adkins
Sent: 13 October 2021 20:13
To: nvda@nvda.groups.io
Subject: [nvda] Goldwave NVDA question

I am using the latest NVDA and the latest Goldwave add on with a new 14 inch Dell laptop. When I have a file open in Goldwave and hit play, nvda tells me what file I am playing. That of course makes editing difficult when using one soundcard. I've only had this happen on this laptop. Normally when I hit play, I just hear the word play or I just hear the audio start playing. Why is this happening on the laptop and how can I stop it. Thanks so much. Side note, at my advanced age it seems harder to learn a new keyboard lol!!!! Thanks for reading and thanks for your help.










dennis huckle
 

Hello Jean,

Looking at the latest add on for goldwave it mentions in the help file that this add on works better with goldwave 657.

Also the latest version of nvda must be used due to changes.

This apparently stops announcements of file name in play, rewind and fast forward.

Kind regards,

Dennis huckle.

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Gene
Sent: 13 October 2021 21:28
To: nvda@nvda.groups.io
Subject: Re: [nvda] Goldwave NVDA question

 

I didn’t ask the question properly.  I should have said, is this for a situation where Gold Wave doesn’t know a screen-reader is being used and therefore doesn’t automatically go into screen-reader mode?

 

Gene

-----Original Message-----

Sent: Wednesday, October 13, 2021 2:58 PM

Subject: Re: [nvda] Goldwave NVDA question

 

Hello,
As well as muting speech with nvda key and s you could try from your start button press windows key and in the edit box type goldwave setup.
This takes you to a selection of different settings that aren't in goldwave itself.
At the bottom of that screen is a setting to
Force screen reader mode.
Try checking this and see if it makes a difference.
I know this works with jaws but aren't sure about nvda.
Tab then to save and press enter.
Hope this helps although I am using the latest add on for goldwave and running windows 10 and don't have the same problem but it may be worth fiddling with those settings to see if any make a difference.
Remember to restore speech having muted press nvda key and s twice.
Kind regards,
Dennis huckle.

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Charles Adkins
Sent: 13 October 2021 20:13
To: nvda@nvda.groups.io
Subject: [nvda] Goldwave NVDA question

I am using the latest NVDA and the latest Goldwave add on with a new 14 inch Dell laptop. When I have a file open in Goldwave and hit play, nvda tells me what file I am playing. That of course makes editing difficult when using one soundcard. I've only had this happen on this laptop. Normally when I hit play, I just hear the word play or I just hear the audio start playing. Why is this happening on the laptop and how can I stop it. Thanks so much. Side note, at my advanced age it seems harder to learn a new keyboard lol!!!! Thanks for reading and thanks for your help.









 

Hi Charles,

Can you tell us:

  • NVDA version you are using
  • GoldWave version you are using
  • The version of GoldWave add-on you have

That way we can figure out what's up.

Cheers,

Joseph (creator of and soon to be former maintainer of GoldWave add-on)


Charles Adkins
 

Latest of everything. 


On Oct 13, 2021, at 6:04 PM, Joseph Lee <joseph.lee22590@...> wrote:



Hi Charles,

Can you tell us:

  • NVDA version you are using
  • GoldWave version you are using
  • The version of GoldWave add-on you have

That way we can figure out what's up.

Cheers,

Joseph (creator of and soon to be former maintainer of GoldWave add-on)


Charles Adkins
 

latest of everything


On Oct 13, 2021, at 6:04 PM, Joseph Lee <joseph.lee22590@...> wrote:



Hi Charles,

Can you tell us:

  • NVDA version you are using
  • GoldWave version you are using
  • The version of GoldWave add-on you have

That way we can figure out what's up.

Cheers,

Joseph (creator of and soon to be former maintainer of GoldWave add-on)


 

Hi Charles,

Hmmm, what do you mean by "latest of everything"? Can you elaborate further please?

P.S. I can guess what "latest of everything" means, but I'm intentionally doing it this way because of two reasons: please prove me wrong (I'm thinking NVDA 2021.2, GoldWave 6.57, and GoldWave add-on 21.10), and this is an educational moment on communicating details to someone who might be able to resolve this and/or pass on important info to someone else. I know what I asked above may come across as not quite user-friendly, but believe me when I advise people that details do matter; unless you are the user and/or the developer can make correct guesses, I think just saying "latest of everything" can hinder community investigations. Also apologies for possibly offending someone with this approach.

Cheers,

Joseph


Charles Adkins
 

You are correct that is right. Sorry, shouldn't assume. This only happens on my new Dell laptop and nothing else. You know those Dells lol!!!!! By the way, I learn alot from your posts. Thank you so much. 


On Oct 13, 2021, at 9:06 PM, Joseph Lee <joseph.lee22590@...> wrote:



Hi Charles,

Hmmm, what do you mean by "latest of everything"? Can you elaborate further please?

P.S. I can guess what "latest of everything" means, but I'm intentionally doing it this way because of two reasons: please prove me wrong (I'm thinking NVDA 2021.2, GoldWave 6.57, and GoldWave add-on 21.10), and this is an educational moment on communicating details to someone who might be able to resolve this and/or pass on important info to someone else. I know what I asked above may come across as not quite user-friendly, but believe me when I advise people that details do matter; unless you are the user and/or the developer can make correct guesses, I think just saying "latest of everything" can hinder community investigations. Also apologies for possibly offending someone with this approach.

Cheers,

Joseph


 

Hi Charles,

In this case, I may need a debug log from you (restart NVDA with debug logging enabled, replicate the issue, open the log viewer, copy and paste everything, and send the log fragment as a private email to me) so I can analyze it this weekend.

Cheers,

Jospeh


Aine Kelly Costello
 

Can confirm I also have this behaviour on a Dell XPS, I just thought it was normal haha and I turn the NVD volume down quite a bit to get round it. But, yeah, if it could be stopped that'd be great. I don't like turning speech off for extended editing as I feel like I'm more likely to accidentally press something I didn't mean to and not notice.
NVDA latest alpha, Goldwave 6.57, Goldwave add-on enabled or disabled happens regardless, Windows 10