How do I Stop NVDA from saying Blank when I arrow down in a document or email


JOHN RIEHL
 

I'm just getting started using NVDA at home and at work. About the only issue I'm having so far is that, on my work computer, when I'm arrowing down a document, either in Outlook 2016, Word, or in a web application that uses Firefox or chrome, I can't get NVDA 2021-2 to stop saying "blank" whenever I encounter a blank line. I have punctuation and symbols  set to none, and NVDA is set not to echo typed characters. Strangely, this isn't happening on my home computer using Office 2019 programs and, as far as I know, I have NVDA configured the same way.

Anybody got any suggestions?

 

Thanks for the help.

John Riehl  


Gene
 

I don’t know what accounts for the difference.  While others may know of another solution, you can use the speech dictionary so the word blank is never spoken.  But you may not want to do that in case you want to hear it spoken in certain contexts. 
 
Do you need to read moving line by line or can you read whatever you are reading using read to end.  If you use read to end, blank lines aren’t spoken.
 
Gene

-----Original Message-----
Sent: Saturday, October 02, 2021 10:00 AM
Subject: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email
 

I'm just getting started using NVDA at home and at work. About the only issue I'm having so far is that, on my work computer, when I'm arrowing down a document, either in Outlook 2016, Word, or in a web application that uses Firefox or chrome, I can't get NVDA 2021-2 to stop saying "blank" whenever I encounter a blank line. I have punctuation and symbols  set to none, and NVDA is set not to echo typed characters. Strangely, this isn't happening on my home computer using Office 2019 programs and, as far as I know, I have NVDA configured the same way.

Anybody got any suggestions?

 

Thanks for the help.

John Riehl 


Tony Malykh
 

Two options:
1. If you install Phonetic punctuation add-on, by default it is configured to replace the word "blank"  with a sound effect.
2. BrowserNav add-on is configured to skip blank lines in browsers, so it will just jump over it without announcing anything.
HTH

On 10/2/2021 8:00 AM, JOHN RIEHL via groups.io wrote:

I'm just getting started using NVDA at home and at work. About the only issue I'm having so far is that, on my work computer, when I'm arrowing down a document, either in Outlook 2016, Word, or in a web application that uses Firefox or chrome, I can't get NVDA 2021-2 to stop saying "blank" whenever I encounter a blank line. I have punctuation and symbols  set to none, and NVDA is set not to echo typed characters. Strangely, this isn't happening on my home computer using Office 2019 programs and, as far as I know, I have NVDA configured the same way.

Anybody got any suggestions?

 

Thanks for the help.

John Riehl  


Gene
 

I find the discussion of blank lines in browsers puzzling.  When I am in browse mode, NVDA never stops at or indicates a blank line.  I’m puzzled as to why arrowing through a web page or another document such as a PDF in browse mode may cause some users to come across blank lines.
 
Gene

-----Original Message-----
Sent: Saturday, October 02, 2021 10:55 AM
Subject: Re: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email
 

Two options:
1. If you install Phonetic punctuation add-on, by default it is configured to replace the word "blank"  with a sound effect.
2. BrowserNav add-on is configured to skip blank lines in browsers, so it will just jump over it without announcing anything.
HTH

On 10/2/2021 8:00 AM, JOHN RIEHL via groups.io wrote:

I'm just getting started using NVDA at home and at work. About the only issue I'm having so far is that, on my work computer, when I'm arrowing down a document, either in Outlook 2016, Word, or in a web application that uses Firefox or chrome, I can't get NVDA 2021-2 to stop saying "blank" whenever I encounter a blank line. I have punctuation and symbols  set to none, and NVDA is set not to echo typed characters. Strangely, this isn't happening on my home computer using Office 2019 programs and, as far as I know, I have NVDA configured the same way.

Anybody got any suggestions?

 

Thanks for the help.

John Riehl 


JOHN RIEHL
 

Unfortunately, my work environment is such that I can't download and install nvda add-ons.

 

Even if I could use the second option that still does not explain why I'm hearing "blank" in Outlook and word.

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Tony Malykh
Sent: Saturday, October 2, 2021 11:55 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

Two options:
1. If you install Phonetic punctuation add-on, by default it is configured to replace the word "blank"  with a sound effect.
2. BrowserNav add-on is configured to skip blank lines in browsers, so it will just jump over it without announcing anything.
HTH

On 10/2/2021 8:00 AM, JOHN RIEHL via groups.io wrote:

I'm just getting started using NVDA at home and at work. About the only issue I'm having so far is that, on my work computer, when I'm arrowing down a document, either in Outlook 2016, Word, or in a web application that uses Firefox or chrome, I can't get NVDA 2021-2 to stop saying "blank" whenever I encounter a blank line. I have punctuation and symbols  set to none, and NVDA is set not to echo typed characters. Strangely, this isn't happening on my home computer using Office 2019 programs and, as far as I know, I have NVDA configured the same way.

Anybody got any suggestions?

 

Thanks for the help.

John Riehl  


JOHN RIEHL
 

I need to move line by line, unfortunately.

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Gene
Sent: Saturday, October 2, 2021 11:39 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

I don’t know what accounts for the difference.  While others may know of another solution, you can use the speech dictionary so the word blank is never spoken.  But you may not want to do that in case you want to hear it spoken in certain contexts. 

 

Do you need to read moving line by line or can you read whatever you are reading using read to end.  If you use read to end, blank lines aren’t spoken.

 

Gene

-----Original Message-----

Sent: Saturday, October 02, 2021 10:00 AM

Subject: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

I'm just getting started using NVDA at home and at work. About the only issue I'm having so far is that, on my work computer, when I'm arrowing down a document, either in Outlook 2016, Word, or in a web application that uses Firefox or chrome, I can't get NVDA 2021-2 to stop saying "blank" whenever I encounter a blank line. I have punctuation and symbols  set to none, and NVDA is set not to echo typed characters. Strangely, this isn't happening on my home computer using Office 2019 programs and, as far as I know, I have NVDA configured the same way.

Anybody got any suggestions?

 

Thanks for the help.

John Riehl 


Jonathan COHN
 

Hello,
rather forcing blank to be changed in pronunciation using a regular expression dictionary entry might be useful.
^ is the beginning of line in regular expressions.
$ is the end of line in regular expressions.
* in regular expressions means 0 or more of the previous character or pattern 
So: 
^ *$ 
should match a line with just spaces in it.  ( note there is a space between the ^ and the * , also note you might want to turn on all punctuation to read my descriptions above, I can't be sure on this computer how much of NVDA reads of the above special characters.
Jonathan 


On Oct 2, 2021, at 11:38, Gene <gsasner@...> wrote:

I don’t know what accounts for the difference.  While others may know of another solution, you can use the speech dictionary so the word blank is never spoken.  But you may not want to do that in case you want to hear it spoken in certain contexts. 
 
Do you need to read moving line by line or can you read whatever you are reading using read to end.  If you use read to end, blank lines aren’t spoken.
 
Gene
-----Original Message-----
Sent: Saturday, October 02, 2021 10:00 AM
Subject: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email
 
I'm just getting started using NVDA at home and at work. About the only issue I'm having so far is that, on my work computer, when I'm arrowing down a document, either in Outlook 2016, Word, or in a web application that uses Firefox or chrome, I can't get NVDA 2021-2 to stop saying "blank" whenever I encounter a blank line. I have punctuation and symbols  set to none, and NVDA is set not to echo typed characters. Strangely, this isn't happening on my home computer using Office 2019 programs and, as far as I know, I have NVDA configured the same way.
Anybody got any suggestions?
 
Thanks for the help.
John Riehl 


JOHN RIEHL
 

Very interesting. Where do I go in NVDA to do this? If this is an elementary question I apologize; I'm a new user.

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Jonathan COHN via groups.io
Sent: Saturday, October 2, 2021 1:45 PM
To: Gene <gsasner@...>
Cc: nvda@nvda.groups.io
Subject: Re: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

Hello,

rather forcing blank to be changed in pronunciation using a regular expression dictionary entry might be useful.

^ is the beginning of line in regular expressions.

$ is the end of line in regular expressions.

* in regular expressions means 0 or more of the previous character or pattern 

So: 

^ *$ 

should match a line with just spaces in it.  ( note there is a space between the ^ and the * , also note you might want to turn on all punctuation to read my descriptions above, I can't be sure on this computer how much of NVDA reads of the above special characters.

Jonathan 

 



On Oct 2, 2021, at 11:38, Gene <gsasner@...> wrote:

 

I don’t know what accounts for the difference.  While others may know of another solution, you can use the speech dictionary so the word blank is never spoken.  But you may not want to do that in case you want to hear it spoken in certain contexts. 

 

Do you need to read moving line by line or can you read whatever you are reading using read to end.  If you use read to end, blank lines aren’t spoken.

 

Gene

-----Original Message-----

Sent: Saturday, October 02, 2021 10:00 AM

Subject: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

I'm just getting started using NVDA at home and at work. About the only issue I'm having so far is that, on my work computer, when I'm arrowing down a document, either in Outlook 2016, Word, or in a web application that uses Firefox or chrome, I can't get NVDA 2021-2 to stop saying "blank" whenever I encounter a blank line. I have punctuation and symbols  set to none, and NVDA is set not to echo typed characters. Strangely, this isn't happening on my home computer using Office 2019 programs and, as far as I know, I have NVDA configured the same way.

Anybody got any suggestions?

 

Thanks for the help.

John Riehl 

 


Luke Robinett
 

Thank you for bringing this up! It’s something that frequently irritates me but because it tends to happen during the midst of my work day, I forget to jot it down as a thing to explore here on the message board after work.
What would really be ideal is an option in NVDA settings that would cause the NVDA cursor to simply bypass blank lines. Sometimes when trying to read an email in outlook I have to press the down arrow well over a dozen times just to get to the first non-blank text. Control down arrow is supposed to take you to the next block but this doesn’t work, either. There’s no Practical reason why a user would want to sit there pounding the down arrow like a trained monkey just hearing the word ”blank” over and over and over LOL. it’s a mindless but seemingly unavoidable waste of time.

On Oct 2, 2021, at 10:47 AM, JOHN RIEHL via groups.io <REALMAN02@...> wrote:



Very interesting. Where do I go in NVDA to do this? If this is an elementary question I apologize; I'm a new user.

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Jonathan COHN via groups.io
Sent: Saturday, October 2, 2021 1:45 PM
To: Gene <gsasner@...>
Cc: nvda@nvda.groups.io
Subject: Re: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

Hello,

rather forcing blank to be changed in pronunciation using a regular expression dictionary entry might be useful.

^ is the beginning of line in regular expressions.

$ is the end of line in regular expressions.

* in regular expressions means 0 or more of the previous character or pattern 

So: 

^ *$ 

should match a line with just spaces in it.  ( note there is a space between the ^ and the * , also note you might want to turn on all punctuation to read my descriptions above, I can't be sure on this computer how much of NVDA reads of the above special characters.

Jonathan 

 



On Oct 2, 2021, at 11:38, Gene <gsasner@...> wrote:

 

I don’t know what accounts for the difference.  While others may know of another solution, you can use the speech dictionary so the word blank is never spoken.  But you may not want to do that in case you want to hear it spoken in certain contexts. 

 

Do you need to read moving line by line or can you read whatever you are reading using read to end.  If you use read to end, blank lines aren’t spoken.

 

Gene

-----Original Message-----

Sent: Saturday, October 02, 2021 10:00 AM

Subject: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

I'm just getting started using NVDA at home and at work. About the only issue I'm having so far is that, on my work computer, when I'm arrowing down a document, either in Outlook 2016, Word, or in a web application that uses Firefox or chrome, I can't get NVDA 2021-2 to stop saying "blank" whenever I encounter a blank line. I have punctuation and symbols  set to none, and NVDA is set not to echo typed characters. Strangely, this isn't happening on my home computer using Office 2019 programs and, as far as I know, I have NVDA configured the same way.

Anybody got any suggestions?

 

Thanks for the help.

John Riehl 

 


Quentin Christensen
 

There is an issue for skipping blank lines in browse mode: https://github.com/nvaccess/nvda/issues/4904

As I noted in a comment to that issue: The main workaround I would suggest is to use say all (NVDA+down arrow or NVDA+a) to read things like messages in Outlook, which will skip blank lines. Another setting which can help particularly in Outlook is to supress reporting of tables. Press NVDA+control+d to open the document formatting settings, then alt+t until you get to "tables", uncheck that, and NVDA should read emails in Outlook a bit smoother.

Otherwise, if you can add anything else regarding use cases or implementation not already covered in the previous comments on that issue, do please comment on the issue itself.

Quentin.

On Mon, Oct 4, 2021 at 11:11 AM Luke Robinett <lukelistservs@...> wrote:
Thank you for bringing this up! It’s something that frequently irritates me but because it tends to happen during the midst of my work day, I forget to jot it down as a thing to explore here on the message board after work.
What would really be ideal is an option in NVDA settings that would cause the NVDA cursor to simply bypass blank lines. Sometimes when trying to read an email in outlook I have to press the down arrow well over a dozen times just to get to the first non-blank text. Control down arrow is supposed to take you to the next block but this doesn’t work, either. There’s no Practical reason why a user would want to sit there pounding the down arrow like a trained monkey just hearing the word ”blank” over and over and over LOL. it’s a mindless but seemingly unavoidable waste of time.

On Oct 2, 2021, at 10:47 AM, JOHN RIEHL via groups.io <REALMAN02=VERIZON.NET@groups.io> wrote:



Very interesting. Where do I go in NVDA to do this? If this is an elementary question I apologize; I'm a new user.

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Jonathan COHN via groups.io
Sent: Saturday, October 2, 2021 1:45 PM
To: Gene <gsasner@...>
Cc: nvda@nvda.groups.io
Subject: Re: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

Hello,

rather forcing blank to be changed in pronunciation using a regular expression dictionary entry might be useful.

^ is the beginning of line in regular expressions.

$ is the end of line in regular expressions.

* in regular expressions means 0 or more of the previous character or pattern 

So: 

^ *$ 

should match a line with just spaces in it.  ( note there is a space between the ^ and the * , also note you might want to turn on all punctuation to read my descriptions above, I can't be sure on this computer how much of NVDA reads of the above special characters.

Jonathan 

 



On Oct 2, 2021, at 11:38, Gene <gsasner@...> wrote:

 

I don’t know what accounts for the difference.  While others may know of another solution, you can use the speech dictionary so the word blank is never spoken.  But you may not want to do that in case you want to hear it spoken in certain contexts. 

 

Do you need to read moving line by line or can you read whatever you are reading using read to end.  If you use read to end, blank lines aren’t spoken.

 

Gene

-----Original Message-----

Sent: Saturday, October 02, 2021 10:00 AM

Subject: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

I'm just getting started using NVDA at home and at work. About the only issue I'm having so far is that, on my work computer, when I'm arrowing down a document, either in Outlook 2016, Word, or in a web application that uses Firefox or chrome, I can't get NVDA 2021-2 to stop saying "blank" whenever I encounter a blank line. I have punctuation and symbols  set to none, and NVDA is set not to echo typed characters. Strangely, this isn't happening on my home computer using Office 2019 programs and, as far as I know, I have NVDA configured the same way.

Anybody got any suggestions?

 

Thanks for the help.

John Riehl 

 



--
Quentin Christensen
Training and Support Manager


Gene
 

It should be able to be done but is there a reason you don’t use read to end in e-mails?  Read to end doesn’t announce blank lines and starts reading the text skipping all blank lines if there are any.
 
Also, what program are you using for e-mail and are you reading mail in plain text or HTML?
 
Gene

-----Original Message-----
Sent: Sunday, October 03, 2021 7:11 PM
Subject: Re: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email
 
Thank you for bringing this up! It’s something that frequently irritates me but because it tends to happen during the midst of my work day, I forget to jot it down as a thing to explore here on the message board after work.
What would really be ideal is an option in NVDA settings that would cause the NVDA cursor to simply bypass blank lines. Sometimes when trying to read an email in outlook I have to press the down arrow well over a dozen times just to get to the first non-blank text. Control down arrow is supposed to take you to the next block but this doesn’t work, either. There’s no Practical reason why a user would want to sit there pounding the down arrow like a trained monkey just hearing the word ”blank” over and over and over LOL. it’s a mindless but seemingly unavoidable waste of time.

On Oct 2, 2021, at 10:47 AM, JOHN RIEHL via groups.io <REALMAN02@...> wrote:



Very interesting. Where do I go in NVDA to do this? If this is an elementary question I apologize; I'm a new user.

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Jonathan COHN via groups.io
Sent: Saturday, October 2, 2021 1:45 PM
To: Gene <gsasner@...>
Cc: nvda@nvda.groups.io
Subject: Re: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

Hello,

rather forcing blank to be changed in pronunciation using a regular expression dictionary entry might be useful.

^ is the beginning of line in regular expressions.

$ is the end of line in regular expressions.

* in regular expressions means 0 or more of the previous character or pattern

So:

^ *$

should match a line with just spaces in it.  ( note there is a space between the ^ and the * , also note you might want to turn on all punctuation to read my descriptions above, I can't be sure on this computer how much of NVDA reads of the above special characters.

Jonathan

 



On Oct 2, 2021, at 11:38, Gene <gsasner@...> wrote:

 

I don’t know what accounts for the difference.  While others may know of another solution, you can use the speech dictionary so the word blank is never spoken.  But you may not want to do that in case you want to hear it spoken in certain contexts. 

 

Do you need to read moving line by line or can you read whatever you are reading using read to end.  If you use read to end, blank lines aren’t spoken.

 

Gene

-----Original Message-----

Sent: Saturday, October 02, 2021 10:00 AM

Subject: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

I'm just getting started using NVDA at home and at work. About the only issue I'm having so far is that, on my work computer, when I'm arrowing down a document, either in Outlook 2016, Word, or in a web application that uses Firefox or chrome, I can't get NVDA 2021-2 to stop saying "blank" whenever I encounter a blank line. I have punctuation and symbols  set to none, and NVDA is set not to echo typed characters. Strangely, this isn't happening on my home computer using Office 2019 programs and, as far as I know, I have NVDA configured the same way.

Anybody got any suggestions?

 

Thanks for the help.

John Riehl 

 


hurrikennyandopo ...
 

I find it actually good when arr owing down a document or web page when editing it otherwise how would I know when to insert information  into certain part of my website or stories that I am writing.

It also lets me know if there are 2 many blank spaces of which I can simply just delete out if I do not want them.



If i do not want to hear it when reading when I go to review the document or web page I just use the say all command.


Gene nz

 

On 4/10/2021 1:11 pm, Luke Robinett wrote:
Thank you for bringing this up! It’s something that frequently irritates me but because it tends to happen during the midst of my work day, I forget to jot it down as a thing to explore here on the message board after work.
What would really be ideal is an option in NVDA settings that would cause the NVDA cursor to simply bypass blank lines. Sometimes when trying to read an email in outlook I have to press the down arrow well over a dozen times just to get to the first non-blank text. Control down arrow is supposed to take you to the next block but this doesn’t work, either. There’s no Practical reason why a user would want to sit there pounding the down arrow like a trained monkey just hearing the word ”blank” over and over and over LOL. it’s a mindless but seemingly unavoidable waste of time.

On Oct 2, 2021, at 10:47 AM, JOHN RIEHL via groups.io <REALMAN02@...> wrote:



Very interesting. Where do I go in NVDA to do this? If this is an elementary question I apologize; I'm a new user.

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Jonathan COHN via groups.io
Sent: Saturday, October 2, 2021 1:45 PM
To: Gene <gsasner@...>
Cc: nvda@nvda.groups.io
Subject: Re: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

Hello,

rather forcing blank to be changed in pronunciation using a regular expression dictionary entry might be useful.

^ is the beginning of line in regular expressions.

$ is the end of line in regular expressions.

* in regular expressions means 0 or more of the previous character or pattern 

So: 

^ *$ 

should match a line with just spaces in it.  ( note there is a space between the ^ and the * , also note you might want to turn on all punctuation to read my descriptions above, I can't be sure on this computer how much of NVDA reads of the above special characters.

Jonathan 

 



On Oct 2, 2021, at 11:38, Gene <gsasner@...> wrote:

 

I don’t know what accounts for the difference.  While others may know of another solution, you can use the speech dictionary so the word blank is never spoken.  But you may not want to do that in case you want to hear it spoken in certain contexts. 

 

Do you need to read moving line by line or can you read whatever you are reading using read to end.  If you use read to end, blank lines aren’t spoken.

 

Gene

-----Original Message-----

Sent: Saturday, October 02, 2021 10:00 AM

Subject: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

I'm just getting started using NVDA at home and at work. About the only issue I'm having so far is that, on my work computer, when I'm arrowing down a document, either in Outlook 2016, Word, or in a web application that uses Firefox or chrome, I can't get NVDA 2021-2 to stop saying "blank" whenever I encounter a blank line. I have punctuation and symbols  set to none, and NVDA is set not to echo typed characters. Strangely, this isn't happening on my home computer using Office 2019 programs and, as far as I know, I have NVDA configured the same way.

Anybody got any suggestions?

 

Thanks for the help.

John Riehl 

 


Steve Nutt
 

Hi,

 

I’m surprised there isn’t an implicit setting to turn off the reporting of blank lines globally. Most other screen readers tend to have this.

 

All the best


steve

 

--

To subscribe to our News and Special Offers list, go to https://www.comproom.co.uk/subscribe

 

Computer Room Services

77 Exeter Close

Stevenage

Hertfordshire

SG1 4PW

T: +44(0)1438-742286

M: +44(0)7956-334938

F: +44(0)1438-759589

E: steve@...

W: https://www.comproom.co.uk

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Quentin Christensen
Sent: 04 October 2021 01:20
To: nvda@nvda.groups.io
Subject: Re: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

There is an issue for skipping blank lines in browse mode: https://github.com/nvaccess/nvda/issues/4904

 

As I noted in a comment to that issue: The main workaround I would suggest is to use say all (NVDA+down arrow or NVDA+a) to read things like messages in Outlook, which will skip blank lines. Another setting which can help particularly in Outlook is to supress reporting of tables. Press NVDA+control+d to open the document formatting settings, then alt+t until you get to "tables", uncheck that, and NVDA should read emails in Outlook a bit smoother.

 

Otherwise, if you can add anything else regarding use cases or implementation not already covered in the previous comments on that issue, do please comment on the issue itself.

 

Quentin.

 

On Mon, Oct 4, 2021 at 11:11 AM Luke Robinett <lukelistservs@...> wrote:

Thank you for bringing this up! It’s something that frequently irritates me but because it tends to happen during the midst of my work day, I forget to jot it down as a thing to explore here on the message board after work.

What would really be ideal is an option in NVDA settings that would cause the NVDA cursor to simply bypass blank lines. Sometimes when trying to read an email in outlook I have to press the down arrow well over a dozen times just to get to the first non-blank text. Control down arrow is supposed to take you to the next block but this doesn’t work, either. There’s no Practical reason why a user would want to sit there pounding the down arrow like a trained monkey just hearing the word ”blank” over and over and over LOL. it’s a mindless but seemingly unavoidable waste of time.



On Oct 2, 2021, at 10:47 AM, JOHN RIEHL via groups.io <REALMAN02=VERIZON.NET@groups.io> wrote:



Very interesting. Where do I go in NVDA to do this? If this is an elementary question I apologize; I'm a new user.

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Jonathan COHN via groups.io
Sent: Saturday, October 2, 2021 1:45 PM
To: Gene <gsasner@...>
Cc: nvda@nvda.groups.io
Subject: Re: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

Hello,

rather forcing blank to be changed in pronunciation using a regular expression dictionary entry might be useful.

^ is the beginning of line in regular expressions.

$ is the end of line in regular expressions.

* in regular expressions means 0 or more of the previous character or pattern 

So: 

^ *$ 

should match a line with just spaces in it.  ( note there is a space between the ^ and the * , also note you might want to turn on all punctuation to read my descriptions above, I can't be sure on this computer how much of NVDA reads of the above special characters.

Jonathan 

 

 

On Oct 2, 2021, at 11:38, Gene <gsasner@...> wrote:

 

I don’t know what accounts for the difference.  While others may know of another solution, you can use the speech dictionary so the word blank is never spoken.  But you may not want to do that in case you want to hear it spoken in certain contexts. 

 

Do you need to read moving line by line or can you read whatever you are reading using read to end.  If you use read to end, blank lines aren’t spoken.

 

Gene

-----Original Message-----

Sent: Saturday, October 02, 2021 10:00 AM

Subject: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

I'm just getting started using NVDA at home and at work. About the only issue I'm having so far is that, on my work computer, when I'm arrowing down a document, either in Outlook 2016, Word, or in a web application that uses Firefox or chrome, I can't get NVDA 2021-2 to stop saying "blank" whenever I encounter a blank line. I have punctuation and symbols  set to none, and NVDA is set not to echo typed characters. Strangely, this isn't happening on my home computer using Office 2019 programs and, as far as I know, I have NVDA configured the same way.

Anybody got any suggestions?

 

Thanks for the help.

John Riehl 

 


 

--

Quentin Christensen
Training and Support Manager

 


David Griffith
 

Just to explain why read to end is not, as is often suggested,  really a resolution for this issue.

If I am reading and email with say multiple links of 200 characters or more, or obscure graphic descripters, or perhaps obscure table layouts if you need some table verbosity, the last thing you want your screenreader to do is to tediously babble through all these  verbose elements of an email in a read to end sequence.

You need  in these circumstances to quickly skip through all this by simply pressing the down arrow to read through an email efficiently and skip all the verbose link / elelment description whilst being aware it is there if you need to go back and review.

 

David Griffith

 

 

Sent from Mail for Windows

 

From: Gene
Sent: 04 October 2021 02:18
To: nvda@nvda.groups.io
Subject: Re: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

It should be able to be done but is there a reason you don’t use read to end in e-mails?  Read to end doesn’t announce blank lines and starts reading the text skipping all blank lines if there are any.

 

Also, what program are you using for e-mail and are you reading mail in plain text or HTML?

 

Gene

-----Original Message-----

Sent: Sunday, October 03, 2021 7:11 PM

Subject: Re: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

Thank you for bringing this up! It’s something that frequently irritates me but because it tends to happen during the midst of my work day, I forget to jot it down as a thing to explore here on the message board after work.

What would really be ideal is an option in NVDA settings that would cause the NVDA cursor to simply bypass blank lines. Sometimes when trying to read an email in outlook I have to press the down arrow well over a dozen times just to get to the first non-blank text. Control down arrow is supposed to take you to the next block but this doesn’t work, either. There’s no Practical reason why a user would want to sit there pounding the down arrow like a trained monkey just hearing the word ”blank” over and over and over LOL. it’s a mindless but seemingly unavoidable waste of time.



On Oct 2, 2021, at 10:47 AM, JOHN RIEHL via groups.io <REALMAN02@...> wrote:



Very interesting. Where do I go in NVDA to do this? If this is an elementary question I apologize; I'm a new user.

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Jonathan COHN via groups.io
Sent: Saturday, October 2, 2021 1:45 PM
To: Gene <gsasner@...>
Cc: nvda@nvda.groups.io
Subject: Re: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

Hello,

rather forcing blank to be changed in pronunciation using a regular expression dictionary entry might be useful.

^ is the beginning of line in regular expressions.

$ is the end of line in regular expressions.

* in regular expressions means 0 or more of the previous character or pattern

So:

^ *$

should match a line with just spaces in it.  ( note there is a space between the ^ and the * , also note you might want to turn on all punctuation to read my descriptions above, I can't be sure on this computer how much of NVDA reads of the above special characters.

Jonathan

 

 

On Oct 2, 2021, at 11:38, Gene <gsasner@...> wrote:

 

I don’t know what accounts for the difference.  While others may know of another solution, you can use the speech dictionary so the word blank is never spoken.  But you may not want to do that in case you want to hear it spoken in certain contexts. 

 

Do you need to read moving line by line or can you read whatever you are reading using read to end.  If you use read to end, blank lines aren’t spoken.

 

Gene

-----Original Message-----

Sent: Saturday, October 02, 2021 10:00 AM

Subject: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

I'm just getting started using NVDA at home and at work. About the only issue I'm having so far is that, on my work computer, when I'm arrowing down a document, either in Outlook 2016, Word, or in a web application that uses Firefox or chrome, I can't get NVDA 2021-2 to stop saying "blank" whenever I encounter a blank line. I have punctuation and symbols  set to none, and NVDA is set not to echo typed characters. Strangely, this isn't happening on my home computer using Office 2019 programs and, as far as I know, I have NVDA configured the same way.

Anybody got any suggestions?

 

Thanks for the help.

John Riehl 

 

 


Gene
 

As I recall, someone mentioned an add-on today that skipps blank llines when using read to end in browse mode.  So using that should eliminate some of the problem.  You may be able to skip blank lines with the add-on while having the convenience of using read to end.  I don’t use it and others can discuss it, but as I recall, there is a skim feature that allows you to skip to the next line or skip a block of links by using down arrow while in read to end to skip to the next line and n to skip blocks of links while resuming reading in read to end.  You can move as you would when not in read to end and have reading continue without having to issue read to end again.
 
Gene

-----Original Message-----
Sent: Monday, October 04, 2021 11:24 PM
Subject: Re: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email
 

Just to explain why read to end is not, as is often suggested,  really a resolution for this issue.

If I am reading and email with say multiple links of 200 characters or more, or obscure graphic descripters, or perhaps obscure table layouts if you need some table verbosity, the last thing you want your screenreader to do is to tediously babble through all these  verbose elements of an email in a read to end sequence.

You need  in these circumstances to quickly skip through all this by simply pressing the down arrow to read through an email efficiently and skip all the verbose link / elelment description whilst being aware it is there if you need to go back and review.

 

David Griffith

 

 

Sent from Mail for Windows

 

From: Gene
Sent: 04 October 2021 02:18
To: nvda@nvda.groups.io
Subject: Re: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

It should be able to be done but is there a reason you don’t use read to end in e-mails?  Read to end doesn’t announce blank lines and starts reading the text skipping all blank lines if there are any.

 

Also, what program are you using for e-mail and are you reading mail in plain text or HTML?

 

Gene

-----Original Message-----

Sent: Sunday, October 03, 2021 7:11 PM

Subject: Re: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

Thank you for bringing this up! It’s something that frequently irritates me but because it tends to happen during the midst of my work day, I forget to jot it down as a thing to explore here on the message board after work.

What would really be ideal is an option in NVDA settings that would cause the NVDA cursor to simply bypass blank lines. Sometimes when trying to read an email in outlook I have to press the down arrow well over a dozen times just to get to the first non-blank text. Control down arrow is supposed to take you to the next block but this doesn’t work, either. There’s no Practical reason why a user would want to sit there pounding the down arrow like a trained monkey just hearing the word ”blank” over and over and over LOL. it’s a mindless but seemingly unavoidable waste of time.



On Oct 2, 2021, at 10:47 AM, JOHN RIEHL via groups.io <REALMAN02@...> wrote:



Very interesting. Where do I go in NVDA to do this? If this is an elementary question I apologize; I'm a new user.

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Jonathan COHN via groups.io
Sent: Saturday, October 2, 2021 1:45 PM
To: Gene <gsasner@...>
Cc: nvda@nvda.groups.io
Subject: Re: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

Hello,

rather forcing blank to be changed in pronunciation using a regular expression dictionary entry might be useful.

^ is the beginning of line in regular expressions.

$ is the end of line in regular expressions.

* in regular expressions means 0 or more of the previous character or pattern

So:

^ *$

should match a line with just spaces in it.  ( note there is a space between the ^ and the * , also note you might want to turn on all punctuation to read my descriptions above, I can't be sure on this computer how much of NVDA reads of the above special characters.

Jonathan

 

 

On Oct 2, 2021, at 11:38, Gene <gsasner@...> wrote:

 

I don’t know what accounts for the difference.  While others may know of another solution, you can use the speech dictionary so the word blank is never spoken.  But you may not want to do that in case you want to hear it spoken in certain contexts. 

 

Do you need to read moving line by line or can you read whatever you are reading using read to end.  If you use read to end, blank lines aren’t spoken.

 

Gene

-----Original Message-----

Sent: Saturday, October 02, 2021 10:00 AM

Subject: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

I'm just getting started using NVDA at home and at work. About the only issue I'm having so far is that, on my work computer, when I'm arrowing down a document, either in Outlook 2016, Word, or in a web application that uses Firefox or chrome, I can't get NVDA 2021-2 to stop saying "blank" whenever I encounter a blank line. I have punctuation and symbols  set to none, and NVDA is set not to echo typed characters. Strangely, this isn't happening on my home computer using Office 2019 programs and, as far as I know, I have NVDA configured the same way.

Anybody got any suggestions?

 

Thanks for the help.

John Riehl 

 

 


Quentin Christensen
 

You could try the Text Nav add-on: https://addons.nvda-project.org/addons/textnav.en.html

Using it, press alt+shift+up or down arrows to jump to the next "text".  This will work better in emails with blocks of text, rather than advertising with mostly links (as it will skip those).

On Tue, Oct 5, 2021 at 4:01 PM Gene <gsasner@...> wrote:
As I recall, someone mentioned an add-on today that skipps blank llines when using read to end in browse mode.  So using that should eliminate some of the problem.  You may be able to skip blank lines with the add-on while having the convenience of using read to end.  I don’t use it and others can discuss it, but as I recall, there is a skim feature that allows you to skip to the next line or skip a block of links by using down arrow while in read to end to skip to the next line and n to skip blocks of links while resuming reading in read to end.  You can move as you would when not in read to end and have reading continue without having to issue read to end again.
 
Gene
-----Original Message-----
Sent: Monday, October 04, 2021 11:24 PM
Subject: Re: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email
 

Just to explain why read to end is not, as is often suggested,  really a resolution for this issue.

If I am reading and email with say multiple links of 200 characters or more, or obscure graphic descripters, or perhaps obscure table layouts if you need some table verbosity, the last thing you want your screenreader to do is to tediously babble through all these  verbose elements of an email in a read to end sequence.

You need  in these circumstances to quickly skip through all this by simply pressing the down arrow to read through an email efficiently and skip all the verbose link / elelment description whilst being aware it is there if you need to go back and review.

 

David Griffith

 

 

Sent from Mail for Windows

 

From: Gene
Sent: 04 October 2021 02:18
To: nvda@nvda.groups.io
Subject: Re: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

It should be able to be done but is there a reason you don’t use read to end in e-mails?  Read to end doesn’t announce blank lines and starts reading the text skipping all blank lines if there are any.

 

Also, what program are you using for e-mail and are you reading mail in plain text or HTML?

 

Gene

-----Original Message-----

Sent: Sunday, October 03, 2021 7:11 PM

Subject: Re: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

Thank you for bringing this up! It’s something that frequently irritates me but because it tends to happen during the midst of my work day, I forget to jot it down as a thing to explore here on the message board after work.

What would really be ideal is an option in NVDA settings that would cause the NVDA cursor to simply bypass blank lines. Sometimes when trying to read an email in outlook I have to press the down arrow well over a dozen times just to get to the first non-blank text. Control down arrow is supposed to take you to the next block but this doesn’t work, either. There’s no Practical reason why a user would want to sit there pounding the down arrow like a trained monkey just hearing the word ”blank” over and over and over LOL. it’s a mindless but seemingly unavoidable waste of time.



On Oct 2, 2021, at 10:47 AM, JOHN RIEHL via groups.io <REALMAN02=VERIZON.NET@groups.io> wrote:



Very interesting. Where do I go in NVDA to do this? If this is an elementary question I apologize; I'm a new user.

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Jonathan COHN via groups.io
Sent: Saturday, October 2, 2021 1:45 PM
To: Gene <gsasner@...>
Cc: nvda@nvda.groups.io
Subject: Re: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

Hello,

rather forcing blank to be changed in pronunciation using a regular expression dictionary entry might be useful.

^ is the beginning of line in regular expressions.

$ is the end of line in regular expressions.

* in regular expressions means 0 or more of the previous character or pattern

So:

^ *$

should match a line with just spaces in it.  ( note there is a space between the ^ and the * , also note you might want to turn on all punctuation to read my descriptions above, I can't be sure on this computer how much of NVDA reads of the above special characters.

Jonathan

 

 

On Oct 2, 2021, at 11:38, Gene <gsasner@...> wrote:

 

I don’t know what accounts for the difference.  While others may know of another solution, you can use the speech dictionary so the word blank is never spoken.  But you may not want to do that in case you want to hear it spoken in certain contexts. 

 

Do you need to read moving line by line or can you read whatever you are reading using read to end.  If you use read to end, blank lines aren’t spoken.

 

Gene

-----Original Message-----

Sent: Saturday, October 02, 2021 10:00 AM

Subject: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

I'm just getting started using NVDA at home and at work. About the only issue I'm having so far is that, on my work computer, when I'm arrowing down a document, either in Outlook 2016, Word, or in a web application that uses Firefox or chrome, I can't get NVDA 2021-2 to stop saying "blank" whenever I encounter a blank line. I have punctuation and symbols  set to none, and NVDA is set not to echo typed characters. Strangely, this isn't happening on my home computer using Office 2019 programs and, as far as I know, I have NVDA configured the same way.

Anybody got any suggestions?

 

Thanks for the help.

John Riehl 

 

 



--
Quentin Christensen
Training and Support Manager