How to eliminate all beep sounds when speech mode is off


ksaeteurn@...
 

Hello,

I've looked through NVDA's preferences and various settings, and have done a search in this forum, but I haven't found any information about how to resolve this issue.

The problem is, when I have speech mode off, I still hear beeping sounds whenever I click on new windows/programs/tabs that I have on my desktop.

For example:
I have speech mode off. I'm on Mozilla Firefox on one monitor, and then I click on my Atom Text Editor in my second monitor, and I hear the beep right after the click.
Also, clicking on different tabs, whether on my browser, or my text editor, sets off this beep as well.
All of this happens even though I have speech mode off.

Does anyone else have this issue? And can anyone tell me how I can make the beeping sounds go away? I have no need for it. All I need is the speech mode on/off.

I thought perhaps installing this plugin would do the trick, but all it does is eliminate the beep option for when you toggle with "Insert + s" (i.e. with the add on, you can just toggle between speech mode on and off), it doesn't actually eliminate the beeps I still hear when speech mode is off.

Any help would be great. Thank you kindly.


Gene
 

I think there is some sort of sounds add-on.  I’ve seen it discussed when this problem has been discussed before.  Do you have this problem when you start NVDA with all add-ons disabled?  If you don’t know how, we can tell you.  That is the first thing to test unless you know you have the add-on I’m talking about.  We need to know if NVDA has anything to do with this problem in the first place.
 
Gene

-----Original Message-----
Sent: Friday, September 17, 2021 4:10 PM
Subject: [nvda] How to eliminate all beep sounds when speech mode is off
 
Hello,

I've looked through NVDA's preferences and various settings, and have done a search in this forum, but I haven't found any information about how to resolve this issue.

The problem is, when I have speech mode off, I still hear beeping sounds whenever I click on new windows/programs/tabs that I have on my desktop.

For example:
I have speech mode off. I'm on Mozilla Firefox on one monitor, and then I click on my Atom Text Editor in my second monitor, and I hear the beep right after the click.
Also, clicking on different tabs, whether on my browser, or my text editor, sets off this beep as well.
All of this happens even though I have speech mode off.

Does anyone else have this issue? And can anyone tell me how I can make the beeping sounds go away? I have no need for it. All I need is the speech mode on/off.

I thought perhaps installing this plugin would do the trick, but all it does is eliminate the beep option for when you toggle with "Insert + s" (i.e. with the add on, you can just toggle between speech mode on and off), it doesn't actually eliminate the beeps I still hear when speech mode is off.

Any help would be great. Thank you kindly.


Jackie
 

Does it happen when NVDA is off? If you need speech to test this, turn
on Narrator. It may be that system sounds are being activated on
certain events.

On 9/17/21, Gene <gsasner@gmail.com> wrote:
I think there is some sort of sounds add-on. I’ve seen it discussed when
this problem has been discussed before. Do you have this problem when you
start NVDA with all add-ons disabled? If you don’t know how, we can tell
you. That is the first thing to test unless you know you have the add-on
I’m talking about. We need to know if NVDA has anything to do with this
problem in the first place.

Gene
-----Original Message-----
From: ksaeteurn@jellybelly.com
Sent: Friday, September 17, 2021 4:10 PM
To: nvda@nvda.groups.io
Subject: [nvda] How to eliminate all beep sounds when speech mode is off

Hello,

I've looked through NVDA's preferences and various settings, and have done a
search in this forum, but I haven't found any information about how to
resolve this issue.

The problem is, when I have speech mode off, I still hear beeping sounds
whenever I click on new windows/programs/tabs that I have on my desktop.

For example:
I have speech mode off. I'm on Mozilla Firefox on one monitor, and then I
click on my Atom Text Editor in my second monitor, and I hear the beep right
after the click.
Also, clicking on different tabs, whether on my browser, or my text editor,
sets off this beep as well.
All of this happens even though I have speech mode off.

Does anyone else have this issue? And can anyone tell me how I can make the
beeping sounds go away? I have no need for it. All I need is the speech mode
on/off.

I thought perhaps installing this plugin would do the trick, but all it does
is eliminate the beep option for when you toggle with "Insert + s" (i.e.
with the add on, you can just toggle between speech mode on and off), it
doesn't actually eliminate the beeps I still hear when speech mode is off.

Any help would be great. Thank you kindly.





--
Subscribe to a WordPress for Newbies Mailing List by sending a message to:
wp4newbs-request@freelists.org with 'subscribe' in the Subject field OR by
visiting the list page at http://www.freelists.org/list/wp4newbs
& check out my sites at www.brightstarsweb.com & www.mysitesbeenhacked.com


ksaeteurn@...
 
Edited

Hi Gene: Yes, I hear the beeps with and without the add-ons. I disabled the add-on and started NVDA and still heard the beeps.


ksaeteurn@...
 

Hi Jackie: Yes, it happens when NVDA speech mode is off. If I exit and close NVDA, then no, I don't hear the beep sounds. I'm certain this is an NVDA issue. I was hoping someone else experienced it personally and had a solution. The "solution" at the moment is to just exit NVDA completely, but then, that's a little inconvenient when I am writing code and trying to test for accessibility. After all, it's a lot faster to have NVDA on, and be able to toggle easily between speech mode ON and OFF.


Gene
 

This doesn’t sound like an NVDA problem.  I’m not sure what would cause the behavior.
 
Gene

-----Original Message-----
Sent: Friday, September 17, 2021 6:08 PM
Subject: Re: [nvda] How to eliminate all beep sounds when speech mode is off
 
Yes, I hear the beeps with and without the add-ons. I disabled the add-on and started NVDA and still heard the beeps.


Gene
 

You can test further by using something else like Narrator and seeing if you hear the sounds.
 
Gene
 

Sent: Friday, September 17, 2021 6:08 PM
Subject: Re: [nvda] How to eliminate all beep sounds when speech mode is off
 
Yes, I hear the beeps with and without the add-ons. I disabled the add-on and started NVDA and still heard the beeps.


Gene
 

Since you hear the sounds when add-ons are disabled, I don’t know what in NVDA might cause the problem.  It should make no such sounds in itself.
 
Gene

-----Original Message-----
Sent: Friday, September 17, 2021 6:16 PM
Subject: Re: [nvda] How to eliminate all beep sounds when speech mode is off
 
Hi Jackie: Yes, it happens when NVDA speech mode is off. If I exit and close NVDA, then no, I don't hear the beep sounds. I'm certain this is an NVDA issue. I was hoping someone else experienced it personally and had a solution. The "solution" at the moment is to just exit NVDA completely, but then, that's a little inconvenient when I am writing code and trying to test for accessibility. After all, it's a lot faster to have NVDA on, and be able to toggle easily between speech mode ON and OFF.


Jackie
 

Under mouse, is your play audio coordinates checked?

On 9/17/21, Gene <gsasner@gmail.com> wrote:
Since you hear the sounds when add-ons are disabled, I don’t know what in
NVDA might cause the problem. It should make no such sounds in itself.

Gene
-----Original Message-----
From: ksaeteurn@jellybelly.com
Sent: Friday, September 17, 2021 6:16 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] How to eliminate all beep sounds when speech mode is
off

Hi Jackie: Yes, it happens when NVDA speech mode is off. If I exit and close
NVDA, then no, I don't hear the beep sounds. I'm certain this is an NVDA
issue. I was hoping someone else experienced it personally and had a
solution. The "solution" at the moment is to just exit NVDA completely, but
then, that's a little inconvenient when I am writing code and trying to test
for accessibility. After all, it's a lot faster to have NVDA on, and be able
to toggle easily between speech mode ON and OFF.





--
Subscribe to a WordPress for Newbies Mailing List by sending a message to:
wp4newbs-request@freelists.org with 'subscribe' in the Subject field OR by
visiting the list page at http://www.freelists.org/list/wp4newbs
& check out my sites at www.brightstarsweb.com & www.mysitesbeenhacked.com


 

On Fri, Sep 17, 2021 at 07:16 PM, <ksaeteurn@...> wrote:
After all, it's a lot faster to have NVDA on, and be able to toggle easily between speech mode ON and OFF.
-
Well, I believe you could use the toggle to put NVDA into sleep mode (NVDA + Shift + S - desktop, substitute Z for laptop layout).  It terminates all output from NVDA without terminating NVDA itself, and if you want NVDA back you just hit that toggle again.
--

Brian - Windows 10, 64-Bit, Version 21H1, Build 19043  

Nothing in all the world is more dangerous than sincere ignorance and conscientious stupidity.

         ~Martin Luther King, Jr.

 


Jackie
 

Also, under object presentation, try setting your progress bar output
to speak & ensure report background progress bars is unchecked. Also
while there, ensure play a sound when autosuggestions appear is
unchecked. Let's see if that helps you.

On 9/17/21, Jackie McBride <abletec@gmail.com> wrote:
Under mouse, is your play audio coordinates checked?

On 9/17/21, Gene <gsasner@gmail.com> wrote:
Since you hear the sounds when add-ons are disabled, I don’t know what in
NVDA might cause the problem. It should make no such sounds in itself.

Gene
-----Original Message-----
From: ksaeteurn@jellybelly.com
Sent: Friday, September 17, 2021 6:16 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] How to eliminate all beep sounds when speech mode is
off

Hi Jackie: Yes, it happens when NVDA speech mode is off. If I exit and
close
NVDA, then no, I don't hear the beep sounds. I'm certain this is an NVDA
issue. I was hoping someone else experienced it personally and had a
solution. The "solution" at the moment is to just exit NVDA completely,
but
then, that's a little inconvenient when I am writing code and trying to
test
for accessibility. After all, it's a lot faster to have NVDA on, and be
able
to toggle easily between speech mode ON and OFF.






--
Subscribe to a WordPress for Newbies Mailing List by sending a message to:
wp4newbs-request@freelists.org with 'subscribe' in the Subject field OR by
visiting the list page at http://www.freelists.org/list/wp4newbs
& check out my sites at www.brightstarsweb.com & www.mysitesbeenhacked.com
--
Subscribe to a WordPress for Newbies Mailing List by sending a message to:
wp4newbs-request@freelists.org with 'subscribe' in the Subject field OR by
visiting the list page at http://www.freelists.org/list/wp4newbs
& check out my sites at www.brightstarsweb.com & www.mysitesbeenhacked.com


ksaeteurn@...
 

@Jackie, nope, it's unchecked. That sound was hard on my ears. I'm glad my volume was down haha.
@Brian, I tried NVDA + Shift + S but it didn't work.

Anyway, I found the issue. The beeping sounds were coming from Preferences > Settings > Browse Mode > "Audio indication of focus and browse modes". That option, by default, was selected. Unselecting that made the beeps go away entirely while Speech Mode was off. Tested thoroughly, and confirmed that this was causing the beeps while Speech Mode was off.

Please see this image: https://ibb.co/RvCc3Dt

Maybe this isn't an issue for everyone (it sounds like it isn't), so to be clear, I'm on a windows 10 machine and my NVDA version is 2021.2.

Hope this helps others in the future. Thank you everyone for your patience and support.


 

On Mon, Sep 20, 2021 at 11:46 AM, <ksaeteurn@...> wrote:
@Brian, I tried NVDA + Shift + S but it didn't work.
-
Interesting.  I looked at the screenshot you posted and it makes even less sense to me that these sounds were being produced when NVDA was in sleep mode.  As described, that's supposed to suppress all output from NVDA.

The question now is whether this is true universally, which means a bug (or sure does to me), or not, which means something idiosyncratic to your machine.
--

Brian - Windows 10, 64-Bit, Version 21H1, Build 19043  

Nothing in all the world is more dangerous than sincere ignorance and conscientious stupidity.

         ~Martin Luther King, Jr.

 


 

A correction, the documentation says of sleep mode:  "sleep mode disables all NVDA commands and speech/braille output for the current application."

That "for the current application" proviso is something I just glossed over.  I also glossed over "speech/braille output," as that doesn't include other audio output, at least as stated.

Sleep mode seems to be a sort of temporary application profile only for the application that NVDA is running over at the moment you invoke it.

I could have sworn that there was, for lack of a better way of putting it, a "global suspend" command for NVDA where it continues to run, but does absolutely nothing while suspended.  But if there is I haven't found it with a quick search.
--

Brian - Windows 10, 64-Bit, Version 21H1, Build 19043  

Nothing in all the world is more dangerous than sincere ignorance and conscientious stupidity.

         ~Martin Luther King, Jr.

 


Sarah k Alawami
 

No there is not, sleep mode is what you would be looking for int is case.

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Brian Vogel
Sent: Monday, September 20, 2021 9:28 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] How to eliminate all beep sounds when speech mode is off

 

A correction, the documentation says of sleep mode:  "sleep mode disables all NVDA commands and speech/braille output for the current application."

That "for the current application" proviso is something I just glossed over.  I also glossed over "speech/braille output," as that doesn't include other audio output, at least as stated.

Sleep mode seems to be a sort of temporary application profile only for the application that NVDA is running over at the moment you invoke it.

I could have sworn that there was, for lack of a better way of putting it, a "global suspend" command for NVDA where it continues to run, but does absolutely nothing while suspended.  But if there is I haven't found it with a quick search.
--

Brian - Windows 10, 64-Bit, Version 21H1, Build 19043  

Nothing in all the world is more dangerous than sincere ignorance and conscientious stupidity.

         ~Martin Luther King, Jr.

 


ksaeteurn@...
 

@Brian, thank you for looking into this in depth for me. I'm new to NVDA, so I appreciate the help.

Perhaps you are correct. Some of these issues might be specific to my machine. I'm not sure.

Regarding enabling Sleep Mode, I tested it once more by putting everything back to the default settings, including re-selecting "Audio indication of focus and browse modes". You were right. There is a "global suspend" option that eliminates the beeping sounds entirely when both Speech Mode is On and Sleep Mode is On. In other words, with Speech and Sleep Modes On, I don't hear those beeping sounds. However, the beeping sounds still occur when Speech Mode is On and Sleep Mode is Off. The beeps occur when I navigate through elements on a page (either with my tab key or mouse). The beep will sound just before NVDA starts reading stuff.

Ultimately the solution for me is to unselect that "Audio indication..." setting to get NVDA to fit my needs (the beeps literally hurts my ears).


 

On Mon, Sep 20, 2021 at 01:18 PM, <ksaeteurn@...> wrote:
Ultimately the solution for me is to unselect that "Audio indication..." setting to get NVDA to fit my needs (the beeps literally hurts my ears).
-
I could have sworn that the sounds used were somehow "tweakable" but I'm not finding anything in the User Manual.

In any case, NVDA will just speak the mode it's transitioned into as those transitions occur.

 
--

Brian - Windows 10, 64-Bit, Version 21H1, Build 19043  

Nothing in all the world is more dangerous than sincere ignorance and conscientious stupidity.

         ~Martin Luther King, Jr.

 


Gene
 

It is important to understand when and why the browser is switching between browse mode and forms mode.  It is important to read the information in the user guide about browsing.  The web page isn’t changing.  the screen-reader is automatically switching modes. 
 
Sleep mode is a red herring.  It has nothing to do with the issue. 
 
You should also be able to get information about browsing with NVDA in various tutorials and training materials.  But if you don’t get this information, you may have ongoing confusion.
 
Do you know how to work with the user guide?  I won’t go into where the information is is this message.
 
Gene

-----Original Message-----
Sent: Monday, September 20, 2021 12:18 PM
Subject: Re: [nvda] How to eliminate all beep sounds when speech mode is off
 
@Brian, thank you for looking into this in depth for me. I'm new to NVDA, so I appreciate the help.

Perhaps you are correct. Some of these issues might be specific to my machine. I'm not sure.

Regarding enabling Sleep Mode, I tested it once more by putting everything back to the default settings, including re-selecting "Audio indication of focus and browse modes". You were right. There is a "global suspend" option that eliminates the beeping sounds entirely when both Speech Mode is On and Sleep Mode is On. In other words, with Speech and Sleep Modes On, I don't hear those beeping sounds. However, the beeping sounds still occur when Speech Mode is On and Sleep Mode is Off. The beeps occur when I navigate through elements on a page (either with my tab key or mouse). The beep will sound just before NVDA starts reading stuff.

Ultimately the solution for me is to unselect that "Audio indication..." setting to get NVDA to fit my needs (the beeps literally hurts my ears).


 

On Mon, Sep 20, 2021 at 02:34 PM, Gene wrote:
Sleep mode is a red herring.  It has nothing to do with the issue. 
-
Then, Gene, please do elaborate on what you see as "the issue."

It wasn't perfectly clear at the outset, and the original poster did say, much later, that sleep mode was silencing everything, which is what I thought he wanted based on, "The problem is, when I have speech mode off, I still hear beeping sounds whenever I click on new windows/programs/tabs that I have on my desktop."

It's pretty clear now that all he wanted to do was to eliminate the two sounds NVDA uses to signal the switch between browse and focus modes because he found them very annoying.  That has been achieved, by unchecking the setting noted.

The original poster does not seem, from anything said in this topic, to have any confusion about what browse and focus mode are or how they behave.
--

Brian - Windows 10, 64-Bit, Version 21H1, Build 19043  

Nothing in all the world is more dangerous than sincere ignorance and conscientious stupidity.

         ~Martin Luther King, Jr.

 


Gene
 

I can’t comment on the desktop sounds.  It also isn’t clear if the user uses some sight.  If you use sleep in whatever program you are in, you won’t be able to use the screen-reader at all, yet the person didn’t comment on that. 
 
In terms of the browser, from what the person wrote in recent messages, the problem is that the person is hearing the sounds that the browser makes by default when automatically switching between browse mode and focus mode as you move through a web page and come to certain structures. 
 
Sleep mode would stop these sounds, if done in such a way that it is on while the browser is running because NVDA is completely inactive.  But then you wouldn’t have browse mode and you wouldn’t have any screen-reader information so you wouldn’t use the browser in the first place unless you were using sight to move around the web page.  Perhaps the person has enough site for navigation but not enough for comfortable extended reading.  There is too much we don’t know about how the person uses NVDA, but, we now know  that the person didn’t want to hear the change sounds.
 
Gene

-----Original Message-----
Sent: Monday, September 20, 2021 3:13 PM
Subject: Re: [nvda] How to eliminate all beep sounds when speech mode is off
 
On Mon, Sep 20, 2021 at 02:34 PM, Gene wrote:
Sleep mode is a red herring.  It has nothing to do with the issue.
-
Then, Gene, please do elaborate on what you see as "the issue."

It wasn't perfectly clear at the outset, and the original poster did say, much later, that sleep mode was silencing everything, which is what I thought he wanted based on, "The problem is, when I have speech mode off, I still hear beeping sounds whenever I click on new windows/programs/tabs that I have on my desktop."

It's pretty clear now that all he wanted to do was to eliminate the two sounds NVDA uses to signal the switch between browse and focus modes because he found them very annoying.  That has been achieved, by unchecking the setting noted.

The original poster does not seem, from anything said in this topic, to have any confusion about what browse and focus mode are or how they behave.
--

Brian - Windows 10, 64-Bit, Version 21H1, Build 19043  

Nothing in all the world is more dangerous than sincere ignorance and conscientious stupidity.

         ~Martin Luther King, Jr.