How to stop Eloquence from spelling punctuation and space


Sarah k Alawami
 

I did this before on my old computer; I cannot remember how to stop this behavior on my new computer.  It is driving me up the wall. Something like process, but I shut that off in eloquence’s settings. I’m running nvda 22.x on Windows 11 21H2 (x64) build 22000.739 I think I need to look under speech to be sure. I thought it was discussed on this group, but I can’t remember where that check box is to save my sanity.

 

Take care all.


 

Depending on precisely what you want to accomplish, and when, you'll use a combination of the Punctuation/Symbol level setting in Speech settings (defaults to most) and the actual Symbol Pronunciation dialog.  It could be that just trying the "some" level instead of the "most" level may work.  It all depends on when and how, precisely, you don't want these things announced.
--

Brian - Windows 10, 64-Bit, Version 21H2, Build 19044  

The real art of conversation is not only to say the right thing in the right place but to leave unsaid the wrong thing at the tempting moment.

        ~ Dorothy Nevill


Sarah k Alawami
 
Edited

Ok, we got it.  It is not where one would expect, and I misunderstood the setting, but go under Speech and uncheck the Use spelling functionality if supported check box.  It's checked by default.

I hope this helps someone, again. lol!

Happy Saturday to all.


Sarah k Alawami
 

No. check my post. It is one check box that needs to be unchecked if it isn’t already.  Try it with eloquence from ATGuys. Then go to nvda’s settings under speech. It is the last check box.

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Brian Vogel
Sent: Saturday, July 9, 2022 9:44 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] how to sotp eloquence from spelling punctuaiton and space

 

Depending on precisely what you want to accomplish, and when, you'll use a combination of the Punctuation/Symbol level setting in Speech settings (defaults to most) and the actual Symbol Pronunciation dialog.  It could be that just trying the "some" level instead of the "most" level may work.  It all depends on when and how, precisely, you don't want these things announced.
--

Brian - Windows 10, 64-Bit, Version 21H2, Build 19044  

The real art of conversation is not only to say the right thing in the right place but to leave unsaid the wrong thing at the tempting moment.

        ~ Dorothy Nevill


Gene
 

I'm not sure what was occurring from your subject line.  Was the synthesizer spelling punctuation marks like comma and spelling space when you moved by character?  If so, what you did is an interesting solution.  It appears the problem is unexpected behavior even if this check box is checked and it causes odd behaviors with some MSAPI synthesizers, as the User Guide says.

Here is an explanation of what this setting does when on.

Use spelling functionality if supported
Some words consist of only one character, but the pronunciation is different depending on whether the character is being spoken as an individual character (such as when spelling) or a word. For example, in English, "a" is both a letter and a word and is pronounced differently in each case. This option allows the synthesizer to differentiate between these two cases if the synthesizer supports this. Most synthesizers do support it.
This option should generally be enabled. However, some Microsoft Speech API synthesizers do not implement this correctly and behave strangely when it is enabled. If you are having problems with the pronunciation of individual characters, try disabling this option.

I wonder if there is an underlying problem that causes this behavior.  I have used the Code Factory MSAPI demo on at least three computers and I haven't had the problem.  The setting was checked in all cases.

Your problem reminds me of an odd problem I've had now and then which I'll describe here in case someone finds it useful.
I have had an odd behavior now and then when I made an entry in the spelling dictionary. 
For some reason, every word was spelled out.  As I recall, removing the entry solved the problem.  I don't recall what such an entry consists of but in case someone has this behavior and wants to try to stop it, if you just made or recently made an entry in the speech dictionary, remove it and see what happens.

Gene

On 7/9/2022 11:48 AM, Sarah k Alawami wrote:
Ok, we got it It is not where one would expect, and I misunderstood the box, but go under speech and uncheck  Use spelling functionality if supported  check box  not checked  I hope this helps someone, again. lol!

Happy saturday to all.


Brian's Mail list account
 

Yes one does need to be careful. I did something the other day which has seemingly resulted in all words that are completely capitalised sometimes not being pronounced correctly in Espeak.
I cannot see how any of my entries would do this.
Brian

--
bglists@...
Sent via blueyonder.(Virgin media)
Please address personal E-mail to:-
briang1@..., putting 'Brian Gaff'
in the display name field.

----- Original Message -----
From: "Gene" <gsasner@...>
To: <nvda@nvda.groups.io>
Sent: Saturday, July 09, 2022 9:14 PM
Subject: Re: [nvda] How to stop Eloquence from spelling punctuation and space


I'm not sure what was occurring from your subject line. Was the
synthesizer spelling punctuation marks like comma and spelling space
when you moved by character? If so, what you did is an interesting
solution. It appears the problem is unexpected behavior even if this
check box is checked and it causes odd behaviors with some MSAPI
synthesizers, as the User Guide says.

Here is an explanation of what this setting does when on.

Use spelling functionality if supported
Some words consist of only one character, but the pronunciation is
different depending on whether the character is being spoken as an
individual character (such as when spelling) or a word. For example, in
English, "a" is both a letter and a word and is pronounced differently
in each case. This option allows the synthesizer to differentiate
between these two cases if the synthesizer supports this. Most
synthesizers do support it.
This option should generally be enabled. However, some Microsoft Speech
API synthesizers do not implement this correctly and behave strangely
when it is enabled. If you are having problems with the pronunciation of
individual characters, try disabling this option.

I wonder if there is an underlying problem that causes this behavior. I
have used the Code Factory MSAPI demo on at least three computers and I
haven't had the problem. The setting was checked in all cases.

Your problem reminds me of an odd problem I've had now and then which
I'll describe here in case someone finds it useful.
I have had an odd behavior now and then when I made an entry in the
spelling dictionary.
For some reason, every word was spelled out. As I recall, removing the
entry solved the problem. I don't recall what such an entry consists of
but in case someone has this behavior and wants to try to stop it, if
you just made or recently made an entry in the speech dictionary, remove
it and see what happens.

Gene
On 7/9/2022 11:48 AM, Sarah k Alawami wrote:
Ok, we got it It is not where one would expect, and I misunderstood
the box, but go under speech and uncheck Use spelling functionality
if supported check box not checked I hope this helps someone, again.
lol!

Happy saturday to all.