In NVDA, most Microsoft OneCore voices are the same voice for me.


John Isige
 

Hi all.


So I've got all of the extra English OneCore voices installed, so Richard, Linda, James, that kind of thing. For some reason, if I set NVDA to use the OneCore voices and change voices, all of them are David, except for Zira and Mark. I'm pretty sure this worked at one point, but it's obviously broken now. I've tried restarting with addons disabled, and I still have the same issue.


I know the voices are installed properly because if I go into settings/time & language/speech, the voices show up there and preview as themselves. Additionally, if I run Narrator, I can change to each voice in the list and it's actually the correct voice. Anybody have any ideas? It's not vitally important that I get this working or anything, I mostly use Code Factory's SAPI 5 Eloquence, but it's pretty strange, and I like to fix those kinds of things if I can.


Quentin Christensen
 

Firstly,

Have you rebooted the PC since updating?  It's worth doing that as we do often see odd things like this after updating and before restarting.  Next, if you press NVDA+Q then down arrow to "Restart with add-ons disabled" does that make a difference?

Kind regards

Quentin.

On Tue, Jul 13, 2021 at 4:13 AM John Isige <gwynn@...> wrote:
Hi all.


So I've got all of the extra English OneCore voices installed, so
Richard, Linda, James, that kind of thing. For some reason, if I set
NVDA to use the OneCore voices and change voices, all of them are David,
except for Zira and Mark. I'm pretty sure this worked at one point, but
it's obviously broken now. I've tried restarting with addons disabled,
and I still have the same issue.


I know the voices are installed properly because if I go into
settings/time & language/speech, the voices show up there and preview as
themselves. Additionally, if I run Narrator, I can change to each voice
in the list and it's actually the correct voice. Anybody have any ideas?
It's not vitally important that I get this working or anything, I mostly
use Code Factory's SAPI 5 Eloquence, but it's pretty strange, and I like
to fix those kinds of things if I can.








--
Quentin Christensen
Training and Support Manager


John Isige
 

Rebooted the PC, this has actually been going on for a while. I assumed it was just Windows being messed up. I also restarted with addons disabled, and no difference whatsoever. It's pretty weird.


On 7/12/2021 9:53 PM, Quentin Christensen wrote:
Firstly,

Have you rebooted the PC since updating?  It's worth doing that as we do often see odd things like this after updating and before restarting.  Next, if you press NVDA+Q then down arrow to "Restart with add-ons disabled" does that make a difference?

Kind regards

Quentin.

On Tue, Jul 13, 2021 at 4:13 AM John Isige <gwynn@...> wrote:
Hi all.


So I've got all of the extra English OneCore voices installed, so
Richard, Linda, James, that kind of thing. For some reason, if I set
NVDA to use the OneCore voices and change voices, all of them are David,
except for Zira and Mark. I'm pretty sure this worked at one point, but
it's obviously broken now. I've tried restarting with addons disabled,
and I still have the same issue.


I know the voices are installed properly because if I go into
settings/time & language/speech, the voices show up there and preview as
themselves. Additionally, if I run Narrator, I can change to each voice
in the list and it's actually the correct voice. Anybody have any ideas?
It's not vitally important that I get this working or anything, I mostly
use Code Factory's SAPI 5 Eloquence, but it's pretty strange, and I like
to fix those kinds of things if I can.








--
Quentin Christensen
Training and Support Manager


Quentin Christensen
 

It sounds like the OneCore voices / languages might have been corrupted - I've seen that happen (with various results) elsewhere - try removing and re-adding a language / language pack and see if that helps.

Kind regards

Quentin.

On Tue, Jul 13, 2021 at 2:10 PM John Isige <gwynn@...> wrote:

Rebooted the PC, this has actually been going on for a while. I assumed it was just Windows being messed up. I also restarted with addons disabled, and no difference whatsoever. It's pretty weird.


On 7/12/2021 9:53 PM, Quentin Christensen wrote:
Firstly,

Have you rebooted the PC since updating?  It's worth doing that as we do often see odd things like this after updating and before restarting.  Next, if you press NVDA+Q then down arrow to "Restart with add-ons disabled" does that make a difference?

Kind regards

Quentin.

On Tue, Jul 13, 2021 at 4:13 AM John Isige <gwynn@...> wrote:
Hi all.


So I've got all of the extra English OneCore voices installed, so
Richard, Linda, James, that kind of thing. For some reason, if I set
NVDA to use the OneCore voices and change voices, all of them are David,
except for Zira and Mark. I'm pretty sure this worked at one point, but
it's obviously broken now. I've tried restarting with addons disabled,
and I still have the same issue.


I know the voices are installed properly because if I go into
settings/time & language/speech, the voices show up there and preview as
themselves. Additionally, if I run Narrator, I can change to each voice
in the list and it's actually the correct voice. Anybody have any ideas?
It's not vitally important that I get this working or anything, I mostly
use Code Factory's SAPI 5 Eloquence, but it's pretty strange, and I like
to fix those kinds of things if I can.








--
Quentin Christensen
Training and Support Manager



--
Quentin Christensen
Training and Support Manager


John Isige
 

Huh. Definitely some kind of Windows issue, yeah. I removed all of the extra voices, except for Ireland which doesn't have a removal button, which is a problem I suspect. Weirdly, all the voices still show up in the voice list, even though I've removed them. So there's definitely something weird going on. Unless anybody has any ideas, I'll probably just leave it alone. I suspect to really remove everything at this point and start fresh we're talking registry stuff, and I am not qualified to deal with that at all.


On 7/13/2021 12:30 AM, Quentin Christensen wrote:
It sounds like the OneCore voices / languages might have been corrupted - I've seen that happen (with various results) elsewhere - try removing and re-adding a language / language pack and see if that helps.

Kind regards

Quentin.

On Tue, Jul 13, 2021 at 2:10 PM John Isige <gwynn@...> wrote:

Rebooted the PC, this has actually been going on for a while. I assumed it was just Windows being messed up. I also restarted with addons disabled, and no difference whatsoever. It's pretty weird.


On 7/12/2021 9:53 PM, Quentin Christensen wrote:
Firstly,

Have you rebooted the PC since updating?  It's worth doing that as we do often see odd things like this after updating and before restarting.  Next, if you press NVDA+Q then down arrow to "Restart with add-ons disabled" does that make a difference?

Kind regards

Quentin.

On Tue, Jul 13, 2021 at 4:13 AM John Isige <gwynn@...> wrote:
Hi all.


So I've got all of the extra English OneCore voices installed, so
Richard, Linda, James, that kind of thing. For some reason, if I set
NVDA to use the OneCore voices and change voices, all of them are David,
except for Zira and Mark. I'm pretty sure this worked at one point, but
it's obviously broken now. I've tried restarting with addons disabled,
and I still have the same issue.


I know the voices are installed properly because if I go into
settings/time & language/speech, the voices show up there and preview as
themselves. Additionally, if I run Narrator, I can change to each voice
in the list and it's actually the correct voice. Anybody have any ideas?
It's not vitally important that I get this working or anything, I mostly
use Code Factory's SAPI 5 Eloquence, but it's pretty strange, and I like
to fix those kinds of things if I can.








--
Quentin Christensen
Training and Support Manager



--
Quentin Christensen
Training and Support Manager


mattias
 

How can people use OneCore voices at all_

They are slow etc etc

And we should not talk about quality..

 

Skickades från E-post för Windows 10

 

Från: John Isige
Skickat: den 13 juli 2021 19:08
Till: nvda@nvda.groups.io
Ämne: Re: [nvda] In NVDA, most Microsoft OneCore voices are the same voice for me.

 

Huh. Definitely some kind of Windows issue, yeah. I removed all of the extra voices, except for Ireland which doesn't have a removal button, which is a problem I suspect. Weirdly, all the voices still show up in the voice list, even though I've removed them. So there's definitely something weird going on. Unless anybody has any ideas, I'll probably just leave it alone. I suspect to really remove everything at this point and start fresh we're talking registry stuff, and I am not qualified to deal with that at all.

 

On 7/13/2021 12:30 AM, Quentin Christensen wrote:

It sounds like the OneCore voices / languages might have been corrupted - I've seen that happen (with various results) elsewhere - try removing and re-adding a language / language pack and see if that helps.

 

Kind regards

 

Quentin.

 

On Tue, Jul 13, 2021 at 2:10 PM John Isige <gwynn@...> wrote:

Rebooted the PC, this has actually been going on for a while. I assumed it was just Windows being messed up. I also restarted with addons disabled, and no difference whatsoever. It's pretty weird.

 

On 7/12/2021 9:53 PM, Quentin Christensen wrote:

Firstly,

 

Have you rebooted the PC since updating?  It's worth doing that as we do often see odd things like this after updating and before restarting.  Next, if you press NVDA+Q then down arrow to "Restart with add-ons disabled" does that make a difference?

 

Kind regards

 

Quentin.

 

On Tue, Jul 13, 2021 at 4:13 AM John Isige <gwynn@...> wrote:

Hi all.


So I've got all of the extra English OneCore voices installed, so
Richard, Linda, James, that kind of thing. For some reason, if I set
NVDA to use the OneCore voices and change voices, all of them are David,
except for Zira and Mark. I'm pretty sure this worked at one point, but
it's obviously broken now. I've tried restarting with addons disabled,
and I still have the same issue.


I know the voices are installed properly because if I go into
settings/time & language/speech, the voices show up there and preview as
themselves. Additionally, if I run Narrator, I can change to each voice
in the list and it's actually the correct voice. Anybody have any ideas?
It's not vitally important that I get this working or anything, I mostly
use Code Factory's SAPI 5 Eloquence, but it's pretty strange, and I like
to fix those kinds of things if I can.






 

--

Quentin Christensen
Training and Support Manager

 


 

--

Quentin Christensen
Training and Support Manager

 

 


Chris
 

As already suggested , did you restart after removal?

 

 

From: John Isige
Sent: 13 July 2021 18:08
To: nvda@nvda.groups.io
Subject: Re: [nvda] In NVDA, most Microsoft OneCore voices are the same voice for me.

 

Huh. Definitely some kind of Windows issue, yeah. I removed all of the extra voices, except for Ireland which doesn't have a removal button, which is a problem I suspect. Weirdly, all the voices still show up in the voice list, even though I've removed them. So there's definitely something weird going on. Unless anybody has any ideas, I'll probably just leave it alone. I suspect to really remove everything at this point and start fresh we're talking registry stuff, and I am not qualified to deal with that at all.

 

On 7/13/2021 12:30 AM, Quentin Christensen wrote:

It sounds like the OneCore voices / languages might have been corrupted - I've seen that happen (with various results) elsewhere - try removing and re-adding a language / language pack and see if that helps.

 

Kind regards

 

Quentin.

 

On Tue, Jul 13, 2021 at 2:10 PM John Isige <gwynn@...> wrote:

Rebooted the PC, this has actually been going on for a while. I assumed it was just Windows being messed up. I also restarted with addons disabled, and no difference whatsoever. It's pretty weird.

 

On 7/12/2021 9:53 PM, Quentin Christensen wrote:

Firstly,

 

Have you rebooted the PC since updating?  It's worth doing that as we do often see odd things like this after updating and before restarting.  Next, if you press NVDA+Q then down arrow to "Restart with add-ons disabled" does that make a difference?

 

Kind regards

 

Quentin.

 

On Tue, Jul 13, 2021 at 4:13 AM John Isige <gwynn@...> wrote:

Hi all.


So I've got all of the extra English OneCore voices installed, so
Richard, Linda, James, that kind of thing. For some reason, if I set
NVDA to use the OneCore voices and change voices, all of them are David,
except for Zira and Mark. I'm pretty sure this worked at one point, but
it's obviously broken now. I've tried restarting with addons disabled,
and I still have the same issue.


I know the voices are installed properly because if I go into
settings/time & language/speech, the voices show up there and preview as
themselves. Additionally, if I run Narrator, I can change to each voice
in the list and it's actually the correct voice. Anybody have any ideas?
It's not vitally important that I get this working or anything, I mostly
use Code Factory's SAPI 5 Eloquence, but it's pretty strange, and I like
to fix those kinds of things if I can.






 

--

Quentin Christensen
Training and Support Manager

 


 

--

Quentin Christensen
Training and Support Manager

 

 


John Isige
 

Yes. I think this is like the third time I've mentioned restarting at this point. Sadly, the problem is impervious to the magical magicalness of the magic of rebooting.


On 7/13/2021 1:30 PM, Chris via groups.io wrote:

As already suggested , did you restart after removal?

 

 

From: John Isige
Sent: 13 July 2021 18:08
To: nvda@nvda.groups.io
Subject: Re: [nvda] In NVDA, most Microsoft OneCore voices are the same voice for me.

 

Huh. Definitely some kind of Windows issue, yeah. I removed all of the extra voices, except for Ireland which doesn't have a removal button, which is a problem I suspect. Weirdly, all the voices still show up in the voice list, even though I've removed them. So there's definitely something weird going on. Unless anybody has any ideas, I'll probably just leave it alone. I suspect to really remove everything at this point and start fresh we're talking registry stuff, and I am not qualified to deal with that at all.

 

On 7/13/2021 12:30 AM, Quentin Christensen wrote:

It sounds like the OneCore voices / languages might have been corrupted - I've seen that happen (with various results) elsewhere - try removing and re-adding a language / language pack and see if that helps.

 

Kind regards

 

Quentin.

 

On Tue, Jul 13, 2021 at 2:10 PM John Isige <gwynn@...> wrote:

Rebooted the PC, this has actually been going on for a while. I assumed it was just Windows being messed up. I also restarted with addons disabled, and no difference whatsoever. It's pretty weird.

 

On 7/12/2021 9:53 PM, Quentin Christensen wrote:

Firstly,

 

Have you rebooted the PC since updating?  It's worth doing that as we do often see odd things like this after updating and before restarting.  Next, if you press NVDA+Q then down arrow to "Restart with add-ons disabled" does that make a difference?

 

Kind regards

 

Quentin.

 

On Tue, Jul 13, 2021 at 4:13 AM John Isige <gwynn@...> wrote:

Hi all.


So I've got all of the extra English OneCore voices installed, so
Richard, Linda, James, that kind of thing. For some reason, if I set
NVDA to use the OneCore voices and change voices, all of them are David,
except for Zira and Mark. I'm pretty sure this worked at one point, but
it's obviously broken now. I've tried restarting with addons disabled,
and I still have the same issue.


I know the voices are installed properly because if I go into
settings/time & language/speech, the voices show up there and preview as
themselves. Additionally, if I run Narrator, I can change to each voice
in the list and it's actually the correct voice. Anybody have any ideas?
It's not vitally important that I get this working or anything, I mostly
use Code Factory's SAPI 5 Eloquence, but it's pretty strange, and I like
to fix those kinds of things if I can.






 

--

Quentin Christensen
Training and Support Manager

 


 

--

Quentin Christensen
Training and Support Manager

 

 


Gene
 

You can speed them up but others will have to discuss that.
 
Gene

-----Original Message-----
From: mattias
Sent: Tuesday, July 13, 2021 12:58 PM
Subject: Re: [nvda] In NVDA, most Microsoft OneCore voices are the same voice for me.
 

How can people use OneCore voices at all_

They are slow etc etc

And we should not talk about quality..

 

Skickades från E-post för Windows 10

 

Från: John Isige
Skickat: den 13 juli 2021 19:08
Till: nvda@nvda.groups.io
Ämne: Re: [nvda] In NVDA, most Microsoft OneCore voices are the same voice for me.

 

Huh. Definitely some kind of Windows issue, yeah. I removed all of the extra voices, except for Ireland which doesn't have a removal button, which is a problem I suspect. Weirdly, all the voices still show up in the voice list, even though I've removed them. So there's definitely something weird going on. Unless anybody has any ideas, I'll probably just leave it alone. I suspect to really remove everything at this point and start fresh we're talking registry stuff, and I am not qualified to deal with that at all.

 

On 7/13/2021 12:30 AM, Quentin Christensen wrote:

It sounds like the OneCore voices / languages might have been corrupted - I've seen that happen (with various results) elsewhere - try removing and re-adding a language / language pack and see if that helps.

 

Kind regards

 

Quentin.

 

On Tue, Jul 13, 2021 at 2:10 PM John Isige <gwynn@...> wrote:

Rebooted the PC, this has actually been going on for a while. I assumed it was just Windows being messed up. I also restarted with addons disabled, and no difference whatsoever. It's pretty weird.

 

On 7/12/2021 9:53 PM, Quentin Christensen wrote:

Firstly,

 

Have you rebooted the PC since updating?  It's worth doing that as we do often see odd things like this after updating and before restarting.  Next, if you press NVDA+Q then down arrow to "Restart with add-ons disabled" does that make a difference?

 

Kind regards

 

Quentin.

 

On Tue, Jul 13, 2021 at 4:13 AM John Isige <gwynn@...> wrote:

Hi all.


So I've got all of the extra English OneCore voices installed, so
Richard, Linda, James, that kind of thing. For some reason, if I set
NVDA to use the OneCore voices and change voices, all of them are David,
except for Zira and Mark. I'm pretty sure this worked at one point, but
it's obviously broken now. I've tried restarting with addons disabled,
and I still have the same issue.


I know the voices are installed properly because if I go into
settings/time & language/speech, the voices show up there and preview as
themselves. Additionally, if I run Narrator, I can change to each voice
in the list and it's actually the correct voice. Anybody have any ideas?
It's not vitally important that I get this working or anything, I mostly
use Code Factory's SAPI 5 Eloquence, but it's pretty strange, and I like
to fix those kinds of things if I can.






 

--

Quentin Christensen
Training and Support Manager

 


 

--

Quentin Christensen
Training and Support Manager

 

 


 

On Tue, Jul 13, 2021 at 08:45 PM, Gene wrote:
You can speed them up but others will have to discuss that.
-
And it has been discussed, in depth, multiple times.

The easiest way is to increase the rate to 100% under Windows, then you can "further increase" it using NVDA's settings.  I know that someone has written about getting into OneCore Voice internals and how to tweak those  to get an even more radical increase in speed, but I can't seem to find that now.

Sarah Alawami mentioned the above technique here:  https://nvda.groups.io/g/nvda/message/59349 
--

Brian - Windows 10, 64-Bit, Version 21H1, Build 19043  

I do not understand why some seek to separate a person from their actions.  The self is composed of an individual’s thoughts, actions, and expression, which are contained in and actuated by the body.  What you do and say is the clearest indicator of who you are.

      ~ Brian Vogel

 


John Isige
 

Modern NVDA has a rate boost for them. If you're one of the crazy people who cranks things up super fast I guess it might not be fast enough for you, but it's pretty gabbly at 100 with rate boost on. I generally have Eloquence at 75, this is the Code Factory SAPI 5 version, and OneCore at 40 or 45 with rate boost on. That works fine for me.


On 7/13/2021 9:02 PM, Brian Vogel wrote:
On Tue, Jul 13, 2021 at 08:45 PM, Gene wrote:
You can speed them up but others will have to discuss that.
-
And it has been discussed, in depth, multiple times.

The easiest way is to increase the rate to 100% under Windows, then you can "further increase" it using NVDA's settings.  I know that someone has written about getting into OneCore Voice internals and how to tweak those  to get an even more radical increase in speed, but I can't seem to find that now.

Sarah Alawami mentioned the above technique here:  https://nvda.groups.io/g/nvda/message/59349 
--

Brian - Windows 10, 64-Bit, Version 21H1, Build 19043  

I do not understand why some seek to separate a person from their actions.  The self is composed of an individual’s thoughts, actions, and expression, which are contained in and actuated by the body.  What you do and say is the clearest indicator of who you are.

      ~ Brian Vogel

 


Hope Williamson
 

Mine's around 40% with rate boost, when I use one core. I can get eloquence up to 80%

On 7/13/2021 9:21 PM, John Isige wrote:

Modern NVDA has a rate boost for them. If you're one of the crazy people who cranks things up super fast I guess it might not be fast enough for you, but it's pretty gabbly at 100 with rate boost on. I generally have Eloquence at 75, this is the Code Factory SAPI 5 version, and OneCore at 40 or 45 with rate boost on. That works fine for me.


On 7/13/2021 9:02 PM, Brian Vogel wrote:
On Tue, Jul 13, 2021 at 08:45 PM, Gene wrote:
You can speed them up but others will have to discuss that.
-
And it has been discussed, in depth, multiple times.

The easiest way is to increase the rate to 100% under Windows, then you can "further increase" it using NVDA's settings.  I know that someone has written about getting into OneCore Voice internals and how to tweak those  to get an even more radical increase in speed, but I can't seem to find that now.

Sarah Alawami mentioned the above technique here:  https://nvda.groups.io/g/nvda/message/59349 
--

Brian - Windows 10, 64-Bit, Version 21H1, Build 19043  

I do not understand why some seek to separate a person from their actions.  The self is composed of an individual’s thoughts, actions, and expression, which are contained in and actuated by the body.  What you do and say is the clearest indicator of who you are.

      ~ Brian Vogel

 


Sarah k Alawami
 

Actually they are not. You can speed them up via the settings and speech. I have mine at 100 percent, plus the 100 percent for nvda and it is fast fast fast.

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of mattias
Sent: Tuesday, July 13, 2021 10:58 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] In NVDA, most Microsoft OneCore voices are the same voice for me.

 

How can people use OneCore voices at all_

They are slow etc etc

And we should not talk about quality..

 

Skickades från E-post för Windows 10

 

Från: John Isige
Skickat: den 13 juli 2021 19:08
Till: nvda@nvda.groups.io
Ämne: Re: [nvda] In NVDA, most Microsoft OneCore voices are the same voice for me.

 

Huh. Definitely some kind of Windows issue, yeah. I removed all of the extra voices, except for Ireland which doesn't have a removal button, which is a problem I suspect. Weirdly, all the voices still show up in the voice list, even though I've removed them. So there's definitely something weird going on. Unless anybody has any ideas, I'll probably just leave it alone. I suspect to really remove everything at this point and start fresh we're talking registry stuff, and I am not qualified to deal with that at all.

 

On 7/13/2021 12:30 AM, Quentin Christensen wrote:

It sounds like the OneCore voices / languages might have been corrupted - I've seen that happen (with various results) elsewhere - try removing and re-adding a language / language pack and see if that helps.

 

Kind regards

 

Quentin.

 

On Tue, Jul 13, 2021 at 2:10 PM John Isige <gwynn@...> wrote:

Rebooted the PC, this has actually been going on for a while. I assumed it was just Windows being messed up. I also restarted with addons disabled, and no difference whatsoever. It's pretty weird.

 

On 7/12/2021 9:53 PM, Quentin Christensen wrote:

Firstly,

 

Have you rebooted the PC since updating?  It's worth doing that as we do often see odd things like this after updating and before restarting.  Next, if you press NVDA+Q then down arrow to "Restart with add-ons disabled" does that make a difference?

 

Kind regards

 

Quentin.

 

On Tue, Jul 13, 2021 at 4:13 AM John Isige <gwynn@...> wrote:

Hi all.


So I've got all of the extra English OneCore voices installed, so
Richard, Linda, James, that kind of thing. For some reason, if I set
NVDA to use the OneCore voices and change voices, all of them are David,
except for Zira and Mark. I'm pretty sure this worked at one point, but
it's obviously broken now. I've tried restarting with addons disabled,
and I still have the same issue.


I know the voices are installed properly because if I go into
settings/time & language/speech, the voices show up there and preview as
themselves. Additionally, if I run Narrator, I can change to each voice
in the list and it's actually the correct voice. Anybody have any ideas?
It's not vitally important that I get this working or anything, I mostly
use Code Factory's SAPI 5 Eloquence, but it's pretty strange, and I like
to fix those kinds of things if I can.





 

--

Quentin Christensen
Training and Support Manager

 


 

--

Quentin Christensen
Training and Support Manager

 

 


 

On Wed, Jul 14, 2021 at 01:22 PM, Sarah k Alawami wrote:
And we should not talk about quality..
-
Actually, we really should not.  It's become abundantly apparent over time that, "One person's trash is another's treasure," when it comes to opinions regarding synthesizers and voices.

The mechanics of using any one of them are worth discussing.  Answering questions about one's personal and specific perceptions, when asked, is worth doing.  But offering of broad assessments is really not particularly useful at all.
--

Brian - Windows 10, 64-Bit, Version 21H1, Build 19043  

I do not understand why some seek to separate a person from their actions.  The self is composed of an individual’s thoughts, actions, and expression, which are contained in and actuated by the body.  What you do and say is the clearest indicator of who you are.

      ~ Brian Vogel