Topics

Issue with NVDA and links

sinkaranuja@...
 

Hi all, need your help on the following issue I am facing with NVDA:
I am experiencing situations where a user will navigate to a link on a page with NVDA, but when activating the link, it actually activates the link that the user had previously tabbed from. When used with just the keyboard (no NVDA), tab to the link and press enter, it works as expected but works strangely with keyboard + NVDA.

Jonathan COHN
 

I am not quite sure what you are describing here. Are you saying that if a user is on any link on any web page, and they hit tab and then enter, the Browser is opening the previous link? Does this happen with just one page. Please let us also know what the browser this is happening in, and if possible the version number.

I’m wondering, is this a new NVDA user that had been using JAWS before encountering this?

Best Wishes,

Jonathan Cohn

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io>
Date: Friday, May 22, 2020 at 1:19 PM
To: nvda@nvda.groups.io <nvda@nvda.groups.io>
Subject: [nvda] Issue with NVDA and links

External email alert: Be wary of links & attachments.

Hi all, need your help on the following issue I am facing with NVDA:

I am experiencing situations where a user will navigate to a link on a page with NVDA, but when activating the link, it actually activates the link that the user had previously tabbed from. When used with just the keyboard (no NVDA), tab to the link and press enter, it works as expected but works strangely with keyboard + NVDA.

Gene
 

Also, the problem may be eliminated by moving by link using the letter k instead of by tabbing.  Sometimes, for technical reasons I don't know a lot about, moving by tab doesn't cause browse mode and the underlying web page to be properly lined up.  In cases where I don't move correctly by link when I tab on a page, I do when I use k.
 
Gene

----- Original Message -----
Sent: Friday, May 22, 2020 1:46 PM
Subject: Re: [nvda] Issue with NVDA and links

I am not quite sure what you are describing here. Are you saying that if a user is on any link on any web page, and they hit tab and then enter, the Browser is opening the previous link? Does this happen with just one page. Please let us also know what the browser this is happening in, and if possible the version number.

I’m wondering, is this a new NVDA user that had been using JAWS before encountering this?

Best Wishes,

Jonathan Cohn

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io>
Date: Friday, May 22, 2020 at 1:19 PM
To: nvda@nvda.groups.io <nvda@nvda.groups.io>
Subject: [nvda] Issue with NVDA and links

External email alert: Be wary of links & attachments.

Hi all, need your help on the following issue I am facing with NVDA:

I am experiencing situations where a user will navigate to a link on a page with NVDA, but when activating the link, it actually activates the link that the user had previously tabbed from. When used with just the keyboard (no NVDA), tab to the link and press enter, it works as expected but works strangely with keyboard + NVDA.