Topics

Joseph Lee's add-ons: important note on Add-on Updater, Python 2 versions to be removed on March 3rd

 

Hi all,

 

Two important announcements:

 

Add-on Updater: as you should know by now, Add-on Updater is compatible with NVDA 2019.2.1 or later, and I did say that a future release will drop support for 2019.2.1. The time has come to do that: Add-on Updater 20.03, scheduled for March 10, 2020, will absolutely require NVDA 2019.3 or later. I have intentionally delayed enforcing this requirement so you can keep add-ons updated before the cut-off date.

 

Python 2 versions of various add-ons: when you visit community add-ons website (addons.nvda-project.org), some add-ons developed by me include a link to download older releases compatible with old NVDA releases. These links will retire on March 3, 2020. Going forward, all add-ons by me will require NVDA 2019.3 or later.

 

Cheers,

Joseph