Topics

Ms Word behaving strangely around pages

Vincent Le Goff
 

Hi everyone,


For a few days I've realized that Word behaves very strangely.  I can't just press the down arrow or up arrow to go to the next page or previous page, when I'm at the end/bottom of a page.  That sounded like a minor discomfort (I had to activate the application mode and use the arrow keys) but it has become a pain as I can't select text spanning on several pages.  Who's the guilty one?  I don't remember turning on or off any setting in NVDA, but maybe I did.  Though it looks like an annoying setting in Word itself, a setting that was added more recently since I don't think I had this issue.


Does anyone else experience the same behavior and, if so, have you find a workaround?


Microsoft Word: office 365.

NVDA: 2019.2.

Settings: use UI automation in Word: no.


Thanks for your help,


Vincent

Giles Turnbull
 

Hi Vincent,

that sounds like a not-uncommon issue and it does have a simple workaround. Go to the View ribbon  and tab to Draft View. In that view the down arrow will take you to the next page. The shortcut keystroke is ALT+w followed by e.

I've noticed many Google results for how to get MS Word to open documents in draft view by default, but I've never seen anybody get it to successfuly do that! It certainly doesn't work for me! The first action I do when opening a Word doc is to go to the View ribbon and switch to draft view.

Hope that helps,

Giles

Vincent Le Goff
 

Thanks.  Yeah the way Word opens documents in its read-only mode by default isn't that great for accessibility (or perhaps it's ont, because I use a Braille display).  In any case, actually restarting Word fixed the issue this time.  I do hope it doesn't happen too often, as writing professional reports will get tedious, but in the meantime it seems to be a Word issue more than a NVDA one.


Thanks again,


Vincent

On 11/5/2019 3:17 PM, Giles Turnbull wrote:
Hi Vincent,

that sounds like a not-uncommon issue and it does have a simple workaround. Go to the View ribbon  and tab to Draft View. In that view the down arrow will take you to the next page. The shortcut keystroke is ALT+w followed by e.

I've noticed many Google results for how to get MS Word to open documents in draft view by default, but I've never seen anybody get it to successfuly do that! It certainly doesn't work for me! The first action I do when opening a Word doc is to go to the View ribbon and switch to draft view.

Hope that helps,

Giles

Giles Turnbull
 

Hi Vincent,

yes, it is definitely an MS Word behaviour  rather than an NVDA one.

I find that when a document opens in read-only mode, going into the file menu (ALT+f) and pressing the down arrow to get to the info item and then navigating to and activating the button that allows editing, that action does persist for future re-openings of the same document, assuming you have saved it from the email or download link where it was first opened from.

Documents you have created yourself should not open in read-only mode.

Giles

Quentin Christensen
 

On a document opened in protected mode (that you've downloaded from the web or email) you can also press F6 to get to the "enable editing" toolbar, tab to the enable editing button and press enter.  Of course, rather than automatically doing that to any document, do first ensure that you KNOW what the document is and where it came from and that you trust it and want to open it.  As annoying as Word's protected mode is, the reason it does it is to protect you from malware from infected files.

On Thu, Nov 7, 2019 at 2:07 AM Giles Turnbull <giles.turnbull@...> wrote:

Hi Vincent,

yes, it is definitely an MS Word behaviour  rather than an NVDA one.

I find that when a document opens in read-only mode, going into the file menu (ALT+f) and pressing the down arrow to get to the info item and then navigating to and activating the button that allows editing, that action does persist for future re-openings of the same document, assuming you have saved it from the email or download link where it was first opened from.

Documents you have created yourself should not open in read-only mode.

Giles



--
Quentin Christensen
Training and Support Manager