Topics

Need help about the sleep mode feature

 

Hi all
Using Windows 10 pro 64 bit, v1809 with NVDA 2019.1.1
I'm teaching basic skill of using keyboard with Sao Mai Typing tutor (SMTT), a self-voicing typing program from the company I work. When I press NVDA+Shift+S
in SMTT to put NVDA in the sleep mode, it works, but when I close and reopen SMTT, NVDA become active like I didn't put it into sleep mode before. I could
write a short add-on to put the program into sleep mode, but I think this is a bug, or I misunderstand about the sleep mode feature so please help me to
solve the problem, or understand this feature clearly. If this is a bug, I'll create an issue on github.
Any help would be appreciated.
Cuong--

 

Dan,
When I press NVDA+Shift+S  in SMTT to put NVDA in the sleep mode, it works, but when I close and reopen SMTT, NVDA become active like I didn't put it into sleep mode before.
I think this is a bug, or I misunderstand about the sleep mode feature so please help me to  solve the problem, or understand this feature clearly.
In short, what you're getting is the normal behavior of NVDA's Sleep Mode :)

When you put NVDA on a sleep mode, it just keep sleeping until you close that program window. If you ever reopen it NVDA won't be sleeping anymore.

Hth
Cheers,
Marcio AKA Starboy

Sent from a galaxy far, far away.

--
Are you a Thunderbird user? Then join the Thunderbird mailing list to help and be helped with all Thunderbird things - questions, features, add-ons and much more!

Luke Davis
 

On Tue, 4 Jun 2019, Dang Manh Cuong wrote:

a self-voicing typing program from the company I work. When I press NVDA+Shift+S
in SMTT to put NVDA in the sleep mode, it works, but when I close and reopen SMTT, NVDA become active like I didn't put it into sleep mode before.
That is the expected behavior. Have you tried creating a configuration profile to handle this?

Create a profile that triggers when SMTT opens.
Then, open SMTT, and put NVDA to Sleep.
Last, press NVDA+ctrl+c, which should save the configuration for you.

Luke

 

Thanks Luke and all. I'll give a try.

Cuong

On 4/6/2019 3:53 PM, Luke Davis wrote:
On Tue, 4 Jun 2019, Dang Manh Cuong wrote:

a self-voicing typing program from the company I work. When I press NVDA+Shift+S
in SMTT to put NVDA in the sleep mode, it works, but when I close and reopen SMTT, NVDA become active like I didn't put it into sleep mode before.
That is the expected behavior. Have you tried creating a configuration profile to handle this?

Create a profile that triggers when SMTT opens.
Then, open SMTT, and put NVDA to Sleep.
Last, press NVDA+ctrl+c, which should save the configuration for you.

Luke


--
Đặng Mạnh Cường
Chuyên viên công nghệ trợ giúp
Trung tâm hướng nghiệp và công nghệ trợ giúp cho người mù Sao Mai
52/22 Huỳnh Thiện Lộc, P. Hòa Thạnh, Q. Tân Phú, TP. HCM
Điện thoại: 028-7302-4488
E-mail: tech@...
Website: http://www.trungtamsaomai.org; http://www.saomaicenter.org
Điện thoại di động / Zalo: 0902-572-300
E-mail: @cuongdang; cuong@...
Skype: dangmanhcuong
facebook: http://facebook.com/dangmanhcuong
Twitter: ManhCuongTech

Gene
 

As I recall, there is a way to make NVDA sleep whenever it is in a specific program but I don't recall how.  Someone may explain it.  If not, I can try to find information.
 
Gene

----- Original Message -----
Sent: Tuesday, June 04, 2019 3:20 AM
Subject: Re: [nvda] Need help about the sleep mode feature

Dan,
When I press NVDA+Shift+S  in SMTT to put NVDA in the sleep mode, it works, but when I close and reopen SMTT, NVDA become active like I didn't put it into sleep mode before.
I think this is a bug, or I misunderstand about the sleep mode feature so please help me to  solve the problem, or understand this feature clearly.
In short, what you're getting is the normal behavior of NVDA's Sleep Mode :)

When you put NVDA on a sleep mode, it just keep sleeping until you close that program window. If you ever reopen it NVDA won't be sleeping anymore.

Hth
Cheers,
Marcio AKA Starboy

Sent from a galaxy far, far away.

--
Are you a Thunderbird user? Then join the Thunderbird mailing list to help and be helped with all Thunderbird things - questions, features, add-ons and much more!

Richard Wells
 

Luke and all: could you explain more about creating a sleep profile or
point me to where in documentation to find this? Thank you all for all
you teach me about NVDA.

On 6/4/2019 3:54 AM, Dang Manh Cuong wrote:
Thanks Luke and all. I'll give a try.

Cuong

On 4/6/2019 3:53 PM, Luke Davis wrote:
On Tue, 4 Jun 2019, Dang Manh Cuong wrote:

a self-voicing typing program from the company I work. When I press
NVDA+Shift+S
in SMTT to put NVDA in the sleep mode, it works, but when I close
and reopen SMTT, NVDA become active like I didn't put it into sleep
mode before.
That is the expected behavior. Have you tried creating a
configuration profile to handle this?

Create a profile that triggers when SMTT opens.
Then, open SMTT, and put NVDA to Sleep.
Last, press NVDA+ctrl+c, which should save the configuration for you.

Luke



 

Hi
Simpley, just create a configuration profile, and activate it with the program in which you want to put in sleep mode, then press NVDA+Shift+S (Laptop NVDA+Shift+Z) at the program window to put it in sleep mode, and press NVDA+Shift+C to save the configuration. However, I just accomplish to save the configuration after activating sleep mode if I use keyboard as laptop layout. Don't know why.
By the way, I'm think of create an issue on github that suggest to make the sleep mode active forever so we don't need to do more stuff for this job. What do you think?
Cuong

On 4/6/2019 10:18 PM, Richard Wells wrote:
Luke and all: could you explain more about creating a sleep profile or
point me to where in documentation to find this? Thank you all for all
you teach me about NVDA.

On 6/4/2019 3:54 AM, Dang Manh Cuong wrote:
Thanks Luke and all. I'll give a try.

Cuong

On 4/6/2019 3:53 PM, Luke Davis wrote:
On Tue, 4 Jun 2019, Dang Manh Cuong wrote:

a self-voicing typing program from the company I work. When I press
NVDA+Shift+S
in SMTT to put NVDA in the sleep mode, it works, but when I close
and reopen SMTT, NVDA become active like I didn't put it into sleep
mode before.
That is the expected behavior. Have you tried creating a
configuration profile to handle this?

Create a profile that triggers when SMTT opens.
Then, open SMTT, and put NVDA to Sleep.
Last, press NVDA+ctrl+c, which should save the configuration for you.

Luke



--
Đặng Mạnh Cường
Chuyên viên công nghệ trợ giúp
Trung tâm hướng nghiệp và công nghệ trợ giúp cho người mù Sao Mai
52/22 Huỳnh Thiện Lộc, P. Hòa Thạnh, Q. Tân Phú, TP. HCM
Điện thoại: 028-7302-4488
E-mail: tech@...
Website: http://www.trungtamsaomai.org; http://www.saomaicenter.org
Điện thoại di động / Zalo: 0902-572-300
E-mail: @cuongdang; cuong@...
Skype: dangmanhcuong
facebook: http://facebook.com/dangmanhcuong
Twitter: ManhCuongTech

Luke Davis
 

On Wed, 5 Jun 2019, Dang Manh Cuong wrote:

By the way, I'm think of create an issue on github that suggest to make the sleep mode active forever so we don't need to do more stuff for this job. What do you think?
I think almost immediately, someone with "save configuration on exit" would accidentally turn on sleep mode in the main profile without knowing what it is, restart NVDA because it stopped talking, and then email this list to say NVDA doesn't talk any more! After which a lot of unnecessary debugging efforts would be undertaken by this community.

So personally i think saving the sleep mode state should require a bit of work (but it's only a little bit of work), to prevent people causing themselves a lot of trouble.

Luke

 

Its easy enough to turn the thing on and off when needed.

For me I use it in elektron apps, some bgt apps, and apps like eurofly.

The thing is that eurofly has one mode where its a major list where you need sleep on but there is a general mode where it will do it to everything to, you really need to be carefull with sleeping something.

The only time I have set something like this ever is if the reader is spewing spurious information at me.

On 5/06/2019 4:20 PM, Luke Davis wrote:
On Wed, 5 Jun 2019, Dang Manh Cuong wrote:

By the way, I'm think of create an issue on github that suggest to make the sleep mode active forever so we don't need to do more stuff for this job. What do you think?
I think almost immediately, someone with "save configuration on exit" would accidentally turn on sleep mode in the main profile without knowing what it is, restart NVDA because it stopped talking, and then email this list to say NVDA doesn't talk any more!  After which a lot of unnecessary debugging efforts would be undertaken by this community.

So personally i think saving the sleep mode state should require a bit of work (but it's only a little bit of work), to prevent people causing themselves a lot of trouble.

Luke



Luke Davis
 

The advice I gave earlier in this thread was incorrect. There is currently no way to save the sleepmode state.

Although this has been a feature request since 2013.
https://github.com/nvaccess/nvda/issues/3721

Luke

On Tue, 4 Jun 2019, Luke Davis wrote:

On Tue, 4 Jun 2019, Dang Manh Cuong wrote:

a self-voicing typing program from the company I work. When I press NVDA+Shift+S
in SMTT to put NVDA in the sleep mode, it works, but when I close and reopen SMTT, NVDA become active like I didn't put it into sleep mode before.
That is the expected behavior. Have you tried creating a configuration profile to handle this?

Create a profile that triggers when SMTT opens.
Then, open SMTT, and put NVDA to Sleep.
Last, press NVDA+ctrl+c, which should save the configuration for you.

Luke