NVDA 2021.1 RC2 available


Quentin Christensen
 

Hi everyone,

NVDA 2021.1 Release Candidate 2 (RC2) is now available for download & testing. We encourage all users to download this RC & provide feedback. Unless any critical bugs are found, this will be identical to the final 2021.1 release. New features & download at https://www.nvaccess.org/post/nvda-2021-1rc2/


--
Quentin Christensen
Training and Support Manager


Ian Blackburn
 

What does it mean when it says that the release candidate breaks support for add-ons
Can I put the release candidate and then add all my add-ons back on again
Or can I not add any add-ons at all



On 5 Jul 2021, at 3:30 pm, Quentin Christensen <quentin@...> wrote:


Hi everyone,

NVDA 2021.1 Release Candidate 2 (RC2) is now available for download & testing. We encourage all users to download this RC & provide feedback. Unless any critical bugs are found, this will be identical to the final 2021.1 release. New features & download at https://www.nvaccess.org/post/nvda-2021-1rc2/


--
Quentin Christensen
Training and Support Manager


Rowen Cary
 

I cannot update from rc1 to rc2, and the update went smoothly after I removed the add-ons available in rc1. Has anyone else encountered this situation?


hurrikennyandopo ...
 

Hi


If you want to use nvda 2021.1 when it comes out you will need to use add ons that are compatible with this version.


The following page should help you work out which ones are compatible with the newer version nvda 2021.1 If it says they are not then your older add ons will not work on this version.

the link to this page is https://addons.nvda-project.org/addons/nvdacompat.en.html


Gene nz


On 5/07/2021 9:05 pm, Ian Blackburn wrote:
What does it mean when it says that the release candidate breaks support for add-ons
Can I put the release candidate and then add all my add-ons back on again
Or can I not add any add-ons at all



On 5 Jul 2021, at 3:30 pm, Quentin Christensen <quentin@...> wrote:


Hi everyone,

NVDA 2021.1 Release Candidate 2 (RC2) is now available for download & testing. We encourage all users to download this RC & provide feedback. Unless any critical bugs are found, this will be identical to the final 2021.1 release. New features & download at https://www.nvaccess.org/post/nvda-2021-1rc2/


--
Quentin Christensen
Training and Support Manager


Quentin Christensen
 

Just to clarify the answer for the original poster - NVDA 2021.1 introduces a few changes such that add-ons which worked when 2020.4 was released won't work with 2021.1.  The authors will need to update and re-release them, and in something like 2/3 of add-ons this has already happened.  See the link Gene shared: https://addons.nvda-project.org/addons/nvdacompat.en.html

We anticipate most add-ons should be updated and work by the time the final version comes out in a week or so, and most of the rest not long after that.  If you do have any add-ons which are listed as not compatible on that list, it's worth sending the add-on developer an email to check they are working on it.

Kind regards

Quentin.

On Mon, Jul 5, 2021 at 7:13 PM hurrikennyandopo ... <hurrikennyandopo@...> wrote:

Hi


If you want to use nvda 2021.1 when it comes out you will need to use add ons that are compatible with this version.


The following page should help you work out which ones are compatible with the newer version nvda 2021.1 If it says they are not then your older add ons will not work on this version.

the link to this page is https://addons.nvda-project.org/addons/nvdacompat.en.html


Gene nz


On 5/07/2021 9:05 pm, Ian Blackburn wrote:
What does it mean when it says that the release candidate breaks support for add-ons
Can I put the release candidate and then add all my add-ons back on again
Or can I not add any add-ons at all



On 5 Jul 2021, at 3:30 pm, Quentin Christensen <quentin@...> wrote:


Hi everyone,

NVDA 2021.1 Release Candidate 2 (RC2) is now available for download & testing. We encourage all users to download this RC & provide feedback. Unless any critical bugs are found, this will be identical to the final 2021.1 release. New features & download at https://www.nvaccess.org/post/nvda-2021-1rc2/


--
Quentin Christensen
Training and Support Manager



--
Quentin Christensen
Training and Support Manager


Rowen Cary
 

Hi, I suspect there is a major error in RC2. ctypes throws many errors. Many add-ons that are compatible in rc1 are completely unavailable in rc2. The above problem also occurred when updating from alpha-23249 to alpha-23278.

In addition, after updating to alpha23278, there will be an error dialog box prompting "Error registering focus winEvent hook".

There are many cdll.LoadLibrary errors in the log, But I don't have time to open an Issue now, hoping to attract the attention of others. Thanks.


Quentin Christensen
 

Thanks Rowan, I've shared this with the team, will advise what we find out.


On Mon, Jul 5, 2021 at 7:50 PM Rowen Cary <manchen_0528@...> wrote:

Hi, I suspect there is a major error in RC2. ctypes throws many errors. Many add-ons that are compatible in rc1 are completely unavailable in rc2. The above problem also occurred when updating from alpha-23249 to alpha-23278.

In addition, after updating to alpha23278, there will be an error dialog box prompting "Error registering focus winEvent hook".

There are many cdll.LoadLibrary errors in the log, But I don't have time to open an Issue now, hoping to attract the attention of others. Thanks.



--
Quentin Christensen
Training and Support Manager


Rui Fontes
 

Here, updated from RC1 to RC2 without any errors...

All add-ons working in RC1 still working in RC2...


Rui Fontes


Às 11:00 de 05/07/2021, Quentin Christensen escreveu:

Thanks Rowan, I've shared this with the team, will advise what we find out.

On Mon, Jul 5, 2021 at 7:50 PM Rowen Cary <manchen_0528@...> wrote:

Hi, I suspect there is a major error in RC2. ctypes throws many errors. Many add-ons that are compatible in rc1 are completely unavailable in rc2. The above problem also occurred when updating from alpha-23249 to alpha-23278.

In addition, after updating to alpha23278, there will be an error dialog box prompting "Error registering focus winEvent hook".

There are many cdll.LoadLibrary errors in the log, But I don't have time to open an Issue now, hoping to attract the attention of others. Thanks.



--
Quentin Christensen
Training and Support Manager


anthony borg
 

Hi Quentin

 

Today I installed the new version of NVDA 21.1rc2 and this time all the add-ons I have remained enable.

Best regards

 

Anthony

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Quentin Christensen
Sent: 05 July 2021 09:28
To: nvda@nvda.groups.io
Subject: [nvda] NVDA 2021.1 RC2 available

 

Hi everyone,

 

NVDA 2021.1 Release Candidate 2 (RC2) is now available for download & testing. We encourage all users to download this RC & provide feedback. Unless any critical bugs are found, this will be identical to the final 2021.1 release. New features & download at https://www.nvaccess.org/post/nvda-2021-1rc2/


 

--

Quentin Christensen
Training and Support Manager

 


Rowen Cary
 

HI, have you installed the IBM-TTS speech synthesizer? This add-on has released a version compatible with NVDA 2021.1, but I’m crashing here https://github.com/davidacm/NVDA-IBMTTS-Driver


Quentin Christensen
 

Rowen,

I was going to say we can't replicate your issue here, and was going to ask if you have rebooted.

We can't support illegal add-ons.  If you want Eloquence, please just buy the legal version: https://codefactoryglobal.com/app-store/voices-for-nvda/

(I believe their add-on has been updated, they may not have updated the site yet thought).

Kind regards

Quentin.

On Mon, Jul 5, 2021 at 9:47 PM Rowen Cary <manchen_0528@...> wrote:

HI, have you installed the IBM-TTS speech synthesizer? This add-on has released a version compatible with NVDA 2021.1, but I’m crashing here https://github.com/davidacm/NVDA-IBMTTS-Driver



--
Quentin Christensen
Training and Support Manager


Andre Fisher
 

Hi.

No. All add-ons working quite smoothly on my end. Make sure you are indeed using the rc2 version, rather than an alpha build.


Jim Noseworthy
 

Hello Folks:

 

I am not able to install the NVDARemote add-in with this latest version.

 

Cheers.

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Quentin Christensen
Sent: Monday, July 05, 2021 9:36 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2021.1 RC2 available

 

Rowen,

 

I was going to say we can't replicate your issue here, and was going to ask if you have rebooted.

 

We can't support illegal add-ons.  If you want Eloquence, please just buy the legal version: https://codefactoryglobal.com/app-store/voices-for-nvda/

 

(I believe their add-on has been updated, they may not have updated the site yet thought).

 

Kind regards

 

Quentin.

 

On Mon, Jul 5, 2021 at 9:47 PM Rowen Cary <manchen_0528@...> wrote:

HI, have you installed the IBM-TTS speech synthesizer? This add-on has released a version compatible with NVDA 2021.1, but I’m crashing here https://github.com/davidacm/NVDA-IBMTTS-Driver


 

--

Quentin Christensen
Training and Support Manager

 


Rui Fontes
 

Or buy the SAPI5 version...

No problems with NVDA changes...


Rui Fontes

Tiflotecnia, Lda.


Às 13:35 de 05/07/2021, Quentin Christensen escreveu:

Rowen,

I was going to say we can't replicate your issue here, and was going to ask if you have rebooted.

We can't support illegal add-ons.  If you want Eloquence, please just buy the legal version: https://codefactoryglobal.com/app-store/voices-for-nvda/

(I believe their add-on has been updated, they may not have updated the site yet thought).

Kind regards

Quentin.

On Mon, Jul 5, 2021 at 9:47 PM Rowen Cary <manchen_0528@...> wrote:

HI, have you installed the IBM-TTS speech synthesizer? This add-on has released a version compatible with NVDA 2021.1, but I’m crashing here https://github.com/davidacm/NVDA-IBMTTS-Driver



--
Quentin Christensen
Training and Support Manager


 

On Mon, Jul 5, 2021 at 05:05 AM, Ian Blackburn wrote:
What does it mean when it says that the release candidate breaks support for add-ons
-
Exactly what it says, and has been said here repeatedly for months:  NVDA 2021.1 will only be compatible with add-ons that have been updated to keep compatibility with this release.

A very great many add-ons are already compatible with 2021.1, and I put out an Admin Notice, and have bumped it several times, with a direct link to the page for checking compatibility:  https://addons.nvda-project.org/addons/nvdacompat.en.html

Several others have mentioned it and/or shared it in this topic.

If the add-on or add-ons you use are shown as not being compatible, the appropriate point of contact is the developer or developers for that add-on.
--

Brian - Windows 10, 64-Bit, Version 21H1, Build 19043  

I do not understand why some seek to separate a person from their actions.  The self is composed of an individual’s thoughts, actions, and expression, which are contained in and actuated by the body.  What you do and say is the clearest indicator of who you are.

      ~ Brian Vogel

 


Rowen Cary
 

Thanks everyone, these problems no longer exist after I restarted the computer. It seems to be a misunderstanding, I'm really sorry.