NVDA 2021.3.1 cursor doesn't move in Google product edit fields


Louise Pfau
 

Hi.  When I type into Google product edit fields like the search fields in Youtube or Google search, I can't move the cursor around the text using the ARROW KEYS unless I TAB out of and back into the edit field.  I tried both Microsoft Edge and Google Chrome with the same result, but they are both chromium-based browsers.  I only have those browsers installed on my computer, and they are both up-to-date.  This doesn't happen in other edit fields like the Windows search box.  I'm using Windows 10 Pro Version 21H2 (OS Build 19044.1466), NVDA 2021.3.1, Microsoft Edge Version 97.0.1072.62 (Official build) (64-bit), and Google Chrome Version 97.0.4692.71 (Official Build) (64-bit).  Has anyone else come across this?

Louise


Gene
 

I haven’t tested with the browsers you have named but the Brave browser, another Chrome-based browser, displays this behavior in the Google search edit field.  I haven’t tried other edit fields. 
 
Firefox doesn’t display this behavior. 
 
Gene

-----Original Message-----
Sent: Friday, January 14, 2022 3:56 PM
Subject: [nvda] NVDA 2021.3.1 cursor doesn't move in Google product edit fields
 
Hi.  When I type into Google product edit fields like the search fields in Youtube or Google search, I can't move the cursor around the text using the ARROW KEYS unless I TAB out of and back into the edit field.  I tried both Microsoft Edge and Google Chrome with the same result, but they are both chromium-based browsers.  I only have those browsers installed on my computer, and they are both up-to-date.  This doesn't happen in other edit fields like the Windows search box.  I'm using Windows 10 Pro Version 21H2 (OS Build 19044.1466), NVDA 2021.3.1, Microsoft Edge Version 97.0.1072.62 (Official build) (64-bit), and Google Chrome Version 97.0.4692.71 (Official Build) (64-bit).  Has anyone else come across this?

Louise


 

Well firefox 96 seems to have better processer handling and the latest 96.01 seems to handle displaying of some stuff a lot better to.

Security wize, its quite fast on release runs usually.

And after my own issue with firefox namely noscript I simply have gotten to understand that I just don't bother with that and well things run faster.

With privacy badger causing me issues and https everywhere no longer about.

The only things I use are an addon for rss feeds, I want my rss, add block+ and the extra sounds addon and thats it.

On chrome I use show you rss which does the same thing and add block +.

The addons dialogs on both thunderbird and firefox could be a little more accessible but on the other hand I don't need 1000 addons nore do I really see myself needing to add any more addons to anything.

In fact thunderbird has no addons what so ever.

The only issue that really gets me is that until there is say an file extention which is not included in default setups, I can't do anything till I try to download the thing the first time then I can adjust things.

If I say hide windows installer packages that also effects executable programs which I don't think should be correct.

It also doesn't reccognise nvda-addon files probably because its a weird format even though its just a zip file with a different name.

A while ago there used to be a custom file extention setting but that was ages ago.

These are gripes I have.

I also have the cpu and fan burn to hot when running things but its not like this amd unit has much to do otherwise and its not caused things to crash.

In fact firefox has been really constant from v90 onwards.

I have had waterfox a thing  I used till the end of 2019 get worse and worse to the point it was unusable.

Firefox had a bad patch and I was determined I'd never go back to firefox.

But since the last version that worked was  released august 2020 and I couldn't get any better releases after that that worked I decided to leave classic completely and move to g3.

G3 crashed and screwed up my system a lot and in fact waterfox is still recieving a lot of bad crap on the forums.

I decided to go back to firefox and while I had to leave noscript behind the display issues I had were gone and it worked.

It was a bit slower and crashed from time to time but at least it didn't crash all the time when I visited certain websites no one could find my issues in fact no one seemed to care that much saying nothing was wrong.

The users even told me it was in my head and or it was a problem with windows.

Nothing has changed and the bs has gotten to the point where some users have left.

Ever since waterfox switched to a new investment company it seems like this company is calling the shots rather than its original bosses.

I know firefox is not for everyone.

If you have a slow or an old system then you may not be able to handle it that well.


But it depends what you have loaded.

You really don't need a lot of stuff loaded with this.

I have checked firefox extentions and if you take out the 10-20 search extentions, the 5 or 6 decoders, my extentions which aparently seem to include a few things at least 3 or 4 things, and the mozilla updaters and such there isn't that much.

Some of these are double up so out of 42 different things its more like 20 or less and out of those well as I said its a mixed bag.

On edge most of these are edge related. and in chrome its worse.


Now mozilla has a lot of extra tracking and other stuff but compaired to chrome and or even edge mozilla has about the same components or slightly more than edge


On 15/01/2022 11:16 am, Gene wrote:
I haven’t tested with the browsers you have named but the Brave browser, another Chrome-based browser, displays this behavior in the Google search edit field.  I haven’t tried other edit fields. 
 
Firefox doesn’t display this behavior. 
 
Gene
-----Original Message-----
Sent: Friday, January 14, 2022 3:56 PM
Subject: [nvda] NVDA 2021.3.1 cursor doesn't move in Google product edit fields
 
Hi.  When I type into Google product edit fields like the search fields in Youtube or Google search, I can't move the cursor around the text using the ARROW KEYS unless I TAB out of and back into the edit field.  I tried both Microsoft Edge and Google Chrome with the same result, but they are both chromium-based browsers.  I only have those browsers installed on my computer, and they are both up-to-date.  This doesn't happen in other edit fields like the Windows search box.  I'm using Windows 10 Pro Version 21H2 (OS Build 19044.1466), NVDA 2021.3.1, Microsoft Edge Version 97.0.1072.62 (Official build) (64-bit), and Google Chrome Version 97.0.4692.71 (Official Build) (64-bit).  Has anyone else come across this?

Louise


Nate Kile
 

I have also noticed this. It definitely impacts workflow.


On Fri, Jan 14, 2022 at 1:17 PM Gene <gsasner@...> wrote:
I haven’t tested with the browsers you have named but the Brave browser, another Chrome-based browser, displays this behavior in the Google search edit field.  I haven’t tried other edit fields. 
 
Firefox doesn’t display this behavior. 
 
Gene
-----Original Message-----
Sent: Friday, January 14, 2022 3:56 PM
Subject: [nvda] NVDA 2021.3.1 cursor doesn't move in Google product edit fields
 
Hi.  When I type into Google product edit fields like the search fields in Youtube or Google search, I can't move the cursor around the text using the ARROW KEYS unless I TAB out of and back into the edit field.  I tried both Microsoft Edge and Google Chrome with the same result, but they are both chromium-based browsers.  I only have those browsers installed on my computer, and they are both up-to-date.  This doesn't happen in other edit fields like the Windows search box.  I'm using Windows 10 Pro Version 21H2 (OS Build 19044.1466), NVDA 2021.3.1, Microsoft Edge Version 97.0.1072.62 (Official build) (64-bit), and Google Chrome Version 97.0.4692.71 (Official Build) (64-bit).  Has anyone else come across this?

Louise


Russell James
 

I have observed at least similar results using Firefox and GMail compose/edit boxes.

I cannot be sure but I think this is the same symptoms/problem...

To clarify, I don't think the cursor is not moving, it is just not speaking when it is moved.

This is happening more often with recent versions of NVDA.

Unfortunately, I do not have a set of steps to reproduce the problem.

As others have reported, moving away from the edit box and coming back is the only known work around.

Until recently, I had only experienced this while using Linked-In message compose/edit boxes.
At that time, probably 2/3 years back, I thought it was LI specific and reported the problem to LI.

Russ


On Fri, Jan 14, 2022 at 5:36 PM Nate Kile <theblindprogrammercorner@...> wrote:
I have also noticed this. It definitely impacts workflow.

On Fri, Jan 14, 2022 at 1:17 PM Gene <gsasner@...> wrote:
I haven’t tested with the browsers you have named but the Brave browser, another Chrome-based browser, displays this behavior in the Google search edit field.  I haven’t tried other edit fields. 
 
Firefox doesn’t display this behavior. 
 
Gene
-----Original Message-----
Sent: Friday, January 14, 2022 3:56 PM
Subject: [nvda] NVDA 2021.3.1 cursor doesn't move in Google product edit fields
 
Hi.  When I type into Google product edit fields like the search fields in Youtube or Google search, I can't move the cursor around the text using the ARROW KEYS unless I TAB out of and back into the edit field.  I tried both Microsoft Edge and Google Chrome with the same result, but they are both chromium-based browsers.  I only have those browsers installed on my computer, and they are both up-to-date.  This doesn't happen in other edit fields like the Windows search box.  I'm using Windows 10 Pro Version 21H2 (OS Build 19044.1466), NVDA 2021.3.1, Microsoft Edge Version 97.0.1072.62 (Official build) (64-bit), and Google Chrome Version 97.0.4692.71 (Official Build) (64-bit).  Has anyone else come across this?

Louise


Sarah k Alawami
 

I have sort of experienced this in some electron apps such as discord but it happens so rarely I can’t really say, ok, brake now. I do hope this problem is fixed though and someone can figure out the magic sauce.

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Russell James
Sent: Saturday, January 15, 2022 8:14 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2021.3.1 cursor doesn't move in Google product edit fields

 

I have observed at least similar results using Firefox and GMail compose/edit boxes.

 

I cannot be sure but I think this is the same symptoms/problem...

 

To clarify, I don't think the cursor is not moving, it is just not speaking when it is moved.

 

This is happening more often with recent versions of NVDA.

 

Unfortunately, I do not have a set of steps to reproduce the problem.

 

As others have reported, moving away from the edit box and coming back is the only known work around.

 

Until recently, I had only experienced this while using Linked-In message compose/edit boxes.

At that time, probably 2/3 years back, I thought it was LI specific and reported the problem to LI.

 

Russ

 

 

On Fri, Jan 14, 2022 at 5:36 PM Nate Kile <theblindprogrammercorner@...> wrote:

I have also noticed this. It definitely impacts workflow.

 

On Fri, Jan 14, 2022 at 1:17 PM Gene <gsasner@...> wrote:

I haven’t tested with the browsers you have named but the Brave browser, another Chrome-based browser, displays this behavior in the Google search edit field.  I haven’t tried other edit fields. 

 

Firefox doesn’t display this behavior. 

 

Gene

-----Original Message-----

Sent: Friday, January 14, 2022 3:56 PM

Subject: [nvda] NVDA 2021.3.1 cursor doesn't move in Google product edit fields

 

Hi.  When I type into Google product edit fields like the search fields in Youtube or Google search, I can't move the cursor around the text using the ARROW KEYS unless I TAB out of and back into the edit field.  I tried both Microsoft Edge and Google Chrome with the same result, but they are both chromium-based browsers.  I only have those browsers installed on my computer, and they are both up-to-date.  This doesn't happen in other edit fields like the Windows search box.  I'm using Windows 10 Pro Version 21H2 (OS Build 19044.1466), NVDA 2021.3.1, Microsoft Edge Version 97.0.1072.62 (Official build) (64-bit), and Google Chrome Version 97.0.4692.71 (Official Build) (64-bit).  Has anyone else come across this?

Louise


Deenadayalan Moodley
 

Hi,

 

It also happens in Chrome as well.  When in the search field for google search page, no keys are echoed.  This only started recently.

 

Thanks.

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Russell James
Sent: Saturday, 15 January 2022 18:14
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2021.3.1 cursor doesn't move in Google product edit fields

 

I have observed at least similar results using Firefox and GMail compose/edit boxes.

 

I cannot be sure but I think this is the same symptoms/problem...

 

To clarify, I don't think the cursor is not moving, it is just not speaking when it is moved.

 

This is happening more often with recent versions of NVDA.

 

Unfortunately, I do not have a set of steps to reproduce the problem.

 

As others have reported, moving away from the edit box and coming back is the only known work around.

 

Until recently, I had only experienced this while using Linked-In message compose/edit boxes.

At that time, probably 2/3 years back, I thought it was LI specific and reported the problem to LI.

 

Russ

 

 

On Fri, Jan 14, 2022 at 5:36 PM Nate Kile <theblindprogrammercorner@...> wrote:

I have also noticed this. It definitely impacts workflow.

 

On Fri, Jan 14, 2022 at 1:17 PM Gene <gsasner@...> wrote:

I haven’t tested with the browsers you have named but the Brave browser, another Chrome-based browser, displays this behavior in the Google search edit field.  I haven’t tried other edit fields. 

 

Firefox doesn’t display this behavior. 

 

Gene

-----Original Message-----

Sent: Friday, January 14, 2022 3:56 PM

Subject: [nvda] NVDA 2021.3.1 cursor doesn't move in Google product edit fields

 

Hi.  When I type into Google product edit fields like the search fields in Youtube or Google search, I can't move the cursor around the text using the ARROW KEYS unless I TAB out of and back into the edit field.  I tried both Microsoft Edge and Google Chrome with the same result, but they are both chromium-based browsers.  I only have those browsers installed on my computer, and they are both up-to-date.  This doesn't happen in other edit fields like the Windows search box.  I'm using Windows 10 Pro Version 21H2 (OS Build 19044.1466), NVDA 2021.3.1, Microsoft Edge Version 97.0.1072.62 (Official build) (64-bit), and Google Chrome Version 97.0.4692.71 (Official Build) (64-bit).  Has anyone else come across this?

Louise


Gene
 

I wonder if it is an add-on, as Ron suggested.  I don't have the behavior in Chrome or Edge.  I do have it in Brave. 


Gene

On 1/15/2022 2:18 PM, Deenadayalan Moodley wrote:

Hi,

 

It also happens in Chrome as well.  When in the search field for google search page, no keys are echoed.  This only started recently.

 

Thanks.

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Russell James
Sent: Saturday, 15 January 2022 18:14
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2021.3.1 cursor doesn't move in Google product edit fields

 

I have observed at least similar results using Firefox and GMail compose/edit boxes.

 

I cannot be sure but I think this is the same symptoms/problem...

 

To clarify, I don't think the cursor is not moving, it is just not speaking when it is moved.

 

This is happening more often with recent versions of NVDA.

 

Unfortunately, I do not have a set of steps to reproduce the problem.

 

As others have reported, moving away from the edit box and coming back is the only known work around.

 

Until recently, I had only experienced this while using Linked-In message compose/edit boxes.

At that time, probably 2/3 years back, I thought it was LI specific and reported the problem to LI.

 

Russ

 

 

On Fri, Jan 14, 2022 at 5:36 PM Nate Kile <theblindprogrammercorner@...> wrote:

I have also noticed this. It definitely impacts workflow.

 

On Fri, Jan 14, 2022 at 1:17 PM Gene <gsasner@...> wrote:

I haven’t tested with the browsers you have named but the Brave browser, another Chrome-based browser, displays this behavior in the Google search edit field.  I haven’t tried other edit fields. 

 

Firefox doesn’t display this behavior. 

 

Gene

-----Original Message-----

From: Louise Pfau

Sent: Friday, January 14, 2022 3:56 PM

Subject: [nvda] NVDA 2021.3.1 cursor doesn't move in Google product edit fields

 

Hi.  When I type into Google product edit fields like the search fields in Youtube or Google search, I can't move the cursor around the text using the ARROW KEYS unless I TAB out of and back into the edit field.  I tried both Microsoft Edge and Google Chrome with the same result, but they are both chromium-based browsers.  I only have those browsers installed on my computer, and they are both up-to-date.  This doesn't happen in other edit fields like the Windows search box.  I'm using Windows 10 Pro Version 21H2 (OS Build 19044.1466), NVDA 2021.3.1, Microsoft Edge Version 97.0.1072.62 (Official build) (64-bit), and Google Chrome Version 97.0.4692.71 (Official Build) (64-bit).  Has anyone else come across this?

Louise


Russell James
 

I'm not using any add-ons and it's happening fairly regularly with recent versions

Russ


Louise Pfau
 

Hi.  I'll try to isolate if there is an add-on behind it.  I get typing echo when I type in the Google edit fields, but no spoken feedback when I navigate with the ARROW KEYS in the event that I made a typo that I want to correct.  That's what led me to believe that the cursor wasn't moving.  I tried navigating within another application's edit field to isolate the issue to Google products before I posted the original message.

Louise


 

If, at some point, when someone is certain that they can consistently replicate the behavior, I'd be happy to have a quick remote session with Windows Quick Assist so that I can determine whether the cursor is indeed moving, and NVDA is silent, or if it has stalled.

One of the quickest ways to rule out the possiblity of an add-on being at fault is restarting NVDA with add-ons disabled and try the process again.  If it recurs, it's almost certainly NVDA itself, and if it doesn't, it's almost certainly an add-on that's the culprit.
--

Brian - Windows 10, 64-Bit, Version 21H2, Build 19044  

The instinctive need to be the member of a closely-knit group fighting for common ideals may grow so strong that it becomes inessential what these ideals are.

       ~ Konrad Lorenz (1903-1989)

 


Sidaqvir Singh Lotay
 

I also noticed this bug.


Michael Chopra
 

Hi. I have also noticed this as well and have had to use the work around of tabbing away then coming back to it in order to navigate properly. From what I can figure out, NVDA seems to be selecting the text for some reason when you go back into the edit field. I will also add that I only started noticing this at least for me and others, since version 2021.3.1.
Thanks.
From Michael.


Gene
 

As I recall, I reported two or three days ago that I didn't have the problem in Chrome nor in Edge.  I'm not sure why, but I tested again now with Chrome and the problem is there.  I may test Edge but I haven't yet.


However, tabbing away from the field and returning is not the only way to have text be read when you move the cursor.  Opening the menus and closing them does so as well.  It isn't how you leave the field, its that you leave the field that matters.


Gene

On 1/17/2022 8:17 AM, Michael Chopra wrote:
Hi. I have also noticed this as well and have had to use the work around of tabbing away then coming back to it in order to navigate properly. From what I can figure out, NVDA seems to be selecting the text for some reason when you go back into the edit field. I will also add that I only started noticing this at least for me and others, since version 2021.3.1.
Thanks.
From Michael.


Gene
 

Also, I have a number of different versions of NVDA and installers on my machine.  I realized that I hadn't tested with the latest version previously.  It was 2021.1 beta that I tested with previously.  I tested today with both 2021.3.  and 2021.1 beta.  I had the problem with both versions.  that may not matter but perhaps it does.


I just tried testing with an older version and I had the same problem.  I tested with 2020.1beta1.


Since I  don't use Google much nor Edge, I wonder if Google has updated since my first test.  Have those reporting different results checked their version numbers?  If you do so, by going into About, the browser will begin looking for updates and will update if it hasn't.  As far as I know, updating is supposed to be automatic, but it appears to me that, at least at times, Chrome-based browsers may not automatically update and that you need to open the about dialog for them to do so.  Making sure of browser version numbers may help determine why people are reporting different results.


I don't think this matters, but I'm using Windows 7.


Gene

On 1/17/2022 8:39 AM, Gene via groups.io wrote:

As I recall, I reported two or three days ago that I didn't have the problem in Chrome nor in Edge.  I'm not sure why, but I tested again now with Chrome and the problem is there.  I may test Edge but I haven't yet.


However, tabbing away from the field and returning is not the only way to have text be read when you move the cursor.  Opening the menus and closing them does so as well.  It isn't how you leave the field, its that you leave the field that matters.


Gene

On 1/17/2022 8:17 AM, Michael Chopra wrote:
Hi. I have also noticed this as well and have had to use the work around of tabbing away then coming back to it in order to navigate properly. From what I can figure out, NVDA seems to be selecting the text for some reason when you go back into the edit field. I will also add that I only started noticing this at least for me and others, since version 2021.3.1.
Thanks.
From Michael.


Louise Pfau
 

Hi.  I just tried typing into a Google product search edit field with add-ons disabled, and I was able to replicate the issue.  I should note that the password edit fields appear to behave correctly.

Louise


Russell James
 

To answer Brian's questions

Funny, this is happening as I write this message

I'm not using any NVDA add ons

When this is happening the keyboard continues to speak
The mouse over text using the physical mouse continues to speak

The arrow keys are moving the cursor correctly, however, it is not speaking

This is happening much more often then when I first experienced it
Russ

On Mon, Jan 17, 2022 at 3:46 PM Louise Pfau <louise.pfau@...> wrote:
Hi.  I just tried typing into a Google product search edit field with add-ons disabled, and I was able to replicate the issue.  I should note that the password edit fields appear to behave correctly.

Louise


David Griffith
 

I have experienced identical behaviour but confusingly not on all edit fields – only some.

So for example  I can type and receive appropriate feedback on the Start Page search edit  as well as  Duck Duck go

But I have definitely also encountered the behaviour you describe.

The next time I encounter this I will report back the site.

 

David Griffith

Sent from Mail for Windows

 

From: Louise Pfau
Sent: 16 January 2022 00:02
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2021.3.1 cursor doesn't move in Google product edit fields

 

Hi.  I'll try to isolate if there is an add-on behind it.  I get typing echo when I type in the Google edit fields, but no spoken feedback when I navigate with the ARROW KEYS in the event that I made a typo that I want to correct.  That's what led me to believe that the cursor wasn't moving.  I tried navigating within another application's edit field to isolate the issue to Google products before I posted the original message.

Louise

 


Quentin Christensen
 

Just a quick note to advise that a) I, too, can repro this, and b) I've written up an issue for it: https://github.com/nvaccess/nvda/issues/13272  Do please add any detail I've missed to the issue.

Kind regards

Quentin.

On Tue, Jan 25, 2022 at 4:54 AM David Griffith <daj.griffith@...> wrote:

I have experienced identical behaviour but confusingly not on all edit fields – only some.

So for example  I can type and receive appropriate feedback on the Start Page search edit  as well as  Duck Duck go

But I have definitely also encountered the behaviour you describe.

The next time I encounter this I will report back the site.

 

David Griffith

Sent from Mail for Windows

 

From: Louise Pfau
Sent: 16 January 2022 00:02
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2021.3.1 cursor doesn't move in Google product edit fields

 

Hi.  I'll try to isolate if there is an add-on behind it.  I get typing echo when I type in the Google edit fields, but no spoken feedback when I navigate with the ARROW KEYS in the event that I made a typo that I want to correct.  That's what led me to believe that the cursor wasn't moving.  I tried navigating within another application's edit field to isolate the issue to Google products before I posted the original message.

Louise

 



--
Quentin Christensen
Training and Support Manager