Topics

NVDA and file explorer

Don H
 

Running latest released version of NVDA on a Win 10 1903 system. Having a issue where on what seems to be a random thing where NVDA will not read anything in file explorer.  So if I open my downloads folder, my documents folder and such I can not arrow down through the list of files and folders.  If this silence happens I can unload NVDA and start Jaws 2019 and it reads fine. Unload Jaws and reload NVDA and problem still exists.  A system restart will resolve the problem until it randomly happens again.

Any help would be appreciated.

Quentin Christensen
 

When NVDA goes silent, does it work anywhere else?  EG if you then open Word does it read there?

Are you running any add-ons?  If so, if you restart NVDA with add-ons disabled (press NVDA+q then down arrow to restart with add-ons disabled and press ENTER) does that make a difference?

Finally, a copy of your log would hopefully shed some light on what is going on.  If you could send me a copy of your log I can have a look - since you have to unload NVDA (and either restart or use Jaws), you will find the log in the %temp% folder, either as nvda.log if you have not restarted NVDA since it happened, or nvda-old.log if you have restarted NVDA.  Email to me at info@... (alternatively you can open the log in notepad and copy the contents in a reply to the list here - you just can't attach files to emails to the list).

Kind regards

Quentin.

On Thu, Jun 6, 2019 at 6:07 AM Don H <lmddh50@...> wrote:
Running latest released version of NVDA on a Win 10 1903 system. Having
a issue where on what seems to be a random thing where NVDA will not
read anything in file explorer.  So if I open my downloads folder, my
documents folder and such I can not arrow down through the list of files
and folders.  If this silence happens I can unload NVDA and start Jaws
2019 and it reads fine. Unload Jaws and reload NVDA and problem still
exists.  A system restart will resolve the problem until it randomly
happens again.

Any help would be appreciated.







--
Quentin Christensen
Training and Support Manager

Official NVDA Training modules and expert certification now available: http://www.nvaccess.org/shop/

Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess 

Laz
 

On 6/5/19, Quentin Christensen <quentin@...> wrote:
Are you running any add-ons? If so, if you restart NVDA with add-ons
disabled (press NVDA+q then down arrow to restart with add-ons disabled and
press ENTER) does that make a difference?
* I tried the above directions to run NVDA without add-ons and all it
did was unload NVDA and nothing else. What's the correct keyboard
command to start NVDA without also loading the add-ons?

laz

Quentin Christensen
 

There is an option in NVDA's general settings (press NVDA+control+g) to "show exit options when exiting NVDA".  That is checked by default, in which case my steps should work - if that is unchecked, NVDA will exit as soon as you press NVDA+q, in which case you won't be able to get to the dropdown to select to restart with add-ons disabled.  The easiest way then is to open settings, check that box, then restart NVDA with add-ons disabled.


On Fri, Jun 7, 2019 at 2:51 AM Laz <laz@...> wrote:
On 6/5/19, Quentin Christensen <quentin@...> wrote:
> Are you running any add-ons?  If so, if you restart NVDA with add-ons
> disabled (press NVDA+q then down arrow to restart with add-ons disabled and
> press ENTER) does that make a difference?

* I tried the above directions to run NVDA without add-ons and all it
did was unload NVDA and nothing else. What's the correct keyboard
command to start NVDA without also loading the add-ons?

laz





--
Quentin Christensen
Training and Support Manager

NVDA 2019.2beta1 now available!

Luke Davis
 

On Thu, 6 Jun 2019, Laz wrote:

* I tried the above directions to run NVDA without add-ons and all it
did was unload NVDA and nothing else. What's the correct keyboard
command to start NVDA without also loading the add-ons?
There isn't one.

The most rapid way to do it, is to press windows+r, and type the following (careful of your punctuation and spacing):

nvda -r --disable-addons

Press enter, and a moment later you will be running without addons.

Another way is to press NVDA+ctrl+g, and tab to "show exit options". Check that box. You might want to also make sure "Save configuration on exit" isn't checked, so that the other setting doesn't become permanent. Then press OK, followed by NVDA+Q as in the original instructions.

Luke