NVDA and Thunderbird


Danny Park
 

I wanted to see if anyone has any thoughts on this.  I have several filter rules setup to move messages to folders but when I am trying to read messages I get notifications read telling me about the moves.  Is there any way to stop these from being read while I am reading messages.  Any thoughts on this would be greatly appreciated.


Thanks,

Danny


 

One suggestion, which may or may not apply, is to do your filtering on the server side.  Gmail, for one example, there are others, allows you to set up your filtering and folders so that the work is done before it ever hits your computer.

For Gmail specifically, see:  Creating IMAP Labels (Folders) and Filters for Gmail
--

Brian - Windows 10, 64-Bit, Version 21H1, Build 19043  

The ignorance of one voter in a democracy impairs the security of all.

         ~ John F. Kennedy

 


Gene
 

I suspect this is an aspect of the status bar being improperly set up.  At times, it forces speech.  You can turn off the status line and see if that solves the problem.  Do the following:
Open the view menu, alt v. 
Down arrow to toolbars and press enter.  Down arrow to status bar, which should say checked.  Press enter and it will no longer be shown and the menus will close.
To have it shown again, follow the same procedure.
 
Gene

-----Original Message-----
From: Danny Park
Sent: Thursday, November 04, 2021 11:30 AM
Subject: [nvda] NVDA and Thunderbird
 
I wanted to see if anyone has any thoughts on this.  I have several
filter rules setup to move messages to folders but when I am trying to
read messages I get notifications read telling me about the moves.  Is
there any way to stop these from being read while I am reading
messages.  Any thoughts on this would be greatly appreciated.


Thanks,

Danny






Danny Park
 

This problem only seems to occur when using NVDA it works just fine with jaws and I get none of  the messages about messages being moved to  folders.

Dannyg


On Nov 4, 2021, at 12:33, Gene <gsasner@...> wrote:


I suspect this is an aspect of the status bar being improperly set up.  At times, it forces speech.  You can turn off the status line and see if that solves the problem.  Do the following:
Open the view menu, alt v. 
Down arrow to toolbars and press enter.  Down arrow to status bar, which should say checked.  Press enter and it will no longer be shown and the menus will close.
To have it shown again, follow the same procedure.
 
Gene
-----Original Message-----
From: Danny Park
Sent: Thursday, November 04, 2021 11:30 AM
Subject: [nvda] NVDA and Thunderbird
 
I wanted to see if anyone has any thoughts on this.  I have several
filter rules setup to move messages to folders but when I am trying to
read messages I get notifications read telling me about the moves.  Is
there any way to stop these from being read while I am reading
messages.  Any thoughts on this would be greatly appreciated.


Thanks,

Danny






Gene
 

That may be but the actual problem is not an NVDA problem.  This problem began perhaps six or eight months ago when a Thunderbird developer caused the status bar to force a lot of unwanted speech.  Much of it was removed after complaints.  This speech probably wasn’t heard in JAWS either but improperly implemented accessibility isn’t the fault of NVDA.
 
Perhaps this is done in the same way as forced Aria speech is.  JAWS has a setting for stopping forced Aria speech, and I think NVDA should as well, but the actual problem itself is a Thunderbird problem.
 
Gene

-----Original Message-----
From: Danny Park
Sent: Thursday, November 04, 2021 5:23 PM
Subject: Re: [nvda] NVDA and Thunderbird
 
This problem only seems to occur when using NVDA it works just fine with jaws and I get none of  the messages about messages being moved to  folders.
 
Dannyg
 

On Nov 4, 2021, at 12:33, Gene <gsasner@...> wrote:


I suspect this is an aspect of the status bar being improperly set up.  At times, it forces speech.  You can turn off the status line and see if that solves the problem.  Do the following:
Open the view menu, alt v. 
Down arrow to toolbars and press enter.  Down arrow to status bar, which should say checked.  Press enter and it will no longer be shown and the menus will close.
To have it shown again, follow the same procedure.
 
Gene
-----Original Message-----
From: Danny Park
Sent: Thursday, November 04, 2021 11:30 AM
Subject: [nvda] NVDA and Thunderbird
 
I wanted to see if anyone has any thoughts on this.  I have several
filter rules setup to move messages to folders but when I am trying to
read messages I get notifications read telling me about the moves.  Is
there any way to stop these from being read while I am reading
messages.  Any thoughts on this would be greatly appreciated.


Thanks,

Danny






Danny Park
 

The status bar is already unchecked.  It seems to happen only when I have opened a message and trying to read it.


Danny

On 11/4/2021 12:33 PM, Gene wrote:
I suspect this is an aspect of the status bar being improperly set up.  At times, it forces speech.  You can turn off the status line and see if that solves the problem.  Do the following:
Open the view menu, alt v. 
Down arrow to toolbars and press enter.  Down arrow to status bar, which should say checked.  Press enter and it will no longer be shown and the menus will close.
To have it shown again, follow the same procedure.
 
Gene
-----Original Message-----
From: Danny Park
Sent: Thursday, November 04, 2021 11:30 AM
Subject: [nvda] NVDA and Thunderbird
 
I wanted to see if anyone has any thoughts on this.  I have several
filter rules setup to move messages to folders but when I am trying to
read messages I get notifications read telling me about the moves.  Is
there any way to stop these from being read while I am reading
messages.  Any thoughts on this would be greatly appreciated.


Thanks,

Danny






Danny Park
 

Just found an interesting thing.  When you are reading a message it has a different set of settings.  When I was in a list of messages and did the alt-v the status bar was turned off, however, when in the message itself and I did the alt-v the status bar was turned on and changing that one helped.


Danny

On 11/4/2021 12:33 PM, Gene wrote:
I suspect this is an aspect of the status bar being improperly set up.  At times, it forces speech.  You can turn off the status line and see if that solves the problem.  Do the following:
Open the view menu, alt v. 
Down arrow to toolbars and press enter.  Down arrow to status bar, which should say checked.  Press enter and it will no longer be shown and the menus will close.
To have it shown again, follow the same procedure.
 
Gene
-----Original Message-----
From: Danny Park
Sent: Thursday, November 04, 2021 11:30 AM
Subject: [nvda] NVDA and Thunderbird
 
I wanted to see if anyone has any thoughts on this.  I have several
filter rules setup to move messages to folders but when I am trying to
read messages I get notifications read telling me about the moves.  Is
there any way to stop these from being read while I am reading
messages.  Any thoughts on this would be greatly appreciated.


Thanks,

Danny






Gene
 

If the information isn’t coming from forced reading of the status bar, I don’t know where it is coming from.  If I understand what you are describing, you have a message rule and the speech is coming when the rule is applied when new mail comes in.  But if that is the case, you should hear it whether a message is opened or not.
 
Gene

-----Original Message-----
From: Danny Park
Sent: Friday, November 05, 2021 11:17 AM
Subject: Re: [nvda] NVDA and Thunderbird
 

The status bar is already unchecked.  It seems to happen only when I have opened a message and trying to read it.

 

Danny

On 11/4/2021 12:33 PM, Gene wrote:
I suspect this is an aspect of the status bar being improperly set up.  At times, it forces speech.  You can turn off the status line and see if that solves the problem.  Do the following:
Open the view menu, alt v. 
Down arrow to toolbars and press enter.  Down arrow to status bar, which should say checked.  Press enter and it will no longer be shown and the menus will close.
To have it shown again, follow the same procedure.
 
Gene
-----Original Message-----
From: Danny Park
Sent: Thursday, November 04, 2021 11:30 AM
Subject: [nvda] NVDA and Thunderbird
 
I wanted to see if anyone has any thoughts on this.  I have several
filter rules setup to move messages to folders but when I am trying to
read messages I get notifications read telling me about the moves.  Is
there any way to stop these from being read while I am reading
messages.  Any thoughts on this would be greatly appreciated.


Thanks,

Danny






Gene
 

That explains it.
 
Gene

-----Original Message-----
From: Danny Park
Sent: Friday, November 05, 2021 11:27 AM
Subject: Re: [nvda] NVDA and Thunderbird
 

Just found an interesting thing.  When you are reading a message it has a different set of settings.  When I was in a list of messages and did the alt-v the status bar was turned off, however, when in the message itself and I did the alt-v the status bar was turned on and changing that one helped.

 

Danny

On 11/4/2021 12:33 PM, Gene wrote:
I suspect this is an aspect of the status bar being improperly set up.  At times, it forces speech.  You can turn off the status line and see if that solves the problem.  Do the following:
Open the view menu, alt v. 
Down arrow to toolbars and press enter.  Down arrow to status bar, which should say checked.  Press enter and it will no longer be shown and the menus will close.
To have it shown again, follow the same procedure.
 
Gene
-----Original Message-----
From: Danny Park
Sent: Thursday, November 04, 2021 11:30 AM
Subject: [nvda] NVDA and Thunderbird
 
I wanted to see if anyone has any thoughts on this.  I have several
filter rules setup to move messages to folders but when I am trying to
read messages I get notifications read telling me about the moves.  Is
there any way to stop these from being read while I am reading
messages.  Any thoughts on this would be greatly appreciated.


Thanks,

Danny