NVDA can not read win10 command prompt window


David Mehler
 

Hello,

Using the latest version of NVDA though this problem occurred
previously, and win10 trying to read a command prompt window. This is
on a desktop. I can not read it, I am wondering if there's a setting I
have to enable?

Thanks.
Dave.


John Isige
 

Do you have "report dynamic content changes" checked under preferences/settings/object presentation? You can also toggle this with NVDA-5 on the number row. I'm pretty sure if you don't have this turned on, the window doesn't read. I just checked, and that is indeed the case.

On 10/3/2021 9:53 PM, David Mehler wrote:
Hello,

Using the latest version of NVDA though this problem occurred
previously, and win10 trying to read a command prompt window. This is
on a desktop. I can not read it, I am wondering if there's a setting I
have to enable?

Thanks.
Dave.




David Mehler
 

Hello,

Thanks for the suggestion. I just checked and yes I do have report
dynamic content changes checked.

Thanks.
Dave.

On 10/3/21, John Isige <gwynn@tds.net> wrote:
Do you have "report dynamic content changes" checked under
preferences/settings/object presentation? You can also toggle this with
NVDA-5 on the number row. I'm pretty sure if you don't have this turned
on, the window doesn't read. I just checked, and that is indeed the case.


On 10/3/2021 9:53 PM, David Mehler wrote:
Hello,

Using the latest version of NVDA though this problem occurred
previously, and win10 trying to read a command prompt window. This is
on a desktop. I can not read it, I am wondering if there's a setting I
have to enable?

Thanks.
Dave.









Chris Mullins
 

Hi Dave

I just opened command prompt, typed “dir c:\” and pressed enter.  I then used the 7 key on the Numpad to work backwards through the displayed info.  The 7,8,9 keys read previous , current, next line, 4,5,6 do the same by word and 1,2,3 by character.  This worked irrespective of the “Dynamic content” setting.

 

Cheers

Chris

 

Sent from Mail for Windows

 

From: David Mehler
Sent: 04 October 2021 04:02
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA can not read win10 command prompt window

 

Hello,

 

Thanks for the suggestion. I just checked and yes I do have report

dynamic content changes checked.

 

Thanks.

Dave.

 

 

On 10/3/21, John Isige <gwynn@...> wrote:

> Do you have "report dynamic content changes" checked under

> preferences/settings/object presentation? You can also toggle this with

> NVDA-5 on the number row. I'm pretty sure if you don't have this turned

> on, the window doesn't read. I just checked, and that is indeed the case.

> On 10/3/2021 9:53 PM, David Mehler wrote:

>> Hello,

>> 

>> Using the latest version of NVDA though this problem occurred

>> previously, and win10 trying to read a command prompt window. This is

>> on a desktop. I can not read it, I am wondering if there's a setting I

>> have to enable?

>> 

>> Thanks.

>> Dave.

>> 

>> 

>> 

>> 

>> 

>

 

 

 

 

 


tim
 

In the settings go down to advanced and turn on the UI stuff.

On 10/3/2021 11:02 PM, David Mehler wrote:
Hello,

Thanks for the suggestion. I just checked and yes I do have report
dynamic content changes checked.

Thanks.
Dave.


On 10/3/21, John Isige <gwynn@tds.net> wrote:
Do you have "report dynamic content changes" checked under
preferences/settings/object presentation? You can also toggle this with
NVDA-5 on the number row. I'm pretty sure if you don't have this turned
on, the window doesn't read. I just checked, and that is indeed the case.


On 10/3/2021 9:53 PM, David Mehler wrote:
Hello,

Using the latest version of NVDA though this problem occurred
previously, and win10 trying to read a command prompt window. This is
on a desktop. I can not read it, I am wondering if there's a setting I
have to enable?

Thanks.
Dave.









David Mehler
 

Hello,

Retried the dir c:\ and using 7 8 and 9 which I know does not work on
it, NVDA just says top and bottom. I did check the settings, advanced,
UI section and use UI in command prompt windows is checked.

Thanks.
Dave.

On 10/4/21, tim <z2004a1@gmail.com> wrote:
In the settings go down to advanced and turn on the UI stuff.

On 10/3/2021 11:02 PM, David Mehler wrote:
Hello,

Thanks for the suggestion. I just checked and yes I do have report
dynamic content changes checked.

Thanks.
Dave.


On 10/3/21, John Isige <gwynn@tds.net> wrote:
Do you have "report dynamic content changes" checked under
preferences/settings/object presentation? You can also toggle this with
NVDA-5 on the number row. I'm pretty sure if you don't have this turned
on, the window doesn't read. I just checked, and that is indeed the
case.


On 10/3/2021 9:53 PM, David Mehler wrote:
Hello,

Using the latest version of NVDA though this problem occurred
previously, and win10 trying to read a command prompt window. This is
on a desktop. I can not read it, I am wondering if there's a setting I
have to enable?

Thanks.
Dave.














Jacob Kruger
 

Dave, make sure you've switched back to object navigation mode, and not screen review mode while scanning through lines in command prompt?


As in, I work a lot in command line, and, just tested it, and, if in screen review mode, it will also just tell me top and bottom, while in object navigation mode it works fine?


Jacob Kruger
Blind Biker
Skype: BlindZA
"Resistance is futile...but, acceptance is versatile..."

On 2021-10-04 02:20 PM, David Mehler wrote:
Hello,

Retried the dir c:\ and using 7 8 and 9 which I know does not work on
it, NVDA just says top and bottom. I did check the settings, advanced,
UI section and use UI in command prompt windows is checked.

Thanks.
Dave.


On 10/4/21, tim <z2004a1@gmail.com> wrote:
In the settings go down to advanced and turn on the UI stuff.

On 10/3/2021 11:02 PM, David Mehler wrote:
Hello,

Thanks for the suggestion. I just checked and yes I do have report
dynamic content changes checked.

Thanks.
Dave.


On 10/3/21, John Isige <gwynn@tds.net> wrote:
Do you have "report dynamic content changes" checked under
preferences/settings/object presentation? You can also toggle this with
NVDA-5 on the number row. I'm pretty sure if you don't have this turned
on, the window doesn't read. I just checked, and that is indeed the
case.


On 10/3/2021 9:53 PM, David Mehler wrote:
Hello,

Using the latest version of NVDA though this problem occurred
previously, and win10 trying to read a command prompt window. This is
on a desktop. I can not read it, I am wondering if there's a setting I
have to enable?

Thanks.
Dave.












Lukasz Golonka
 

On Mon, 4 Oct 2021 08:20:00 -0400
"David Mehler" <dave.mehler@gmail.com> wrote:

I did check the settings, advanced,
UI section and use UI in command prompt windows is checked.
The next logical step would be to uncheck Use UIA and retry as that
option is still experimental.

--
Regards
Lukasz


Gene
 

It makes me wonder if there is a problem with your installation of Windows.  I don’t know if Narrator reads command prompt windows but JAWS does.  Do you have a JAWS demo to test with?
 
Also, and I don’t know if this matters, but do you have the add-on that provides more functionality in NVDA in Windows 10?  I think it may be called Apps Enhancements.;.  I don’t know if that improves reading in the command prompt but others will, I hope, comment.
 
Gene
Gene
riginal Message-----

Sent: Monday, October 04, 2021 7:20 AM
Subject: Re: [nvda] NVDA can not read win10 command prompt window
 
Hello,

Retried the dir c:\ and using 7 8 and 9 which I know does not work on
it, NVDA just says top and bottom. I did check the settings, advanced,
UI section and use UI in command prompt windows is checked.

Thanks.
Dave.


On 10/4/21, tim <z2004a1@...> wrote:
> In the settings go down to advanced and turn on the UI stuff.
>
> On 10/3/2021 11:02 PM, David Mehler wrote:
>> Hello,
>>
>> Thanks for the suggestion. I just checked and yes I do have report
>> dynamic content changes checked.
>>
>> Thanks.
>> Dave.
>>
>>
>> On 10/3/21, John Isige <gwynn@...> wrote:
>>> Do you have "report dynamic content changes" checked under
>>> preferences/settings/object presentation? You can also toggle this with
>>> NVDA-5 on the number row. I'm pretty sure if you don't have this turned
>>> on, the window doesn't read. I just checked, and that is indeed the
>>> case.
>>>
>>>
>>> On 10/3/2021 9:53 PM, David Mehler wrote:
>>>> Hello,
>>>>
>>>> Using the latest version of NVDA though this problem occurred
>>>> previously, and win10 trying to read a command prompt window. This is
>>>> on a desktop. I can not read it, I am wondering if there's a setting I
>>>> have to enable?
>>>>
>>>> Thanks.
>>>> Dave.
>>>>
>>>>
>>>>
>>>>
>>>>
>>>
>>>
>>>
>>>
>>>
>>
>>
>>
>>
>
>
>
>
>
>





Gene
 

That's a good suggestion.  I hadn't thought about it.  It is another demonstration of what I've contended for a long time, that NVDA should automatically revert to object navigation when you leave the window you were working in when in review mode.  This not occurring, I suspect, causes unnecessary confusion, perhaps quite a bit.


Gene

On 10/4/2021 7:25 AM, Lukasz Golonka via groups.io wrote:
On Mon, 4 Oct 2021 08:20:00 -0400
"David Mehler" <dave.mehler@gmail.com> wrote:

I did check the settings, advanced,
UI section and use UI in command prompt windows is checked.
The next logical step would be to uncheck Use UIA and retry as that
option is still experimental.


Chris Mullins
 

Hi Dave

Sounds like you’re in screen review mode with the top/bottom, try pressing NVDA+Numpad 1 and make sure you are in object review mode, then try 7, 8 and 9 again.

 

Cheers

Chris

 

Sent from Mail for Windows

 

From: David Mehler
Sent: 04 October 2021 13:20
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA can not read win10 command prompt window

 

Hello,

 

Retried the dir c:\ and using 7 8 and 9 which I know does not work on

it, NVDA just says top and bottom. I did check the settings, advanced,

UI section and use UI in command prompt windows is checked.

 

Thanks.

Dave.

 

 

On 10/4/21, tim <z2004a1@...> wrote:

> In the settings go down to advanced and turn on the UI stuff.

> On 10/3/2021 11:02 PM, David Mehler wrote:

>> Hello,

>> 

>> Thanks for the suggestion. I just checked and yes I do have report

>> dynamic content changes checked.

>> 

>> Thanks.

>> Dave.

>> 

>> 

>> On 10/3/21, John Isige <gwynn@...> wrote:

>>> Do you have "report dynamic content changes" checked under

>>> preferences/settings/object presentation? You can also toggle this with

>>> NVDA-5 on the number row. I'm pretty sure if you don't have this turned

>>> on, the window doesn't read. I just checked, and that is indeed the

>>> case.

>>> 

>>> 

>>> On 10/3/2021 9:53 PM, David Mehler wrote:

>>>> Hello,

>>>> 

>>>> Using the latest version of NVDA though this problem occurred

>>>> previously, and win10 trying to read a command prompt window. This is

>>>> on a desktop. I can not read it, I am wondering if there's a setting I

>>>> have to enable?

>>>> 

>>>> Thanks.

>>>> Dave.

>>>> 

>>>> 

>>>> 

>>>> 

>>>> 

>>> 

>>> 

>>> 

>>> 

>>> 

>> 

>> 

>> 

>> 

>

 

 

 

 

 


Steve Nutt
 

Hi,

 

I think this may be the answer.

 

Press your windows key and type CMD, you should hear Command Prompt.

 

Next, press your applications key and go to Open File Location.

 

Next, press Alt Enter on the Command Prompt to bring up its properties.

 

Shift tab to the tabs, and go right to Options.

 

Now tab to Legacy Console, and if it is unchecked, check it.

 

Hit apply then OK, and you should be golden.

 

All the best


Steve

 

--

To subscribe to our News and Special Offers list, go to https://www.comproom.co.uk/subscribe

 

Computer Room Services

77 Exeter Close

Stevenage

Hertfordshire

SG1 4PW

T: +44(0)1438-742286

M: +44(0)7956-334938

F: +44(0)1438-759589

E: steve@...

W: https://www.comproom.co.uk

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Gene
Sent: 04 October 2021 13:36
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA can not read win10 command prompt window

 

It makes me wonder if there is a problem with your installation of Windows.  I don’t know if Narrator reads command prompt windows but JAWS does.  Do you have a JAWS demo to test with?

 

Also, and I don’t know if this matters, but do you have the add-on that provides more functionality in NVDA in Windows 10?  I think it may be called Apps Enhancements.;.  I don’t know if that improves reading in the command prompt but others will, I hope, comment.

 

Gene

Gene

riginal Message-----

Sent: Monday, October 04, 2021 7:20 AM

Subject: Re: [nvda] NVDA can not read win10 command prompt window

 

Hello,

Retried the dir c:\ and using 7 8 and 9 which I know does not work on
it, NVDA just says top and bottom. I did check the settings, advanced,
UI section and use UI in command prompt windows is checked.

Thanks.
Dave.


On 10/4/21, tim <z2004a1@...> wrote:
> In the settings go down to advanced and turn on the UI stuff.
>
> On 10/3/2021 11:02 PM, David Mehler wrote:
>> Hello,
>>
>> Thanks for the suggestion. I just checked and yes I do have report
>> dynamic content changes checked.
>>
>> Thanks.
>> Dave.
>>
>>
>> On 10/3/21, John Isige <gwynn@...> wrote:
>>> Do you have "report dynamic content changes" checked under
>>> preferences/settings/object presentation? You can also toggle this with
>>> NVDA-5 on the number row. I'm pretty sure if you don't have this turned
>>> on, the window doesn't read. I just checked, and that is indeed the
>>> case.
>>>
>>>
>>> On 10/3/2021 9:53 PM, David Mehler wrote:
>>>> Hello,
>>>>
>>>> Using the latest version of NVDA though this problem occurred
>>>> previously, and win10 trying to read a command prompt window. This is
>>>> on a desktop. I can not read it, I am wondering if there's a setting I
>>>> have to enable?
>>>>
>>>> Thanks.
>>>> Dave.
>>>>
>>>>
>>>>
>>>>
>>>>
>>>
>>>
>>>
>>>
>>>
>>
>>
>>
>>
>
>
>
>
>
>




anthony borg
 

Hi chris

 

What did you do to open the command prompt please?

Thanks in advance

 

Anthony

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Chris Mullins
Sent: 04 October 2021 12:02
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA can not read win10 command prompt window

 

Hi Dave

I just opened command prompt, typed “dir c:\” and pressed enter.  I then used the 7 key on the Numpad to work backwards through the displayed info.  The 7,8,9 keys read previous , current, next line, 4,5,6 do the same by word and 1,2,3 by character.  This worked irrespective of the “Dynamic content” setting.

 

Cheers

Chris

 

Sent from Mail for Windows

 

From: David Mehler
Sent: 04 October 2021 04:02
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA can not read win10 command prompt window

 

Hello,

 

Thanks for the suggestion. I just checked and yes I do have report

dynamic content changes checked.

 

Thanks.

Dave.

 

 

On 10/3/21, John Isige <gwynn@...> wrote:

> Do you have "report dynamic content changes" checked under

> preferences/settings/object presentation? You can also toggle this with

> NVDA-5 on the number row. I'm pretty sure if you don't have this turned

> on, the window doesn't read. I just checked, and that is indeed the case.

> On 10/3/2021 9:53 PM, David Mehler wrote:

>> Hello,

>> 

>> Using the latest version of NVDA though this problem occurred

>> previously, and win10 trying to read a command prompt window. This is

>> on a desktop. I can not read it, I am wondering if there's a setting I

>> have to enable?

>> 

>> Thanks.

>> Dave.

>> 

>> 

>> 

>> 

>> 

>

 

 

 

 

 


Sarah k Alawami
 

control m will be your friend. Once done you can escape out of it. You can even copy lines from there to paste somewhere else.

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of David Mehler
Sent: Sunday, October 3, 2021 7:53 PM
To: nvda@nvda.groups.io
Subject: [nvda] NVDA can not read win10 command prompt window

Hello,

Using the latest version of NVDA though this problem occurred previously, and win10 trying to read a command prompt window. This is on a desktop. I can not read it, I am wondering if there's a setting I have to enable?

Thanks.
Dave.


JinYoun
 

Hi, should everyone do this? I just checked my cmd properties and the legacy mode was unchecked...
"Press your windows key and type CMD, you should hear Command Prompt.
Next, press your applications key and go to Open File Location.
Next, press Alt Enter on the Command Prompt to bring up its properties.
Shift tab to the tabs, and go right to Options.
Now tab to Legacy Console, and if it is unchecked, check it.
Hit apply then OK, and you should be golden." 


Chris Mullins
 

Hi Anthony

There are a couple of ways to do it. The first being via the Windows+x context menu, from where you can open it in standard and admin modes.  The other way is to press Windows+r to open the Run dialog box, type “cmd” (without the quotes) and press either enter for standard mode or Control+shift+Enter for Admin mode.  Note: if you elect to use the command prompt in admin mode and User Account Control is active, you will get a UAC prompt before you can proceed.

 

Cheers

Chris   

 

Sent from Mail for Windows

 

From: anthony borg
Sent: 04 October 2021 16:30
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA can not read win10 command prompt window

 

Hi chris

 

What did you do to open the command prompt please?

Thanks in advance

 

Anthony

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Chris Mullins
Sent: 04 October 2021 12:02
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA can not read win10 command prompt window

 

Hi Dave

I just opened command prompt, typed “dir c:\” and pressed enter.  I then used the 7 key on the Numpad to work backwards through the displayed info.  The 7,8,9 keys read previous , current, next line, 4,5,6 do the same by word and 1,2,3 by character.  This worked irrespective of the “Dynamic content” setting.

 

Cheers

Chris

 

Sent from Mail for Windows

 

From: David Mehler
Sent: 04 October 2021 04:02
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA can not read win10 command prompt window

 

Hello,

 

Thanks for the suggestion. I just checked and yes I do have report

dynamic content changes checked.

 

Thanks.

Dave.

 

 

On 10/3/21, John Isige <gwynn@...> wrote:

> Do you have "report dynamic content changes" checked under

> preferences/settings/object presentation? You can also toggle this with

> NVDA-5 on the number row. I'm pretty sure if you don't have this turned

> on, the window doesn't read. I just checked, and that is indeed the case.

> On 10/3/2021 9:53 PM, David Mehler wrote:

>> Hello,

>> 

>> Using the latest version of NVDA though this problem occurred

>> previously, and win10 trying to read a command prompt window. This is

>> on a desktop. I can not read it, I am wondering if there's a setting I

>> have to enable?

>> 

>> Thanks.

>> Dave.

>> 

>> 

>> 

>> 

>> 

>

 

 

 

 

 

 


Chris Mullins
 

Hi

I don’t think this is what legacy mode is for.  I can read the command prompt window contents using the review cursor with Object mode active and I do not have legacy mode switched on.

 

Cheers

Chris

 

Sent from Mail for Windows

 

From: JinYoun
Sent: 04 October 2021 17:21
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA can not read win10 command prompt window

 

Hi, should everyone do this? I just checked my cmd properties and the legacy mode was unchecked...
"Press your windows key and type CMD, you should hear Command Prompt.

Next, press your applications key and go to Open File Location.

Next, press Alt Enter on the Command Prompt to bring up its properties.

Shift tab to the tabs, and go right to Options.

Now tab to Legacy Console, and if it is unchecked, check it.

Hit apply then OK, and you should be golden." 

 


Sarah k Alawami
 

Iv’e never had ot do this. I just hit control m to read my window and escape to go back to what I was doing.

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of JinYoun
Sent: Monday, October 4, 2021 9:21 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA can not read win10 command prompt window

 

Hi, should everyone do this? I just checked my cmd properties and the legacy mode was unchecked...
"Press your windows key and type CMD, you should hear Command Prompt.

Next, press your applications key and go to Open File Location.

Next, press Alt Enter on the Command Prompt to bring up its properties.

Shift tab to the tabs, and go right to Options.

Now tab to Legacy Console, and if it is unchecked, check it.

Hit apply then OK, and you should be golden."