NVDA not always reading cell contents in MS Excel?


Sally Kiebdaj
 

Hello all,

Normally, I can press F2 on a cel in MS Excel and NVDA will allow me to read and edit the cell contents. Today, this has stopped working. In a spreadsheet I've been using for a week with no problems, I now cannot hear any cell contents after pressing F2. The contents are there and if I make edits and hit enter I can read my edits.However, this is not sufficient for editing prose. 

I'm running:


NVDA 2021.2
Microsoft® Excel® 2019 MSO (16.0.10380.20037) 64-bit 
Windows 10 Pro: Version 2004 (OS Build 19041.1348)

Any ideas? 

Thank you!
Sally 


Louis Maher
 

Hello Sally,

 

This problem comes up periodically.  You can try unchecking the box which says “allow editing directly in cells”.  In Excel 365, do this:

Open an Excel spreadsheet. 

Type alt + f. Up arrow to options, hit enter. Down arrow to advanced. Tab until you find the box which says “allow editing directly in cells. Uncheck that

box. Shift + Tab until you reach OK. Hit enter.

 

 

Regards

Louis Maher

Phone: 713-444-7838

E-mail: ljmaher03@...

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Sally Kiebdaj
Sent: Monday, December 6, 2021 3:06 AM
To: nvda@nvda.groups.io
Subject: [nvda] NVDA not always reading cell contents in MS Excel?

 

Hello all,

 

Normally, I can press F2 on a cel in MS Excel and NVDA will allow me to read and edit the cell contents. Today, this has stopped working. In a spreadsheet I've been using for a week with no problems, I now cannot hear any cell contents after pressing F2. The contents are there and if I make edits and hit enter I can read my edits.However, this is not sufficient for editing prose. 

 

I'm running:

 

 

NVDA 2021.2

Microsoft® Excel® 2019 MSO (16.0.10380.20037) 64-bit 

Windows 10 Pro: Version 2004 (OS Build 19041.1348)

 

Any ideas? 

 

Thank you!

Sally 


Sally Kiebdaj
 

Well, that's a tidy work around. Thank you!
Warmly,
Sally 

On Mon, Dec 6, 2021 at 12:31 PM Louis Maher <ljmaher03@...> wrote:

Hello Sally,

 

This problem comes up periodically.  You can try unchecking the box which says “allow editing directly in cells”.  In Excel 365, do this:

Open an Excel spreadsheet. 

Type alt + f. Up arrow to options, hit enter. Down arrow to advanced. Tab until you find the box which says “allow editing directly in cells. Uncheck that

box. Shift + Tab until you reach OK. Hit enter.

 

 

Regards

Louis Maher

Phone: 713-444-7838

E-mail: ljmaher03@...

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Sally Kiebdaj
Sent: Monday, December 6, 2021 3:06 AM
To: nvda@nvda.groups.io
Subject: [nvda] NVDA not always reading cell contents in MS Excel?

 

Hello all,

 

Normally, I can press F2 on a cel in MS Excel and NVDA will allow me to read and edit the cell contents. Today, this has stopped working. In a spreadsheet I've been using for a week with no problems, I now cannot hear any cell contents after pressing F2. The contents are there and if I make edits and hit enter I can read my edits.However, this is not sufficient for editing prose. 

 

I'm running:

 

 

NVDA 2021.2

Microsoft® Excel® 2019 MSO (16.0.10380.20037) 64-bit 

Windows 10 Pro: Version 2004 (OS Build 19041.1348)

 

Any ideas? 

 

Thank you!

Sally 


Louise Pfau
 

On Mon, Dec 6, 2021 at 04:31 AM, Louis Maher wrote:

This problem comes up periodically.  You can try unchecking the box which says “allow editing directly in cells”.  In Excel 365, do this:

Open an Excel spreadsheet. 

Type alt + f. Up arrow to options, hit enter. Down arrow to advanced. Tab until you find the box which says “allow editing directly in cells. Uncheck that

box. Shift + Tab until you reach OK. Hit enter.

I'm glad to know this is happening in newer versions of Excel as well, and I'm not the only one.  Thanks for the specific instructions.  I knew the setting had been mentioned in prior topics (not necessarily on this list), but I don't recall if there were specific instructions on how to find it.  I hope this fixes the problem I'm having with editing too.  The wording for the command sounds counterintuitive, because the box has to be unchecked to allow editing in cells.

Thanks,

Louise


Louis Maher
 

You are welcome Louise.

 

Regards

Louis Maher

Phone: 713-444-7838

E-mail: ljmaher03@...

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Louise Pfau
Sent: Monday, December 6, 2021 2:18 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA not always reading cell contents in MS Excel?

 

On Mon, Dec 6, 2021 at 04:31 AM, Louis Maher wrote:

This problem comes up periodically.  You can try unchecking the box which says “allow editing directly in cells”.  In Excel 365, do this:

Open an Excel spreadsheet. 

Type alt + f. Up arrow to options, hit enter. Down arrow to advanced. Tab until you find the box which says “allow editing directly in cells. Uncheck that

box. Shift + Tab until you reach OK. Hit enter.

I'm glad to know this is happening in newer versions of Excel as well, and I'm not the only one.  Thanks for the specific instructions.  I knew the setting had been mentioned in prior topics (not necessarily on this list), but I don't recall if there were specific instructions on how to find it.  I hope this fixes the problem I'm having with editing too.  The wording for the command sounds counterintuitive, because the box has to be unchecked to allow editing in cells.

Thanks,

Louise