Topics

Problem about NVDA control and arrow keys

Surendra JUJJAVARAPU
 
Edited

Hi friends this is Surendra I have a small problem with NVDA version 19.1.1 when I press NVDA key + control + right and left arrow I can't able to configure rate volume options but the NVDA is is saying vote by old Eid can anyone tell me what is the problem and suggest MI to rectify the problem

 

Surendra,
when I press nvd a key + control + right and left arrow I can't able to configure rate volume options
Actually, the command is Control+Shift+NVDA+Right/Left arrows to move through the options and Control+Shit+NVDA+Up/Down arrows to configure the option you've selected.

Hope this helps :)

On a related note, I just discovered something curious.
Here, Control+Shift+NVDA+Left arrow works like a charm. However, the same isn't true for the command using the right arrow. In fact, the problem seems to be with the combo Control+Insert+Right arrow.
Can anyone tell me why that is happening? Would my keyboard not be capable of processing this combo at once?

Thanks a lot.

Cheers,
Marcio AKA Starboy

Sent from a galaxy far, far away.

--
Are you a Thunderbird user? Then join the Thunderbird mailing list to help and be helped with all Thunderbird things - questions, features, add-ons and much more!

Giles Turnbull
 

Hi Surendra and Marcio,

the keystroke to cycle through the options doesn't include the shift key. On my system (Win10, NVDA 2019.1.1) I press NVDA+CTRL plus the left or right arrows, and then NVDA+CTRL plus the up or down arrows depending on whether I want to increase or decrease the values :)

Giles

Rui Fontes
 

Sorry, but both are right...

NVDA+Control+Alt+arrows belongs to Desktop keyboard scheme.

NVDA+Control+Shift+Alt+arrows belong to Laptop keyboard scheme...

Best regards,

Rui Fontes
NVDA portuguese team


Às 14:38 de 11/07/2019, Giles Turnbull escreveu:

Hi Surendra and Marcio,
the keystroke to cycle through the options doesn't include the shift key. On my system (Win10, NVDA 2019.1.1) I press NVDA+CTRL plus the left or right arrows, and then NVDA+CTRL plus the up or down arrows depending on whether I want to increase or decrease the values :)
Giles

Gene
 

Which is why people should stipulate what keyboard command scheme is being used unless they know the command is the same in either.  Considerable confusion would be eliminated.  Details should be given in discussing problems or procedures in general, even if they seem unimportant.  They may not be.
 
Gene

----- Original Message -----
From: Rui Fontes
Sent: Thursday, July 11, 2019 8:46 AM
Subject: Re: [nvda] Problem about NVDA control and arrow keys

Sorry, but both are right...

NVDA+Control+Alt+arrows belongs to Desktop keyboard scheme.

NVDA+Control+Shift+Alt+arrows belong to Laptop keyboard scheme...

Best regards,

Rui Fontes
NVDA portuguese team


Às 14:38 de 11/07/2019, Giles Turnbull escreveu:
> Hi Surendra and Marcio,
>
> the keystroke to cycle through the options doesn't include the shift
> key. On my system (Win10, NVDA 2019.1.1) I press NVDA+CTRL plus the left
> or right arrows, and then NVDA+CTRL plus the up or down arrows depending
> on whether I want to increase or decrease the values :)
>
> Giles
>


Chris Mullins
 

Hi
On my Desktop keyboard layout based NVDA config, it's as Giles says NVDA+Ctrl+Arrows, the alt key is not involved.

Cheers
Chris

-----Original Message-----
From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Rui Fontes
Sent: 11 July 2019 14:46
To: nvda@nvda.groups.io
Subject: Re: [nvda] Problem about NVDA control and arrow keys

Sorry, but both are right...

NVDA+Control+Alt+arrows belongs to Desktop keyboard scheme.

NVDA+Control+Shift+Alt+arrows belong to Laptop keyboard scheme...

Best regards,

Rui Fontes
NVDA portuguese team


Às 14:38 de 11/07/2019, Giles Turnbull escreveu:
Hi Surendra and Marcio,

the keystroke to cycle through the options doesn't include the shift
key. On my system (Win10, NVDA 2019.1.1) I press NVDA+CTRL plus the left
or right arrows, and then NVDA+CTRL plus the up or down arrows depending
on whether I want to increase or decrease the values :)

Giles

Rui Fontes
 

Sorry! In none of the chemes Alt is envolved!

For Desktop keyboard scheme, NVDA+Control+arrows!
For Laptop keyboard scheme, NVDA+Control+Shift+arrows!

Rui Fontes


Às 15:24 de 11/07/2019, Chris Mullins escreveu:

Hi
On my Desktop keyboard layout based NVDA config, it's as Giles says NVDA+Ctrl+Arrows, the alt key is not involved.
Cheers
Chris
-----Original Message-----
From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Rui Fontes
Sent: 11 July 2019 14:46
To: nvda@nvda.groups.io
Subject: Re: [nvda] Problem about NVDA control and arrow keys
Sorry, but both are right...
NVDA+Control+Alt+arrows belongs to Desktop keyboard scheme.
NVDA+Control+Shift+Alt+arrows belong to Laptop keyboard scheme...
Best regards,
Rui Fontes
NVDA portuguese team
Às 14:38 de 11/07/2019, Giles Turnbull escreveu:
Hi Surendra and Marcio,

the keystroke to cycle through the options doesn't include the shift
key. On my system (Win10, NVDA 2019.1.1) I press NVDA+CTRL plus the left
or right arrows, and then NVDA+CTRL plus the up or down arrows depending
on whether I want to increase or decrease the values :)

Giles

Luke Davis
 

On Wed, 10 Jul 2019, Marcio via Groups.Io wrote:

when I press nvd a key + control + right and left arrow I can't able to configure rate volume options
Actually, the command is Control+Shift+NVDA+Right/Left arrows to move through the options and Control+Shit+NVDA+Up/Down arrows to configure the option
you've selected.
Marcio, that is only true in laptop layout. In desktop layout, the shift key is not involved.

The OP didn't specify what mode he/she was in, but it is possible that the user expects to be in desktop, and is actually in laptop, which would probably explain the behavior mentioned.

On a related note, I just discovered something curious.
Here, Control+Shift+NVDA+Left arrow works like a charm. However, the same isn't true for the command using the right arrow. In fact, the problem seems to be
with the combo Control+Insert+Right arrow.
Did you forget a shift in that last one?

Can anyone tell me why that is happening? Would my keyboard not be capable of processing this combo at once?
Most likely you accidentally remapped it in gesture settings.

If you can launch a portable copy, you can test whether the problem still exists. There are other ways, of course, but that might be the one that has the least chance of munging up your existing settings.

Luke

 

Luke,

I wrote:
In fact, the problem seems to be with the combo Control+Insert+Right arrow.
And you asked:
Did you forget a shift in that last one?
Nah :) I was just saying that the problem seems to be with this combo no matter what else may be involved.
For example I can press Control+Insert+Capslock+right arrow, and I would have the same result.
I discovered that because Control+Insert+Right arrow is also an NVDA command, which should be reported with the NVDA+F1 mode on (forgot its name, sorry) and it's not being reported either.

Most likely you accidentally remapped it in gesture settings.
Considering the scenario I don't think so. However, if you still think I should try it, please let me know :)

Cheers,
Marcio AKA Starboy

Sent from a galaxy far, far away.

--
Are you a Thunderbird user? Then join the Thunderbird mailing list to help and be helped with all Thunderbird things - questions, features, add-ons and much more!

Luke Davis
 

On Fri, 12 Jul 2019, Marcio via Groups.Io wrote:

I wrote:
In fact, the problem seems to be with the combo Control+Insert+Right arrow.
And you asked:
Did you forget a shift in that last one?
Nah :) I was just saying that the problem seems to be with this combo no matter what else may be involved.
For example I can press Control+Insert+Capslock+right arrow, and I would have the same result.
If you have capslock set as an NVDA modifier key, that is effectively pressing ctrl+NVDA+NVDA+right arrow.
On my system I can't actually do that: I get "control+nvda+nvda" in key describer.

Interestingly, if I attach a USB keyboard, I find that certain combinations are possible, and others impossible:
Capslock+either ctrl+right arrow: succeeds.
Insert+left ctrl+right arrow: fails.
Insert+right ctrl+right arrow: succeeds.

Also, using the insert key on the USB keyboard, along with either ctrl and right arrow on the laptop, succeeds. And yes, I had to use a foot to achieve that particular three handed contortion.

Lastly, sometimes I could get some of these to work, depending on which order I hit the modifier keys.

The bottom line seems to be that some combinations just don't work with all keyboards, in every expected order.

I discovered that because Control+Insert+Right arrow is also an NVDA command, which should be reported with the NVDA+F1 mode on (forgot its name, sorry) and
In laptop mode: Moves the review cursor to the next word of the navigator object and speaks it.

Luke

Luke Davis
 

On Fri, 12 Jul 2019, Luke Davis wrote:

The bottom line seems to be that some combinations just don't work with all keyboards, in every expected order.
I should have added an actual solution to this, instead of just implying one. To solve the problem, you have three options.

1. Change the order in which you press the modifiers. That has a slim chance of working.
2. Use a different modifier key.
* If control is required, and the control key you normally use doesn't work, try the other one. Same with shift and alt.
* If NVDA is required, you have two or three possible options of which NVDA key to use: six-pack insert (sometimes along the top somewhere with laptop keyboards, maybe with the FN modifier), numpad 0/insert if you have a numpad, or of course capslock.
3. If you can't modify your choice of modifiers to solve the problem, either because it's too uncomfortable or because it just doesn't work, you are left with remapping the command (and probably its related command, such as the one to go in the other direction) in gesture configuration, to a set of commands that actually work.

Luke

Quentin Christensen
 

Hi Surendra,

Assuming you are using NVDA in desktop keyboard layout, then NVDA+control+left and right arrows are correct for what you are trying to do.  (If using NVDA in laptop layout, then Marcio's post is correct and the keystroke is NVDA+control+shift+arrows)  Firstly, check that num lock is "off" if you are using the numpad insert as your NVDA modifier key.  Are you using any add-ons?  If you restart NVDA with add-ons disabled (press NVDA+Q then down arrow to "restart with add-ons disabled" and press enter) does the issue still occur?

If so, if you could send a copy of your log to info@..., I can have a look.

Kind regards

Quentin.

On Wed, Jul 10, 2019 at 11:41 PM Surendra JUJJAVARAPU <surendrajujjavarapu9@...> wrote:

Hi friends this is Surendra I have a small problem with n v d a ae version 19.1.1 when I press nvd a key + control + right and left arrow I can't able to configure rate volume options but the n v d a is is saying vote by old Eid can anyone tell me what is the problem and suggest MI to rectify the problem



--
Quentin Christensen
Training and Support Manager

NVDA 2019.2beta1 now available!

Quentin Christensen
 

Hi Marcio,

NVDA+control+left and right is correct to move through the synth settings ring if NVDA is set to desktop keyboard layout.  If set to laptop keyboard layout, then your command of NVDA+control+shift+arrows is correct.

Re your issue, the only thing I can think of is your right arrow perhaps serving a dual function and you need to press Fn or something to make it work normally?  Can you press right arrow otherwise?  Trying it myself here, I can move in both directions around the synth setting ring in both desktop and laptop keyboard layouts.

If you turn on input help (NVDA+1) and then press the keystroke, what does NVDA report? (NVDA+1 again to turn input help off).

Kind regards

Quentin.

On Thu, Jul 11, 2019 at 6:26 AM Marcio via Groups.Io <marcinhorj21=yahoo.com.br@groups.io> wrote:
Surendra,
when I press nvd a key + control + right and left arrow I can't able to configure rate volume options
Actually, the command is Control+Shift+NVDA+Right/Left arrows to move through the options and Control+Shit+NVDA+Up/Down arrows to configure the option you've selected.

Hope this helps :)

On a related note, I just discovered something curious.
Here, Control+Shift+NVDA+Left arrow works like a charm. However, the same isn't true for the command using the right arrow. In fact, the problem seems to be with the combo Control+Insert+Right arrow.
Can anyone tell me why that is happening? Would my keyboard not be capable of processing this combo at once?

Thanks a lot.

Cheers,
Marcio AKA Starboy

Sent from a galaxy far, far away.

--
Are you a Thunderbird user? Then join the Thunderbird mailing list to help and be helped with all Thunderbird things - questions, features, add-ons and much more!



--
Quentin Christensen
Training and Support Manager

NVDA 2019.2beta1 now available!

 

Luke,
1. Change the order in which you press the modifiers. That has a slim chance of working.
Tested, not working :(

2. Use a different modifier key.
* If control is required, and the control key you normally use doesn't work, try the other one. Same with shift and alt.
Ok it definitely worked (after a good few acrobatic sessions).
Well, of course I won't be using it because sooner or later who knows in what it could result to my arms :) but this was a good (and fun) experiment.

3. If you can't modify your choice of modifiers to solve the problem, either because it's too uncomfortable or because it just doesn't work, you are left with remapping the command (and probably its related command, such as the one to go in the other direction) in gesture configuration, to a set of commands that actually work.
Honestly I'mnot feeling like doing it. Fortunately, it seems like it's only happening with this combo so oh well, I can live without it after all.

Thanks for your answer. It's indeed much appreciated! Now I know that if I ever need to do it, and if I really need, I have at least one way to achieve it :)

Cheers,
Marcio AKA Starboy

Sent from a galaxy far, far away.

--
Are you a Thunderbird user? Then join the Thunderbird mailing list to help and be helped with all Thunderbird things - questions, features, add-ons and much more!

 

Quentin,
Re your issue, the only thing I can think of is your right arrow perhaps serving a dual function and you need to press Fn or something to make it work normally? Can you press right arrow otherwise? Trying it myself here, I can move in both directions around the synth setting ring in both desktop and laptop keyboard layouts.
Well it's technically the case, but for doing the other function I need to press FN with the arrow. If I only press right arrow it's the default behavior :)

If you turn on input help (NVDA+1) and then press the keystroke, what does NVDA report?
Nothing at all, and this was how I found it out. At first I thought it was my NVDA configured incorrectly but after checking the gestures and testing with input help turned on, it turned out that it's not the case.

I guess I'll just have to deal with it, anyway :(

Cheers,
Marcio AKA Starboy

Sent from a galaxy far, far away.

--
Are you a Thunderbird user? Then join the Thunderbird mailing list to help and be helped with all Thunderbird things - questions, features, add-ons and much more!