Topics

Question about NVDA reading documents or pages containing text in multiple languages


Laurie Mehta
 

Hello,
I have stumbled upon a strange thing and hope someone has some helpful advice for this problem.
When I receive a document that is 99% in English with a small portion in another language NVDA reads that entire document (Word or pdf) as if it is entirely in that other language (not English.) What I mean is that NVDA is pronouncing the words as if in that other language and even going over a word character by character, NVDA spells in that other language's alphabet.
This has happened before and for short documents copying into notepad yields an entirely readable text. A notepad file is less practical for a long document, though, and I think that NVDA ought to be able to read a document in a language even if it has a line or two in a second language.

For example, I recently downloaded a document that is in English with only a line or so in Italian from a Vatican website. Saved in either Word or as pdf, the whole document reads as if NVDA is trying to read it in Italian-- even using the Italian alphabet when I move character by character. If I copy and paste the document into notepad, it reads in English with no problem.

I think that I must have some setting set in NVDA which is causing this issue but I don't know where to look for setting things right.
It seems that NVDA is recognizing some trigger to adjust to a particular language for reading, but I don't know how or where to find that trigger to possibly remove it.
Obviously I could just make a very long txt file for the document to read it, but if I can retain the headings and other formatting of the almost 200 page original I would prefer that.

Do any of you have some helpful advice for this issue?
Thanks!

Laurie M.


 

Well I just turn off auto language switching.

Its really no good doing other language speech unless you don't use espeak in anything other than english.

I am sorry but while I like the clear and robotic fast nature of espeak I don't find other languages clear at all.

On 26/05/2020 10:21 am, Laurie Mehta via groups.io wrote:
Hello,
I have stumbled upon a strange thing and hope someone has some helpful advice for this problem.
When I receive a document that is 99% in English with a small portion in another language NVDA reads that entire document (Word or pdf) as if it is entirely in that other language (not English.) What I mean is that NVDA is pronouncing the words as if in that other language and even going over a word character by character, NVDA spells in that other language's alphabet.
This has happened before and for short documents copying into notepad yields an entirely readable text. A notepad file is less practical for a long document, though, and I think that NVDA ought to be able to read a document in a language even if it has a line or two in a second language.

For example, I recently downloaded a document that is in English with only a line or so in Italian from a Vatican website. Saved in either Word or as pdf, the whole document reads as if NVDA is trying to read it in Italian-- even using the Italian alphabet when I move character by character. If I copy and paste the document into notepad, it reads in English with no problem.

I think that I must have some setting set in NVDA which is causing this issue but I don't know where to look for setting things right.
It seems that NVDA is recognizing some trigger to adjust to a particular language for reading, but I don't know how or where to find that trigger to possibly remove it.
Obviously I could just make a very long txt file for the document to read it, but if I can retain the headings and other formatting of the almost 200 page original I would prefer that.

Do any of you have some helpful advice for this issue?
Thanks!

Laurie M.


Laurie Mehta
 

If there was auto language switching, wouldn't that switch from one language to another rather than continuing in one?
Where is that setting?
Thanks,
Laurie M.

On Monday, May 25, 2020, 03:32:37 PM PDT, Shaun Everiss <sm.everiss@...> wrote:


Well I just turn off auto language switching.

Its really no good doing other language speech unless you don't use
espeak in anything other than english.

I am sorry but while I like the clear and robotic fast nature of espeak
I don't find other languages clear at all.



On 26/05/2020 10:21 am, Laurie Mehta via groups.io wrote:
> Hello,
> I have stumbled upon a strange thing and hope someone has some helpful advice for this problem.
> When I receive a document that is 99% in English with a small portion in another language NVDA reads that entire document (Word or pdf) as if it is entirely in that other language (not English.) What I mean is that NVDA is pronouncing the words as if in that other language and even going over a word character by character, NVDA spells in that other language's alphabet.
> This has happened before and for short documents copying into notepad yields an entirely readable text. A notepad file is less practical for a long document, though, and I think that NVDA ought to be able to read a document in a language even if it has a line or two in a second language.
>
> For example, I recently downloaded a document that is in English with only a line or so in Italian from a Vatican website. Saved in either Word or as pdf, the whole document reads as if NVDA is trying to read it in Italian-- even using the Italian alphabet when I move character by character. If I copy and paste the document into notepad, it reads in English with no problem.
>
> I think that I must have some setting set in NVDA which is causing this issue but I don't know where to look for setting things right.
> It seems that NVDA is recognizing some trigger to adjust to a particular language for reading, but I don't know how or where to find that trigger to possibly remove it.
> Obviously I could just make a very long txt file for the document to read it, but if I can retain the headings and other formatting of the almost 200 page original I would prefer that.
>
> Do any of you have some helpful advice for this issue?
> Thanks!
>
> Laurie M.

>
>
>




Gene
 

I haven't read about this in a long time but it probably decides which language to use depending on how the document is coded, if such coding exists.  In HTML, for example, code is placed in the document telling the browser which language the document is in.  Evidently, you received a document with the code for a language other than English, though most of the document is in English.
 
To turn the feature off, it's on by default, use the command NVDA key control v to open the voice dialog.  Tab until you get to a check box that says automatic language switching when supported.  If it is checked, press the space bar to uncheck it.
Then tab to and activate the ok button.
 
Gene

----- Original Message -----
Sent: Monday, May 25, 2020 6:07 PM
Subject: Where is the auto language switching setting in NVDA? Re: [nvda] Question about NVDA reading documents or pages containing text in multiple languages

If there was auto language switching, wouldn't that switch from one language to another rather than continuing in one?
Where is that setting?
Thanks,
Laurie M.
On Monday, May 25, 2020, 03:32:37 PM PDT, Shaun Everiss <sm.everiss@...> wrote:


Well I just turn off auto language switching.

Its really no good doing other language speech unless you don't use
espeak in anything other than english.

I am sorry but while I like the clear and robotic fast nature of espeak
I don't find other languages clear at all.



On 26/05/2020 10:21 am, Laurie Mehta via groups.io wrote:
> Hello,
> I have stumbled upon a strange thing and hope someone has some helpful advice for this problem.
> When I receive a document that is 99% in English with a small portion in another language NVDA reads that entire document (Word or pdf) as if it is entirely in that other language (not English.) What I mean is that NVDA is pronouncing the words as if in that other language and even going over a word character by character, NVDA spells in that other language's alphabet.
> This has happened before and for short documents copying into notepad yields an entirely readable text. A notepad file is less practical for a long document, though, and I think that NVDA ought to be able to read a document in a language even if it has a line or two in a second language.
>
> For example, I recently downloaded a document that is in English with only a line or so in Italian from a Vatican website. Saved in either Word or as pdf, the whole document reads as if NVDA is trying to read it in Italian-- even using the Italian alphabet when I move character by character. If I copy and paste the document into notepad, it reads in English with no problem.
>
> I think that I must have some setting set in NVDA which is causing this issue but I don't know where to look for setting things right.
> It seems that NVDA is recognizing some trigger to adjust to a particular language for reading, but I don't know how or where to find that trigger to possibly remove it.
> Obviously I could just make a very long txt file for the document to read it, but if I can retain the headings and other formatting of the almost 200 page original I would prefer that.
>
> Do any of you have some helpful advice for this issue?
> Thanks!
>
> Laurie M.

>
>
>




hurrikennyandopo ...
 

Hi


If i remember right under the voice settings menu.


I usually have 2 of the settings turned off down there Automatic language switching (when supported) and the one under it i un check.


That way I do not get that trying to think it is another language if on the site.


Gene nz


On 26/05/2020 11:07 am, Laurie Mehta via groups.io wrote:
If there was auto language switching, wouldn't that switch from one language to another rather than continuing in one?
Where is that setting?
Thanks,
Laurie M.
On Monday, May 25, 2020, 03:32:37 PM PDT, Shaun Everiss <sm.everiss@...> wrote:


Well I just turn off auto language switching.

Its really no good doing other language speech unless you don't use
espeak in anything other than english.

I am sorry but while I like the clear and robotic fast nature of espeak
I don't find other languages clear at all.



On 26/05/2020 10:21 am, Laurie Mehta via groups.io wrote:
> Hello,
> I have stumbled upon a strange thing and hope someone has some helpful advice for this problem.
> When I receive a document that is 99% in English with a small portion in another language NVDA reads that entire document (Word or pdf) as if it is entirely in that other language (not English.) What I mean is that NVDA is pronouncing the words as if in that other language and even going over a word character by character, NVDA spells in that other language's alphabet.
> This has happened before and for short documents copying into notepad yields an entirely readable text. A notepad file is less practical for a long document, though, and I think that NVDA ought to be able to read a document in a language even if it has a line or two in a second language.
>
> For example, I recently downloaded a document that is in English with only a line or so in Italian from a Vatican website. Saved in either Word or as pdf, the whole document reads as if NVDA is trying to read it in Italian-- even using the Italian alphabet when I move character by character. If I copy and paste the document into notepad, it reads in English with no problem.
>
> I think that I must have some setting set in NVDA which is causing this issue but I don't know where to look for setting things right.
> It seems that NVDA is recognizing some trigger to adjust to a particular language for reading, but I don't know how or where to find that trigger to possibly remove it.
> Obviously I could just make a very long txt file for the document to read it, but if I can retain the headings and other formatting of the almost 200 page original I would prefer that.
>
> Do any of you have some helpful advice for this issue?
> Thanks!
>
> Laurie M.

>
>
>




Quentin Christensen
 

When you create a document, most programs (eg Word) allow you to specify the language it is written in.  You can also specify a different language for portions of the document in another language.  What has most likely happened here, is that the editor was set to Italian, so NVDA tried to read it with Italian inflections, even though the words themselves were in English.

So, your options are to either tell Word the document is actually in English, or set NVDA to ignore language changes and simply read everything in English.

Regards

Quentin.

On Tue, May 26, 2020 at 8:21 AM Laurie Mehta via groups.io <lauriemehta=yahoo.com@groups.io> wrote:
Hello,
I have stumbled upon a strange thing and hope someone has some helpful advice for this problem.
When I receive a document that is 99% in English with a small portion in another language NVDA reads that entire document (Word or pdf) as if it is entirely in that other language (not English.) What I mean is that NVDA is pronouncing the words as if in that other language and even going over a word character by character, NVDA spells in that other language's alphabet.
This has happened before and for short documents copying into notepad yields an entirely readable text. A notepad file is less practical for a long document, though, and I think that NVDA ought to be able to read a document in a language even if it has a line or two in a second language.

For example, I recently downloaded a document that is in English with only a line or so in Italian from a Vatican website. Saved in either Word or as pdf, the whole document reads as if NVDA is trying to read it in Italian-- even using the Italian alphabet when I move character by character. If I copy and paste the document into notepad, it reads in English with no problem.

I think that I must have some setting set in NVDA which is causing this issue but I don't know where to look for setting things right.
It seems that NVDA is recognizing some trigger to adjust to a particular language for reading, but I don't know how or where to find that trigger to possibly remove it.
Obviously I could just make a very long txt file for the document to read it, but if I can retain the headings and other formatting of the almost 200 page original I would prefer that.

Do any of you have some helpful advice for this issue?
Thanks!

Laurie M.





--
Quentin Christensen
Training and Support Manager


Laurie Mehta
 

Thanks Gene (NZ) and Shaun!
I made the change and now all reads well.
-Laurie M.

On Monday, May 25, 2020, 04:17:19 PM PDT, hurrikennyandopo ... <hurrikennyandopo@...> wrote:


Hi


If i remember right under the voice settings menu.


I usually have 2 of the settings turned off down there Automatic language switching (when supported) and the one under it i un check.


That way I do not get that trying to think it is another language if on the site.


Gene nz


On 26/05/2020 11:07 am, Laurie Mehta via groups.io wrote:
If there was auto language switching, wouldn't that switch from one language to another rather than continuing in one?
Where is that setting?
Thanks,
Laurie M.
On Monday, May 25, 2020, 03:32:37 PM PDT, Shaun Everiss <sm.everiss@...> wrote:


Well I just turn off auto language switching.

Its really no good doing other language speech unless you don't use
espeak in anything other than english.

I am sorry but while I like the clear and robotic fast nature of espeak
I don't find other languages clear at all.



On 26/05/2020 10:21 am, Laurie Mehta via groups.io wrote:
> Hello,
> I have stumbled upon a strange thing and hope someone has some helpful advice for this problem.
> When I receive a document that is 99% in English with a small portion in another language NVDA reads that entire document (Word or pdf) as if it is entirely in that other language (not English.) What I mean is that NVDA is pronouncing the words as if in that other language and even going over a word character by character, NVDA spells in that other language's alphabet.
> This has happened before and for short documents copying into notepad yields an entirely readable text. A notepad file is less practical for a long document, though, and I think that NVDA ought to be able to read a document in a language even if it has a line or two in a second language.
>
> For example, I recently downloaded a document that is in English with only a line or so in Italian from a Vatican website. Saved in either Word or as pdf, the whole document reads as if NVDA is trying to read it in Italian-- even using the Italian alphabet when I move character by character. If I copy and paste the document into notepad, it reads in English with no problem.
>
> I think that I must have some setting set in NVDA which is causing this issue but I don't know where to look for setting things right.
> It seems that NVDA is recognizing some trigger to adjust to a particular language for reading, but I don't know how or where to find that trigger to possibly remove it.
> Obviously I could just make a very long txt file for the document to read it, but if I can retain the headings and other formatting of the almost 200 page original I would prefer that.
>
> Do any of you have some helpful advice for this issue?
> Thanks!
>
> Laurie M.

>
>
>




Laurie Mehta
 




Thanks, that worked! All is reading well now.
-Laurie M.

On Monday, May 25, 2020, 04:15:19 PM PDT, Gene <gsasner@...> wrote:


I haven't read about this in a long time but it probably decides which language to use depending on how the document is coded, if such coding exists.  In HTML, for example, code is placed in the document telling the browser which language the document is in.  Evidently, you received a document with the code for a language other than English, though most of the document is in English.
 
To turn the feature off, it's on by default, use the command NVDA key control v to open the voice dialog.  Tab until you get to a check box that says automatic language switching when supported.  If it is checked, press the space bar to uncheck it.
Then tab to and activate the ok button.
 
Gene
----- Original Message -----
Sent: Monday, May 25, 2020 6:07 PM
Subject: Where is the auto language switching setting in NVDA? Re: [nvda] Question about NVDA reading documents or pages containing text in multiple languages

If there was auto language switching, wouldn't that switch from one language to another rather than continuing in one?
Where is that setting?
Thanks,
Laurie M.
On Monday, May 25, 2020, 03:32:37 PM PDT, Shaun Everiss <sm.everiss@...> wrote:


Well I just turn off auto language switching.

Its really no good doing other language speech unless you don't use
espeak in anything other than english.

I am sorry but while I like the clear and robotic fast nature of espeak
I don't find other languages clear at all.



On 26/05/2020 10:21 am, Laurie Mehta via groups.io wrote:
> Hello,
> I have stumbled upon a strange thing and hope someone has some helpful advice for this problem.
> When I receive a document that is 99% in English with a small portion in another language NVDA reads that entire document (Word or pdf) as if it is entirely in that other language (not English.) What I mean is that NVDA is pronouncing the words as if in that other language and even going over a word character by character, NVDA spells in that other language's alphabet.
> This has happened before and for short documents copying into notepad yields an entirely readable text. A notepad file is less practical for a long document, though, and I think that NVDA ought to be able to read a document in a language even if it has a line or two in a second language.
>
> For example, I recently downloaded a document that is in English with only a line or so in Italian from a Vatican website. Saved in either Word or as pdf, the whole document reads as if NVDA is trying to read it in Italian-- even using the Italian alphabet when I move character by character. If I copy and paste the document into notepad, it reads in English with no problem.
>
> I think that I must have some setting set in NVDA which is causing this issue but I don't know where to look for setting things right.
> It seems that NVDA is recognizing some trigger to adjust to a particular language for reading, but I don't know how or where to find that trigger to possibly remove it.
> Obviously I could just make a very long txt file for the document to read it, but if I can retain the headings and other formatting of the almost 200 page original I would prefer that.
>
> Do any of you have some helpful advice for this issue?
> Thanks!
>
> Laurie M.

>
>
>




 

hi shaun.
do you mean that automatic language switching is not good for people
who use only espeak?
but, its good for people who use two synthesizers one espeak and one
for example ivona, microsoft voices etc for reading documents in
different languages?

On 5/26/20, Shaun Everiss <@smeveriss> wrote:
Well I just turn off auto language switching.

Its really no good doing other language speech unless you don't use
espeak in anything other than english.

I am sorry but while I like the clear and robotic fast nature of espeak
I don't find other languages clear at all.



On 26/05/2020 10:21 am, Laurie Mehta via groups.io wrote:
Hello,
I have stumbled upon a strange thing and hope someone has some helpful
advice for this problem.
When I receive a document that is 99% in English with a small portion in
another language NVDA reads that entire document (Word or pdf) as if it is
entirely in that other language (not English.) What I mean is that NVDA is
pronouncing the words as if in that other language and even going over a
word character by character, NVDA spells in that other language's
alphabet.
This has happened before and for short documents copying into notepad
yields an entirely readable text. A notepad file is less practical for a
long document, though, and I think that NVDA ought to be able to read a
document in a language even if it has a line or two in a second language.

For example, I recently downloaded a document that is in English with only
a line or so in Italian from a Vatican website. Saved in either Word or as
pdf, the whole document reads as if NVDA is trying to read it in Italian--
even using the Italian alphabet when I move character by character. If I
copy and paste the document into notepad, it reads in English with no
problem.

I think that I must have some setting set in NVDA which is causing this
issue but I don't know where to look for setting things right.
It seems that NVDA is recognizing some trigger to adjust to a particular
language for reading, but I don't know how or where to find that trigger
to possibly remove it.
Obviously I could just make a very long txt file for the document to read
it, but if I can retain the headings and other formatting of the almost
200 page original I would prefer that.

Do any of you have some helpful advice for this issue?
Thanks!

Laurie M.




--
By God,
were I given all the seven heavens
with all they contain
in order that
I may disobey God
by depriving an ant
from the husk of a grain of barley,
I would not do it.
imam ali


Bianka Brankovic <bianka.brankovic@...>
 

Hello list,

personally, I like Espeak because it can be used with many languages out of the box.

No, it's not perfect but if you just need a certain language once in a while, it's perfectly fine.

I am currently using German and English interchangeably and automatic language detection works just fine as long as the markup is good.

Just my 2 cents.

Kind regards,

Bianka



-----Ursprüngliche Nachricht-----
Von: nvda@nvda.groups.io <nvda@nvda.groups.io> Im Auftrag von zahra
Gesendet: Dienstag, 26. Mai 2020 12:21
An: nvda@nvda.groups.io
Betreff: Re: [nvda] Question about NVDA reading documents or pages containing text in multiple languages

hi shaun.
do you mean that automatic language switching is not good for people who use only espeak?
but, its good for people who use two synthesizers one espeak and one for example ivona, microsoft voices etc for reading documents in different languages?

On 5/26/20, Shaun Everiss <@smeveriss> wrote:
Well I just turn off auto language switching.

Its really no good doing other language speech unless you don't use
espeak in anything other than english.

I am sorry but while I like the clear and robotic fast nature of
espeak I don't find other languages clear at all.



On 26/05/2020 10:21 am, Laurie Mehta via groups.io wrote:
Hello,
I have stumbled upon a strange thing and hope someone has some
helpful advice for this problem.
When I receive a document that is 99% in English with a small portion
in another language NVDA reads that entire document (Word or pdf) as
if it is entirely in that other language (not English.) What I mean
is that NVDA is pronouncing the words as if in that other language
and even going over a word character by character, NVDA spells in
that other language's alphabet.
This has happened before and for short documents copying into notepad
yields an entirely readable text. A notepad file is less practical
for a long document, though, and I think that NVDA ought to be able
to read a document in a language even if it has a line or two in a second language.

For example, I recently downloaded a document that is in English with
only a line or so in Italian from a Vatican website. Saved in either
Word or as pdf, the whole document reads as if NVDA is trying to read
it in Italian-- even using the Italian alphabet when I move character
by character. If I copy and paste the document into notepad, it reads
in English with no problem.

I think that I must have some setting set in NVDA which is causing
this issue but I don't know where to look for setting things right.
It seems that NVDA is recognizing some trigger to adjust to a
particular language for reading, but I don't know how or where to
find that trigger to possibly remove it.
Obviously I could just make a very long txt file for the document to
read it, but if I can retain the headings and other formatting of the
almost
200 page original I would prefer that.

Do any of you have some helpful advice for this issue?
Thanks!

Laurie M.





--
By God,
were I given all the seven heavens
with all they contain
in order that
I may disobey God
by depriving an ant
from the husk of a grain of barley,
I would not do it.
imam ali