Reading Output in Programming Environments Automatically


Bhavya shah
 

Dear all,

I am using NVDA 2021.3.1 on Windows 10. When using the Command Prompt
or Windows Subsystem for Linux, NVDA does not auto-read the output on
pressing Enter. This means that I need to use the review cursor to
manually inspect the output each time. I do not recall experiencing
this behaviour in the past. I ran the COM registration fixing tool and
restarted with add-ons disabled without success. Is there a
work-around or patch to enable NVDA to auto-read output?

I would truly appreciate all suggestions and inputs on this.

Best Regards,
Bhavya Shah
Stanford University | Class of 2024
LinkedIn: https://www.linkedin.com/in/bhavyashah125/


Gene
 

Check to see if report dynamic content changes is on.  It is by default but it may have been turned off by a typing error.  The command to toggle it on or off is NVDA 5, 5 on the main keyboard.
 
Gene

-----Original Message-----
Sent: Sunday, January 09, 2022 5:54 PM
To: nvda
Subject: [nvda] Reading Output in Programming Environments Automatically
 
Dear all,

I am using NVDA 2021.3.1 on Windows 10. When using the Command Prompt
or Windows Subsystem for Linux, NVDA does not auto-read the output on
pressing Enter. This means that I need to use the review cursor to
manually inspect the output each time. I do not recall experiencing
this behaviour in the past. I ran the COM registration fixing tool and
restarted with add-ons disabled without success. Is there a
work-around or patch to enable NVDA to auto-read output?

I would truly appreciate all suggestions and inputs on this.

Best Regards,
Bhavya Shah
Stanford University | Class of 2024
LinkedIn: https://www.linkedin.com/in/bhavyashah125/





Bhavya shah
 

Dear Gene,

Spot on. I had probably turned it off on accident, and having
re-enabled it on your recommendation, output is auto-read at least in
Command Prompt. Much appreciated.

Thanks.

On 1/9/22, Gene <gsasner@gmail.com> wrote:
Check to see if report dynamic content changes is on. It is by default but
it may have been turned off by a typing error. The command to toggle it on
or off is NVDA 5, 5 on the main keyboard.

Gene
-----Original Message-----
From: Bhavya shah
Sent: Sunday, January 09, 2022 5:54 PM
To: nvda
Subject: [nvda] Reading Output in Programming Environments Automatically

Dear all,

I am using NVDA 2021.3.1 on Windows 10. When using the Command Prompt
or Windows Subsystem for Linux, NVDA does not auto-read the output on
pressing Enter. This means that I need to use the review cursor to
manually inspect the output each time. I do not recall experiencing
this behaviour in the past. I ran the COM registration fixing tool and
restarted with add-ons disabled without success. Is there a
work-around or patch to enable NVDA to auto-read output?

I would truly appreciate all suggestions and inputs on this.

Best Regards,
Bhavya Shah
Stanford University | Class of 2024
LinkedIn: https://www.linkedin.com/in/bhavyashah125/









--
Best Regards,
Bhavya Shah
Stanford University | Class of 2024
LinkedIn: https://www.linkedin.com/in/bhavyashah125/