Stopping NVDA from reading partial URLs in Firefox.


John Isige
 

Hi all.


Sorry if this is off topic, because it might end up being a Firefox usage question, I don't know.


So if you type something in Firefox, say banjo, you can arrow down and get a list of sites in your bookmarks that have that word in them. That's great, I want that.


What I don't want is this. I want to research networking on Windows. SO I start typing "how to set up a network bridge in Windows 10". What I hear is this. I type h, I hear "www.super-banjos.com", probably because it was the last URL I visited. As I type more, it will either keep saying that URL, or change to another one if it thinks it's found something else that matches. Only when I get past that will it stop speaking, because I've hit a point where it has no more matches.


Can I turn this off somehow? I don't have any of NVDA's keyboard echo stuff turned on because it's super confusing to me when I'm typing to hear random stuff come up. It slows me down and messes up my typing. This is doing the exact same thing. It's incredibly annoying.


Gene
 

 
 

From: John Isige
Sent: Wednesday, September 01, 2021 6:17 PM
Subject: [nvda] Stopping NVDA from reading partial URLs in Firefox.
 
Hi all.


Sorry if this is off topic, because it might end up being a Firefox
usage question, I don't know.


So if you type something in Firefox, say banjo, you can arrow down and
get a list of sites in your bookmarks that have that word in them.
That's great, I want that.


What I don't want is this. I want to research networking on Windows. SO
I start typing "how to set up a network bridge in Windows 10". What I
hear is this. I type h, I hear "www.super-banjos.com", probably because
it was the last URL I visited. As I type more, it will either keep
saying that URL, or change to another one if it thinks it's found
something else that matches. Only when I get past that will it stop
speaking, because I've hit a point where it has no more matches.


Can I turn this off somehow? I don't have any of NVDA's keyboard echo
stuff turned on because it's super confusing to me when I'm typing to
hear random stuff come up. It slows me down and messes up my typing.
This is doing the exact same thing. It's incredibly annoying.






Gene
 

Just turn off speech before you type with NVDA key s.  Then when you finish typing, turn speech on again with NVDA key s twice.
 
Or, if you are doing a search, instead of using control l and then typing, use control k.  I don’t know if that will sto;p you hearing suggestions but try it and see. 
 
I’d have to check to see if you can turn off suggestions when typing in the search field or the address bar. 
 
Gene

-----Original Message-----
From: John Isige
Sent: Wednesday, September 01, 2021 6:17 PM
Subject: [nvda] Stopping NVDA from reading partial URLs in Firefox.
 
Hi all.


Sorry if this is off topic, because it might end up being a Firefox
usage question, I don't know.


So if you type something in Firefox, say banjo, you can arrow down and
get a list of sites in your bookmarks that have that word in them.
That's great, I want that.


What I don't want is this. I want to research networking on Windows. SO
I start typing "how to set up a network bridge in Windows 10". What I
hear is this. I type h, I hear "www.super-banjos.com", probably because
it was the last URL I visited. As I type more, it will either keep
saying that URL, or change to another one if it thinks it's found
something else that matches. Only when I get past that will it stop
speaking, because I've hit a point where it has no more matches.


Can I turn this off somehow? I don't have any of NVDA's keyboard echo
stuff turned on because it's super confusing to me when I'm typing to
hear random stuff come up. It slows me down and messes up my typing.
This is doing the exact same thing. It's incredibly annoying.






 

i disabled various options including search suggestions to avoid such problems.

On 9/2/21, John Isige <gwynn@tds.net> wrote:
Hi all.


Sorry if this is off topic, because it might end up being a Firefox
usage question, I don't know.


So if you type something in Firefox, say banjo, you can arrow down and
get a list of sites in your bookmarks that have that word in them.
That's great, I want that.


What I don't want is this. I want to research networking on Windows. SO
I start typing "how to set up a network bridge in Windows 10". What I
hear is this. I type h, I hear "www.super-banjos.com", probably because
it was the last URL I visited. As I type more, it will either keep
saying that URL, or change to another one if it thinks it's found
something else that matches. Only when I get past that will it stop
speaking, because I've hit a point where it has no more matches.


Can I turn this off somehow? I don't have any of NVDA's keyboard echo
stuff turned on because it's super confusing to me when I'm typing to
hear random stuff come up. It slows me down and messes up my typing.
This is doing the exact same thing. It's incredibly annoying.






--
By God,
were I given all the seven heavens
with all they contain
in order that
I may disobey God
by depriving an ant
from the husk of a grain of barley,
I would not do it.
imam ali


Gene
 

I just checked this.  As I thought, if you search in the address bar, control l, you will hear suggestions spoken.  If you use control k, a search field for searching and nothing else, you will not hear suggestions spoken. 
Control k, type the search and press enter.  The results page will come up.  it will be the results page from your default search engine.  I believe in Firefox, its Google, but I’m not sure.
 
Gene

-----Original Message-----
From: zahra
Sent: Thursday, September 02, 2021 4:16 AM
Subject: Re: [nvda] Stopping NVDA from reading partial URLs in Firefox.
 
i disabled various options including search suggestions to avoid such problems.

On 9/2/21, John Isige <gwynn@...> wrote:
> Hi all.
>
>
> Sorry if this is off topic, because it might end up being a Firefox
> usage question, I don't know.
>
>
> So if you type something in Firefox, say banjo, you can arrow down and
> get a list of sites in your bookmarks that have that word in them.
> That's great, I want that.
>
>
> What I don't want is this. I want to research networking on Windows. SO
> I start typing "how to set up a network bridge in Windows 10". What I
> hear is this. I type h, I hear "www.super-banjos.com", probably because
> it was the last URL I visited. As I type more, it will either keep
> saying that URL, or change to another one if it thinks it's found
> something else that matches. Only when I get past that will it stop
> speaking, because I've hit a point where it has no more matches.
>
>
> Can I turn this off somehow? I don't have any of NVDA's keyboard echo
> stuff turned on because it's super confusing to me when I'm typing to
> hear random stuff come up. It slows me down and messes up my typing.
> This is doing the exact same thing. It's incredibly annoying.
>
>
>
>
>
>
>


--
By God,
were I given all the seven heavens
with all they contain
in order that
I may disobey God
by depriving an ant
from the husk of a grain of barley,
I would not do it.
imam ali





John Isige
 

OK, I've figured out the issue, at least. I literally just turned off every search thing I can find, I even changed it from use the address bar to search and told it to put a search thingy in the toolbar. The reason it's reading something is because it's literally filling in a URL. So for example, if I type www, it literally writes www.youtube.com into the address bar. So I think what's happening is that as I type, it's filling that in, or something else if it finds another match, until I type enough that it can't match anymore. I have no idea where it's pulling from though.


Anyway since this is apparently a Firefox problem now, I'll go and do my own digging on it, so as not to be off topic.


On 9/2/2021 4:21 AM, Gene wrote:
I just checked this.  As I thought, if you search in the address bar, control l, you will hear suggestions spoken.  If you use control k, a search field for searching and nothing else, you will not hear suggestions spoken. 
Control k, type the search and press enter.  The results page will come up.  it will be the results page from your default search engine.  I believe in Firefox, its Google, but I’m not sure.
 
Gene
-----Original Message-----
From: zahra
Sent: Thursday, September 02, 2021 4:16 AM
Subject: Re: [nvda] Stopping NVDA from reading partial URLs in Firefox.
 
i disabled various options including search suggestions to avoid such problems.

On 9/2/21, John Isige <gwynn@...> wrote:
> Hi all.
>
>
> Sorry if this is off topic, because it might end up being a Firefox
> usage question, I don't know.
>
>
> So if you type something in Firefox, say banjo, you can arrow down and
> get a list of sites in your bookmarks that have that word in them.
> That's great, I want that.
>
>
> What I don't want is this. I want to research networking on Windows. SO
> I start typing "how to set up a network bridge in Windows 10". What I
> hear is this. I type h, I hear "www.super-banjos.com", probably because
> it was the last URL I visited. As I type more, it will either keep
> saying that URL, or change to another one if it thinks it's found
> something else that matches. Only when I get past that will it stop
> speaking, because I've hit a point where it has no more matches.
>
>
> Can I turn this off somehow? I don't have any of NVDA's keyboard echo
> stuff turned on because it's super confusing to me when I'm typing to
> hear random stuff come up. It slows me down and messes up my typing.
> This is doing the exact same thing. It's incredibly annoying.
>
>
>
>
>
>
>


--
By God,
were I given all the seven heavens
with all they contain
in order that
I may disobey God
by depriving an ant
from the husk of a grain of barley,
I would not do it.
imam ali