Strange say-all phenomenon


Christopher Bartlett
 

Running NVDA 2021.1 and using the Onecore voices.  In some programs, (Microsoft Word is the most recent example I've come across,) say all is using a different voice than the one I've selected for the application-specific profile.  I've gone into settings and verified that I have the voice set properly.  What's weird is that NVDA is using Microsoft David, a voice I have never used for anything because I don't like it.  If I scroll through the document manually, the correct voice happens.
I've also experienced this problem in Qread,  Is there some way to have a separate say all voice that I've forgotten about?  I looked through the help yesterday, and couldn't find anything.  What's going on here?

Christopher BArtlett


--
Christopher Bartlett


darkmad88@...
 

 Hello, Christopher!
I think, it may be caused by automatic language switching functionality of NVDA. Possibly, NVDA tries to use system default voice  for reading  a Word document in "Say all" mode. You can try to turn of automatic language switching in NVDA speech settings, or set default Windows voice same as you use as NVDA default voice.


Quentin Christensen
 

The other possibility could be have you setup a configuration profile for Word, or any programs?  You can change the voice or the whole synthesizer in different programs if you so desire - I wrote about it in this week's In-Process as it happens: https://www.nvaccess.org/post/in-process-19th-august-2021/#Profiles

Kind regards

Quentin.

On Fri, Aug 20, 2021 at 12:24 AM <darkmad88@...> wrote:
 Hello, Christopher!
I think, it may be caused by automatic language switching functionality of NVDA. Possibly, NVDA tries to use system default voice  for reading  a Word document in "Say all" mode. You can try to turn of automatic language switching in NVDA speech settings, or set default Windows voice same as you use as NVDA default voice.



--
Quentin Christensen
Training and Support Manager


Christopher Bartlett
 

Hi Quentin.  As it happens, I have a word profile with a different voice set up than the general default.  I read In Process and was reminded that there is a say all profile, but I don't remember how to get to it.

CWB


On Fri, Aug 20, 2021 at 1:10 AM Quentin Christensen <quentin@...> wrote:
The other possibility could be have you setup a configuration profile for Word, or any programs?  You can change the voice or the whole synthesizer in different programs if you so desire - I wrote about it in this week's In-Process as it happens: https://www.nvaccess.org/post/in-process-19th-august-2021/#Profiles

Kind regards

Quentin.

On Fri, Aug 20, 2021 at 12:24 AM <darkmad88@...> wrote:
 Hello, Christopher!
I think, it may be caused by automatic language switching functionality of NVDA. Possibly, NVDA tries to use system default voice  for reading  a Word document in "Say all" mode. You can try to turn of automatic language switching in NVDA speech settings, or set default Windows voice same as you use as NVDA default voice.



--
Quentin Christensen
Training and Support Manager



--
Christopher Bartlett


Quentin Christensen
 

I did link to the previous post with instructions on Say all: https://www.nvaccess.org/post/in-process-26th-october-2018/#NVDAProfiles

Basically though, open configuration profiles, find your say all profile in the list and manually activate it.  Alternatively, create a new profile and in "Use this profile for" set "Say all".  OK to load the profile.

Change whatever settings you want, then manually deactivate the profile.

Quentin.

On Fri, Aug 20, 2021 at 11:01 PM Christopher Bartlett <themusicalbrewer@...> wrote:
Hi Quentin.  As it happens, I have a word profile with a different voice set up than the general default.  I read In Process and was reminded that there is a say all profile, but I don't remember how to get to it.

CWB


On Fri, Aug 20, 2021 at 1:10 AM Quentin Christensen <quentin@...> wrote:
The other possibility could be have you setup a configuration profile for Word, or any programs?  You can change the voice or the whole synthesizer in different programs if you so desire - I wrote about it in this week's In-Process as it happens: https://www.nvaccess.org/post/in-process-19th-august-2021/#Profiles

Kind regards

Quentin.

On Fri, Aug 20, 2021 at 12:24 AM <darkmad88@...> wrote:
 Hello, Christopher!
I think, it may be caused by automatic language switching functionality of NVDA. Possibly, NVDA tries to use system default voice  for reading  a Word document in "Say all" mode. You can try to turn of automatic language switching in NVDA speech settings, or set default Windows voice same as you use as NVDA default voice.



--
Quentin Christensen
Training and Support Manager



--
Christopher Bartlett



--
Quentin Christensen
Training and Support Manager