Topics

symbols don't get spoken despite being added to both lists


Anne Günther
 

Hi,
I've just started to learn esperanto, which has some special symbols. I added the first one, which is translated in one specific vowel and it worked finge. I added another which gets translated into a group of letters and it doesn't get spoken. I tried to add it to the standard dictionary. But that doesn't work either. In the symbol dialogue, I set the level to "all" and also the "gets send to speech" to "always.
What could be the problem?
best wishes, Guenni


Quentin Christensen
 

When adding a symbol, the symbol level (None, some, most or all) corresponds to NVDA's punctuation / symbol level.  When NVDA is set to "Some", only symbols with a symbol level of "None" or "Some" are reported.  At most, NVDA reads symbols with a level of "None", "Some" or "Most" etc.  You can adjust NVDA's symbol level with NVDA+p or from NVDA's speech / voice settings (NVDA+control+v to open that screen and tab to "Punctuation / Symbol level".

So, if you set a symbol to have a level of "All", it will only be read at symbol level "All".

Kind regards

Quentin.

On Wed, Sep 30, 2020 at 10:42 PM Anne Günther <ag82lca@...> wrote:
Hi,
I've just started to learn esperanto, which has some special symbols. I
added the first one, which is translated in one specific vowel and it
worked finge. I added another which gets translated into a group of
letters and it doesn't get spoken. I tried to add it to the standard
dictionary. But that doesn't work either. In the symbol dialogue, I set
the level to "all" and also the "gets send to speech" to "always.
What could be the problem?
best wishes, Guenni








--
Quentin Christensen
Training and Support Manager


Anne Günther
 

Hi,
*sigh*. YYou are so right! With the first symbols I realized my mistake and set tho option to the right end of the scale. With the latter, I messed it up unce more.
Thanks for your answer.
best wishes, Guenni


Quentin Christensen
 

Glad to help :)

Also, re the "Always send symbol to synthesizer" option, what that does is send either the symbol itself, or the pronunciation instead, to the synthesizer.  Where this can make a difference is if the synthesizer does something with it as well as simply speaking it.   For instance, if I set up an entry for the period or comma or question mark - normally when the synthesizer receives those, it speaks it (if required) and then pauses (at the end of the sentence, or a shorter break for the comma).  If you don't send the symbol to the synthesizer, you won't get that pause.

Regards

Quentin.

On Thu, Oct 1, 2020 at 6:46 PM Anne Günther <ag82lca@...> wrote:
Hi,
*sigh*. YYou are so right! With the first symbols I realized my mistake
and set tho option to the right end of the scale. With the latter, I
messed it up unce more.
Thanks for your answer.
best wishes, Guenni







--
Quentin Christensen
Training and Support Manager