Weird NVDA sound output problem


David Griffith
 

Over the weekend a problem developed with my RealTek sound card on my laptop wich meant I could not use the 3.5  audio headphone socket.

Basically it was giving out distorted incomprehensible  sound.

I have implemented 2 solutions for the time being which work with everything audio except NVDA.

The first solution was to plug in a Creative Soundblaster USB card/dongle.

I have made this my default sound card in windows system.

This sound blaster  card works with everything audio except NVDA.

So I have tested the following which all work fine

Narrator Zoom all media through   VLC, Jaws 2021  all system sounds and web media content.

However as soon as I load NVDA it starts to put out sound through my laptop speakers rather than the headphones I am wearing though other sounds still come through the headphones. Today I tried another solution and paired a pair of Bluetooth headphones.

These again worked fine with all the above programs, narrator, Jaws Zoom etc but as soon as I loaded NVDA it started to chatter out noisily through the laptop speakers instead.

I have looked all through NVDA settings but cannot find anything to change?

At the moment NVDA is unusable as my deafness means that I cannot really hear without headphones.

David Griffith

,

 

Sent from Mail for Windows 10

 


Tyler Spivey
 

Press ctrl+NVDA+s and tab once. Set the output device to Microsoft Sound Mapper and try again.

On 8/3/2021 9:58 AM, David Griffith wrote:
Over the weekend a problem developed with my RealTek sound card on my laptop wich meant I could not use the 3.5  audio headphone socket.
Basically it was giving out distorted incomprehensible  sound.
I have implemented 2 solutions for the time being which work with everything audio except NVDA.
The first solution was to plug in a Creative Soundblaster USB card/dongle.
I have made this my default sound card in windows system.
This sound blaster  card works with everything audio except NVDA.
So I have tested the following which all work fine
Narrator Zoom all media through   VLC, Jaws 2021  all system sounds and web media content.
However as soon as I load NVDA it starts to put out sound through my laptop speakers rather than the headphones I am wearing though other sounds still come through the headphones. Today I tried another solution and paired a pair of Bluetooth headphones.
These again worked fine with all the above programs, narrator, Jaws Zoom etc but as soon as I loaded NVDA it started to chatter out noisily through the laptop speakers instead.
I have looked all through NVDA settings but cannot find anything to change?
At the moment NVDA is unusable as my deafness means that I cannot really hear without headphones.
David Griffith
,
Sent from Mail <https://go.microsoft.com/fwlink/?LinkId=550986> for Windows 10


Gene
 

When NVDA is running, do the following:
Open the synthesizer dialog, NVDA key, control, s.
Tab, I  believe once to a combo box where you specify the sound cardd NVDA will send speech to.  Then press enter. 
If you are using the default NVDA setting that automatically saves settings when you close NVDA, you don’t have to do this extra step.  If not, save the setting with NVDA key control c.
 
Close and run NVDA again and see if sound comes through the soundcard you specified.
 
Gene

-----Original Message-----
Sent: Tuesday, August 03, 2021 11:58 AM
Subject: [nvda] Weird NVDA sound output problem
 

Over the weekend a problem developed with my RealTek sound card on my laptop wich meant I could not use the 3.5  audio headphone socket.

Basically it was giving out distorted incomprehensible  sound.

I have implemented 2 solutions for the time being which work with everything audio except NVDA.

The first solution was to plug in a Creative Soundblaster USB card/dongle.

I have made this my default sound card in windows system.

This sound blaster  card works with everything audio except NVDA.

So I have tested the following which all work fine

Narrator Zoom all media through   VLC, Jaws 2021  all system sounds and web media content.

However as soon as I load NVDA it starts to put out sound through my laptop speakers rather than the headphones I am wearing though other sounds still come through the headphones. Today I tried another solution and paired a pair of Bluetooth headphones.

These again worked fine with all the above programs, narrator, Jaws Zoom etc but as soon as I loaded NVDA it started to chatter out noisily through the laptop speakers instead.

I have looked all through NVDA settings but cannot find anything to change?

At the moment NVDA is unusable as my deafness means that I cannot really hear without headphones.

David Griffith

,

 

Sent from Mail for Windows 10

 


David Griffith
 

Many thanks to yourself and Jean for rescuing the use of NVDA for me. Changing the option to Windows Sound Mapper has indeed done the trick. I am very relieved being able to hear NVDA again.

This is Something for me to remember as it was not completely obvious going through the settings.

Could I suggest as a feature request generally to the NVDA community that this option be included under speech in the main NVDA  settings  as unless I was seriously not paying enough attention I could not find it there. Given that most users would look there first it seems  a logical place to put the option. Presumably others would have a similar confusion.

 

David Griffith

 

 

 

 

 

Sent from Mail for Windows 10

 

From: Tyler Spivey via groups.io
Sent: 03 August 2021 18:24
To: nvda@nvda.groups.io
Subject: Re: [nvda] Weird NVDA sound output problem

 

Press ctrl+NVDA+s and tab once. Set the output device to Microsoft Sound

Mapper and try again.

 

On 8/3/2021 9:58 AM, David Griffith wrote:

> Over the weekend a problem developed with my RealTek sound card on my

> laptop wich meant I could not use the 3.5  audio headphone socket.

>

> Basically it was giving out distorted incomprehensible  sound.

>

> I have implemented 2 solutions for the time being which work with

> everything audio except NVDA.

>

> The first solution was to plug in a Creative Soundblaster USB card/dongle.

>

> I have made this my default sound card in windows system.

>

> This sound blaster  card works with everything audio except NVDA.

>

> So I have tested the following which all work fine

>

> Narrator Zoom all media through   VLC, Jaws 2021  all system sounds and

> web media content.

>

> However as soon as I load NVDA it starts to put out sound through my

> laptop speakers rather than the headphones I am wearing though other

> sounds still come through the headphones. Today I tried another solution

> and paired a pair of Bluetooth headphones.

>

> These again worked fine with all the above programs, narrator, Jaws Zoom

> etc but as soon as I loaded NVDA it started to chatter out noisily

> through the laptop speakers instead.

>

> I have looked all through NVDA settings but cannot find anything to change?

>

> At the moment NVDA is unusable as my deafness means that I cannot really

> hear without headphones.

>

> David Griffith

>

> ,

>

> Sent from Mail <https://go.microsoft.com/fwlink/?LinkId=550986> for

> Windows 10

>

>

 

 

 

 

 


Gene
 

I’m not sure where you want it.  it doesn’t make sense to place it in the speech dialog where you set the speech rate, pitch, punctuation, etc. for whatever synthesizer you are using.  It makes the most sense where it is, in the synthesizer dialog.  It is a universal setting.  It remains the same whatever synthesizer you select. 
 
 
Also, sound mapper may not always work.  I have had times when I had to set NVDA to use the specific name of the sound card I want to use.  For example, the name of my internal sound card is Speakers (Conexant CX20671.  I want my internal sound card to be used and I may have to use that choice to make sure it always is, regardless of what other sound card I connect.
 
Gene

-----Original Message-----
Sent: Tuesday, August 03, 2021 3:51 PM
Subject: Re: [nvda] Weird NVDA sound output problem
 

Many thanks to yourself and Jean for rescuing the use of NVDA for me. Changing the option to Windows Sound Mapper has indeed done the trick. I am very relieved being able to hear NVDA again.

This is Something for me to remember as it was not completely obvious going through the settings.

Could I suggest as a feature request generally to the NVDA community that this option be included under speech in the main NVDA  settings  as unless I was seriously not paying enough attention I could not find it there. Given that most users would look there first it seems  a logical place to put the option. Presumably others would have a similar confusion.

 

David Griffith

 

 

 

 

 

Sent from Mail for Windows 10

 

From: Tyler Spivey via groups.io
Sent: 03 August 2021 18:24
To: nvda@nvda.groups.io
Subject: Re: [nvda] Weird NVDA sound output problem

 

Press ctrl+NVDA+s and tab once. Set the output device to Microsoft Sound

Mapper and try again.

 

On 8/3/2021 9:58 AM, David Griffith wrote:

> Over the weekend a problem developed with my RealTek sound card on my

> laptop wich meant I could not use the 3.5  audio headphone socket.

>

> Basically it was giving out distorted incomprehensible  sound.

>

> I have implemented 2 solutions for the time being which work with

> everything audio except NVDA.

>

> The first solution was to plug in a Creative Soundblaster USB card/dongle.

>

> I have made this my default sound card in windows system.

>

> This sound blaster  card works with everything audio except NVDA.

>

> So I have tested the following which all work fine

>

> Narrator Zoom all media through   VLC, Jaws 2021  all system sounds and

> web media content.

>

> However as soon as I load NVDA it starts to put out sound through my

> laptop speakers rather than the headphones I am wearing though other

> sounds still come through the headphones. Today I tried another solution

> and paired a pair of Bluetooth headphones.

>

> These again worked fine with all the above programs, narrator, Jaws Zoom

> etc but as soon as I loaded NVDA it started to chatter out noisily

> through the laptop speakers instead.

>

> I have looked all through NVDA settings but cannot find anything to change?

>

> At the moment NVDA is unusable as my deafness means that I cannot really

> hear without headphones.

>

> David Griffith

>

> ,

>

> Sent from Mail <https://go.microsoft.com/fwlink/?LinkId=550986> for

> Windows 10

>

>