Work laptop locks even though say all is active


Pranav Lal
 

Hi all,

My work laptop is running windows 10 and I am using nvda 2021.3. I am using
office 365 on that machine.

The laptop is set to automatically lock if there is no keyboard or mouse
activity. I was reading a long document yesterday and it locked.

I have tested this and can duplicate it.

Is there a way for NVDA to keep the laptop awake or do I need to tell the IT
team to disable some setting? I do not want to disable the locking setting
because it has been put there due to security concerns which I find valid.

Pranav


Nimer Jaber
 

Hello,

Yes, this also seems to happen when reading with a Braille displ'ay as well. I am not aware of any setting to keep the computer awake when NVDA is in use, and not actually interacting with a keyboard or mouse, short of changing the sleep settings which, as you say, are a security risk.

On Wed, Dec 15, 2021 at 5:53 PM Pranav Lal <pranav@...> wrote:
Hi all,

My work laptop is running windows 10 and I am using nvda 2021.3. I am using
office 365 on that machine.

The laptop is set to automatically lock if there is no keyboard or mouse
activity. I was reading a long document yesterday and it locked.

I have tested this and can duplicate it.

Is there a way for NVDA to keep the laptop awake or do I need to tell the IT
team to disable some setting? I do not want to disable the locking setting
because it has been put there due to security concerns which I find valid.

Pranav








--
Best,

Nimer Jaber

Registered Linux User 529141.
http://counter.li.org/

To find out about a free, open-source, and versatile screen reader for Windows, visit nvaccess.org

You can follow @nimerjaber on Twitter for the latest technology news.

Thank you, and have a great day!


 

The easiest thing is to determine how long the period is before lock:  Settings, Personalization, Lock Screen, Screen timeout settings link.

It is possible to set the lock to Never, but it's clearly shorter than that.  You have 5 minute increments followed by 1 hour up to 5 hours followed by never.  You may get the result you're seeking just by increasing he time before the screen turns off and the computer sleeps (which are analogous and on that same pane).  In your case, the screen being turned off is likely irrelevant, as the screen reader doesn't depend on the display being on.  But the sleep time is.

Otherwise, have them set the screen off and sleep times "long enough" that you're not being constantly interrupted and locked out, but not so long that the security you seek is compromised.

No matter what it is, just activating a single keyboard key, and I'd pause reading for a moment, and start it again, prevents the machine from sleeping if it's done before that time limit for inactivity is reached.
--

Brian - Windows 10, 64-Bit, Version 21H1, Build 19043  

Science has become just another voice in the room; it has lost its platform.  Now, you simply declare your own truth.

       ~ Dr. Paul A. Offit, in New York Times article, How Anti-Vaccine Sentiment Took Hold in the United States, September 23, 2019

 


Pranav Lal
 

Hi Brian and Nimer,

 

I have changed the screen time out setting and have also taken Brian’s suggestion to heart about hitting a key from time to time.

 

So far, things are working as in the laptop is no longer going to sleep.

 

Pranav